Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 31 Jul 2014, 05:38
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Flite text to MP3
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [19 Posts]   Goto page: Previous 1, 2
Author Message
Enrique Corbellini


Joined: 20 May 2009
Posts: 93

PostPosted: Mon 22 Apr 2013, 19:20    Post subject: festival looks good  

when trying to install flitegui_1.4-2-2 pet in slackopup it says "not possible to install it". I'm using yakitome.com in Spanish in the meantime, but it shouldn't be necessary to use the internet to have a text converted to good human voice (by the way, yakitome has a sweet female voice, difficult to improve). Wink
Back to top
View user's profile Send private message 
Puppyt

Joined: 09 May 2008
Posts: 561
Location: Gatton, Queensland

PostPosted: Fri 12 Jul 2013, 21:53    Post subject:  

Hi Geof -
thanks very much for your work here, unfortunately I can't get your flite gui's working in Pemasu's Upup 3.8.3.1. jrb's pet also loads up, but file conversion falls there also. I went to the ubuntu repo's and no luck there either with the official flite and flitelib installs. Do you want some sort of diagnostics to help solve the issue?
Cheers Smile

_________________
Toowoomba Linux Community
http://groups.google.com/group/toowoombalinux
Back to top
View user's profile Send private message Visit poster's website 
Geoffrey


Joined: 30 May 2010
Posts: 1328
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sat 13 Jul 2013, 01:19    Post subject:  

Puppyt wrote:
Hi Geof -
thanks very much for your work here, unfortunately I can't get your flite gui's working in Pemasu's Upup 3.8.3.1. jrb's pet also loads up, but file conversion falls there also. I went to the ubuntu repo's and no luck there either with the official flite and flitelib installs. Do you want some sort of diagnostics to help solve the issue?
Cheers Smile


I downloaded Upup 3.8.3.1 to see what the problem was, installed jrb's pet, the old Gui don't work but replacing it with the gtkdialog4 version works fine, tested making wav and mp3 files, all appears to work ok.

you can change line 105 in the gtkdialog4 flitegui to read:
Code:
exec defaultaudioplayer $DIR/$NEW_MP3_NAME.$file &

that will get pMusic to play it.
Smile

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
Puppyt

Joined: 09 May 2008
Posts: 561
Location: Gatton, Queensland

PostPosted: Sat 13 Jul 2013, 05:12    Post subject:
Subject description: Flite of the Discords
 

Thanks Geoffrey!
That's you, going beyond the call, again, cheers! I'll look into the gtkdialog4 version again (flitegui-2.3.tar.gz - it was the first one I tried, but didn't seem to produce the MP3 at all). I've had troubles with other Flite versions, including ones downloaded via PPM in various puplets - has been a frustrating day. I just want to flick various docx files- converted to straight text - into mp3's to playback on my olde PocketPC2003 when I'm out walking. The hope is I can study and get the blood circulating simultaneously - maybe even do my exam preparations 'on the run'...
Cheers Smile

EDIT:
Still no joy with v2.3. It loads fine, permits file selection and modification but when 'Record' is clicked, a SAVED [filename].mp3 message comes up instantly, only a strange [filename].mp3.txt file is generated. 'listen' button doesn't give the usual time speech - an ALSA problem perhaps? pMusic opens also, presumably to play the mp3 file that doesn't exist. Is there something wrong with my text file format? I've attached a copy of the file I'm trying to give voice to - perhaps someone might spot my problem?

EDIT2:
DOH Embarassed Missed the obvious - had to install the v 2.2 pet FIRST to get the voices etc, and then overlay the flitegui in /usr/bin with the v 2.3 tar.gz. It wasn't until I tried to reinstall in MacPup520 which I also have on this laptop, that this error occurred to me. The pharmacological and latin pronunciations actually very good with the Scottish male voice - but I'll have to read along with the text first before I go out walking with this as a revision aid Smile Discord over - thanks Smile
gcsummary2.txt.gz
Description  not a gz - remove for text opening
gz

 Download 
Filename  gcsummary2.txt.gz 
Filesize  30.04 KB 
Downloaded  60 Time(s) 

_________________
Toowoomba Linux Community
http://groups.google.com/group/toowoombalinux
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 2 [19 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0564s ][ Queries: 13 (0.0045s) ][ GZIP on ]