Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 09:38
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Lugaru and fixing it's problems
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
asparuh13

Joined: 06 Jul 2013
Posts: 11

PostPosted: Fri 12 Jul 2013, 03:32    Post subject:  Lugaru and fixing it's problems
Subject description: my path of trial and error
 

Hello! i saw the following post: http://www.murga-linux.com/puppy/viewtopic.php?search_id=1152678970&t=70817 and decided i'd give this game a try cause it looked really interesting, i didn't get far though, as the "libdirectfb 1.2.9.so" was missing...after a long search google cam up with nothing and i was wondering what to do....

Then i downloaded the source code from http://packages.debian.org/squeeze/libdirectfb-1.2-9 and compiled it with some errors as i wanted the package to be able to run on systems other than my own so that other people could use it too...didn't work though so i made it just for mine using this tutorial
http://puppy.b0x.me/wiki/doku.php?id=compile

After that i had some problems with libts-0.0.so.0 , which i got from http://www.murga-linux.com/puppy/viewtopic.php?p=608824

i then extracted the .lib and moved it to /usr/lib...

The game now runs! A big thank you to everybody! I decided i'd post it since other people had the same issues but didn't seem to find the .libs and fix the problems...
Back to top
View user's profile Send private message 
Eldon

Joined: 09 Sep 2010
Posts: 110

PostPosted: Sat 13 Jul 2013, 01:58    Post subject:  

Yeah I think I would've done that but I run Slacko from a USB drive so I think I had problems with memory/space when I tried to install/run the DEVX module successfully. Or maybe I just got errors. It's been a while since I tried but I didn't have much luck.

You probably should've just replied to the Lugaru thread instead of starting a new one, but thanks for trying to compile the lib for the rest of us Wink .
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0466s ][ Queries: 12 (0.0091s) ][ GZIP on ]