Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 14:18
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Precise Puppy 5.7.1
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 27 [399 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 25, 26, 27 Next
Author Message
backi

Joined: 27 Feb 2011
Posts: 466
Location: GERMANY

PostPosted: Tue 30 Jul 2013, 08:36    Post subject:  

Hi watchdog !

I have to agree ..... there is something with my german keyboard .. does not work as usual but only (for me )in Chromium20 Browser....
. did some changes in countrysettings of the browser..now is working........almost .........still @ is now on another button.

Maybe one have to download and install specific langpack .

.
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 934
Location: London, England

PostPosted: Tue 30 Jul 2013, 09:27    Post subject:  

The easiest way I have found to reproduce the keyboard layout bug is:-

Restart X Server
Open Geany
Type characters such as @ " # \

Perhaps other UK users at least would be so kind as to try this simple test.

_________________
Oscar in England

Back to top
View user's profile Send private message 
anikin

Joined: 10 May 2012
Posts: 554

PostPosted: Tue 30 Jul 2013, 10:12    Post subject:  

OscarTalks,
awhile ago, I had some keyboard misbehaviour too, with at least two puppies, although it wasn't severe. I created "90-keyboard-layout.conf" like this:
Code:
Section "InputClass"
   Identifier "keyboard-all"
   MatchIsKeyboard "on"
   MatchDevicePath "/dev/input/event*"
   Driver "evdev"
   Option "XkbModel" "pc102"
   Option "XkbLayout" "us,ru"
   Option "XkbOptions"  "grp:ctrl_shift_toggle,grp_led:scroll,compose:rwin"
   Option "XkbVariant" ",winkeys" #xkbvariant0
   Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

and put it in:
usr/share/x11/xorg.conf.d
My problem was, that in geany, I couldn't toggle keyboard layout, and that solved the issue for me (can't remember if I did something else). Just google for "90-keyboard-layout.conf" + your specific XkbOptions. What's important, as I understand it, this conf needs to be there in addition to xkb section of xorg.conf. So I have both.
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Tue 30 Jul 2013, 10:25    Post subject:  

OscarTalks wrote:
The easiest way I have found to reproduce the keyboard layout bug is:-

Restart X Server
Open Geany
Type characters such as @ " # \

Perhaps other UK users at least would be so kind as to try this simple test.


Oscar:

I confirm the bug in Geany (but not any other program I have tried.) I am taking a look at geany.conf.

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
cygnus_odile

Joined: 30 Jul 2013
Posts: 6
Location: Tokyo, Japan

PostPosted: Tue 30 Jul 2013, 10:39    Post subject: /root/.Xdefaults has an unecpected space.  

Hellow, everyone, and Thanks to Mr Barry K. for your Puppy.
I've been using "Puppy" for long time (about 4yeras), and mainly Japanese edition.

In Recent Precise Puppy's "/root/.Xdefaults" has an unexpected space at the end of line 8.
Code:
Rxvt.keysym.0xFF57: \033[4~


So pushing "END" key causes the Cursor to jump and gives an unexpected space at the end of line, when editing the command line or using a text-editor on Urxvt.

This point is corrected in Precise Puppy 550JP ( Mr. Shinobar's Japanese edition).

Dear Mr.Barry K. please delete it (a space) in .Xdefaults and .Xdefaults.back, in next release.

... ... thank you for reading my post through.
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Tue 30 Jul 2013, 10:43    Post subject:  

Terryphi wrote:
OscarTalks wrote:
The easiest way I have found to reproduce the keyboard layout bug is:-

Restart X Server
Open Geany
Type characters such as @ " # \

Perhaps other UK users at least would be so kind as to try this simple test.


Oscar:

I confirm the bug in Geany (but not any other program I have tried.) I am taking a look at geany.conf.


This fixes Geany for UK keyboard:

/root/.conf/geany.conf

Line 66
Amend
pref_editor_default_encoding=ISO-8859-1
to
pref_editor_default_encoding=ISO-8859-15

Save file and restart X server. It may take a few tries to "stick". (I would have preferred to use UTF-8 but I could not get that to "stick".) This is a workaround but probably the bug is elsewhere because this amendment is not necessary in Racy/Wary.

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
OscarTalks

Joined: 05 Feb 2012
Posts: 934
Location: London, England

PostPosted: Tue 30 Jul 2013, 11:32    Post subject:  

Hello Terryphi,

Thanks for taking a look. The bug still persists for me. What happens is that if you open Geany (or can be Leafpad or other program that you would type into), type something, then close it, once you open it a second time (or any other program) the layout problem has gone away. This may be why it appeared that it was only in Geany and not other programs.

If you restart X again (or reboot) then open any program the problem will be there again until you try to type and then close it.

_________________
Oscar in England

Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Tue 30 Jul 2013, 12:01    Post subject:  

OscarTalks wrote:
Hello Terryphi,

Thanks for taking a look. The bug still persists for me. What happens is that if you open Geany (or can be Leafpad or other program that you would type into), type something, then close it, once you open it a second time (or any other program) the layout problem has gone away. This may be why it appeared that it was only in Geany and not other programs.

If you restart X again (or reboot) then open any program the problem will be there again until you try to type and then close it.


Oscar, yes you are right. It does happen in the way you describe for many programs (including Leafpad and Firefox and Chromium from Ubuntu repositories.) but not all. For instance my Opera SFS does not show this behaviour. Maybe it is caused by a file that all these programs reference.

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
Sage

Joined: 04 Oct 2005
Posts: 4833
Location: GB

PostPosted: Tue 30 Jul 2013, 12:13    Post subject:  

Geany/Keboard/5.7/Full.
Interesting - it's more of a feature than a fault. I have an illuminated bni keyboard that I use for general testing. I used a marker pen to overwrite the @ " # \ symbols which were transposed " @ £ plus extra key for \|~, respectively. The bni compliance notice refers to Canada alone; I don't know anything else about it's origins.
I swapped this k/b with a regular UK one and the installation crashed. Rebooted, it made some changes and I rebooted again. Ignore X error message, got Error in /root/Choices/ROX-Filer/Puppy/Pin, go OK, old pinboard converted to new XML format OK gives single SDA1 icon lower left, CNTRL-Backspce + xwin - SDA1 and FD0, no other icons???? Everything appears to work from Menu, correct UK symbols for @"#\ appear as per (UK) keyboard.
Swap back to illuminated k/b, Geany, symbols revert to (Canadian?) keys as originally marked, but the desktop icons have disappeared again, just the HD and FD ones showing, not even the optical drive (IDE). Fiddled around with various icon handling utilities but nothing would bring them back.
Reinstalled FULL, availed of patch in PPM, set xv in Mplayer - all back as was with (Canadian?) key strokes in Geany.
All this is beyond my ambit. Just one mission critical matter - cannot get the £ symbol to show in Geany but UK regular key positions (overwritten on illuminated keyboard) in Abiword.
Having these issues? Try changing the keyboard?
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Tue 30 Jul 2013, 12:17    Post subject:  

Seems to me Restart X server is resetting to default US keyboard layout but corrects itself to selected keyboard layout after any program receives keyboard input and is closed. Weird!
_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
Sage

Joined: 04 Oct 2005
Posts: 4833
Location: GB

PostPosted: Tue 30 Jul 2013, 13:13    Post subject:  

Weird, indeed. In principle, all the keys can be re-mapped - I used to do it with that other OS. That was a long time ago; no idea how to do it in Linux. It may also be possible to obtain stick-on key logos or overlay cards although I've not seen them recently. Sometimes, new keyboards come with a spare/blank key. Got to be easier solutions, especially as keyboards can be had new for £2-3 rather than the IBM monstrosity at ~£120 some decades ago. How about the euro symbol? The £ symbol might come in useful...
Back to top
View user's profile Send private message 
tronkel


Joined: 30 Sep 2005
Posts: 1104
Location: Vienna Austria

PostPosted: Tue 30 Jul 2013, 14:13    Post subject:  

Oscar Talks wrote:

Quote:
is anyone else having any issues with the keyboard layout?


Yep I've got the same problem. I think I had it Precise 5.6.1 also. There seems to be a problem with the Quick Setup first run settings - it's simply being ignored, so the keyboard layout has to be to be configured for a second time in the normal way, i.e. from the Puppy keyboard settings wizard. Then it works.

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send private message Visit poster's website AIM Address 
OscarTalks

Joined: 05 Feb 2012
Posts: 934
Location: London, England

PostPosted: Tue 30 Jul 2013, 14:53    Post subject:  

Well I have just looked at Precise Puppy 5.6.1 on 2 computers, one netbook and now posting from an HP Compaq Small Form Factor desktop and the bug does NOT happen for me in 5.6.1 so it would appear to be something which has crept in between 5.6.1 and 5.7 so hopefully that narrows it down a bit.
_________________
Oscar in England

Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 4833
Location: GB

PostPosted: Tue 30 Jul 2013, 14:59    Post subject:  

Quote:
a problem with the Quick Setup first run settings - it's simply being ignore

- not too sure about that? I get perfect behaviour with Abiword but not Geany at all stages and conditions. There are lots of transatlantic keyboards buzzing around Europe and it's not always apparent because the £ symbol is often present when $ shows, and v.v.; also many non-standard layouts like my illuminated model, 'compact'/mini versions, ad inf. Not been a Geany fan, prefer gedit and mousepad, so not sure how long this has been going on.

Just tried Leafpad/illiuminated - only @ and " are interposed - the £ symbol is normal, as well as the remainder.
Gedit requires too many deps. to check it tonight - I'm busy!

PS. Any Brits needing a spare k/b - just let me know how many.
Back to top
View user's profile Send private message 
witekjeden

Joined: 11 Feb 2013
Posts: 23

PostPosted: Tue 30 Jul 2013, 15:26    Post subject:  

I run live-cd retro version on my Maxdata Eco4010iw 512ram and system works quite good, thanks for new Precise. There is a little problem: can not to execute PeasyGlue and Pidgin with polish language. I guess the nls packages are not including into iso file because after installing pidgin_nls from Wary repo Pidgin works in polish.
.
Oooops, sorry. The langpack needs to upgrade.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 27 [399 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 25, 26, 27 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0956s ][ Queries: 13 (0.0092s) ][ GZIP on ]