Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Aug 2014, 08:00
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Precise Puppy 5.7.1
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 10 of 25 [368 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12, ..., 23, 24, 25 Next
Author Message
FeodorF


Joined: 07 Jul 2010
Posts: 167
Location: Heidelberg, Germany

PostPosted: Sun 04 Aug 2013, 06:33    Post subject: Quick test report (desktop pc)  

Operating System: Precise Puppy - 5.7.1
Kernel Version: Linux 3.9.11 (i686)
Date/Time: Sun 04 Aug 2013 12:24:56 PM GMT-1

Processor: Pentium III-933 (Coppermine)
Memory: 1293MB (185MB used)

Display Resolution: 1600x900 pixels
OpenGL: Nouveau, Mesa DRI nv18 x86/MMX/SSE
Monitor 0: 1600x900 pixels
Monitor 1: 1024x768 pixels

Audio Adapter: CMI8738 C-Media CMI8738

Hard disk: ATA WDC WD5000AADS-0
DVD-RAM: HL-DT-ST DVDRAM GH22NS40
Card reader: Generic Storage Device
-----------------------------------------------------
This Puppy version runs fast - very fast!

Last edited by FeodorF on Fri 09 Aug 2013, 08:44; edited 1 time in total
Back to top
View user's profile Send private message 
tlchost

Joined: 05 Aug 2007
Posts: 1674
Location: Baltimore, Maryland USA

PostPosted: Sun 04 Aug 2013, 07:52    Post subject: Pmusic  

The version of pmusic in 5.7.1 apparently does not store/access the radio station list correctly. Installing the latest version of pmusic solves the problem.
http://www.meownplanet.net/zigbert/pmusic-4.1.0.pet

Perhaps include this in the next release.

Download info: username: puppy , password: linux
Back to top
View user's profile Send private message Visit poster's website 
Sylvander

Joined: 15 Dec 2008
Posts: 3421
Location: West Lothian, Scotland, UK

PostPosted: Sun 04 Aug 2013, 09:53    Post subject:  

How should the included version of Pmusic be removed prior to installing the version linked above?

Tried to use "Menu->Setup->Remove builtin packages", but couldn't find "pmusic" listed.
Back to top
View user's profile Send private message 
tlchost

Joined: 05 Aug 2007
Posts: 1674
Location: Baltimore, Maryland USA

PostPosted: Sun 04 Aug 2013, 10:46    Post subject:  

Sylvander wrote:
How should the included version of Pmusic be removed prior to installing the version linked above?

Tried to use "Menu->Setup->Remove builtin packages", but couldn't find "pmusic" listed.


I didn't even think to remove the old version....just installed the new one.
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5675
Location: Valåmoen, Norway

PostPosted: Sun 04 Aug 2013, 12:15    Post subject:  

You might also need the latest gtkdialog ???
found here


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
OscarTalks

Joined: 05 Feb 2012
Posts: 861
Location: London, England

PostPosted: Sun 04 Aug 2013, 12:37    Post subject:  

Question(s) for BarryK

Precise Puppy has 2 instances of gtkdialog

There is gtkdialog in /usr/bin which is a symlink to gtkdialog4 in /usr/bin AND there is gtkdialog in /usr/sbin which is a symlink to gtkdialog3 in /usr/sbin

Console reports version number as 0.8.3

Zigbert's latest pMusic and pBurn require a more recent gtkdialog which is numbered 0.8.4r514

Would it be OK to just have this latest gtkdialog as a file in either /usr/bin or /usr/sbin and have gtkdialog3 and gtkdialog4 as symlinks to that file or are there programs in Puppy which might still need the older gtkdialog (as gtkdialog3 or gtkdialog4)?

Also, do these files need to be in both locations (/usr/bin and /usr/sbin) and if so could they be symlinks from one to the other so everything just points to one real file?

_________________
Oscar in England

Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 861
Location: London, England

PostPosted: Sun 04 Aug 2013, 13:15    Post subject:  

Here is pMusic 4.1.0 running in Precise Puppy 5.7.1
Dependency check looks OK
Needs gtkdialog-0.8.4r514 (see zigbert's post above).
Running as root - haven't tried as spot.

NOTE:- Precise Puppy has libav in place of ffmpeg
substitution is not recommended
pMusic is mainly developed on ffmpeg
some issues may arise because of this
but hopefully they will be minor.
I guess it is just a case of keeping a watchful eye
and report any issues to zigbert
pmusic-precise-5.7.1.png
 Description   pMusic 4.1.0 looking good in Precise 5.7.1
 Filesize   167.1 KB
 Viewed   1497 Time(s)

pmusic-precise-5.7.1.png


_________________
Oscar in England

Back to top
View user's profile Send private message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Sun 04 Aug 2013, 13:49    Post subject: disk drives icons  

I have noticed one small bug with disk drives icons. I have USB-flash which is formated to have two partitions (by BootFlash, USB-ZIP mode). Precise-5.7.1 (and Slacko-5.5.71) show only first partition when flash is hot-plugged and both partitions when flash is present at the boot time. It's Ok in Precise-5.4.2. I know, there were some changes in disk drives icons scripts.
slacko.png
 Description   
 Filesize   21.58 KB
 Viewed   1457 Time(s)

slacko.png

precise571.png
 Description   
 Filesize   20.77 KB
 Viewed   1456 Time(s)

precise571.png

Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5675
Location: Valåmoen, Norway

PostPosted: Sun 04 Aug 2013, 14:02    Post subject:  

OscarTalks
Thank you for testing, feedback and info.

And Yes, - please post any issues in the pMusic thread. I am not scanning the entire forum.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
OscarTalks

Joined: 05 Feb 2012
Posts: 861
Location: London, England

PostPosted: Sun 04 Aug 2013, 14:41    Post subject:  

Here is pBurn 4.0.4 running in Precise Puppy 5.7.1
Again, needs gtkdialog-0.8.4r514 (see zigbert's post a few above)

Also needs cdrtools-3 (it is version 3.01a16) which I compiled from source in Precise Puppy 5.7.1 and am attaching below.

This is for testing purposes. Install at your own risk. If anyone knows of any problems which installing this package causes, please do speak up. It may be perfectly OK though, don't know.

Dependency check looks OK

Again, remember, Precise Puppy has libav in place of ffmpeg

With Datafilehost you need the small grey "DOWNLOAD" button for direct download.

cdrtools-3.01a16 Precise .PET
download = http://www1.datafilehost.com/d/b6384be8
md5sum = 164abdddae8f204a43e32cbb106e8001

cdrtools_DEV-3.01a16 Precise .PET
download = http://www1.datafilehost.com/d/7cecefea
md5sum = 3997bdb7507d7dc65166504e073a51f9
cdrtools_DOC-3.01a16-precise.pet
Description  Optional DOC files cdrtools-3 - Main and DEV via Datafilehost above
pet

 Download 
Filename  cdrtools_DOC-3.01a16-precise.pet 
Filesize  168.78 KB 
Downloaded  232 Time(s) 
pburn-precise-5.7.1.jpg
 Description   pBurn 4.0.4 looking good in Precise 5.7.1
 Filesize   75.11 KB
 Viewed   1441 Time(s)

pburn-precise-5.7.1.jpg


_________________
Oscar in England

Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3421
Location: West Lothian, Scotland, UK

PostPosted: Sun 04 Aug 2013, 15:37    Post subject:  

As above...
Installed:
pmusic-4.1.0.pet
pburn-4.0.4.pet [from HERE]
cdrtools-3.01a16-precise.pet
gtkdialog-precise-0.8.4r514.pet

All installed OK, and appear to be working OK, but....
When I check pmusic & pburn in "Check dependencies", I get the following missing dependency reported for each:
00.jpg
 Description   
 Filesize   19.32 KB
 Viewed   1400 Time(s)

00.jpg

Back to top
View user's profile Send private message 
Jades

Joined: 07 Aug 2010
Posts: 440
Location: Somewhere in Blighty.

PostPosted: Sun 04 Aug 2013, 17:21    Post subject: Precise 5.7.1 Retro not booting on K6-2 500
Subject description: Kernel panic at switch_root stage
 

I'm getting a kernel panic at the switch root stage on the K6-2 500 with Precise Puppy 5.7.1. Explicitly chose pfix=ram boot. I have checked md5sum for iso, successfully booted from the disc on another PC and copied the files off the disc successfully. Probably incompatibility with the CPU, which is odd given the release notes say it should be i486 compatible (K6-2 500 is i586). See attached photo for debug info.

Looks like I'm sticking with Wary 5.5 again.

Edit: Just noticed that the Trace in the debug info is remarkably similar to the kernel panic I had on the same machine when I was testing Precise 5.6.1.
Precise571retrokp.jpg
 Description   Photo of kernel panic on K6-2 500. Caps Lock and Scroll Lock lights also flashing.
 Filesize   63.32 KB
 Viewed   1355 Time(s)

Precise571retrokp.jpg


_________________
Zhaan - AMD K6 2 500, 512MB RAM, ATI Rage 128 VR. Full install Wary 5.5 HardInfo Report
Merlin - Pentium D 3.4GHz, 2GB RAM, Radeon X1650 Pro AGP. Slacko 5.7.0 HardInfo Report
Back to top
View user's profile Send private message Visit poster's website 
Sylvander

Joined: 15 Dec 2008
Posts: 3421
Location: West Lothian, Scotland, UK

PostPosted: Mon 05 Aug 2013, 03:56    Post subject:  

PROBLEM! Sad
Since applying the changes above...
Each of "SaveMyModem" [smm], and Thunderbird, are unable to fetch from my POP3 server.
I'll try rebooting without saving the changes, and see if that returns things to their previous working state.

That worked!
Things now back to their previous [working/functional] state.

Actually...
What I'd done in full was:
1. Previously used a 2nd Puppy to delete the new pupsave, and restore the old pupsave.
That fixed the problem.
Then...

2. Once again installed the various PET's as above.
That re-created the problem.
Then...

3. Re-booted without any save of the session changes.
That eliminated the problem.
Back to top
View user's profile Send private message 
OscarTalks

Joined: 05 Feb 2012
Posts: 861
Location: London, England

PostPosted: Mon 05 Aug 2013, 11:02    Post subject:  

Hello Sylvander,

Regarding the dependencies, I was looking mainly at the dependency check in the "help" menus of pMusic and pBurn. On my machine if I run the Puppy dependency checker I only get core-utils reported as missing. I wonder if you have other programs installed which are generating the other missing dependencies you are seeing?

I need to ask zigbert about this, but the core-utils missing dependency report happens because "+core-utils," is listed as a dependency in the pet.specs file in the pBurn .pet and I may be completely wrong about this but I thought I read somewhere that busybox provides the core-utils files in Puppy which means that no package named core-utils is installed. Anyway, if I expand the .pet and remove the "+core-utils," from the pet.specs file the dependency checker (obviously) no longer reports it as missing. Hopefully zigbert can confirm that all the needed files for pBurn are actually present.

LATER :- Just looking at installed packages it seems we do have coreutils (without the dash) but not core-utils so maybe I am wrong about busybox, perhaps it is just that the name in the pet.specs file just needs the dash removed.

As for the other problem, it is difficult for me to try to reproduce it because I have never used POP3 or the programs you mentioned. Perhaps you can confirm by elimination that it is the cdrtools-3 package that is causing the problem? I did have concerns about it because it is overwriting existing files from the old packages (of cdrkit, I think?). If it is this package that is causing the problem there are a couple of ideas I could try, but after that I may need to leave this task to someone with more experience than me.

_________________
Oscar in England

Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5675
Location: Valåmoen, Norway

PostPosted: Mon 05 Aug 2013, 12:05    Post subject:  

OscarTalks
dash is removed in pBurn pet.specs for next release.


Thank you
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 10 of 25 [368 Posts]   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12, ..., 23, 24, 25 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0961s ][ Queries: 13 (0.0091s) ][ GZIP on ]