Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Sep 2014, 08:09
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
GUI to download LibreOffice - beta quality
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 17 of 18 [260 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17, 18 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7802
Location: qld

PostPosted: Tue 06 Aug 2013, 17:12    Post subject: Re: GUI to download LibreOffice - beta quality
Subject description: with Language support
 

01micko on the front page wrote:

version 0.24
* fix for 64 bit
* add some logging, saved to /tmp/LO_log_"the date and time here"


Mr.Puppy,

A log might have been handy Smile

Anyway, I tested a FULL install choosing NO at the build in ram option and can reproduce your bug, saw it in the log. You won't get the choice unless you have 1GB of free RAM at the time of running. I suspect that may have happened. I had set the variable in the wrong place and it got nuked so sfs_load couldn't find the sfs. Fix pending.

Thanks for the report.
Code:
LO LOG
-------
Wed_Aug__7_07:12:53_EST_2013
get_libreoffice-0.28
PUPMODE = 2
en-GB
Is it ok to build in RAM? no
building in /
this is 4.1.0
major ver: 4.1
help enabled? true
lang enabled? true
LibreOffice_4.1.0_Linux_x86_deb_helppack_
LibreOffice_4.1.0_Linux_x86_deb_langpack_

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7802
Location: qld

PostPosted: Tue 06 Aug 2013, 17:46    Post subject:  

0.29 is out.

See Main Post

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Mr.Puppy

Joined: 05 Aug 2013
Posts: 14

PostPosted: Thu 08 Aug 2013, 10:16    Post subject:  

Thanks for the 0.29 version of the GUI to download and install LibreOffice. I have deleted the full install of Puppy Precise and done a frugal install on the same ext4-partition on which Antix Linux has been installed. A frugal install of Puppy Linux instead of a full install is also recommended. Now the .SFS file of LibreOffice works fine.
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Sun 06 Oct 2013, 23:02    Post subject:  

This is wonderful. I could easily get the latest LibreOffice (v4.1.2 at the moment of writing this) with built in Spanish translations and help files. Thank you, 01micko. Very Happy
_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Sun 24 Nov 2013, 21:50    Post subject:  

Trying to get LibreOffice 4.1.3 from Puppy Precise 5.7.1 the langpack and help won't be included in the final SFS, it remains English-only.
_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7802
Location: qld

PostPosted: Mon 25 Nov 2013, 01:22    Post subject:  

Is this a bug report? Where is the log if so? Wink
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Mon 25 Nov 2013, 12:25    Post subject:  

01micko wrote:
Is this a bug report? Where is the log if so? Wink


You mean there should be a log file somewhere? Or should I run get-libreoffice by terminal? I get no error messages, everything is downloaded but when the SFS is created the langpack and help won't make it into the SFS file.

All I know is I first set it to get the Spanish langpack and help plus two more languages. When everything was ready I opened LO Writer and it was in English (system language 'es'). Tools > Options > Language Settings displayed English as the one and only installed. I tried again with Spanish only, which had worked for v4.1.2 -- nothing. I made a fresh save file and tried again -- still English only. I finally gave up and set everything for an English-only SFS.

In my free time I usually make individual packages of popular languages and post them here. But if there is an option to have your language built in, why not make use of it? Wink

_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7802
Location: qld

PostPosted: Mon 25 Nov 2013, 16:59    Post subject: Re: GUI to download LibreOffice - beta quality
Subject description: with Language support
 

01micko on the first page wrote:

All bug reports MUST contain a log, located at /tmp/LO_$(date)

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Mon 25 Nov 2013, 20:57    Post subject: Re: GUI to download LibreOffice - beta quality
Subject description: with Language support
 

01micko wrote:
01micko on the first page wrote:

All bug reports MUST contain a log, located at /tmp/LO_$(date)


/temp/LO_log_lun_nov_25_21:30:24_ART_2013 wrote:
LO LOG
-------
lun_nov_25_21:30:24_ART_2013
get_libreoffice-0.29
PUPMODE = 12
es
Is it ok to build in RAM? no
building in /initrd/mnt/dev_save
this is 4.1.3
major ver: 4.1
help enabled? true
lang enabled? true
LibreOffice_4.1.3_Linux_x86_deb_helppack_
LibreOffice_4.1.3_Linux_x86_deb_langpack_
Current working dir is /initrd/mnt/dev_save/libre_download/LibreOffice_4.1.3.2_Linux_x86_deb/DEBS
Screenshot_2013-11-25_22_01_32.png
 Description   
 Filesize   13.32 KB
 Viewed   417 Time(s)

Screenshot_2013-11-25_22_01_32.png

Screenshot_2013-11-25_22_03_27.jpg
 Description   
 Filesize   28.18 KB
 Viewed   463 Time(s)

Screenshot_2013-11-25_22_03_27.jpg


_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7802
Location: qld

PostPosted: Tue 26 Nov 2013, 20:49    Post subject:  

Hello vicmz,

Well I'm perplexed Confused

I changed local to es_AR and went through the procedure on a clean install and it succeeded.

My only suggestion is to try it from commandline and see if there are errors not logged.
Code:
get_libreoffice

The program does do a size check.. but I wonder if you ran out of space when unpacking the debs, especially since libreoffice has grown somewhat. My sfs ended up 162M (xz).
Screenshot(1).png
 Description   
 Filesize   33.86 KB
 Viewed   422 Time(s)

Screenshot(1).png


_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Wed 27 Nov 2013, 16:16    Post subject: No extra locales
Subject description: for LibreOffice 4.1.3
 

Puppy Precise 5.7.1 - getlibreoffice 0.29

My HDD had 1.8 GB free space. I deleted or moved some stuff getting up to 6.6 GB. I deleted /root/.config/libreoffice/. I ran GetLibreOffice in ROXTerm:

Code:
sh-4.1# get_libreoffice
saving LO_log_mié_nov_27_17:33:12_ART_2013 to /tmp/LO_log_mié_nov_27_17:33:12_ART_2013
ok
es
Is it ok to build in RAM? no
building in /initrd/mnt/dev_save
EXIT="Exit on timeout"
this is 4.1.3
major ver: 4.1
/usr/sbin/get_libreoffice: line 790: 30641 Terminated              gtkdialog-splash -close never -icon /usr/share/pixmaps/throbber.gif -bg green -text "$INFOMSG1"
find: paths must precede expression: LibreOffice_4.1.3.2_Linux_x86_deb_helppack_it
Usage: find [-H] [-L] [-P] [-Olevel] [-D help|tree|search|stat|rates|opt|exec] [path...] [expression]
BusyBox v1.21.0 (2013-02-18 15:57:06 WST) multi-call binary.

Usage: basename FILE [SUFFIX]

Strip directory path and .SUFFIX from FILE


find: paths must precede expression: LibreOffice_4.1.3.2_Linux_x86_deb_langpack_it
Usage: find [-H] [-L] [-P] [-Olevel] [-D help|tree|search|stat|rates|opt|exec] [path...] [expression]
BusyBox v1.21.0 (2013-02-18 15:57:06 WST) multi-call binary.

Usage: basename FILE [SUFFIX]

Strip directory path and .SUFFIX from FILE


mv: cannot stat `./desktop-integration/*': No such file or directory
sed: -e expression #1, char 0: no previous regular expression
grep: printeradmin.desktop: No such file or directory
sed: can't read printeradmin.desktop: No such file or directory
sh: line 1:  2220 Terminated              gtkdialog-splash -close never -icon /usr/share/pixmaps/throbber.gif -bg yellow -text "$INFOMSG2a $LIBO_EN_US $INFOMSG2b"  (wd: ~)
sh-4.1#


File size still 155 MB (should be bigger).
No extra locale and help files for both cases - system language only and system language + extra languages.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7802
Location: qld

PostPosted: Wed 27 Nov 2013, 17:04    Post subject:  

Hi vicmz

Well the find calls weren't exactly correct and I didn't notice, but I adjusted those and hopefully it works now. Let me know. I added a bit more logging too.
get_libreoffice-0.30.pet
Description  for testing
pet

 Download 
Filename  get_libreoffice-0.30.pet 
Filesize  26.63 KB 
Downloaded  270 Time(s) 

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Wed 27 Nov 2013, 23:40    Post subject:  

This time I could finally get an SFS with built in Spanish langpack and help. I couldn't get an SFS including more languages, the extras function didn't work -- maybe no one has really tried getting a multilingual SFS before, so it can add just one new language. At /mnt/home/libreoffice_download I could see that the LibreOffice langpack and help DEBs weren't actually extracted along with the main LibreOffice DEB files in my previous attempts.

EDIT: I forgot to say thanks. Very Happy

Log:

Code:
LO LOG
-------
jue_nov_28_00:31:46_ART_2013
get_libreoffice-0.30
PUPMODE = 12
es
pup distro = precise-5.7.1
Is it ok to build in RAM? no
building in /initrd/mnt/dev_save
this is 4.1.3
major ver: 4.1
help enabled? true
lang enabled? true
LibreOffice_4.1.3_Linux_x86_deb_helppack_es
LibreOffice_4.1.3_Linux_x86_deb_langpack_es
Current working dir is /initrd/mnt/dev_save/libre_download/LibreOffice_4.1.3.2_Linux_x86_deb/DEBS


ROXTerm:

Code:
sh-4.1# get_libreoffice
saving LO_log_jue_nov_28_00:31:46_ART_2013 to /tmp/LO_log_jue_nov_28_00:31:46_ART_2013
ok
es
Is it ok to build in RAM? no
building in /initrd/mnt/dev_save
EXIT="Exit on timeout"
this is 4.1.3
major ver: 4.1
/usr/sbin/get_libreoffice: line 794:  8215 Terminated              gtkdialog-splash -close never -icon /usr/share/pixmaps/throbber.gif -bg green -text "$INFOMSG1"
true
true
LibreOffice_4.1.3_Linux_x86_deb_helppack_
LibreOffice_4.1.3_Linux_x86_deb_langpack_
/initrd/mnt/dev_save/libre_download/LibreOffice_4.1.3.2_Linux_x86_deb/DEBS
mv: cannot stat `./desktop-integration/*': No such file or directory
sed: -e expression #1, char 0: no previous regular expression
/usr/sbin/get_libreoffice: line 413: 14734 Terminated              gtkdialog-splash -close never -icon /usr/share/pixmaps/throbber.gif -bg yellow -text "$INFOMSG2a $LIBO_EN_US $INFOMSG2b"  (wd: ~)
/initrd/mnt/dev_save/libre_download/LibreOffice_4.1.3.2_Linux_x86_deb/DEBS
_es
EXIT="Exit on timeout"
gtk-update-icon-cache: Cache file created successfully.
/usr/sbin/sfs_load: line 192: 24601 Terminated              $GTKDIALOG -p DIALOG -c > /dev/null
Generating /root/.icewm/menu...
Generating /root/.jwmrc...
Generating /root/.config/openbox/menu.xml...
/usr/sbin/sfs_load: line 2404: 24990 Terminated              $GTKDIALOG -p DIALOG -c > /dev/null
sfs_load: --stop
sh-4.1#
Screenshot_2013-11-28_01_17_17.png
 Description   
 Filesize   22.63 KB
 Viewed   324 Time(s)

Screenshot_2013-11-28_01_17_17.png

Screenshot_2013-11-28_01_19_19.png
 Description   
 Filesize   40.71 KB
 Viewed   331 Time(s)

Screenshot_2013-11-28_01_19_19.png


_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1108

PostPosted: Wed 18 Dec 2013, 13:41    Post subject:  

get-libreoffice 0.30 working well on Precise 5.7.1 - got new LibreOffice 4.1.4 with langpack and help perfectly. Thanks 01micko. Very Happy
_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
Puppus Dogfellow


Joined: 07 Jan 2013
Posts: 572
Location: nyc

PostPosted: Sun 22 Dec 2013, 16:59    Post subject:  

version 30 appears to be working as well as the others have for me with just one little bit of weirdness: it told me i had 248 version of libreoffice to choose to build from and listed blank spaces and music files. 414 and 406 were among the choices, so not a big deal, just a bit odd.

created sfs file works fine--thanks again, 01micko! (precise 561 fwiw. LO files made under it using your program have been documented to work in 5.5, 5.6, 5.7 (upup), 531 slacko, 5.5 slacko, wheezy---). really cool.

here's a shot of the weirdness:

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 17 of 18 [260 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17, 18 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1006s ][ Queries: 13 (0.0102s) ][ GZIP on ]