Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Aug 2014, 00:16
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Filename is not valid UTF-8. You should rename it.
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
djodjodjo

Joined: 20 Aug 2013
Posts: 11

PostPosted: Tue 20 Aug 2013, 08:30    Post subject:  Filename is not valid UTF-8. You should rename it.  

Hello,

First excuse me for my english because I'm French Very Happy. I've SEARCHED A LOT before posting this thread but none of the solutions I've seen have worked for me...

I'm using Puppy 5.6 and I want to backup data from a nearly-broken hard drive. I've put it in an external USB box and I've mounted it with Puppy.

I can see all the files and folders I want to backup BUT all the folders/files with accents are red-colored and it says "Filename is not valid UTF-8. You should rename it." when the mouse goes over.

I've a read-only access to the disk (too much "broken") so I can't rename anything (and anyways there are too many files with accents).

I CAN copy folders with accents but only one-by-one. If I try to copy a folder (with no accent) that contains one or more folders with accents, then I'll have this message : "ERROR : invalid or incomplete multibyte or wide character" during the copy.

I've activated UTF-8 at loading (now the accents appear but the problem is still here).

I'd like to do exactly this : http://blog.bullrox.net/ntfs-3g-invalid-or-incomplete-multibyte-or-wide-character.html
but for Puppy

I've tried this too but there is no file named "locale.gen" in /etc/ and the command locale-gen is not a valid command in puppy... :

Code:
For oui, How to make ArchPup speak french Laughing

Download locale.alias.gz, remove false gz extension and copy this file to /usr/share/locale
then open /etc/locale.gen, uncomment
fr_FR.UTF-8 UTF-8
fr_FR ISO-8859-1
en_US ISO-8859-1
en_US.UTF-8 UTF-8
then in terminal run locale-gen.
Open /etc/profile and add this
Code:   
export LANG="fr_FR.UTF-8"
export LC_CTYPE="fr_FR.UTF-8"
export LC_NUMERIC="fr_FR.UTF-8"
export LC_TIME="fr_FR.UTF-8"
export LC_COLLATE="fr_FR.UTF-8"
export LC_MONETARY="fr_FR.UTF-8"
export LC_MESSAGES="fr_FR.UTF-8"
export LC_PAPER="fr_FR.UTF-8"
export LC_NAME="fr_FR.UTF-8"
export LC_ADDRESS="fr_FR.UTF-8"
export LC_TELEPHONE="fr_FR.UTF-8"
export LC_MEASUREMENT="fr_FR.UTF-8"
export LC_IDENTIFICATION="fr_FR.UTF-8"
export LC_ALL="fr_FR.UTF-8"


Thanks a lot for your help !
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11017
Location: Arizona USA

PostPosted: Tue 20 Aug 2013, 09:42    Post subject:  

I think your version of Puppy probably has "Pudd backup drive partition" somewhere in the menu. Have you tried using Pudd to copy the drive? I don't think Pudd will care about the UTF-8.
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2829
Location: Everybody knows this is nowhere...

PostPosted: Tue 20 Aug 2013, 13:31    Post subject:  

Bonjour, djodjodjo! Welcome, as we say, to the Kennels!

Your English is far better than my French -- I am American ( "L'Américain...!" Rolling Eyes ) and it appears that my tongue is not nearly flexible enough for your language, having been spoiled by English instead Razz

We do have a French section here, if you would feel more comfortable asking there. You will find it at the end of this link --> http://murga-linux.com/puppy/index.php?f=26

Also, the firstboot wizard (which you can bring up by selecting IIRC "Personalize Settings" from somewhere in the Menu) lets you set your language (and, if needed, keyboard layout). That may help things somewhat as well.

_________________
Loving X-Slacko 2.1!
Custom Build: HP MOCA-AR + Core2Duo T7200 + 4gb RAM + 256gb SSD
...just needs a pretty case Wink
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3964
Location: Kiel,Germany

PostPosted: Tue 20 Aug 2013, 15:36    Post subject:  

Puppy has two ways to mount ntfs read-only :
mount-FULL -t ntfs -o ro /dev/sda1 /mnt/sda1
and
ntfs-3g -o ro /dev/sda1 /mnt/sda1
.

It has also two ways to copy :
cp -a /mnt/sda1 /mnt/USBpartitionNr
and
rsync -a /mnt/sda1 /mnt/USBpartitionNr
.

I got such messages too for ÖÄÜ chars for example . Be aware that the
mount-FULL -t ntfs /dev/sda1 /mnt/sda1
could mount your ntfs partition in a way that creation of new files would be forbidden, but it would be allowed to use the ROX-Filer file manager to rename it or to write to existing files .
Just click ok without changing the filename/directoryname worked for me to make it linux - utf-8 - happy .

Pudd would use the dd command to clone to another partition or filename on a partition of a size greater than the original ntfs partition .
Back to top
View user's profile Send private message Visit poster's website 
djodjodjo

Joined: 20 Aug 2013
Posts: 11

PostPosted: Wed 21 Aug 2013, 03:26    Post subject:  

Hello,

@Flash : So I've tried to use "Pudd backup drive partition" and it gives an "Input/Output" error and stops itself after only 76MB copied...

@starhawk : Thanks for the link I think I'm gonna post a new thread

@Karl Godt : When I plug the external hard drive I just click on the icon to mount it and I always get a red window that appears saying there is an Input/Output error blablabla so the disk can only be accessed in read-only mode... I'll try your command lines but I'm not sure it will work !

Have a nice day
Back to top
View user's profile Send private message 
djodjodjo

Joined: 20 Aug 2013
Posts: 11

PostPosted: Fri 23 Aug 2013, 03:29    Post subject:  

Hello,

Just to tell you I've decided to give up...

I've also tested "Photorec" present in "SystemRescueCd" if you know it.. and I was supposed to wait 567 hours and the hard drive didn't stop creaking (or squeaking I don't know how to say it).

F*cking accents...
Back to top
View user's profile Send private message 
djodjodjo

Joined: 20 Aug 2013
Posts: 11

PostPosted: Fri 23 Aug 2013, 03:34    Post subject:  

Just because of accents I won't be able to retrieve my data... unbelievable...
Back to top
View user's profile Send private message 
marcos90

Joined: 07 Sep 2011
Posts: 77

PostPosted: Sun 01 Dec 2013, 14:15    Post subject:  

Precise Linux 5.7.1

I'm facing an similar problem here . I'm trying to copy all files from an old Hard Disk to an new hard disk . But when I start to copy , there are some files that cannot be transfered because it gives me the following message " cp: accessing " Invalid or incomplete multibyte or wide character
Failed to copy "
I'm assuming this is an "Bad UTF-8 error" , because of the accents on some words . I'll gonna try latest Lubuntu to see what will gonna happens .
EDITED: I've used an live cd with latest Lubunt , and it worked well , no error messages appeared .
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0680s ][ Queries: 12 (0.0093s) ][ GZIP on ]