Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 30 Aug 2014, 14:38
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
How to install Skype 4.2 in puppy 4.31
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
watchdog

Joined: 28 Sep 2012
Posts: 556

PostPosted: Sat 24 Aug 2013, 15:59    Post_subject:  How to install Skype 4.2 in puppy 4.31
Sub_title: No mission impossible...
 

Refer to a earlier HowTo:

http://www.murga-linux.com/puppy/viewtopic.php?t=87172

Download the latest Skype 4.2 in Puppy 4.31 (with glibc upgrade: http://www.murga-linux.com/puppy/viewtopic.php?t=66373) and extract the archive in /usr/local. Copy the bin skype in /usr/bin. Run bootmanager and install qt-4.7.1.sfs from the following link:

http://www.4shared.com/file/Fs1zcssq/qt-471.html

If you installed SFS_load-on-the-fly you can use it. If you need, reboot to get installed qt4. From debian packages download libstdc++6:

http://packages.debian.org/wheezy/i386/libstdc++6/download

With peazip extract in /root/my-documents/libstdc++.so.6.0.17. If you have trouble using peazip I extracted that lib and you can directly download it from:

https://docs.google.com/file/d/0B9iMb4UZBeFkSl9ZYUlpX1dMVUk/edit?usp=sharing

With geany create a bash file name skype4.2 with the following content:

Code:
#!/bin/sh
#export LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so
#export LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so
export LD_PRELOAD=/root/my-documents/libstdc++.so.6.0.17
exec skype


Give it execute permissions and move it in /usr/bin. Drag it to the desktop to create a link on the desktop. It worked in my install: clicking on skype4.2 on the desktop launches skype 4.2 and it works. In terminal there is a warning but it works here. For more details I have installed in puppy 4.31:
gtk+-2.18.3-p4.pet
jwm-657-p4.pet (compiled by me)
gtkdialog3-0.7.20-1.pet
Make your tests.
Back to top
View user's profile Send_private_message 
watchdog

Joined: 28 Sep 2012
Posts: 556

PostPosted: Wed 28 Aug 2013, 04:22    Post_subject:  

The same procedure works in wary 5.5.
Back to top
View user's profile Send_private_message 
watchdog

Joined: 28 Sep 2012
Posts: 556

PostPosted: Thu 29 Aug 2013, 01:22    Post_subject:  

The same preload:

Code:
LD_PRELOAD=/root/my-documents/libstdc++.so.6.0.17


before launching mozilla browsers makes working the latest GoogleTalkPlugin in wary and probably puppy 4.31 (not yet tested...). The GoogleTalkPlugin does not need qt4.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0413s ][ Queries: 12 (0.0035s) ][ GZIP on ]