Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 17 Sep 2014, 17:56
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Devxx_precise_5.7.1 installed, make doesn't work
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
cy3a

Joined: 15 Sep 2012
Posts: 8

PostPosted: Wed 25 Sep 2013, 02:41    Post subject:  Devxx_precise_5.7.1 installed, make doesn't work
Subject description: Trying to install foo2zjs, a Linux printer driver for ZjStream protocol
 

i tried to install foo2zjs:a linux printer driver for ZjStream protocol. I followed steps from page: http://foo2zjs.rkkda.com/
I installed devxx_precise_5.7.1, but when i try to do "make" it said:
Error: must install GNU dc with -e option!
What shall i do?
Thanx.
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Wed 25 Sep 2013, 04:00    Post subject:  

What it said : Get a regular dc binary , since it appears that your Puppy uses the busybox dc applet
Type
Code:
type -a dc
readlink -f `which dc`
dc --help

to check for your dc version .

http://packages.ubuntu.com/precise/dc
dl it and open it with xarchive somewhere and fetch the dc binary and put it into /bin directory .

_________________
«Give me GUI or Death» -- I give you [[Xx]term[inal]] [[Cc]on[s][ole]] .
Macpup user since 2010 on full installations.
People who want problems with Puppy boot frugal Razz
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9108
Location: Stratford, Ontario

PostPosted: Wed 25 Sep 2013, 06:43    Post subject:  

Why are you compiling this driver from source? A year ago, you used a driver PET here.
Back to top
View user's profile Send private message 
cy3a

Joined: 15 Sep 2012
Posts: 8

PostPosted: Mon 30 Sep 2013, 10:45    Post subject:  

rcrsn51 wrote:
Why are you compiling this driver from source? A year ago, you used a driver PET here.
that was with puppy 4.3.1. Now i have 5.7.1, but pet driver doesn't work.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9108
Location: Stratford, Ontario

PostPosted: Mon 30 Sep 2013, 11:14    Post subject:  

If you are using a Puppy with a newer kernel, like Precise 571, the foo2xxx driver requires a patch. It is posted here as foo2xxx_udev_patch_upup387-1.0.pet .

The installation procedure is:

1. Install the foo2xxx PET (if not done already)
2. Install the patch PET
3. Reboot the printer
4. Install the printer in CUPS (if not done already)
5. Print something

Please report back with your success or failure. This is important testing on your part.
Back to top
View user's profile Send private message 
cy3a

Joined: 15 Sep 2012
Posts: 8

PostPosted: Mon 30 Sep 2013, 11:40    Post subject:  

rcrsn51 wrote:
If you are using a Puppy with a newer kernel, like Precise 571, the foo2xxx driver requires a patch. It is posted here as foo2xxx_udev_patch_upup387-1.0.pet .

The installation procedure is:

1. Install the foo2xxx PET (if not done already)
2. Install the patch PET
3. Reboot the printer
4. Install the printer in CUPS (if not done already)
5. Print something

Please report back with your success or failure. This is important testing on your part.
now it is working just fine, thanx a lot Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0535s ][ Queries: 12 (0.0041s) ][ GZIP on ]