Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Sep 2014, 11:51
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Spotify client for Slacko
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [26 Posts]   Goto page: Previous 1, 2
Author Message
baszek

Joined: 06 Oct 2008
Posts: 38

PostPosted: Fri 11 Oct 2013, 05:52    Post subject:  

Hello
Did anybody make it work for newest precise puppy 5.7.1 ? I have loaded two sfs packages from http://www.smokey01.com/pemasu/pet_packages-upup/ (spotify client and gt4.8.2) but it doesn't work at all. When I press spotify in menu nothing happens! Plz help

I have now found that libplc4.so.0d and libnspr4.s0.0d are missing - how to install them on puppy ?

Last edited by baszek on Fri 11 Oct 2013, 06:22; edited 1 time in total
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1826
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Fri 11 Oct 2013, 06:21    Post subject:  

Bonjour,
You can try this:
Install first qt-4.8.0-libs-essentials and qt-4.8.0-webkit-phonon-gstreamer-opengl Arrow from this page
... then Spotify Arrow from this page

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
baszek

Joined: 06 Oct 2008
Posts: 38

PostPosted: Fri 11 Oct 2013, 07:03    Post subject:  

Quote:

Install first qt-4.8.0-libs-essentials and qt-4.8.0-webkit-phonon-gstreamer-opengl

I have installed it and there is the same problem - when I press at spotify in menu, nothing happens. I have tried run it from console and I get such a error:
"error while loading shared libraries: libgstapp-0.10.so.0: cannot open shared object file: No such file or directory"

I have also tried in console command "ldd /usr/bin/spotify" and I get that few libraries are missing:
libgstapp-0.10.so.0
libgstpbutils-0.10.so.0
libgstvideo-0.10.so.0
libgstbase-0.10.so.0
libgstreamer-0.10.so.0
and also;
libplc4.so.0d
libnspr4.so.0d

When I was using those gt and spotify sfs files from forum only libplc4.so.0d and libnspr4.so.0d were missing.
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1826
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Fri 11 Oct 2013, 09:22    Post subject:  

I think you should install libgstreamer-plugins-base0.10-0_0.10.36 and libgstreamer0.10-0_0.10.36 from PPM.

[EDIT]: As attached file one of the 2 missing libs.
libnspr4.so.0d is not present on my system and Spotify works well.

Cordialement.
131011_155111_729x532_easyshot.png
 Description   
 Filesize   174.26 KB
 Viewed   809 Time(s)

131011_155111_729x532_easyshot.png

libplc4.tar.gz
Description  To uncompress inside /usr/lib
gz

 Download 
Filename  libplc4.tar.gz 
Filesize  13.87 KB 
Downloaded  206 Time(s) 

_________________

Back to top
View user's profile Send private message Visit poster's website 
baszek

Joined: 06 Oct 2008
Posts: 38

PostPosted: Fri 11 Oct 2013, 11:35    Post subject:  

I have installed all of it, including libplc4, but still there is one missing (libnspr4.so.0d) and it will not start with out it. Where can I find libnspr4.so.0d?
By the way what puppy linux version do you have ?
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1826
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Fri 11 Oct 2013, 11:52    Post subject:  

These libs seem to come with Libreoffice and Seamonkey.
Missing lib as attached file: I think Spotifiy should work now.
Quote:
By the way what puppy linux version do you have ?

ToOpPy LINUX: Please, see my signature... Wink

Cordialement.
libnspr4.tar.gz
Description 
gz

 Download 
Filename  libnspr4.tar.gz 
Filesize  252.32 KB 
Downloaded  196 Time(s) 

_________________

Back to top
View user's profile Send private message Visit poster's website 
Ceri

Joined: 26 Apr 2014
Posts: 7
Location: Milan, Italy

PostPosted: Mon 28 Apr 2014, 14:49    Post subject:  
Subject description: Installed but doesnt work
 

Hello guys,

I'm working with Slacko 5.7

I've installed:
qt_all-4.7.3.sfs 43MB (SFS loaded on the fly)
spotify-0.8.4.103.pet 28MB
GConf-ORBit-libs-Slacko.pet 2.1MB
gstreamer-audio-0.10.35.pet 5.4MB

Got NO errors during installation.

I see Spotify's icon in Menu->Multimedia, but when I click nothing happens.

Below a snapshot to proof that everything is installed.

Please help me
Screenshot_2014-04-28_205746.jpg
Description 
jpg

 Download 
Filename  Screenshot_2014-04-28_205746.jpg 
Filesize  160.8 KB 
Downloaded  83 Time(s) 
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5258
Location: Australia

PostPosted: Tue 29 Apr 2014, 04:21    Post subject:  

The Spotify package I contributed in the first post of this thread depends on several shared libraries. In Slacko 5.3.x the shared libraries are under /usr/lib/seamonkey/
but I see that Slacko 5.7 now has Firefox, not Seamonkey.

I have now attached a hotfix to the first post, which corrects the library links for the Firefox version in Slacko 5.7.
Beware, these corrections apply only to Firefox 17.0.11, so is suitable ONLY for Slacko 5.7.

Last edited by tempestuous on Sun 04 May 2014, 05:09; edited 1 time in total
Back to top
View user's profile Send private message 
Ceri

Joined: 26 Apr 2014
Posts: 7
Location: Milan, Italy

PostPosted: Tue 29 Apr 2014, 06:09    Post subject:  

Thanks, I will try it ASAP.

One question:
Firefox is still insalled but I've installed and set Chromium as default browser, I find it faster in loading pages.

Can it be a problem in order to get Spotify working?
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5258
Location: Australia

PostPosted: Tue 29 Apr 2014, 06:48    Post subject:  

No problem. Spotify will use the libraries from Firefox, regardless of whatever other web browsers you may have installed.
Back to top
View user's profile Send private message 
Ceri

Joined: 26 Apr 2014
Posts: 7
Location: Milan, Italy

PostPosted: Tue 29 Apr 2014, 14:12    Post subject:    

It works now...amazing! thanks!!!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [26 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0608s ][ Queries: 13 (0.0046s) ][ GZIP on ]