Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 16 Apr 2014, 06:31
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Nvidia drivers
Post new topic   Reply to topic View previous topic :: View next topic
Page 5 of 5 [68 Posts]   Goto page: Previous 1, 2, 3, 4, 5
Author Message
meeki


Joined: 23 Jul 2012
Posts: 123
Location: Portland OR

PostPosted: Sat 07 Sep 2013, 07:08    Post subject:  

Well made a few more changes.

Found out that it was missing that fact that nouveau was not being detected as running.

# 6sep2013: [Meeki] added LH64 to the skip of msg to run xorg after reboot (see line 286)
# 6sep2013: [Meeki] -a changed to -o meeki (see line 280)
# 6sep2013: [Meeki] tons of edits (see line 284 to 290)

Here is the file with changes.
nvidia - https://dl.dropboxusercontent.com/u/12968946/lighthouse/nvidia

Also some unofficial pets

32bit getnvidia-unofficial
pet - https://dl.dropboxusercontent.com/u/12968946/lighthouse/packages/getnvidia/getnvidia-unofficial-0.9.8.1.pet
md5 - https://dl.dropboxusercontent.com/u/12968946/lighthouse/packages/getnvidia/getnvidia-unofficial-0.9.8.1.pet.md5

64bit getnvidia-unofficial
pet - https://dl.dropboxusercontent.com/u/12968946/lighthouse/packages/getnvidia/getnvidia_unofficial-0.9.9-64.pet
md5 - https://dl.dropboxusercontent.com/u/12968946/lighthouse/packages/getnvidia/getnvidia_unofficial-0.9.9-64.pet.md5

All these edits were done in Lighthouse64 (64bit puppy)
I don't know if it will fix or break the current kernel check issue in another distro.

Last edited by meeki on Sat 07 Sep 2013, 21:02; edited 1 time in total
Back to top
View user's profile Send private message 
Keef


Joined: 20 Dec 2007
Posts: 562
Location: Staffordshire

PostPosted: Sat 07 Sep 2013, 07:36    Post subject:  

meeki

Check the file structure of your pets. The 32bit one won't install because the important bits are buried in several layers of directories from your system.
Back to top
View user's profile Send private message 
meeki


Joined: 23 Jul 2012
Posts: 123
Location: Portland OR

PostPosted: Sat 07 Sep 2013, 21:04    Post subject:  

Keef wrote:
meeki

Check the file structure of your pets. The 32bit one won't install because the important bits are buried in several layers of directories from your system.


Yep, looks like I did botch the pet build.

Fixed it. rather fixed two letters in my rightclick dir2pet app for rox.
the dir structure you see is from building the pet not in the containing dir.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2384
Location: Japan

PostPosted: Fri 18 Oct 2013, 10:11    Post subject: getnvidia-0.9.9  

EDIT: Sorry, the getnvidia-0.9.9 was wrong in the permission of /root/Startup/nvidia.
Check the permission of /root/Startup/nvidia and add executable bits if it isn't, by 'chmod +x /root/Startup/nvidia'. Fixed in the getnvidia-0.9.9.1.

getnvidia-0.9.9.pet to install NVIDIA driver / build SFS/PET.
http://shino.pos.to/party/bridge.cgi?puppy/opt/

For 64bit Puppies, Fatdog 64 or Lighthouse 64, try
getnvidia-0.9.9-64.pet
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup64/

# 4sep2013: [Meeki] Must check xconfig file with nvidia-xconfig -t (see line(s) 255-258 & 296-304)
# 6sep2013: [Meeki] added LH64 to the skip of msg to run xorg after reboot (see line 286)
# 6sep2013: [Meeki] -a changed to -o meeki (see line 280)
# 6sep203: [Meeki] tons of edits (see line 284 to 290)
#v0.9.9: 17oct2013: nvidia sfs first, nvidia old version numbers, kernel version from Makefile

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html

Last edited by shinobar on Tue 22 Oct 2013, 06:00; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2384
Location: Japan

PostPosted: Tue 22 Oct 2013, 05:58    Post subject: getnvidia-0.9.9.1  

Sorry, the getnvidia-0.9.9 was wrong in the permission of /root/Startup/nvidia.
Check the permission of /root/Startup/nvidia and add executable bits if it isn't, by 'chmod +x /root/Startup/nvidia'. Fixed in the getnvidia-0.9.9.1.

getnvidia-0.9.9.1.pet to install NVIDIA driver / build SFS/PET.
http://shino.pos.to/party/bridge.cgi?puppy/opt/

For 64bit Puppies, Fatdog 64 or Lighthouse 64, try
getnvidia-0.9.9.1-64.pet
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup64/

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2384
Location: Japan

PostPosted: Tue 22 Oct 2013, 20:17    Post subject: getnvidia-1.0  

getnvidia-1.0.pet to install NVIDIA driver / build SFS/PET.
http://shino.pos.to/party/bridge.cgi?puppy/opt/

For 64bit Puppies, Fatdog 64 or Lighthouse 64, try
getnvidia-1.0-64.pet
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup64/

#v0.9.9.1: 22oct2013: fix was /root/Startup/nvidia not executable
#v1.0: 22oct2013: fix was LANG reset to en_US

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 47

PostPosted: Tue 14 Jan 2014, 18:43    Post subject:  

Thank you for all your effort on this getnvidia package!
Thank you for adding the ability to build a pet/sfs from an older nvidia*.run file!
Back to top
View user's profile Send private message Visit poster's website 
8-bit


Joined: 03 Apr 2007
Posts: 3274
Location: Oregon

PostPosted: Wed 12 Feb 2014, 00:37    Post subject:  

I am running Puppy Slacko 5.5 and mt video card is the Nvidia 7300 LE.
I tried both driver PETS that are associated with an Nvidia driver for it and neither worked.
I can live with using the nuveau driver, but thought I would pass my problem along.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 5 of 5 [68 Posts]   Goto page: Previous 1, 2, 3, 4, 5
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0546s ][ Queries: 13 (0.0064s) ][ GZIP on ]