Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 24 Sep 2014, 00:49
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Dpup Wheezy. Woof-CE built debian wheezy 7.2 packages used
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 32 of 48 [706 Posts]   Goto page: Previous 1, 2, 3, ..., 30, 31, 32, 33, 34, ..., 46, 47, 48 Next
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 9126
Location: Stratford, Ontario

PostPosted: Wed 20 Nov 2013, 01:07    Post subject:  

pemasu wrote:
That 01mickos`s tempicon is not only incompatible, it is also the reason of hotter laptop.

The older, simpler CPUtemp works in Wheezy.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7802
Location: qld

PostPosted: Wed 20 Nov 2013, 02:44    Post subject:  

rcrsn51 wrote:
pemasu wrote:
That 01mickos`s tempicon is not only incompatible, it is also the reason of hotter laptop.

The older, simpler CPUtemp works in Wheezy.

Well.. I did some debugging and it's the icons! I made a test program, just a super simple status icon with 1 of the temperature icons and the behaviour is reproduced. I'll get Joe on to it as it's been stable everywhere else, even in KDE.

Testprog:
Code:

#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <gtk/gtk.h>
#include <gdk/gdk.h>
#include <gdk/gdkkeysyms.h>
#include <glib/gstdio.h>

GdkPixbuf *temp75_pixbuf;

GError *gerror;
void tray_icon_on_click(GtkStatusIcon *tray_icon, gpointer user_data)
{
   gtk_status_icon_set_tooltip(tray_icon, ("Hello"));
   
}

static GtkStatusIcon *create_tray_icon()
{

   GtkStatusIcon *tray_icon;

   tray_icon = gtk_status_icon_new();
       
   g_signal_connect(G_OBJECT(tray_icon), "activate", G_CALLBACK(tray_icon_on_click), NULL);

   temp75_pixbuf=gdk_pixbuf_new_from_file("/etc/tempicon/temp75.svg",&gerror);
   gtk_status_icon_set_from_pixbuf(tray_icon,temp75_pixbuf);
     
   gtk_status_icon_set_visible(tray_icon, TRUE);
       
   return tray_icon;
}

int main(int argc, char **argv)
{
   GtkStatusIcon *tray_icon;

   gtk_init(&argc, &argv);
   tray_icon = create_tray_icon();
   gtk_main();

   return 0;
}


Of course you'll need /etc/tempicon/temp75.svg

Builds with gcc -Wall -o testing testicon.c `pkg-config --libs --cflags gtk+-2.0`

Kill it with killall testing (as long as you haven't got some other process name 'testing')
temp75.svg.gz
Description 
gz

 Download 
Filename  temp75.svg.gz 
Filesize  288 Bytes 
Downloaded  64 Time(s) 

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
anikin

Joined: 10 May 2012
Posts: 481

PostPosted: Wed 20 Nov 2013, 03:27    Post subject:  

Updated Debian 7: 7.2 released

October 12th, 2013

The Debian project is pleased to announce the second update of its stable distribution Debian 7 (codename "wheezy"). This update mainly adds corrections for security problems to the stable release, along with a few adjustments for serious problems. Security advisories were already published separately and are referenced where available.>>http://www.debian.org/News/2013/20131012

among many other things, they have addressed this one in the update:
Code:
lm-sensors - Skip probing for EDID or graphics cards, as it might cause hardware issues

http://packages.debian.org/search?searchon=sourcenames&keywords=lm-sensors
Any relevance to the problem?
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Wed 20 Nov 2013, 10:00    Post subject:  

My build used fresh debian wheezy packages. The release statement of packages:
http://http.us.debian.org/debian/dists/wheezy/main/binary-i386/Release

Archive: stable
Origin: Debian
Label: Debian
Version: 7.2
Component: main
Architecture: i386

The packages should be from Debian 7.2. So I should have included updated packages in use.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7802
Location: qld

PostPosted: Wed 20 Nov 2013, 10:10    Post subject:  

anikin wrote:
Any relevance to the problem?


Absolutely none.

Recently Joe introduced to JWM the ability for non square icons to show as rectangles in the system tray. I suspect it's ok for xpm, png, jpeg but for svg it's broken. I placed an issue on Joe's github page with a link to my above test program. He'll figure it out and at least let me know if it's my fault.. Laughing

EDIT: fixed now with square (instead of rectangular) icons <-- http://www.murga-linux.com/puppy/viewtopic.php?p=738387#738387

_________________
Woof Mailing List | keep the faith Cool |

Last edited by 01micko on Thu 21 Nov 2013, 02:28; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
spandey

Joined: 20 Sep 2012
Posts: 66

PostPosted: Wed 20 Nov 2013, 22:30    Post subject:  

Anyone using Wine with this Wheezy, can you please help me locating it?
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1009
Location: South of Belgium

PostPosted: Thu 21 Nov 2013, 01:51    Post subject:  

Hi, Very Happy
here using wine on puppy and currently wheezy for 4 years with full satisfaction Cool
locating wine ...download here:
http://murga-linux.com/puppy/viewtopic.php?t=53675
better is to use the latest version (although mine is 1.1.20 ... Shocked ...yes! some old ms compatible apps work better on that earlier wine version)
Cheers, charlie
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1009
Location: South of Belgium

PostPosted: Thu 21 Nov 2013, 02:06    Post subject:  

Hi Pemasu,
tons of thanks having upgraded wheezy...! ... and also glad to read from you !
BTW any idea on how to use the "psave" parameter in order to set the grub boot parameters to start on the pupsave ..oops sorry...the wheezysave-XXX specified after that parameter in /boot/grub/menu.lst?
Digging into initrd.gz, I did not find any psave parameter in the init script.
I have opened a thread on that question here...
http://murga-linux.com/puppy/viewtopic.php?t=90255
i suspect it has something to do with the DISTRO_FILE_PREFIX in the FINDING PUPPY FILES section of init script ... (...i should have to spent months to learn script writing before solving that question... Crying or Very sad )
thanks for any idea
charlie

Last edited by charlie6 on Thu 21 Nov 2013, 05:02; edited 1 time in total
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5762
Location: Kentucky

PostPosted: Thu 21 Nov 2013, 04:36    Post subject:  

Fresh manual frugal install....looks good.

# report-video
VIDEO REPORT: Dpup Wheezy, version 3.5.2.8

Chip description:
VGA compatible controller: NVIDIA Corporation NV18 [GeForce4 MX 4000] (rev a4)

Requested by /etc/X11/xorg.conf:
Resolution (widthxheight, in pixels): 1024x768
Depth (bits, or planes): 24
Modules requested to be loaded: dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
Driver loaded (and currently in use): nouveau
Loaded modules: dbe dri dri2 exa extmod fb fbdevhw glx kbd mouse record shadowfb

Actual rendering on monitor:
Resolution: 1024x768 pixels (270x203 millimeters)
Depth: 24 planes

...the above also recorded in /tmp/report-video

-Computer-
Processor : AMD Athlon(tm) 64 Processor 3800+
Memory : 2073MB (322MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Thu 21 Nov 2013 02:50:35 AM CST
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : VIA8237 - VIA 8251
Back to top
View user's profile Send private message 
Smithy


Joined: 12 Dec 2011
Posts: 431

PostPosted: Thu 21 Nov 2013, 05:31    Post subject:  

Nice distro.

Is it possible to put open box/ tint 2 on this, or is it strictly jwm?

I tried, but it goes to the modprobe screen and will only work as xwin jwm.

Just wondering generally, does the package manager update, for instance if there was a new wine or qtractor would that appear in the package manager? I usually just do this with pets, but was looking at the puppy package manager (offline ).
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 21 Nov 2013, 11:40    Post subject:  

Charlie6. I think that there isnt any 'psave' functionality in init script. I find no reference into it when I searched through init script. I think that you are on your own with 'psave' functionality. As you probably noticed pupsaves are recognized with PUPSAVE references...and there is a lot of them to create functionality in different situations. But no 'psave'.

Smithy. There is no reason why openbox with tint2 should not work. I believe that in the past people have used them a lot. Those who have used them, probably have ready made packages for it. I think I have provided them also...by just uploading them to some repos....
I believe I uploaded openbox-fbpanel-tint2 pets to the exprimo repo in smokey01.com. they should provide templates how to do it. I had 'wmswitcher' included in exprimo to provide easy windowmanager switching though and /etc/xdg/templates/_root_.jwmrc edited to show that wmswitcher in jwm main menu.
I havent played with them in dpup wheezy, since I have been happy with jwm. I use openbox with lxde in Lubuntu 64 bit and jwm with Puppy. So...happy experimenting.

PS. Radky probably have openbox related ready packages. He has recently updated that kind stuff in recent Lucid Puppy releases.
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 603
Location: Pennsylvania U.S.

PostPosted: Thu 21 Nov 2013, 14:13    Post subject: 3.5.2.8  

Geeeee... I'll try just once more to get this to the right thread Sad

Upgrade to 3.5.2.4

All went well (desktop icons to be fixed & background) but retained my wbar settings from 3.5.2.4 and...

'it's looking very good pemasu, thanks for continuing with puppy!'

On with the testing.

>>>---Indian------>
desktop-1.png
 Description   
 Filesize   139.54 KB
 Viewed   282 Time(s)

desktop-1.png


_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 603
Location: Pennsylvania U.S.

PostPosted: Thu 21 Nov 2013, 14:16    Post subject: 3.5.2.8  

Dup post Crying or Very sad
_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192

Last edited by sszindian on Thu 21 Nov 2013, 14:19; edited 1 time in total
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 603
Location: Pennsylvania U.S.

PostPosted: Thu 21 Nov 2013, 14:18    Post subject: 3.5.2.8  

For sure... not my day another dup Crying or Very sad
_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
anikin

Joined: 10 May 2012
Posts: 481

PostPosted: Thu 21 Nov 2013, 15:33    Post subject:  

pemasu,
I know you have already precompiled and included the eee module. It's playing tricks on me: it doesn't show up in proc (modprobes OK). And strangely, I found it in firmware, but it's place is acpi - have moved it into acpi folder - makes no difference Sad
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 32 of 48 [706 Posts]   Goto page: Previous 1, 2, 3, ..., 30, 31, 32, 33, 34, ..., 46, 47, 48 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0995s ][ Queries: 13 (0.0138s) ][ GZIP on ]