(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
https://forum.puppylinux.com
and continue your work there. Thank you.

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 30 Sep 2020, 18:18
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Dpup Wheezy. Woof-CE built debian wheezy 7.2 packages used
Moderators: Flash, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 34 of 53 [791 Posts]   Goto page: Previous 1, 2, 3, ..., 32, 33, 34, 35, 36, ..., 51, 52, 53 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5485
Location: Finland

PostPosted: Tue 26 Nov 2013, 15:31    Post subject:  

koulaxizis

Update Puppy Package Manager: OK! - But before the update i could see 6 repositories in total.
After the update i had 13 repositories (see screenshots)!! Which 5 repositories should i enable?

-------> When you update ppm, skip Packages-debian-wheezy-mmd_main, it causes the update databases to fail and afterwards you have update databases and real ones, which are not merged as they should. Yeah...it is bug or better....problem because I included that debian multimedia repo....but that repo has some nice apps and libs. I need that repo for compiling.
Yeah I would need help from able ppm master to fix that one.

SFS Downloader: From "Install" desktop icon -> "Click button to choose an SFS file from the official repo" - Can't find the repository (see screenshot).

--------> I dont have official repo yet. Under work. I hope I will have it. There is project ongoing.

Also, Firefox keeps asking me to install missing flash but can't find how to!

---------> Install libflashplayer. Older getflash was broken and I didnt know that there is newer one available when I woofed this one:
http://www.murga-linux.com/puppy/viewtopic.php?p=590805#590805

Why I didnt include libflashplaeyr.so. People with older comp have problem with newer libflash. Pentium III or Athlon probably need older version. Newer comp owners should use latest security updated one. You choose.
Back to top
View user's profile Send private message 
koulaxizis


Joined: 17 Jul 2011
Posts: 455
Location: Greece

PostPosted: Tue 26 Nov 2013, 15:53    Post subject:  

pemasu wrote:
koulaxizis

Update Puppy Package Manager: OK! - But before the update i could see 6 repositories in total.
After the update i had 13 repositories (see screenshots)!! Which 5 repositories should i enable?

-------> When you update ppm, skip Packages-debian-wheezy-mmd_main, it causes the update databases to fail and afterwards you have update databases and real ones, which are not merged as they should. Yeah...it is bug or better....problem because I included that debian multimedia repo....but that repo has some nice apps and libs. I need that repo for compiling.
Yeah I would need help from able ppm master to fix that one.

SFS Downloader: From "Install" desktop icon -> "Click button to choose an SFS file from the official repo" - Can't find the repository (see screenshot).

--------> I dont have official repo yet. Under work. I hope I will have it. There is project ongoing.

Also, Firefox keeps asking me to install missing flash but can't find how to!

---------> Install libflashplayer. Older getflash was broken and I didnt know that there is newer one available when I woofed this one:
http://www.murga-linux.com/puppy/viewtopic.php?p=590805#590805

Why I didnt include libflashplaeyr.so. People with older comp have problem with newer libflash. Pentium III or Athlon probably need older version. Newer comp owners should use latest security updated one. You choose.


Thank you for your really fast and detailed answer as well as for your hard work!

As you probably know, i'm not a developer, not even an experienced user.
But if i can help somehow just say it! I'm very interested in this project! Wink

_________________
Christos Koulaxizis
Woof woof from Greece!

[ Puppy Stuff Repository ]
Back to top
View user's profile Send private message Visit poster's website 
Smithy


Joined: 12 Dec 2011
Posts: 1157

PostPosted: Tue 26 Nov 2013, 16:13    Post subject:  

Pemasu, is open box already built into this puppy?

I ask because after I added a wallpaper, openbox config appeared in the menu. It wasn't there previously. I am wondering if I have accidently put it in or whether it is in there already.

Anyways I have tried a combination of tint2 and open boxes to test, and it seems to have MAJOR problems trying to work.
When you run wheezy with openbox, there are scores of desktops appearing (more than twelve at least). There's a fight going on somewhere with Tint2 and Jwm I think.

Jwm looks ok if it could be tarted up a bit (semi transparent taskbar maybe and a few icon changes). I've only just found the jwm editor, so newbie mode is on!

The rest of it is great so far.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5485
Location: Finland

PostPosted: Tue 26 Nov 2013, 16:21    Post subject:  

# find /mnt/sda7/woof/dpup-wheezy-november/woof-out_x86_x86_debian_wheezy/packages-wheezy -name "*openbox*"
#

Didnt find anything with openbox in filename or in folder name. I would say Dpup Wheezy is stripped of any openbox related. I also havent included anything purposely.

I just dont have time now to tackle with openbox - tint2 combo. I hope someone experienced with openbox and using it would take the challenge and create wheezy compatible pets for it.
Back to top
View user's profile Send private message 
Smithy


Joined: 12 Dec 2011
Posts: 1157

PostPosted: Tue 26 Nov 2013, 16:32    Post subject:  

Cheers Pemasu, it must have been me bu**gering about with your distro.
Will try a clean start again on it. Thanks.
Back to top
View user's profile Send private message 
Satori

Joined: 14 Jan 2013
Posts: 47

PostPosted: Tue 26 Nov 2013, 18:28    Post subject: tempiconsvg 0.21  

YEA!!! I see that TempIconSVG was updated to 0.21 and is fixed with the new JWM,
it works well with no problems.

Since Woof2 is meant to build a consistent Puppy from any Linux Distro's executable/binaries,
does this mean there's a dPup-64 in our future Smile

Thanks!
Back to top
View user's profile Send private message 
koulaxizis


Joined: 17 Jul 2011
Posts: 455
Location: Greece

PostPosted: Thu 28 Nov 2013, 08:06    Post subject:  

Hm... seems like my PPM is now broken (can't open!) because i didn't skip the problematic repository the first time. Do you know how i can fix it?
_________________
Christos Koulaxizis
Woof woof from Greece!

[ Puppy Stuff Repository ]
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5485
Location: Finland

PostPosted: Thu 28 Nov 2013, 10:14    Post subject:  

koulaxizis
Remove /root/.packages/Packages-*

Copy from /initrd/puppy_r02/root/.packages/Packages-*
to the /root/.packages

So that you get the original versions back.
Back to top
View user's profile Send private message 
koulaxizis


Joined: 17 Jul 2011
Posts: 455
Location: Greece

PostPosted: Thu 28 Nov 2013, 10:24    Post subject:  

pemasu wrote:
koulaxizis
Remove /root/.packages/Packages-*

Copy from /initrd/puppy_r02/root/.packages/Packages-*
to the /root/.packages

So that you get the original versions back.


Thanks mate!! Very Happy

_________________
Christos Koulaxizis
Woof woof from Greece!

[ Puppy Stuff Repository ]
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 5524
Location: Ontario

PostPosted: Thu 28 Nov 2013, 18:41    Post subject:  

I was able to install the latest wheezy on a USB Card reader
using Boot flash by Barry Kauler (/usr/sbin/bootflash)

I then used a PLOP CD to boot up since my USB is unbootable.

my settings in boot flash..

_____________________________________________
Back to top
View user's profile Send private message 
Schpankme


Joined: 09 Nov 2013
Posts: 51

PostPosted: Thu 28 Nov 2013, 20:01    Post subject:    

koulaxizis wrote:


... Dpup Wheezy 3.5.2.8
... Firefox keeps asking me to install missing flash but can't find how to!
... help with these problems?


http://puppylinux.org/wikka/libflashplayer

Update Flash Player

- Get Flash at: http://get.adobe.com/flashplayer/?no_redirect

- select .tar.gz

- extract libflashplayer.so

- copy to folder / replace any existing file at: /usr/lib/mozilla/plugins/libflashplayer.so


All my knowledge comes from Puppy Search: http://www.wellminded.com/puppy/pupsearch.html
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1268

PostPosted: Thu 28 Nov 2013, 21:13    Post subject:  

pemasu wrote:
I just dont have time now to tackle with openbox - tint2 combo. I hope someone experienced with openbox and using it would take the challenge and create wheezy compatible pets for it.


Done:
http://murga-linux.com/puppy/viewtopic.php?t=86206

Note: Obconf doesn't work, but there's Lxappearance with Obconf plugin. The package (6 MB) is twice the size of the original OpenboxPlus (3 MB) because of the dependencies for Lxappearance. Also, fixing menus doesn't fix Openbox right-click menu. Any feedback and fixes are appreciated.
tint2.jpg
 Description   Dpup Wheezy, Openbox, Tint2
 Filesize   20.16 KB
 Viewed   377 Time(s)

tint2.jpg

lxpanel.jpg
 Description   Dpup Wheezy, Openbox, Lxpanel
 Filesize   24.65 KB
 Viewed   389 Time(s)

lxpanel.jpg


_________________
Puppy Linux en español
Back to top
View user's profile Send private message 
Smithy


Joined: 12 Dec 2011
Posts: 1157

PostPosted: Fri 29 Nov 2013, 18:17    Post subject:  

Vicmz, it might be worth contacting Tman, I think he knows about tint and open box, his tinted slacko is excellent.

Tinted works well in Lucid, but it is a wreck in not just Wheezy.
I have "forced" it using a combination of exprimo openbox and openbox plus, but the jwm menus that are "nested" like desktop/desktop and system/system just carry on for eternity and fill the screen.
The menus that are just one thing like graphics/ show up as expected.
I think if you terminal "fixmenus" in jwm and then restart in openbox sometimes the new menus appear, sometimes not.
Back to top
View user's profile Send private message 
bohocmasni

Joined: 01 Jun 2012
Posts: 20
Location: Hungary

PostPosted: Sat 30 Nov 2013, 03:57    Post subject:  

Pemasu, did you set an auto update mechanism for firefox and such programs?
I can't prevent firefox from upgrading by choose "never check for updates", i must think that puppy does this.

_________________
http://www.youtube.com/watch?v=G6D1YI-41ao
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5485
Location: Finland

PostPosted: Sat 30 Nov 2013, 14:10    Post subject:  

I am curious to know how this autoupdate happened.
Curious because I have latest Firefox atm. I think it is quite impossible to test if the autoupdate works or not.
Or...I have missed something.
And no...I havent installed anything which should prevent that never check for updates to be active.

I just believe you cant test if it is working or not, because there isnt anything to update....yet. Lets wait about 2 - 4 weeks and we are more wise.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 34 of 53 [791 Posts]   Goto page: Previous 1, 2, 3, ..., 32, 33, 34, 35, 36, ..., 51, 52, 53 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1699s ][ Queries: 13 (0.0925s) ][ GZIP on ]