Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 16 Apr 2014, 09:44
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
QtWeb - fast portable browser
Post new topic   Reply to topic View previous topic :: View next topic
Page 5 of 6 [84 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
Dewbie

Joined: 15 Apr 2010
Posts: 1763

PostPosted: Sat 14 Dec 2013, 22:15    Post subject:  

zaivala wrote:
Quote:
OK,am I supposed to download both files (-1 and -2) or just -2?

Just -2.

01 micko, who maintains the Ibiblio Puppy repo, said -1 has to stay there or some will get confused when it won't download from ppm (without an update).
Back to top
View user's profile Send private message 
zaivala

Joined: 21 Mar 2011
Posts: 105

PostPosted: Sun 15 Dec 2013, 10:10    Post subject:  

Got it. Works great. However... it is now the "previous version"... are we getting up update pet soon?
Back to top
View user's profile Send private message 
Dewbie

Joined: 15 Apr 2010
Posts: 1763

PostPosted: Sun 15 Dec 2013, 15:08    Post subject:  

zaivala wrote:
Quote:
Got it. Works great. However... it is now the "previous version"... are we getting up update pet soon?

Have a look at musher0's post over here.
Since I run Wary (and older Pups), I had the same issues with those missing libs.
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 358

PostPosted: Thu 26 Dec 2013, 14:27    Post subject: qtweb 3.8.4-2 flash not working
Subject description: pulp03 (puppy 4.1.2)
 

/usr/lib/mozilla/plugins/libflashplayer.so (flash 11.2)
user agent opera (or firefox)
Flash works in opera and firefox, which I installed portably not as pets.
(Unpackaged in their own directories, cd to where the binary is located, ./opera).
I also simply unpackaged the qtweb pet tar -zxvf and start it the same way.

Someone reported it working in pulp03 with user agent opera and plugin as above.
Was this with portable or installed qtweb and opera?

Wary 5.5 runs so slowly on here it is not worth trying to make work with qtweb/flash but I think I had the same problem.
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2082
Location: New Zealand

PostPosted: Thu 26 Dec 2013, 14:37    Post subject: Re: qtweb 3.8.4-2 flash not working
Subject description: pulp03 (puppy 4.1.2)
 

sindi wrote:
Someone reported it working in pulp03 with user agent opera and plugin as above.
Was this with portable or installed qtweb and opera?

Hi sindi, that was my comment here:
http://murga-linux.com/puppy/viewtopic.php?p=680579#680579
I was definitely not using the portable version (as I don't know how to do that yet...).

It was a while ago so I don't remember the specifics of what I did (sorry), I just know I installed some version of qtweb from a pet. I may be able to work out what I did if you haven't already moved past the problem...
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 358

PostPosted: Thu 26 Dec 2013, 15:27    Post subject: portable qtweb  

I simply downloaded the 3.8.4-2 pet from ibiblio (the first 'here')
and unpacked it with tar -zxvf instead of installing it, to make it
'portable'. I then cd to the directory containing the binary.
This works for opera, firefox, seamonkey. I can then keep all the
browsers in one partition outside of the various puppies, and load
them by cd'ing to the location of the binary and ./QtWeb ./opera etc.
I make scripts to do this in /usr/local/bin. Keeps the save file
smaller and I only need to update one copy of each browser for
several puppy versions (or other linuxes).

If you do this, does flash still work for you with opera as user agent?
Back to top
View user's profile Send private message 
Dewbie

Joined: 15 Apr 2010
Posts: 1763

PostPosted: Fri 27 Dec 2013, 01:48    Post subject:  

greengeek wrote:
Quote:
I was definitely not using the portable version (as I don't know how to do that yet...).

BarryK covered that over here.
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 358

PostPosted: Fri 27 Dec 2013, 23:20    Post subject: qtweb tested with various puppys  

QtWeb works with Youtube in wary 5.5, which loads programs and runs so
slowly that Youtube is too jerky to be watchable though cpu usage is
only 90%, and even after reducing resolution to 144p.

Works well with puppy 4.3.1 including Youtube.

With Pulp 03 (4.1.2) Youtube site cannot find Flash player, when
identified as any of the listed browsers. Does flash need newer
libraries from seamonkey 1.1.8 (as in Puppy 4.3.1) or 2.6.1 (wary 5.5)?
Pulp comes with a very old Firefox. ldd libflashplayer found nothing
missing.

Someone reported flash working with qtweb/pulp03. They installed all
their browsers. Mine are all standalone.
Back to top
View user's profile Send private message 
linuxcbon

Joined: 09 Aug 2007
Posts: 749

PostPosted: Sat 28 Dec 2013, 00:13    Post subject:  

I already asked that question, no answer, so I gave it up.
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2082
Location: New Zealand

PostPosted: Mon 30 Dec 2013, 04:52    Post subject:  

linuxcbon wrote:
- I cannot get flash to work if removing seamonkey ? anyone know where to set flash ? variables ? files ?

Hi linuxcbon - it might be worth trying this pet which loads the extra libs that QtWeb needs to play flash:
http://www.murga-linux.com/puppy/viewtopic.php?p=612073#612073
Without these libs QtWeb reports that it can't find the flashplayer which is installed in /usr/lib/mozilla/plugins
(but not all versions of libflashplayer.so will work in QtWeb even if the file is in that correct directory).
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2082
Location: New Zealand

PostPosted: Mon 30 Dec 2013, 05:42    Post subject: Re: qtweb 3.8.4-2 flash not working
Subject description: pulp03 (puppy 4.1.2)
 

sindi wrote:
Someone reported it working in pulp03 with user agent opera and plugin as above. Was this with portable or installed qtweb and opera?
.

I have made some further trials using Pulp03 with QtWeb and flash and have now added a tutorial to the Pulp03 thread.

I still haven't tested it as a portable version, but maybe my workarounds might help find a solution for that also?
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 358

PostPosted: Mon 30 Dec 2013, 14:03    Post subject: qtweb works in pulp 003 with flash 10  

Flash 10.1 and 10.3 work with QtWeb and Pulp03.

Flash 11 was the culprit. As the tutorial says,
older Puppies don't have the libraries it needs.

I also read that it does not work as well on
older hardware. Maybe I will now have fewer
freezes (which Adobe says to 'fix' by stopping
and starting the video).

Copy libflashplayer.so to /usr/lib/mozilla/plugins.
(Or symlink it from a location where several
puppies can share it, to keep save file smaller.)

QtWeb is 3.8.4 (second-most-recent) pet, unpackaged
portably (outside of the file system). To start it:
cd to location of the binary and ./QtWeb
(So yes, portable QtWeb works, so does later version.)

The tutorial for Pulp provides a library pet for
those who don't have SM or Opera (or recent FF)
installed. I use them portably not installed.
I add their location to lib path in /etc/profile
to provide libraries needed by flash.

Thanks for a carefully researched tutorial.

The 36MB or so of QtWebkit 4 libraries are provided
in yesterday's pet of Slimboat browser (1.1.44),
(along with glibc 2.11.3 libraries). Could in
theory be used with dynamically compiled QtWeb.
Back to top
View user's profile Send private message 
Dewbie

Joined: 15 Apr 2010
Posts: 1763

PostPosted: Thu 02 Jan 2014, 01:53    Post subject:  

sindi wrote:
Quote:
Flash 11 was the culprit. As the tutorial says,
older Puppies don't have the libraries it needs.

Have you tried 11.1.102.63 from here?
I haven't tested it with QtWeb, but it's the last one that works with my older Pups.
(Anything later in 11-series, forget it...)
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2082
Location: New Zealand

PostPosted: Thu 02 Jan 2014, 04:08    Post subject:  

Dewbie wrote:
Have you tried 11.1.102.63 from here?
I haven't tested it with QtWeb, but it's the last one that works with my older Pups.
Are you able to list some of the pups this worked with? I have a feeling Pulp03 lacks a lib or two that are present in other pups of the same vintage and I'm keen to try to track down which pups might have a suitable donor lib.
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 358

PostPosted: Thu 02 Jan 2014, 13:19    Post subject: qtweb not working at some sites  

Yesterday flash stopped working again. I also had some odd behavior while trying to view http://www.tomshardware.com - froze up, messed up video, unable to exit. Today I discovered that plugins were now disabled under Privacy. Unchecking that fixed flash again. I was poking around the menu trying to figure out why http://www.centurylink.com (internet provider) works fine with lynx but won't load with QtWeb by turning on cookies - I get three cookies from the site but no webpage. Several other pages looked like they were loading but nothing appeared onscreen. This is NOT going to be my main browser.

QtWeb and flash work with the Opera 10.6 which comes with KLP linux (updated 4.3.1 puppy) and Flash 10.1 or 10.3 but I can play only ONE video, after which I cannot enter a search term (clicking in that box does nothing - no blinking vertical line) or play any of the other suggested videos - it acts like the mouse is nonfunctional. I upgraded glibc to 2.11.2 (used a deb package) and upgraded Opera to 12.15, with the result that the newer Opera would not do flash at all. (The older Opera I think still plays one video).

KLP linux is klp-006.iso at 4shared.com. You can sign in with a Google account.

Last I checked, QtWeb/Flash worked with Puppy 4.3.1 retro kernel 2.6.21.7 (the one used by pulp linux - both standard in 4.1.2). I did not check it with the standard 4.3.1 kernel 2.6.30, which is also used by KLP.

Supposedly Youtube can be viewed with an HTML5 browser instead of with Flash,
but Opera is still missing some capability required. Can QtWeb play Youtube using HTML5?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 5 of 6 [84 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0737s ][ Queries: 13 (0.0058s) ][ GZIP on ]