Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 20:59
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Dropbox
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [35 Posts]   Goto page: Previous 1, 2, 3
Author Message
cimarron

Joined: 30 May 2013
Posts: 122

PostPosted: Sun 22 Sep 2013, 09:23    Post subject:  

Using the portable app (from the first post in this thread) I got Dropbox working on my Lupu 5.1, but it was a bit difficult. It runs, even without python installed, but the icon never appears in the tray.

I had to run the portable Dropbox executable in the terminal the first time, so that it would provide the URL to link my computer to my Dropbox account. After that, it created the Dropbox folder in my root directory and began syncing. No controls for the syncing, though.

But I discovered I could use the CLI script (dropbox.py) to control syncing. That script does require python, and Technosaurus's python sfs did the trick for me. The CLI script allowed me to exclude some folders from syncing, as well as several other useful functions. Once I got it working the way I wanted, I didn't need the CLI script (or python) any more. I just run the portable app executable and it syncs.

I also found I could move the Dropbox folder to my hard drive (out of my save file) as long as I put a link to the Dropbox folder in my root directory. That way the save file doesn't get filled up.


p.s. If anyone's interested, I cleaned this all up and made an sfs out of it:

Dropbox-1.1.43.sfs (19.5 MB)

It includes the portable app, python 2.6.4, and the dropbox.py script. When the sfs is mounted, there's a Dropbox launcher in /usr/share/applications (not sure if it gets placed in the menu properly). Still no tray icon, at least for me.

The Dropbox folder, with synced files, is placed in the root folder.

And I simplified the dropbox.py commands a little (getting rid of the need for the path and the ".py"). With the sfs, these commands work in the terminal:

"dropbox help" displays command options
"dropbox stop" stops the Dropbox daemon, so syncing stops
"dropbox status" gives status of syncing, number of files, time remaining, etc.
"dropbox exclude [list/add/remove]" can also be used to selectively sync (as explained in CLI script info page)

Some of the other CLI script commands may also work. "Start" does NOT work to start or restart Dropbox. I added the command "dropbox-1.1.43" (in /usr/bin) to start Dropbox if it's desired to start it from the terminal. Otherwise, the application launcher works. There's nothing included to start Dropbox automatically on boot, as I don't do that. But a link to /usr/bin/dropbox-1.1.43 could easily be added to the Startup folder.

Important: As I said before, the first time this is run, you'll probably have to run "dropbox-1.1.43" in the terminal, so it displays the url to link your computer to your Dropbox account. After that, the application launcher (or link in Startup folder) works fine.


p.p.s. In this sfs Dropbox will NOT automatically install a newer version. It attempted to do that in another sfs I tried--very annoying.
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4427

PostPosted: Sat 15 Feb 2014, 20:42    Post subject:  

I am just adding this to my watch list. I wrote a dropbox uploader gui that uses only shell (only a couple kb), xdialog and curl. I'll post it sometime if someone wishes to use/maintain it; however, I no longer use a dropbox account, so it may need to be significantly updated to even work.
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
Chariblaze

Joined: 17 Aug 2014
Posts: 1

PostPosted: Sun 17 Aug 2014, 06:44    Post subject:  

The portable version has worked great for me in Precise 2.7.1, but is there an updated version anywhere? Dropbox sent me an email saying they'll be deactivating the current version next week.
Back to top
View user's profile Send private message 
grump


Joined: 10 Oct 2011
Posts: 104
Location: Melbourne, Oz

PostPosted: Sun 17 Aug 2014, 23:16    Post subject:  

Me too. Currently I use the dropbox .sfs on precise. Today I tried the .deb from dropbox but nothing happened.
Back to top
View user's profile Send private message 
Puppus Dogfellow


Joined: 07 Jan 2013
Posts: 692
Location: nyc

PostPosted: Mon 18 Aug 2014, 00:12    Post subject: i also got the notification about an antiquated dropbox
Subject description: was able to install 2.10.28 from the terminal with help (i'm guessing) from that python file...
 

grump wrote:
Me too. Currently I use the dropbox .sfs on precise. Today I tried the .deb from dropbox but nothing happened.


on a 5.7.1 precise install i installed the deb and checked which dropbox in the terminal. i checked the file in geany and saw that somewhere it said it was version 1.6.0 or so. i know the version i installed was 1.143 so something was changed somewhere. dropbox restarted correctly without missing a beat or losing the taskbar icon.

on a 5.5. install i decided that i should download that cli file as well and stick it in my-applications. when i checked the dropbox file in bin same version (1.6.0--"this file is part of nautilus ..."--something like that) but different result. dropbox wouldn't restart. so i tried from a terminal and was told i needed to
Quote:
Run "dropbox start -i" to install the daemon
and now it's indexing all the files as Dropbox 2.10.28....seemed to do the 10000 pretty quickly...

i'll recheck to see if the 571 in fact just ignored the deb or was (hopefully) just slicker about installing it on top of what's there, since there's apparently no reconfiguring necessary.

hth

update: the deb was ignored by the 571 machine--it's still running 1.1.43 (i guess that's one way to not miss a beat) and the cli stuff didn't have the same effect. the response was "bad interpreter" for both start and dropbox start -i.

Confused

upon restart, i had to reinstall > use previous settings > wait for the list to again be indexed.

think i'll try 1.16.16. it's worked before but isn't set up to autorestart out of the box (2.10 doesn't autorestart despite the link being in the startup folder. even worse, it doesn't seem to be aware that it's already been installed...).

dropbox-1.6.16_x86.pet (32 bit)

dropbox-1.6.16_amd64.pet (64 bit)

there's also these two by Whitesnow:

MyCp, interactive Copy installer (cloud storage utility)
MyDbox,interactive Dropbox installer (cloud storage utility)

update 2: Whitesnow's pet worked perfectly on two 571 installations. kept settings, effortless. needs to be launched with start dropbox command on the setups where i installed it over the 1.1.43 pet.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 3 [35 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0623s ][ Queries: 13 (0.0047s) ][ GZIP on ]