Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 30 Sep 2016, 04:28
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
flowblade Video Editor for Precise, Raring,Tahr & Vivid
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message

Joined: 16 Jun 2008
Posts: 1421
Location: 500 seconds from Sol

PostPosted: Fri 17 Jan 2014, 21:02    Post subject:  flowblade Video Editor for Precise, Raring,Tahr & Vivid  

Edited to delete material no longer pertinent in the light of 666philb's post and SFS link, and my following posts.

Edit May 26, 2015: For Tahr and Vivid, skip down to here: http://murga-linux.com/puppy/viewtopic.php?p=847772#847772

Edit June 2, 2015: To make your life easier, if you run Carolina, precise or raring, follow this link: http://www.murga-linux.com/puppy/viewtopic.php?p=788360&sid=6664048b2884380d9bb352a95624e943#788360 and see my post further down regarding installing both flowblade and openshot. My recollection is that version 0.16 did run under raring. But if I've mis-recalled, I am certain that version 0.14 did. You can find it here: http://puppylinuxstuff.meownplanet.net/battleshooter/Carolina/Flowblade/

Why flowblade when we have a couple of simple video tools and a couple of complex video editor?. Well, if you worked with video in XP you'll remember Movie Maker and how easy it was to use multiple source videos, select portions of each, arrange those cuts in any manner and generate a new video. Well, flowblade is like that, only better. The videos used as source material for Movie Maker are limited: permitting only a couple of video and audio codecs and containers; and it only renders the finish product as a wmv. To create a new vid with flowblade, source material having different codecs and containers can be used; and you can choose the format for your finished video.

Watch the vid: http://vimeo.com/40929685

2 move tools
3 trim tools
4 methods to insert/overwrite/append a clip on the timeline
Drag'n'Drop clips on the timeline (--including from preview window)
Clip and Compositor parenting with other clips
Max 9 combined video and audio tracks available
Image compositing
7 compositors. Mix, zoom, move and rotate source video with keyframed animation tools
19 blends. Standard image blend modes like Add, Hardlight and Overlay are available
41 pattern wipes.
Image and audio filtering
50+ image filters. Color correction, image effects, distorts, alpha manipulation, blur, edge detection, motion effects, freeze frame
30+ audio filters. Keyframed volume mixing. Echo, reverb, distort and many other audio effects
Supported editable media types
Most common video and audio formats
JPEG and PNG image file types
SVG vector graphics
Numbered frame sequences
Output encoding
depending on installed MLT/FFMPEG support videos can be rendered with mpeg2, mp4, h264, Theora video codecs and Mp2, mp3, ac3 audio codecs into many container formats
User can define rendering by setting FFMpeg args

Edit: Thanks to 666philb's SFS, I have it running under upup precise 3.8.x, albeit some (all?) of the frei0r filters may not work, and it apparently can't be used to directly render DVDs. See following posts. Like any "full-featured" application, there's an appreciable learning curve to figuring out how to make the most of the GUI. Suggest googling for tutorials/manuals: (there are three vids) and a wiki worth downloading as a pdf.

flowblade home page: http://code.google.com/p/flowblade/


P.S. There's also a ubuntu 32-bit version of Shotcut, the really nice video editor kirk and James Bond included in FatDog64-630. I haven't examined at all the potential for creating a version for 32-bit Puppies. Note, however, Shotcut doesn't enable cutting or trimming clips, recommending avidemus or virtualDub for that function.

Last edited by mikeslr on Mon 01 Jun 2015, 22:38; edited 6 times in total
Back to top
View user's profile Send private message 

Joined: 07 Feb 2010
Posts: 3010
Location: wales

PostPosted: Fri 31 Jan 2014, 14:33    Post subject:  

hi mikeslr

i remember getting this to fire up a while ago when it was in the requests section.... and whilst it loaded ..... i couldn't figure out how to import any clips into it.

tried it again just now and still can't ! Smile

anyway here it is for precise puppy https://copy.com/2ymh7KngsK07

you'll also need the devx loaded ...... and QT from quickpet (in my sig below)
there could well be lots of dependencies missing (python-gnome2 for one ... it's in the PPM)

anyway ... see if you have more luck than me at getting it to do something

Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 

Joined: 16 Jun 2008
Posts: 1421
Location: 500 seconds from Sol

PostPosted: Sun 02 Feb 2014, 13:22    Post subject: You almost got flowblade right  

Hi 666philb,

Actually, you've almost got it.
Last night I downloaded your SFS but it was to late to start playing with it. It's my habit to boot up a Pup and see what's new in Puppyland to clear my head before embarking on breakfast. That's a survival mechanism as I'm insulin dependent and before eating breakfast I have to inject 4 units of novolog (short-term insulin to handle the immediate influx of sugar) and 28 units of levemir (long term to handle sugar from the slow break-down of starch) and if, fuzzy headed, I inject 28 units of novolog there's a good chance it could kill me.
At any rate, I booted into Upup-precise 3.8.3, opened opera to your response and re-read your instructions. Figuring that after breakfast I'd start with a virgin upup, I was interested in examining the problem you mentioned of not being able to load vids. As openshot-1.4.3.sfs –which contains a version of python-- was already loaded on this Pup, I decided it might not be necessary to load devx.sfs. And, as I had qt-4.8.2.sfs sitting in /mnt/home, I decided not to take the time to download the version you suggested. So I loaded qt-4.8.2, and then your flowblade.
Although flowblade loaded, there was no menu entry. [I later opened it's desktop file in /usr/share/applications, and moved the declaration “AudioVideo” to the front of category arguments. Vicmz's OpenboxPlus is pretty good at sorting things out, but I think gets confused when the first declaration is gtk]. At any rate, having started flowblade via a terminal, the below report was generated. I've truncated it to so it shows only the beginning and the problems encountered. Reviewing it gave me a clue as to the “can't load vids” problem. Initially, I couldn't load any either. But then it occurred to me to check what preferences had been set by default. If I remember correctly, PAL-something was the default. And from the below noted complaints, PAL was among the “missing.” By changing the preference to HD 1080i 25 fps, I was able to load an mp4.
It's Super-bowl Sunday so I won't be able to test flowblade as a fresh install following your instructions until tomorrow. But I suspect that even then the “missing” won't be found. I'm not sure why the “frei0r”--stuff isn't found as pfind indicates it's been installed. Haven't a clue as to the missing PAL and NTSC stuff.

Terminal report at flowblade startup:

Launch script dir: /usr/bin
Running from installation...
MLT found, version: 0.7.7
Python 2.7.3 (default, Aug 1 2012, 05:16:07)
[GCC 4.6.3]
GTK+ version: (2, 24, 10)
Locale: en_US
Detecting environment..

MLT detection succeeded, 108 formats, 55 video codecs and 28 audio codecs found.
283 MLT services found.
Loading render profiles...
Lossless HuffYUV / .avi...NOT available, audio codec pcm_s16le missing
AVI DV PAL 4:3...NOT available, audio codec pcm_s16le missing
AVI DV PAL 16:9...NOT available, audio codec pcm_s16le missing
AVI DVCPRO25 PAL 4:3...NOT available, audio codec pcm_s16le missing
AVI DVCPRO25 PAL 16:9...NOT available, audio codec pcm_s16le missing
AVI DVCPRO50 PAL 4:3...NOT available, audio codec pcm_s16le missing
AVI DVCPRO50 PAL 16:9...NOT available, audio codec pcm_s16le missing
AVI DV NTSC 4:3...NOT available, audio codec pcm_s16le missing
AVI DV NTSC 16:9...NOT available, audio codec pcm_s16le missing
AVI DVCPRO25 NTSC 4:3...NOT available, audio codec pcm_s16le missing
AVI DVCPRO25 NTSC 16:9...NOT available, audio codec pcm_s16le missing
AVI DVCPRO50 NTSC 4:3...NOT available, audio codec pcm_s16le missing
AVI DVCPRO50 NTSC 16:9...NOT available, audio codec pcm_s16le missing
Proxy encoding MPEG-4 Preset Ultrafast ...available
Proxy encoding MPEG-2 Transport Stream ...available
Loading filters...
MLT service frei0r.alphagrad not found.
MLT service frei0r.alphaspot not found.
MLT service frei0r.alpha0ps not found.
MLT service frei0r.select0r not found.
MLT service frei0r.spillsupress not found.
MLT service frei0r.vignette not found.
MLT service frei0r.emboss not found.
MLT service frei0r.dither not found.
MLT service frei0r.colorhalftone not found.
MLT service frei0r.softglow not found.
MLT service frei0r.IIRblur not found.
MLT service frei0r.rgbnoise not found.
MLT service movit.saturation not found.
MLT service frei0r.coloradj_RGB not found.
MLT service frei0r.colorize not found.
MLT service frei0r.colgate not found.
MLT service frei0r.posterize not found.
MLT service frei0r.colortap not found.
MLT service frei0r.sigmoidaltransfer not found.
MLT service frei0r.cairoimagegrid not found.
MLT service frei0r.hqdn3d not found.
MLT service frei0r.sharpness not found.
Loading transitions...
MLT transition frei0r.cairoaffineblend not found.

[Using the frei0r and cairo debs I had previously downloaded, I created an SFS which I loaded. The missing remained missing].

Edit: Decidedly odd. Had a few moments so unpacked another copy of upup precise to a new folder, named it vidprecise, added it to Menu.lst, booted into it and created a Savefile. Rebooted into vidprecise, loaded the devx and recommended qt.sfs, then flowblade. Changing preferences didn't enable me to load an mp4 into flowblade. Unloading devx, the recommended qt, and flowblade; then loading openshot, qt-stripped and flowblade --so that I had, I thought, the system which enabled the loading of an mp4 mentioned above,m still didn't allow me to lod the mp4 I had previously loaded. Maybe it needs a reboot.
Nope. Reboot didn't help.
P.S. Starting flowblade via terminal in "new pup" gives the idential "missing" report as above

Back to top
View user's profile Send private message 

Joined: 16 Jun 2008
Posts: 1421
Location: 500 seconds from Sol

PostPosted: Sun 02 Feb 2014, 23:25    Post subject: Loading clips into flowblade  

Ok. I think I figured out the difference between my initial success in loading a clip, and my subsequent failure. I must have done the following before I was entirely awake, and forgot about it by the time I wrote the abov post. What has to be done is either or all of the following before trying to load a clip. It’s been several hours since I first did them, and I didn’t try to load a clip until two or all had been done on my next go-round. Best guess is that only the first may actually be necessary. If not, try the 1st and 3rd steps. I don’t think my original exploration included the second.

Edit: 16 Feb 2014:
Step "0" may be required. Start flowblade by typing "flowblade" --without the quotes-- in a terminal, and note which codec/modules are not found. From the Edit Menu, select preferences and choose something other than the Dv/DVD PAL default or NTSC choices as these modules were not found. Then,

1. Select Profiles Manager from the Edit Submenu. From the Right Side of the window which opens, select one or more of the profiles under the caption “Create User Profile”. I think its best to remember which codec weren’t found. At any rate, I selected HD 1080i 29.7 fps and 25 fps. Click “Save New Profile”. [Perhaps I forgot this click on my second-go-round]. Click “OK" to the dialog telling you you can now use the new profile. Then click “Close Manager.” [flowblade may hang. If so, use your process manager (on the systems submenu) to terminate it, or --waste case-- simultaneously press ctrl-alt-backspace to exit X; then type xwin to restart it. Start flowblade; it will have saved you new profile].
2. From the Project Submenu, click “Proxy Manager.” Then select from among the Proxy Encoding options, and between “Use Proxy Media” and “Use original Media.” Then close that Manager.
3. Then from the File Submenu, click “Save As”, give your project a name, and select a folder where it will be stored.
At any rate, following all the above I was again able to load clips via “Project Add Media Clip” an mp4 I had downloaded it from Youtube using Firefox with the “Download Video Helper” addon. On Youtube, the clip is named “Simon’s Cat in Cat-man-do”, http://www.youtube.com/watch?v=w0ffwDYo00Q. I think I used Download Video Helper to convert it to mp4 during the download, rather than downloading it as a flv and using ffmpeg to do the conversion. It’s been a while.
Once loaded, the clip appears in the central panel. Some video editing programs may call such panel “stock” or “resources.” But to use it drag it to one of the time lines. Doing so will also load it into the preview/viewer panel on the right. It can also be dragged directly into the viewer.
I was also able to load into the same project a clip in wmv and another in avi format. So the "missing codecs" problem may be pertinent only as to what format a vid can be rendered. From the above "missing list" that means not in a format usable in a DVD. If so, then the worse case scenario --if the "missing codec" problem isn't solved-- is that a project in flowblade using a variety of sources can be rendered in a format flowblade "found", and that flowblade rendered project converted via another program into one playable on a dvd. If so, the couple of minutes it takes to set up flowblade will be more than worth it.


Last edited by mikeslr on Sun 16 Feb 2014, 17:31; edited 1 time in total
Back to top
View user's profile Send private message 

Joined: 16 Jun 2008
Posts: 1421
Location: 500 seconds from Sol

PostPosted: Sun 16 Feb 2014, 11:22    Post subject: Flowblade in Precise and Raring
Subject description: Clue to "invalid media problem"

Hi 666philb and all,

As I had 666philb's flowblade working in upup precise, I was curious as to whether it would also work in upup raring So I unpacked another copy of upup raring to a new folder, added it to grub4dos's menu, booted into it, ran FirstRun, created a SaveFile and rebooted into upup raring.
Following 666philb's instructions, flowblade ran, but I was unable to successfully load media clips, even though they were not grayed-out. See my edit to the set-up procedure in my last post. Apparently, as I noted there as "Step 0" the first thing you have to do is change the profile preferences to something other than the Dv/DVD PAL default or NTSC choices as flowblade is unable to find these modules. IIRC, 666philb believes this is a ffmpeg problem.
At any rate, after some experimentation I was able to load media clips. I unloaded raring_devx.sfs and instead loaded openshot-1.4.3.sfs. This version is named "precise", distinguishing it from slacko and carolina sfs versions on the same partition. While I'm certain I downloaded it for use with precise, I'm uncertain whether I renamed it. The purpose of either openshot or devx SFS is to obtain python, its modules and libraries. Apparently, the python modules included in openshot (for precise) are configured somewhat differently than those in the devx.SFS.

I do suggest using 666philb's recommended qt.sfs. It appears to "see" more valid clips than the qt-stripped.sfs I tried.

A couple other notes while I'm here. Running under jwm --rather than openbox-- flowblade shows up in the multimedia submenu as soon as loaded.

Still haven't figured out all the editing bells and whistles. But apparently, once a clip is loaded and selected for editing (make sure the "down-arrow" is on the correct video track) before you can do any cutting you have to use the "razor" blade to divide a clip. Look under the preview monitor. A clip is initially seen as one long stream. After one cut, you can trim-off or move the beginning or end; after two cuts, you can trim-out, or move, the part between the cuts.

Back to top
View user's profile Send private message 

Joined: 16 Jun 2008
Posts: 1421
Location: 500 seconds from Sol

PostPosted: Thu 20 Feb 2014, 13:27    Post subject: flowblade rendered clips won't run (Solved) -sort of  

Hi all,

From the foregoing posts, you know that in order to load clips for editing I had to change the default codec under preferences. It had been my guess that flowblade would not render vids in a format which appeared to be missing when flowblade was started via a terminal. Editing went as smoothly as editing can. I then clicked render timeline from the top menu and obtained a vid having all and only the edited clips. I opened it in gnome-player, and could scroll thru it, but it wouldin't run. Tried selecting different codec which "had been found" and received the same result. So, in desperation, I applied a variation of the adage "when things aren't found where you expect them, look for them where you don't." I clicked Render on Menu in the middle of window (above the time lines) and changed
Render Type from “User defined” to Preset File Type, then I selected one of them from the drop down menu. You'll notice that almost all of these presets relate to various DVD types. A couple relate to ipads. The several presets I tested produced runable clips. My guess such would not be available for rendering was wrong.
The downside of the presets is that all rendered clips take up more space (sometimes significantly more) than the clips used as sources. However, if you're not doing a DVD project, you can use ffmpeg to convert a flowblade rendered clip to a vid in a format using a much smaller size.
Flowblade's editing options still seem to be the best around, making it a valuable tool for video editing.

Sure wish the online-manual --which I downloaded as a pdf-- was more informative.

Back to top
View user's profile Send private message 

Joined: 16 Jun 2008
Posts: 1421
Location: 500 seconds from Sol

PostPosted: Tue 26 May 2015, 11:57    Post subject: flowblade 0.18 for Tahrpup, VividPup & (maybe) Wheezy  

Either things went incredibly smoothly or I've done something wrong. Laughing

Please test this application. Of course, at your own risk. Smile But before complaining about problems or limitations regarding codecs and conversions, please read the earlier posts on this thread and any other documentation you might find.

Having failed about 6 months ago, I anticipated problems cobbling together a functional flowblade for Tahrpup. There weren't any. Googling revealed that a new version had recently been published in the form of a .deb which supposedly would run under Ubuntu Trusty Tahr. Documentation for flowblade at its github site identified its dependencies. With two exceptions, debs fulfilling those dependencies were obtained merely by typing their names into PPM (Puppy Package Manager) after selecting “download only.” I didn't select “and dependencies” figuring I'd build a preliminary version and then run “ldd flowblade” in terminal to see what actually was missing. Puppy isn't Ubuntu, and asking for all dependencies can give you the kitchen sink when all you really need is a bucket.

The two exceptions were python-mlt2 and python-mlt5. PPM couldn't locate them. Scouring all Ubuntu's repos only revealed one of them, and that built for Lucid/Lupu. Searching for debian versions uncovered a couple which might be right, but maybe not.

Googling also revealed complaints by Ubuntu users of being unable to install flowblade because of the unavailability of those dependencies. And a solution: Edit the flowblade file --which is read by Ubuntu's package manager-- to delete references to those “dependencies”. Well, that seemed strange. Rolling Eyes

But a post on the debian forum revealed that the newer version of python-mlt had incorporated the functions of the “missing” lib. If I've got this right, the only reason they show up as dependencies is that no one has updated the dependency list.

How I built the pets:

I used LazyPuppy's PaDS, http://murga-linux.com/puppy/viewtopic.php?p=658359&sid=ec9785cde93ee11b97378aee48dbde31#658359, to create two SFSes: one including only the flowblade deb, and the other of all the dependency debs. Flowblade publishes a new version every couple of months and chances are later version will have the same dependencies. But, if fewer or different, I've stored the debs for later use.

Now having a flowblade.SFS and a flowblade-framework.sfs, I mounted each and copied their contents into folders respectively named flowblade-0.18 and flowblade-framework-May2015. I examined the contents of those folders primarily to make certain that their structures followed Puppy norms, e.g. that execs and libraries were be located where Puppies would expect them to be.

Flowblade-framework has no menu entry. But flowblade, itself, does; and Ubuntu's default /usr/share/application desktop files often start their category argument with “gtkXXX” or similar rather than specifying a category appearing on the Start Menu. Additionally, Puppies employing Openbox require that the category arguments end with an “;” if they are to show up on the Menu. Sometimes the "Icon" argument has to specify a specific location. Flowblade's arguments were edited to be consistent with Puppy usage.

Consistent with Puppy's philosophy of “trimming the fat”, manuals and docs were removed, as were folders relevant only to running flowblade under KDE. I copied these into a folder named flowblade-framework-dev. As far as I can tell, manuals and docs contain no information you can't get online. Currently, there are no recent Pups employing KDE, and AFAIK these files may have no value if a Pup using KDE were developed.

The resulting “stripped” folders were converted into pets via dir2pet. You can download the flowblade-framework pet here, http://www.mediafire.com/download/3w2tv782j09scj6/flowblade-framework-May2015.pet, and the flowblade pet here, http://www.mediafire.com/download/5u7t4jqs6lu0bkx/flowblade-0.18.pet.

You can, of course, use PaDS –or similar applications-- to convert these into SFSes, or combine them into one SFS. My experience has been, however, that applications requiring the python framework have a better chance of functioning if at least that framework is installed [? perhaps as a consequence of how Puppies prioritize SFSes in its “merge-file” system?].

When installed into VividPup these pets also appeared to establish a functional application. Not extensively tested in either VividPup or Tahrpup.

As a result of my googling for information, I suspect that this version of flowblade will also function under a debian build, to wit: Wheezy. Completely untested.

As currently constructed, they will not run in Carolinas, Slackos, Precises or, most likely, older Pups. I think only a few libraries are needed by Carolinas.


P.S. Special thanks to the following:
Barry K -- for developing the woof without which use of Ubuntu & debian applications, if possible at all, would not be as easy. I'm almost prepared to admit that woof wasn't a mistake after all.
666philb -- not only for developing Tahrpup and Vividpup, but also for his initial efforts in providing a functional flowblade for Puppies.
Battleshooter -- for continuing to build flowblades as they evolved.
LazyPuppy/RSH -- for developing PaDS.
To too many actual Puppy/Linux experts to mention, whose contributions to this Forum have provided whatever insight I have.
And to John Murga, without whose foresight and dedication there would be no Puppy Linux Discussion Forum.
Back to top
View user's profile Send private message 

Joined: 24 Feb 2014
Posts: 1618
Location: UK

PostPosted: Mon 04 Jan 2016, 19:39    Post subject:  and flowblade for Tahr 6.0.5 CE  

SFS for flowblade 0.18 for 32 bit pae Tahr (might work in other versions also) http://murga-linux.com/puppy/viewtopic.php?p=880040#880040
Back to top
View user's profile Send private message 

Joined: 10 Sep 2011
Posts: 9460
Location: Mer méditerrannée (1 kms°)

PostPosted: Tue 02 Aug 2016, 11:01    Post subject: Precise 5.4.3 ToOpPy
Subject description: MLT missing

# flowblade
Launch script dir: /usr/bin
Running from installation...
modules path: /usr/share/flowblade/Flowblade
MLT not found, exiting...
ERROR: No module named mlt

It was just a quick test. Openshot is enough, when needed. Video edition, cut and stick i use Avidemux. I never make videos to be shown They are personnal tutorials, to remember how-to do things. I put them in You Tube, but they have to be seen as they are. So there is not nice transitions, titles and so on...

Sprinters choose Puppy Linux as mascot, always happy, always speedy.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0942s ][ Queries: 12 (0.0091s) ][ GZIP on ]