Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 16:20
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
libc.so.6 'GLIBC_2.3.4'
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
mouldy


Joined: 04 May 2005
Posts: 498

PostPosted: Mon 16 May 2005, 17:45    Post subject:  libc.so.6 'GLIBC_2.3.4'  

My ex has AOL account. I have been playing around with penggy which allows linux to connect to AOL. Got it installed and working on Mepis thanks lot to apt-get.

Been trying to get it working on Puppy. Got files from Mandrake rpm. Get error: /lib/libc.so.6: version 'GLIBC_2.3.4' not found (required by /usr/lib/libguile.so.12)

Well dang tried mandrake rpm for it, tried copying it from Mepis. Nothing works. Its there in /usr/lib, but penggy(and guile) cant see it as what they are looking for.

Anybody else successfully installed this library in Puppy for any reason? Dont suppose there are lot linux users that interested in an AOL connection though locally in my area it is a good one.
Back to top
View user's profile Send private message 
mouldy


Joined: 04 May 2005
Posts: 498

PostPosted: Mon 16 May 2005, 18:31    Post subject:  

Hmm, think libguile.so.12.3.0 which has needed symlink of libguile.so.12 is the problem. Tried couple different libguile libraries and got different errors.
Back to top
View user's profile Send private message 
menno
Guest


PostPosted: Tue 17 May 2005, 05:13    Post subject:  

As far I can see , the problem is libc it search for 2.3.4 . look in /lib what version you have .
On my Puppy it is 2.3.2 .
Back to top
mouldy


Joined: 04 May 2005
Posts: 498

PostPosted: Tue 17 May 2005, 13:59    Post subject:  

menno wrote:
As far I can see , the problem is libc it search for 2.3.4 . look in /lib what version you have .
On my Puppy it is 2.3.2 .


Ah, but there is the rub. Yes Puppy has 2.3.2 but SO DOES Mepis that I have installed. Penggy works!!!! on Mepis. However guile on Mepis is not transferable to Puppy. If I do it, I get whole other error as that guile is apparently for debian system only. The Mandrake rpm guile I used insists on 2.3.4 and it does no good to try and statically insert file from Mandrake rpm for 2.3.4.

I have found yet another version of guile1.6 rpm. This one specifically for Mandrake 9.1. Will try it. It shouldnt insist on libc-2.3.4.

I just dont have enough guile I guess......

There is also an older Penggy rpm 386 version instead of 586 version. Cant locate copy of it though. Penggy website used to have all versions of old pengAOL and Penggy, but it down and probably gone for good. Still if Mepis can run penggy with libc-2.3.2 then Puppy shouldnt have problem at least with that.
Back to top
View user's profile Send private message 
mouldy


Joined: 04 May 2005
Posts: 498

PostPosted: Tue 17 May 2005, 14:36    Post subject:  

Nuts, this latest rpm contained a guile binary but no library files. No instructions with any of this stuff.
Back to top
View user's profile Send private message 
mouldy


Joined: 04 May 2005
Posts: 498

PostPosted: Fri 20 May 2005, 13:30    Post subject:  

Success. More time to waste so used the guile 1.6.0 and the libguile12 for 1.6.0 and borrowed couple lib support files from Mepis and voila, Penggy runs on Puppy and connects via AOL account. Works well.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0437s ][ Queries: 12 (0.0029s) ][ GZIP on ]