Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 00:29
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How do I configure GRUB to automatically boot Puppy?(Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
Mechsus
Guest


PostPosted: Wed 27 Jul 2005, 13:26    Post subject:  How do I configure GRUB to automatically boot Puppy?(Solved)  

Ive installed Chubby Puppy 1.0.4 to HD.
When booting up, I get the GNU GRUB boot options of either:

1.MS DOS
2.Puppy
3.Load GRUB to /dev/hda2/

How can you force the computer to automatically boot into Puppy without
any input?
Back to top
doopdoop
Guest


PostPosted: Wed 27 Jul 2005, 14:59    Post subject:  

I do not have a harddisk install, but it should work like this:
Look for a file /boot/menu.lst and open it.

look for entries like:

Code:

title MS-DOS
....


and comment out your do not need

You can select a default entry by adding to menu.lst
Code:

default         0

(0 means the first entry - computer sciencist start to count with 0)

And you can hide the menu by default
Code:

hiddenmenus

or you could select a timeout. This line waits for three seconds and then boots the default.
Code:

timeout         3
Back to top
Mechsus
Guest


PostPosted: Wed 27 Jul 2005, 18:13    Post subject:  

Quote:
I do not have a harddisk install, but it should work like this:
Look for a file /boot/menu.lst and open it.


This is the file I found that you are probably refering to. So, I simply remove the MS DOS references, and add the code you suggested?

(I think the lines starting with # are not executed, right?)


# GRUB configuration file '/boot/grub/menu.lst'.
# generated by 'grubconfig'. Wed Jul 27 19:30:59 2005
#
# The backup copy of the MBR for drive '/dev/hda' is
# here '/boot/grub/mbr.hda.612'. You can restore it like this.
# dd if=/boot/grub/mbr.hda.612 of=/dev/hda bs=512 count=1
#
# Start GRUB global section
#timeout 30
color light-gray/blue black/light-gray
# End GRUB global section
# Other bootable partition config begins
title DOS (on /dev/hda1)
rootnoverify (hd0,0)
makeactive
chainloader +1
# Other bootable partition config ends
# Linux bootable partition config begins
title Linux (on /dev/hda2)
root (hd0,1)
kernel /boot/vmlinuz root=/dev/hda2 ro vga=normal
# Linux bootable partition config ends
title Install GRUB to floppy disk (on /dev/fd0)
pause Insert a formatted floppy disk and press enter.
root (hd0,1)
setup (fd0)
pause Press enter to continue.
title Install GRUB to Linux partition (on /dev/hda2)
root (hd0,1)
setup (hd0,1)
pause Press enter to continue.
title - For help press 'c', then type: 'help'
root (hd0)
title - For usage examples, type: 'cat /boot/grub/usage.txt'
root (hd0)
Back to top
doopdoop
Guest


PostPosted: Wed 27 Jul 2005, 18:21    Post subject:  

Just for safety, you can leave the dos section in there, just remove the # in the line #timeout 30 (the # marks the line as a comment), and maybe reduce it to say "timeout 5". Then you have 5 seconds to choose DOS instead.
Back to top
Mechsus
Guest


PostPosted: Wed 27 Jul 2005, 18:58    Post subject:  

Quote:
just remove the # in the line #timeout 30 (the # marks the line as a comment), and maybe reduce it to say "timeout 5".


Just tried that: What happened was that the computer booted into DOS after 5 seconds. I need to eliminated the option to boot into DOS as well.

On my initial GNU GRUB screen, the first default highlighted option is MS DOS, followed underneath by the Puppy option (Then Grub to Floppy, then Grub to /dev/hda2).
Back to top
Bancobusto


Joined: 13 Jun 2005
Posts: 168
Location: Vancouver Island

PostPosted: Wed 27 Jul 2005, 19:00    Post subject:  

It's not e x a c t l y what yer looking for, but if you un-comment the timeout and set it to zero, it will basically do what you want. It does for me, anyway!

Hope that helps! Very Happy

EDIT: hey. that is some cool advice doop-pooop, sorry, i didn't read yer post carefully enough -

Oh, and in order for my suggestion to work (I'm really out of it for some reason, sorry) you would have to move the entry for Puppy to the top of the list of entries. Rolling Eyes Rolling Eyes Rolling Eyes

_________________
Freedom isn't just a Puppy-Linux forum member!
Back to top
View user's profile Send private message 
Mechsus
Guest


PostPosted: Thu 28 Jul 2005, 00:32    Post subject:  

Quote:
It's not e x a c t l y what yer looking for, but if you un-comment the timeout and set it to zero, it will basically do what you want. It does for me, anyway!


Thanks, Banco. That was *exactly* what I was looking for. I just did the surgery on my menu.lst and it worked fine. I left the timeout to 5 sec because I like to see the option screen boot magically into Puppy. Call me old fashioned.... Thanks to doop too.
Back to top
Bancobusto


Joined: 13 Jun 2005
Posts: 168
Location: Vancouver Island

PostPosted: Thu 28 Jul 2005, 00:34    Post subject:  

You'tr welcome, glad that I could possibly be of help......





Rolling Eyes Rolling Eyes Rolling Eyes

_________________
Freedom isn't just a Puppy-Linux forum member!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0576s ][ Queries: 12 (0.0037s) ][ GZIP on ]