Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 09:34
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Audacity-2.0.5-i686 Compiled in Precise 5.6.1
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Author Message
scabz


Joined: 30 Apr 2009
Posts: 306
Location: Tallahassee FL US

PostPosted: Wed 26 Mar 2014, 01:28    Post_subject:  

Cool man i am glad you got it worked out.

OscarTalks i would include jack if i where you, say a person like me wants to use audacity with out jack it would be useless to me and i wouldnt use it. when it comes to audio recording apps jack is one of the most important one to have.
Back to top
View user's profile Send_private_message AIM YIM 
OscarTalks

Joined: 05 Feb 2012
Posts: 901
Location: London, England

PostPosted: Wed 26 Mar 2014, 15:00    Post_subject:  

@Scabs,
Thanks for the hint regarding how to edit the Makefile. I have now been able to compile Audacity 2.0.5 in Wheezy with static wxWidgets. It does make the package a bit smaller so is worth doing now I know how.

I compiled jack-audio-connection-kit 0.124.1 and then compiled Audacity with it installed so jack support becomes enabled when I configure the build. Wheezy does have libjack in the distro so Audacity will still run even if I don't install the jack package.

Does this jack-audio-connection-kit on its own offer any functionality (maybe via the other program GUIs) or do you always also have to have qjackctl as a GUI to control it? If so that means you are going to need Qt as well.

_________________
Oscar in England

Back to top
View user's profile Send_private_message 
amigo

Joined: 02 Apr 2007
Posts: 2261

PostPosted: Wed 26 Mar 2014, 15:21    Post_subject:  

Uh, shouldn't you remove the 'src' from the binary package name?
Back to top
View user's profile Send_private_message 
scabz


Joined: 30 Apr 2009
Posts: 306
Location: Tallahassee FL US

PostPosted: Wed 26 Mar 2014, 16:27    Post_subject:  

Quote:
Thanks for the hint regarding how to edit the Makefile. I have now been able to compile Audacity 2.0.5 in Wheezy with static wxWidgets. It does make the package a bit smaller so is worth doing now I know how.

Happy to help

Quote:
Does this jack-audio-connection-kit on its own offer any functionality (maybe via the other program GUIs) or do you always also have to have qjackctl as a GUI to control it? If so that means you are going to need Qt as well.

some programs start jackd without the gui and you can start it through console http://trac.jackaudio.org/wiki/jackd(1)

Quote:
Uh, shouldn't you remove the 'src' from the binary package name?

yeah i know my bad i was most likely tired when i compiled and packaged it , alot of my compiling and packaging is done late night after my girlfriend has passed out. i can Fix it in a bit.
Back to top
View user's profile Send_private_message AIM YIM 
scabz


Joined: 30 Apr 2009
Posts: 306
Location: Tallahassee FL US

PostPosted: Wed 26 Mar 2014, 17:18    Post_subject:  

I am going to recompile audacity-2.0.5 later tonight after band practice and then after my g/f goes to bed. I forgot to add flac support.

My audacity-rev13079 has everything enabled
Back to top
View user's profile Send_private_message AIM YIM 
don570


Joined: 10 Mar 2010
Posts: 3345
Location: Ontario

PostPosted: Wed 26 Mar 2014, 18:48    Post_subject:  

Slacko 5.7 does have libflac installed so it worked fine.
_____________________________________________
Back to top
View user's profile Send_private_message 
scabz


Joined: 30 Apr 2009
Posts: 306
Location: Tallahassee FL US

PostPosted: Thu 27 Mar 2014, 03:20    Post_subject:  

audacity-2.0.5 has been recompiled with flac import and twolame export added. If you need these features redownload.
Back to top
View user's profile Send_private_message AIM YIM 
don570


Joined: 10 Mar 2010
Posts: 3345
Location: Ontario

PostPosted: Thu 27 Mar 2014, 19:12    Post_subject:  

You don't have mypaint or gimp-painter in your cloud.
http://www.murga-linux.com/puppy/viewtopic.php?t=91074
____________________________________________________
Back to top
View user's profile Send_private_message 
scabz


Joined: 30 Apr 2009
Posts: 306
Location: Tallahassee FL US

PostPosted: Fri 28 Mar 2014, 16:36    Post_subject:  

Quote:
You don't have mypaint or gimp-painter in your cloud.
http://www.murga-linux.com/puppy/viewtopic.php?t=91074


You mean this

I got it compiled and seems to be working fine but it uses scons to compile and install which makes it a pain to package and then some of the libs use python to build and install so makes packaging hard.
I spent 2 much time trying to package it, i just gave up.

i might have a go at gimp-painter later but not a priority to me cuzz i dont use them.
Back to top
View user's profile Send_private_message AIM YIM 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Sat 29 Mar 2014, 13:35    Post_subject:  

Quote:
You don't have mypaint or gimp-painter in your cloud.

http://smokey01.com/RSH/LazY-Puppy-201/lp201-sfs/single-apps/LP2_GimpPainter-2.8.7.sfs

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3345
Location: Ontario

PostPosted: Thu 03 Apr 2014, 16:52    Post_subject:  

That's a great version of gimp painter.!!!

It worked on Slacko distro , probably others as well.

_________________________________
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0739s ][ Queries: 13 (0.0088s) ][ GZIP on ]