Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 23 Aug 2014, 09:46
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
L.A.S.S.I.E. - Version 0.0.2 - a new LazY Puppy
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 5 [71 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
labbe5

Joined: 13 Nov 2013
Posts: 48

PostPosted: Wed 05 Mar 2014, 11:27    Post subject: Lassie
Subject description: always innovative
 

Hi,

You are certainly one of the most innovative developer for Puppy. No doubt, your innovations will have an impact on future development of Puppies. But it is a bit slow in the making. You are way ahead, i think.

I will try Lassie, mostly out of curiosity, not only because it is new, but also because there is real new stuff coming from you, and new skills to learn from you.

I follow your projects since the beginning.

"don't worry, be happy"
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2399
Location: Germany

PostPosted: Wed 05 Mar 2014, 11:37    Post subject:  

labbe5 wrote:
Hi,

You are certainly one of the most innovative developer for Puppy. No doubt, your innovations will have an impact on future development of Puppies. But it is a bit slow in the making. You are way ahead, i think.

I will try Lassie, mostly out of curiosity, not only because it is new, but also because there is real new stuff coming from you, and new skills to learn from you.

I follow your projects since the beginning.

"don't worry, be happy"

Thank you very much!

seetravel wrote:
Sorry again to bother you.
First boot everything is fine,
The problem starts when i change my country localisation to SR.
Whatever i do i can't fix it.

Never mind, I don't feel bothered!

Ok, I have checked this and got equal results.

Currently I don't have any idea, why this is happen.

But, if you do change the country and language settings when desktop is on VarioMenu-Group 1 (Administrator, the one with the penguin icons), no icons will get lost, because there aren't any icons on the desktop.

When switching to another desktop after the country settings are done and X has restarted, the icons of VarioMenu-Group "Favorites" will appear as usual.

So, for now (until I found the issue and solved it, just change the country settings when VarioMenu-Group 1 (Administrator) is active.

As soon as I found a solution, I will post a fix (when possible).

Thanks for reporting this problem.

RSH

EDIT:

If icons do accidentally disappear from the desktop, go to /initrd/pup_ro2/usr/local/variomen/data/advanced and copy everything or just the needed script to /usr/local/variomen/data/advanced - I recommend to copy only the needed script for the VarioMenu-Group, that has lost its icons. So its sure not to overwrite VarioMenu-Groups wherein you have placed already some of your own icons.

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2399
Location: Germany

PostPosted: Wed 05 Mar 2014, 12:53    Post subject:  

Ok.

The disappearing icons seems not to be a bug or issue or what ever.

L.A.S.S.I.E. is booting into a clean desktop (VarioMenu-Group 1, Administrator) with no icons on it, right?

I can't check it because my version is newer and I do always own only the newest build. While developing the LazY Puppy ISO Builder, I'm developing L.A.S.S.I.E. and a old settings file of ISO Builder says NoIconSetup.

This is the clue.

After changing the country settings it seems to be checked what desktop icon setup is used and this seems to be restored before X starts again - just how it is used to be.

So if you are on "Favorites" when changing the country settings, this VM-Group is restored after X is started. Activating a VarioMenu-Group saves first the current activated VM-Group and loads the new one after this.

So if the current VM-Group is "Favorites" and the new activated one is also "Favorites" it will overwrite itself before loading it again. This means: at first the empty desktop (after changing country settings and restarting X) is saved as VM-Group "Favorites" and then re-loaded, which results in an empty desktop.

So do only change country settings at VM-Group 1, Administrator.

I hope you can follow and understand this explanation and how the VarioMenu is working.

RSH

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
sovielenamen

Joined: 04 Mar 2014
Posts: 2

PostPosted: Fri 14 Mar 2014, 07:30    Post subject: PAE kernel
Subject description: No success
 

LASSIE comes with a pae kernel and refuses to start up on myIBM R51 Thinkpad because Intel thought its a good idea to enable the M-CPUs for pae but let them not set the realted flag so the OS thinks pae is a nogo.
There exists a patch for this as deb package but I am far from being able to apply it. In a few weeks maybe.

I actually asked about this and was told non-pae what surprised me a little bit.

I would very much like something as Lazy on my machine again just more up to date.
And GnuPG and a frontend for it, its strange this is not more or less mandatory for all Linux flavors....

If another kernel must be used then I would like to ask if the realtime kernel from Musix (or a variation thereof) can be used without having to reinvent the wheel?

Pls. dont tell me I dont need it, I prefer to decide this myself. If not I would use Windows or worse: Ubuntu.


Up to now:
- Lazy worked out of the box with minor flaws but is outdated and wont install frugal to hdd (say: I was not able to)
- Precise non-pae runs from CD, installs to hdd and starts decomposing immdiately, icons gone, colors shifted and every reboot makes it worse. Did not like it anyways.
- SLAX looks good, new version without modules not updated since months, no support.
- Bodhi Linux tries to hide it but its evil, its Ubuntu. Wipes Grub4Dos every boottime no questions asked. Desktop dies every 20 minutes, likes to disintegrate too.

and some more.

Puppy Linux and Lazy in special look by far the best. Sadly looks the most chaotic too like somebody tries hard NOT to get famous. Fame is a scourge, so ok.

I am willing to invest some time and effort into getting this running for me, I will not get enslaved by the commandline (its DOS just worse) though. Hey, my first computer was a Mega-Atari Wink


All help is appreciated, usually pointing me to the information is enough.
But not into the direction, but to the information, I must work sometimes too and reading 20pages threads for 5 lines of information needed is something I cannot afford, sorry.


regards
/svn
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2399
Location: Germany

PostPosted: Fri 14 Mar 2014, 17:59    Post subject:  

sovielenamen wrote:
LASSIE comes with a pae kernel and refuses to start up on myIBM R51 Thinkpad because Intel thought its a good idea to enable the M-CPUs for pae but let them not set the realted flag so the OS thinks pae is a nogo.
There exists a patch for this as deb package but I am far from being able to apply it. In a few weeks maybe.

I actually asked about this and was told non-pae what surprised me a little bit.

Hi.

As I wrote in my pm: as far as I know, PAE Oeprating Systems/Puppies do have PAE included in their names. The ISO I'm building L.A.S.S.I.E. from is named precise-5.7.1.iso, but I can't remember from where it has been downloaded.

As far as I know, my machine is non-PAE -but I'm not sure anymore on this detail- and L.A.S.S.I.E. runs fine here. Though, as I wrote in my pm: VirtualBox refuses running L.A.S.S.I.E. and tells me I would need a PAE machine. So I'm a little confused also.

When I'm releasing L.A.S.S.I.E. 002 it will be a non-PAE version, if I'll find a non-PAE precise version to build it from.

Quote:
I would very much like something as Lazy on my machine again just more up to date.

L.A.S.S.I.E. is intended to be a LazY Puppy, but just more up to date and build in a completeley different way as LazY Puppy was build.

Quote:
And GnuPG and a frontend for it, its strange this is not more or less mandatory for all Linux flavors....

As I wrote in my pm: GnuPG is in the Puppy Package Manager. I had successfully build a SFS Module from the files downloaded by Package Manager (two different versions).

I seems it hasn't got a graphical front end included. But I'm not the network/internet expert and also I'm not interested in. So all I could do is to provide a SFS build from the files downloadable by Package Manager. To find a front end and/or to find out how this will work is a job, that could not be done by me.

I don't care about privacy on the internet (still using LazY Puppy's Firefox 7 SFS Module) and I don't save any "top-secret" information (like passwords etc. on my computer (usually!). There are many ways to learrn how to keep such information in mind without the need to save it anywhere else. Also I don't want to waste my time to find out how things will work or how to get things to work, that are out of my needs and out of my interest.

And just to make it clear at all: I don't want to provide such a huge collection of SFS Modules available, as I did for LazY Puppy. L.A.S.S.I.E. includes each and every tool, that's needed for the user to build SFS Modules easily by himself. Also lots of LazY Puppy's SFS Modules still do work in L.A.S.S.I.E. (Precise). Though L.A.S.S.I.E. 002 at least will be more up to date for these jobs.

Quote:
If another kernel must be used then I would like to ask if the realtime kernel from Musix (or a variation thereof) can be used without having to reinvent the wheel?

Sorry, switching kernel version in a puppy is way far out of my knowledge and trying to learn this needs way much more time as I could spend on it for L.A.S.S.I.E. or in general.

Quote:
Pls. dont tell me I dont need it, I prefer to decide this myself. If not I would use Windows or worse: Ubuntu.

No, I don't want to do such!

Quote:
Up to now:
- Lazy worked out of the box with minor flaws but is outdated and wont install frugal to hdd (say: I was not able to)

How about a manual frugal install (just copying files to HD and editing menu.lst file)?
Meanwhile I do install all puppies only this way, since it is the easiest way ever to install a puppy. Just need to run Grub4DOS (or another boot loader) after copying the files (if it was installed onto a new HD or USB flash drive). Forget about all the usual puppy-installers!

Quote:
- Precise non-pae runs from CD, installs to hdd and starts decomposing immdiately, icons gone, colors shifted and every reboot makes it worse. Did not like it anyways.

Got a link to this precise non-PAE version for me?

Maybe you'll need to add some to your boot menu entry in menu.lst:
(Needed for nvidia graphics adapters)
nouveau.noaccel=1 (put in into the kernel line).

Quote:
SLAX looks good, new version without modules not updated since months, no support.

Don't know much about SLAX. Don't want to test it, don't want to use it. Don't want to do anything on it/with it.

Quote:
Bodhi Linux tries to hide it but its evil, its Ubuntu.

Precise is Ubuntu too (12.xx Precise Pangolin).

Quote:
Puppy Linux and Lazy in special look by far the best. Sadly looks the most chaotic too like somebody tries hard NOT to get famous. Fame is a scourge, so ok.

I am willing to invest some time and effort into getting this running for me, I will not get enslaved by the commandline (its DOS just worse) though.

Yes!

Puppy Linux is the best to me too. And LazY Puppy of course is still one of the best Puppies out there. I don't mind about Puppy's "chaotic-look" (as you named it, which of course doesn't mean its "graphical-look") since I'm an Artist.

As you decide to use a Puppy Linux, it's strongly recommended to be willing and able to invest some time to learn how things will work. To create LazY Puppy has taken a huge amount of time and there was a huge bulk of things to learn as well.

Quote:
Hey, my first computer was a Mega-Atari

My first computer ever was a Atari 520 ST plus SM 124 Monochrome Monitor.

Quote:
All help is appreciated, usually pointing me to the information is enough.
But not into the direction, but to the information, I must work sometimes too and reading 20pages threads for 5 lines of information needed is something I cannot afford, sorry.

I'll try to give help where I'm able to do so. But the only way to avoid reading "20 pages for 5 lines of information" is to do a post and asking for it.

Thanks for your interest.

RSH

EDIT:

Ok.

A information-request on the forum did guide me to how to find out if my machine is PAE or non-PAE. I have a PAE machine (which I did not know until today).

Could you send me the link to the non-PAE precise, please?

Last edited by RSH on Fri 14 Mar 2014, 18:04; edited 1 time in total
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5711
Location: Kentucky

PostPosted: Fri 14 Mar 2014, 18:03    Post subject:  

Precise 5.7.1 Retro is the non-pae version.....

http://distro.ibiblio.org/quirky/precise-5.7.1/precise-5.7.1-retro.iso

http://distro.ibiblio.org/quirky/precise-5.7.1/md5sums.txt
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2399
Location: Germany

PostPosted: Fri 14 Mar 2014, 18:51    Post subject:  

James C wrote:
Precise 5.7.1 Retro is the non-pae version.....

http://distro.ibiblio.org/quirky/precise-5.7.1/precise-5.7.1-retro.iso

http://distro.ibiblio.org/quirky/precise-5.7.1/md5sums.txt

Thanks.

Seems I've downloaded it already some earlier this year, so I'm prepared.

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 776
Location: Union New Jersey USA

PostPosted: Fri 14 Mar 2014, 23:50    Post subject: Puppy is what you make it  

Hi sovielenamen,

You're absolutely correct that a Thinkpad R51 can't handle a PAE-enabled kernel. I discovered that failing on my now mute Thinkpad T42 --the slightly lighter but otherwise identical model-- when I tried to run Three-Headed dog. Thereafter, I always argued/pleaded for devs to build non-pae versions as an alternative.
But you're wrong in thinking Lazy is too old. A computer and an operating system are only platforms on which you assemble the tools (applications) you want in order to accomplish something. An operating system is only too old if it can't run the applications you want to run.
As far as I know --RSH can correct me if I'm wrong-- Lazy Puppy used Lupu/Lucid as its base. Many of us still use Lupu as our primary OS. It remains my "fall-back", although I test most Pups as they are published and currently default to pemasu's upup raring. Lupu --and by inference Lazy Puppy-- can do anything, and often more, than recent Pups with the exception (glib changes in newer apps) of running the most recent Chrome web-browser, LibreOffice and gimp. [Gimp work-around: install wine and run Gimp or GimpStudio XP portables].
However, because more graphics and video applications have by now been built for precise, that's the OS I use for artistic endeavors. I prefer pemasu's upup, even though may be slightly older than Barrk K's retro. Pemasu builds in many apps I find useful. Upup precise was built with a non-pae kernel. You can find it here: http://murga-linux.com/puppy/viewtopic.php?p=691423#691423
What you should also know is that --with rare firmware related exceptions-- any application built for a precise will work in any other precise puppy regardless of whether the pup is pae or non-pae. That means that any application --pet or sfs-- RSH created for LASSIE will most likely run under any other precise*. Many will also function under upup raring. [You can safely load any SFS: if there's a problem/conflict just unload it. Create a copy of your SaveFile, safely stored, before testing pets. Some Lupu/Lucid pets will run under precise; fewer under raring].
RSH is one of our most creative developers. I love and use many of the applications he's created. But I prefer a simpler OS. So, for example, I recently added to my upup precise (for video work) his Imagination 3.0 DVD slide show maker and ManDVD 2.5-5 Video DVD Creator.
Among the applications he created is Lazy FRED, http://murga-linux.com/puppy/viewtopic.php?p=649731#649731,a tool to download iso, sfs, pet, deb, tar.gz, .tar.bz2, .tgz, .gz and zip files from "free repositories" like smokey01.com. As far as I know Lazy FRED can be run under any Puppy since it's a bash-script using GTK-dialog or yad to create a GUI. But if it can't be used you can always reach a download location via your browser.
And beyond RSH's prodigious output of applications, you'll find other pets and SFSes for graphics, audio and video on the Additional Software Forum, http://murga-linux.com/puppy/index.php?f=63 or, sometimes, by plugging the name of an application into the Search box (select Puppy Forum under Web Search) located here: http://puppylinux.us/psearch.html.
Hope this helps you to put together a Pup which meets your requirements.

mikesLr

* X-precise, which uses the Xfce-thunar windows/file-manager combination, is an exception because in building it some of the foundation structures required by the jwm/openbox-rox combo aren't included.
Also most precise pups, unlike Lazy Pup and Lassie, can only load up to 6 SFSes by default. So you may find it necessary to install a pet to combine SFSes. If you search, you'll find such application. RSH created one.

Last edited by mikeslr on Sat 15 Mar 2014, 11:26; edited 1 time in total
Back to top
View user's profile Send private message 
sovielenamen

Joined: 04 Mar 2014
Posts: 2

PostPosted: Sat 15 Mar 2014, 10:58    Post subject: pae Thinkpads Lazy UpUpPup more & me
Subject description: step by step
 

Thanks for the replies and suggestions!

I am in special honored that mikeslr, the grey eminence lurking in the kernels shadows, "he who knows how to" popped in to enlighten me. Wink

As its actually his postings which made me decide to stick to Puppyby now, or to give it more time to try at least. All this hinting being able to use modules from about everywhere where squashed programs are applied opens the horizont.
Also he is wisely not going overly public I got the impression he wont refuse if asked directly. This I will do.
Sorry mike, you had it coming. Razz


A quick explanaition what I actually want/need, and I would think now that XP support is off, I might be not the only one looking for new greenings.
- Most important is speed on hardware like 1GB to 2GB RAM and about 1GHz single core processor.
- A small core of preinstalled software which is easily uninstalled so wanted.
- Plenty of software modules to load and unload so needed.
- Some way to have only the firmware/drivers actually needed for the machine and get rid of the rest, probably this means compiling a kernel?

Most distros come actually with to much preinstalled, includes most puppies.

I am very well willing and able to learn to make sfs packages I believe and my only request was for GnuPG as encryption standard as I and I am sure not only I regard this as fundamental nowadays.
I try to stay away from paranoia though. Runing my OS as root makes me not nerveous at all, but as in real life taking somebody aside and having a private talk without listeners which is one to oen and done the equivalent on the net is PG encryption. If you have nothing to hide is not important, your freedom is not defended at your doorstep but at anybodies doorstep.
That was now directed at @RSH and all other PG neglectors Cool

I downloaded and burned what Mike linked - I also downloaded the related Debian versions as I would prefer Debian very much over Ubuntu, and I will give this a try now.

I will try to make frugal hdd installs - somebody has a link with a SHORT step by step for this? There are several threads, all confusing to me. I guess its installing Grub4Dos by Shinobars tool and then some editing as RSH wrote?
And then Bodhi/Ubuntu wil of course wipe the Grub4Dos again on next start and I must start it for there I managed a working GnuPG install.

Its always running circles only hoping its a spiral to the treasure chest.

Last not least:

Solving the pae / non-pae issue on Thinkpads and other computers with mobile Pentium M CPUs:

Those CPUs can very well run pae (or "bigmem") kernels they just dont show the flag on boot up and so the kernel thinks they cant and stall.

Here:
https://launchpad.net/~prof7bit/+archive/fake-pae/+packages

is a patch which solves this by just adjusting the flag on bootup. Should do on Debian, Ubuntu and anything related, probably virtually everywhere.

I dont insist on the bigmem feature in no way, I prefer to have a non-pae, i468 kernel as thats at least 10 to 20% faster then pae and I dont think the "not-execute" feature provides so much security or advantages that its worth it. Not on a machine with limited resources.
I like to have the posibility to try those kernels though, to see if they have something I want.


thx everybody for the work done on this Puppy and still Lazy Puppy was the very best by now, I will not try to salvage the official Precise retro as it is rather ugly and lacking IMHO, I will try other flavors instead.

Of Puppy and other small distros from the land of broken links Smile


regards
/H
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2399
Location: Germany

PostPosted: Mon 17 Mar 2014, 13:38    Post subject:  

###############################################################################
# This is a List of SFS Modules from LazY Puppy Repository, that will run in
# L.A.S.S.I.E. I did not test if programs are working in detail. Only tested
# if Programs are running after loading the SFS Module. I've had loaded these
# SFS Modules while testing: LP2_Qt-4.6.2-S4.sfs and LP2_jre-1.7u13-i586.sfs.
# All testings made under PupMode=5, which means: no save file was in use!
# If there is a SFS Module missed at http://smokey01.com/RSH/ let me know...
###############################################################################

LP2_AFI-1.0.3.sfs
LP2_Aisleriot-2.30-Lucid.sfs
LP2_Albumshaper-2.1-5.sfs
LP2_ALSAPlayer-0.99.81.sfs
LP2_Amarok-1.4.10.sfs
LP2_amuc-1.7-i486.sfs
LP2_Aqualung_0.9-beta11-precise.sfs
LP2_Ardour3-3.5.357-i686-precise.sfs
LP2_arora-0.10.2.sfs
LP2_AsUnder-2.2-i686.sfs
LP2_AtariST-STEem-3.2.sfs
LP2_Audacity1312.sfs
LP2_Audacity-2.0.0-Precise.sfs
LP2_audiveris-4.2.3318-ubuntu-i386.sfs
LP2_AutoAdjustPhoto_GUI-2.0.sfs
LP2_AVIDemux-2.6.4.sfs
LP2_Avogadro-1.0.0.sfs
LP2_Backup-Settings-1.9-3.sfs
LP2_BaconRecorder-2.9-full.sfs
LP2_BibLOS-0.42.sfs
LP2_Blender263.sfs
LP2_Canorus-0.7-2.sfs
LP2_CBR-Pager-0.9.22.sfs
LP2_Celestia-1.4.1.sfs
LP2_Chrome-27.0.1453.93-precise.sfs
LP2_chromium12.0.716.0-79490w5.sfs
LP2_CinelerraCV215.sfs
LP2_Clementine_1.0.1+dfsg-1-precise.sfs
LP2_CPU_Select-1.0-l528.sfs
LP2_Darktable-1.0.3-RoxApp.sfs
LP2_DeadBeef-0.5.6a-precise.sfs
LP2_Dia097.sfs
LP2_DoubleCommander-0.5.4beta.sfs
LP2_DVDStyler-1.8.sfs
LP2_Eagle-5.11.0.sfs
LP2_Ease-0.4-full.sfs
LP2_EasyMP3Gain0502.sfs
LP2_EasyShot-1.0.sfs
LP2_EasyTAG-2.1.7-i686-lp2.sfs
LP2_Eclipse_sdk-4.2.1_x86.sfs
LP2_Exaile_0.3.2.2-2.sfs
LP2_ExtCalc-0.9.2-1.sfs
LP2_Figurine-1.0.5.sfs
LP2_file-roller-2.30.1.sfs
LP2_FileZilla353.sfs
LP2_Firefox7.sfs
LP2_FLite-gui_1.4-2.sfs
LP2_flo-1.0.sfs
LP2_FlPhoto-1.3.1.sfs
LP2_Fluid-FLTK-1.3.0.sfs
LP2_Fotowall10.sfs
LP2_FracPlanet_0.4.0-precise.sfs
LP2_FreePlane-1.2.18.sfs
LP2_Frisbee2b.sfs
LP2_Fyre-1.0.1-1.sfs
LP2_GEdit-2.30.3.sfs
LP2_GeoGebra-4.0.41.0.sfs
LP2_Gimp2612.sfs
LP2_GIMP-2.8.4-Full.sfs
LP2_GimpPainter-2.8.7.sfs
LP2_Ginkgo_CADx-2.12.0.4889_linux_x86.sfs
LP2_GLabels2281.sfs
LP2_Glade3-3.6.7-full-dev.sfs
LP2_Glade3-3.6.7-full.sfs
LP2_GNewPet-6.5.sfs
LP2_GnomeWaveCleaner_0.21.16-precise.sfs
LP2_GNUCash2295.sfs
LP2_GNU-Paint-0.3.3-6_i386.sfs
LP2_GPicView-0.2.2-full.sfs
LP2_GQView-2.0.4.sfs
LP2_Gramps-3.4.1.sfs
LP2_GTick_0.4.2-2.sfs
LP2_GtKam-0.1.16.1.sfs
LP2_GWhere-0.2.3-1.sfs
LP2_Homebank-4.2.1-full.sfs
LP2_IconFinder-1.4.sfs
LP2_ImageMagick-6.6.9-5.sfs
LP2_Imagination-3.0_Sox-14.2.0.sfs
LP2_InkScape-Lite-0.36.sfs
LP2_JackBeat_0.7.6-0-precise.sfs
LP2_JavaMod-2.2.sfs
LP2_JDK16u29.sfs
LP2_JFileSync-2.2.sfs
LP2_JRE17u3.sfs
LP2_JRE16027.sfs
LP2_jre-1.7u13-i586.sfs
LP2_JWildFire-1.01.sfs
LP2_Kid3-2.1-i486.sfs
LP2_Kino134.sfs
LP2_Klavaro_1.9.4-1_i386_full.sfs
LP2_KMyMoney104.sfs
LP2_Kompozer08b3.sfs
LP2_LazarusFPCSuite.sfs
LP2_LazY-EPI-0.4.sfs
LP2_LazY-FReD-1.0.3.sfs
LP2_LazY-MAID-1.0.4.sfs
LP2_LightZone_4.0.0-0_i386.sfs
LP2_LinaxePad-1.4.1.sfs
LP2_LiNGoT-0.7.4-2.sfs
LP2_LiteScribe4L.sfs
LP2_LMMS048.sfs
LP2_Lmms-0.4.5-sfs4.sfs
LP2_LoveGames.sfs
LP2_Mandvd-2.5-5.sfs
LP2_Marble-4.8.3-precise.sfs
LP2_MC-4.8.0-full.sfs
LP2_Merkaartor0172.sfs
LP2_Metaphorical-Silhouette-0.3.sfs
LP2_Midori-0.2.2.sfs
LP2_MilkyTracker_0.90.85+dfsg-2.1-precise.sfs
LP2_Mirage-0.9.3.sfs
LP2_MP3Split226.sfs
LP2_MP-3.2.13.sfs
LP2_MTCellEdit-1.0.sfs
LP2_Multipup-3.3.sfs
LP2_Musescore10.sfs
LP2_MuseScore-1.1-full.sfs
LP2_MX4410.sfs
LP2_Notecase-1.9.8.sfs
LP2_Nted110181.sfs
LP2_OpenMovieEditor-0.0.2008.01.02.sfs
LP2_OpenOffice-4.0.sfs
LP2_Openshot-1.4.3-precise.sfs
LP2_opera-12.14-1738.i386.opt.sfs
LP2_PAVRecord-0.8.3.sfs
LP2_PCal-GUI-4.11.0-1.0.1.sfs
LP2_PCDRipper391.sfs
LP2_PDVDRSAB_0.1.sfs
LP2_PeasyGlue-1.3.sfs
LP2_PEasyMM-Suite-1.0.0.sfs
LP2_PEasyMM-Suite-1.0.1.sfs
LP2_PeasyPDF-1.9.sfs
LP2_PeasyScale-1.4.sfs
LP2_Pencil-0.4.4b.sfs
LP2_Pic2Txt-GUI-0.0.1-1.0.sfs
LP2_Pidgin_Full_Video-2.7.3.sfs
LP2_Pikona2.sfs
LP2_Pinta10.sfs
LP2_Pixelitor_1.1.1.sfs
LP2_Planmaker-rev273.sfs
LP2_PLogo-0.1d.sfs
LP2_PoEdit142.sfs
LP2_Precord701.sfs
LP2_PTag091.sfs
LP2_PupSnap-2.1_Scrot-0.8_32Bit.sfs
LP2_PureData_0.42.5-3_i386.sfs
LP2_Python-2.7-precise.sfs
LP2_QaMix.0.0.7e.sfs
LP2_QCAD2.sfs
LP2_QCAD-3.2.2-x86_32.sfs
LP2_QSynth0341.sfs
LP2_QT-3.3.4.sfs
LP2_Qt-4.6.2-S4.sfs
LP2_Qt-Designer-4.6.2-0.sfs
LP2_QTGain-0.9.5_i386.sfs
LP2_RainLendar2-2.1.sfs
LP2_ReBorn-1.0.sfs
LP2_RipperX272.sfs
LP2_Rosegarden1004.sfs
LP2_Roxterm-1.17.1-Lucid.sfs
LP2_RTSynth-1.9.1.sfs
LP2_SAG_CAD-0.9.14.sfs
LP2_SavePartition-4.0.sfs
LP2_SciLab-5.2.2.sfs
LP2_SciPlore_MindMapping_Linux-015b.sfs
LP2_scite-1.63.sfs
LP2_Scite-2.03-1.sfs
LP2_Scratch-1.4.sfs
LP2_Screeny-0.7-full.sfs
LP2_Scribus150.sfs
LP2_SearchMonkey-0.8.1.sfs
LP2_Simple-Scan-2.32.0.2.sfs
LP2_Sir202.sfs
LP2_SodiPodi034.sfs
LP2_sooperlooper_1.6.14+dfsg-1.sfs
LP2_Specimen.sfs
LP2_SpiralSynthModular-0.2.2rc1.sfs
LP2_Stellarium-0.10.6-0.sfs
LP2_Sunbird10b1.sfs
LP2_sven-0.6-2-fm.sfs
LP2_TakeAShot-1.1.sfs
LP2_tea-10.0.sfs
LP2_Ted221.sfs
LP2_TerminatorX382.sfs
LP2_Termit-2.2.0-vte-0.22.5.sfs
LP2_Textmaker2002.sfs
LP2_Thunar-1.0.2.sfs
LP2_Thunderbird31.sfs
LP2_TuxGuitar12.sfs
LP2_TuxPaint-0.9.21.sfs
LP2_VKeybd_0.1.18d-1.1_i386.sfs
LP2_VKeybd_0.1.18d-2-precise.sfs
LP2_VLC117.sfs
LP2_WhiteDune-0.28.14-1.1.sfs
LP2_Wine.sfs
LP2_WineCorelSuite.sfs
LP2_Wink151.sfs
LP2_WinUSB-1.0.11-full.sfs
LP2_Worker-2.19.6-i686.sfs
LP2_Xaos35.sfs
LP2_XaraLx07.sfs
LP2_XFE1325.sfs
LP2_XineDVD_0.99.6.sfs
LP2_XMind321.sfs
LP2_XMind-linux-3.3.0.sfs
LP2_XMix_2.1-6.sfs
LP2_XMoonTool-3.0.1-full.sfs
LP2_XMorph20090929.sfs
LP2_XNView035Convert098.sfs
LP2_XnView51.sfs
LP2_XPaint-2.8.13-2.sfs
LP2_Xplorer-0.10.0-i686.sfs
LP2_XVidCap-1.1.7.sfs
LP2_XVKbd-3.0-LP2.sfs

###############################################################################
# End of List of SFS Modules for L.A.S.S.I.E.
###############################################################################

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2399
Location: Germany

PostPosted: Wed 02 Apr 2014, 13:07    Post subject:  

Welcome to L.A.S.S.I.E., Version 002 !

L.A.S.S.I.E. 002 is a Multi-Language Puppy-Linux Derivative and it is either based on Precise 5.7.1 (PAE Version) or based on Precise 5.7.1 retro (Non PAE Version). It is build by RSH by using the LazY Puppy ISO Builder and it was released at 2nd of April 2014.

L.A.S.S.I.E. 002 is useable out of the box for these Languages:

DA, DE, EN, ES, FI



FR, NL, IT, PT, TR



L.A.S.S.I.E. 002 is booting directly into language EN. Quicksetup and Welcome1stBoot are disabled by default. You can easily execute them by the menu (lite modification, but you'll find it quickly in Menu Welcome).

After switching L.A.S.S.I.E. 002 to the your language settings and restarting X, a small GUI appears, that gives option to remaster (the SFS only) the OS, so it will boot after this straight into your language (the language you have switched to). If you don't want to remaster the SFS only, just close the window.

But, please, note:

- either switch the language and do the remaster immediately
- or switch the language and just checking out / testing the OS

Do NOT, repeating: do NOT switch the language, testing the OS and remastering after using the OS!

If you've done a remaster, the new SFS will be presented in a ROX filer window. Just copy it to the L.A.S.S.I.E. boot directory (overwrite the existing one, but don't wipe the ISO!)


Special Features (new in L.A.S.S.I.E. 002):

VarioMenu-Groups and Desktops
- Each Desktop/VM-Group now has its own wallpaper
- Desktops and VarioMenu-Groups can be switched by keyboard shortcuts
- - Strg 1 switches to Desktop 1, Alt 1 switches to VM-Group 1 (e.g.)

- Added Option to the Right-click Menu of the Drive Icons to Power Off the Computer
- - it will first unload all loaded SFS Modules
- - after this all mounted ISO, SFS and 2fs, 3fs, 4fs Files in /mnt will be unmounted
- - then the Drives do unmount
- - then the Shutdown-GUI appears on the Screen


- Changed behavior when clicking a PET file
- - a GUI appears when a PET is clicked the 1st time in a session
- - - it offers option to choose either to build a SFS Module automatically
- - - or to install the PET package as usual
- - - if 'build a SFS Modue' is chosen, it will be used as default during the session
- - - though, one can still install PET packages by right-clicking it

_________________
LazY Puppy
RSH's DNA
SARA B.

Last edited by RSH on Wed 02 Apr 2014, 19:48; edited 3 times in total
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2399
Location: Germany

PostPosted: Wed 02 Apr 2014, 13:08    Post subject:  

The L.A.S.S.I.E. VM-Group Wallpapers!

Each of the eight predefined VarioMenu-Group in L.A.S.S.I.E. now has its own Wallpaper, as shown below.

The Wallpapers are created with L.A.S.S.I.E. 002 Development Version, GIMP Painter 2.8.7 and GIMP Beautify PlugIn - both used and loaded by SFS!

Administrator, Audio, Favorites


Graphics, Internet, Multimedia


Office, Video


Apps and Menus in different Languages!

Audacity 2.0.3 in NL


Drive-Icons Right-Click-Menu in DA


Menu in TR


ROX-Right-Click-Menu on Directory in ES


More Information to come soon...

_________________
LazY Puppy
RSH's DNA
SARA B.

Last edited by RSH on Wed 02 Apr 2014, 18:57; edited 2 times in total
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2399
Location: Germany

PostPosted: Wed 02 Apr 2014, 13:10    Post subject: HowTo...
Subject description: ...Build a SFS from multiple .deb files downloaded by Package Manager
 

HowTo build a SFS from multiple .deb files downloaded by Package Manager

I'm choosing for this the aqualung_0.9~beta11-1ubuntu9_i386.deb and its dependent .deb files: libifp4_1.0.0.2-5_i386.deb, libjack-jackd2-0_1.9.8~dfsg.1-1ubuntu2_i386.deb, liblrdf0_0.4.0-5build1_i386.deb, liblua5.1-0_5.1.4-12ubuntu1_i386.deb , libmodplug1_0.8.8.4-1_i386.deb, liboggz2_1.1.1-1_i386.deb, libraptor1_1.4.21-7ubuntu0.1_i386.deb, libwavpack1_4.60.1-2_i386.deb, because it is small in size and therefor fast to download (the SFS will be somewhat around 1.8 MB).

Execute the package manager and search for aqualung and click on the aqualung file inside of the package manager, after it has been found and is presented in the package manager gui.

Choose to examine the dependencies and to download them without to install the downloaded files.

So the complete list of downloaded files should look like some like that:

aqualung_0.9~beta11-1ubuntu9_i386.deb
libifp4_1.0.0.2-5_i386.deb
libjack-jackd2-0_1.9.8~dfsg.1-1ubuntu2_i386.deb
liblrdf0_0.4.0-5build1_i386.deb
liblua5.1-0_5.1.4-12ubuntu1_i386.deb
libmodplug1_0.8.8.4-1_i386.deb
liboggz2_1.1.1-1_i386.deb
libraptor1_1.4.21-7ubuntu0.1_i386.deb
libwavpack1_4.60.1-2_i386.deb

These files should have been downloaded to /root.

Make a directory, called aqualung_0.9-beta11-1ubuntu9_i386 ( replace the wave char (~) between 0.9 and beta by a minus char (-) ).

Move all downloaded .deb files into the new created directory.

Move the directory away from /root, since the SFS is build in /root from directory aqualung_0.9-beta11-1ubuntu9_i386 (or however you have named it). Move it into a sub-directory of /root or -even better- into your HD's file system.

Do execute a right-click onto the directory aqualung_0.9-beta11-1ubuntu9_i386 (or however you have named it) at its new location and choose: Merge to SFS.

If the GUI to create a PET package appears on the screen, let it build the PET package (the SFS is build from this PET package after its creation).

A ROX filer window should open a few moments later, presenting the aqualung_0.9-beta11-1ubuntu9_i386.sfs in /root. Move it to the L.A.S.S.I.E. boot directory. Go to menu Multimedia and look for Aqualung. Click its entry and Aqualung should run after the SFS is loaded automatically.

Everything went fine?

If no menu entry is found, just refresh the menus and restart JWM!
image-1.jpg
 Description   Aqualung build from .deb files, running from SFS by a SFS P.L.U.S. RunScript in L.A.S.S.I.E. 002
 Filesize   70.86 KB
 Viewed   711 Time(s)

image-1.jpg


_________________
LazY Puppy
RSH's DNA
SARA B.

Last edited by RSH on Thu 03 Apr 2014, 16:16; edited 5 times in total
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2399
Location: Germany

PostPosted: Wed 02 Apr 2014, 13:12    Post subject: HowTo...
Subject description: ...build a PlugIn SFS for the use with GIMP
 

HowTo build a PlugIn SFS for the use with GIMP ?

This is written for the use with GIMP Paint 2.8.7, but can be used for GIMP 2.8.x in general.

Either download the LP2_GimpPainter-2.8.7.sfs,
or download the GIMP files provided by don570 and build a SFS from those files.
You can use also these versions of GIMP: 2.8.4 or 2.8.10 and build a SFS from those files.

If you have chosen to build a SFS from don570's files, rename the SFS (add LP2_ in front of its name) and do execute a right-click onto the SFS --> choose: Convert to SFS P.L.U.S.

Whatever SFS you are using, move it to the L.A.S.S.I.E. boot directory.

Download the GIMP Beautify, Border & WaveTank PlugIns. These would be the files: Beautify-Linux_x32.zip and Rip-Border-Textures_0-5-1.zip and Texture-Border-Textures_0-5-1.zip and sf-will-wavetank_gimp-2.8.zip to be downloaded.

Create a directory named: Gimp-PlugIns-2.8 either in /root or any other ext file system. Create a directory root in that Gimp-PlugIns-2.8 directory. Create a directory .gimp-2.8 in that root directory. Create a directory plug-ins in that .gimp-2.8 directory.

So you will have a path: (/your-work-dir-here)/Gimp-PlugIns-2.8/root/.gimp-2.8/plug-ins

Clicking left on Beautify-Linux_x32.zip and let unpack all files.

You'll get those files:

beautify
border
simple-border
skin-whitening

Make sure they are all executable!

Copy those files into directory (/your-work-dir-here)/Gimp-PlugIns-2.8/root/.gimp-2.8/plug-ins.

Clicking left on Rip-Border-Textures_0-5-1.zip and Texture-Border-Textures_0-5-1.zip and let unpack all files.

You'll get those dirs:

rip-border
texture-border

Copy those dirs into directory (/your-work-dir-here)/Gimp-PlugIns-2.8/root/.gimp-2.8

Clicking left on sf-will-wavetank_gimp-2.8.zip and let unpack all files.

You'll get this file:

sf-will-wavetank_gimp-2.8.scm

Create a directory usr in directory Gimp-PlugIns-2.8. Create a directory share in that usr directory. Create a directory gimp in that share directory. Create a directory 2.0 in that gimp directory. Create a directory scripts in that 2.0 directory.

So you will have a path: (/your-work-dir-here)/Gimp-PlugIns-2.8/usr/share/gimp/2.0/scripts.

Copy sf-will-wavetank_gimp-2.8.scm into directory (/your-work-dir-here)/Gimp-PlugIns-2.8/usr/share/gimp/2.0/scripts.

Do execute a righ-click on directory Gimp-PlugIns-2.8 and choose to create a PET package. Move the created PET package and also directory Gimp-PlugIns-2.8 from /root (if they are there) to any other location (best to your HD file system).

Do execute a right-click on the created Gimp-PlugIns-2.8.pet and choose to Convert to SFS P.L.U.S. - a few moments later a LP2_Gimp-PlugIns-2.8.sfs will appear in /root. Move it to the L.A.S.S.I.E. boot directory.



HowTo add a dependent SFS Module to a SFS Module ?

Now locate your LP2_GimpPainter-2.8.7.sfs (or just the one you might have build at your own) and do execute a right-click onto it.

Choose Add Dependencies.

If the 1st text editor window has opened up, drag 'n' drop LP2_Gimp-PlugIns-2.8.sfs into the text editor's edit field and click OK or Apply.

Just close the 2nd text editor window, that will open up.

LP2_Gimp-PlugIns-2.8.sfs is now added as a dependent SFS Module to the your GIMP SFS Module.

Do again execute a right-click onto that GIMP SFS Module and choose: Create RunScript. Select the .desktop file and click OK or Apply. Refresh the menu and restart JWM (not X) to see its menu entry in Graphics menu. Clicking this entry will load the your GIMP SFS Module and also load the LP2_Gimp-PlugIns-2.8.sfs before executing the GIMP.

Ready...
image-1.jpg
 Description   GIMP PlugIn Beautify
 Filesize   62.99 KB
 Viewed   677 Time(s)

image-1.jpg

image-2.jpg
 Description   GIMP PlugIn Texture Border
 Filesize   63.47 KB
 Viewed   679 Time(s)

image-2.jpg


_________________
LazY Puppy
RSH's DNA
SARA B.

Last edited by RSH on Thu 03 Apr 2014, 18:03; edited 4 times in total
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 835
Location: lincoln

PostPosted: Wed 02 Apr 2014, 15:31    Post subject:  

new files mirrored:http://archive.org/details/Puppy_Linux_Lassie

Smile
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 3 of 5 [71 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1835s ][ Queries: 13 (0.0064s) ][ GZIP on ]