Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Jul 2014, 04:18
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
TahrPup 5.8.3 beta
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 5 of 16 [239 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, ..., 14, 15, 16 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7782
Location: qld

PostPosted: Tue 10 Jun 2014, 17:19    Post subject:  

Quote:
Could you plug it in as a local USB printer and report back? That's the crucial issue here.


Yes I'll get back, but it won't be until tomorrow night (my time).

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
sszindian


Joined: 24 Apr 2010
Posts: 600
Location: Pennsylvania U.S.

PostPosted: Tue 10 Jun 2014, 20:54    Post subject: cups  

(1)Fresh download tahr-5.8.0.8 (downloaded with Racy-5.5, checksum varified)
(2)Created new savefile (different HDD)
(3)Installed hplip-14's (from rcrsn51 thread)
(4)Installed tahrfix-5.8.0.8.pet

Same as with previous tahr-5.8.0.8, cups will NOT recognize my HP USB 1050 All-In-One Printer!!!!!! Only available printer available for setup is the PFD Printer in cups.

I will have to conclude that it's 'tahr' that has the issue and not myself or my equipment.

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8904
Location: Stratford, Ontario

PostPosted: Tue 10 Jun 2014, 21:09    Post subject:  

Here are some things to try.

1. Go to the folder /usr/lib/cups/backend
2. Open a terminal
3. Type: ./usb

Does it find anything?

Then go to the folder /dev. Turn the printer off and on several times. Do you see the folder "usb" being created/deleted?

With your printer turned ON, type
Code:
lsmod | grep usblp

Is this module loaded? If not, load it
Code:
modprobe usblp

Check your printer in CUPS.
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 600
Location: Pennsylvania U.S.

PostPosted: Tue 10 Jun 2014, 22:28    Post subject: cups  

Here are some things to try.

1. Go to the folder /usr/lib/cups/backend
2. Open a terminal
3. Type: ./usb

Does it find anything?

sszindian: it says- bash: ./usb: No such file or directory/dev

Then go to the folder /dev. Turn the printer off and on several times. Do you see the folder "usb" being created/deleted?

sszindian: No

With your printer turned ON, type
Code:
lsmod | grep usblp

Is this module loaded? If not, load it
Code:
modprobe usblp

Check your printer in CUPS.

sszindian: Nope, not there!

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8904
Location: Stratford, Ontario

PostPosted: Tue 10 Jun 2014, 22:40    Post subject:  

Are you saying that your folder /usr/lib/cups/backend does NOT contain the executable file named "usb"?

If you do NOT have this file, then it certainly explains your problem.

But it does not explain why this file is missing. I have it in my Tahr.

Quote:
Is this module loaded?

You never answered this question.
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 600
Location: Pennsylvania U.S.

PostPosted: Tue 10 Jun 2014, 23:31    Post subject: cups  

Maybe a couple pictures will explain what you ask?

>>>---Indian------>
cups-2.png
 Description   
 Filesize   10.76 KB
 Viewed   434 Time(s)

cups-2.png

cups-1.png
 Description   
 Filesize   31.74 KB
 Viewed   436 Time(s)

cups-1.png


_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2581
Location: Japan

PostPosted: Wed 11 Jun 2014, 03:30    Post subject: CUPS on Tahr Puppy  

I have tested my printer which is working on Precise Puppy 571JP.

Tahr Puppy 5.8.0.8 furugal install RAM mode.
Installed the driver epson_inkjet_printer_escpr-1.4.0.pet.

Typed on a virtual terminal:
Code:
# /usr/lib/cups/backend/usb
direct usb://EPSON/EP-704A "EPSON EP-704A" "EPSON EP-704A" "MFG:EPSON;CMD:ESCPL2,BDC,D4,D4PX,ESCPR2;MDL:EP-704A;CLS:PRINTER;DES:EPSON EP-704A;CID:EpsonRGB;FID:FXN,DPN,WFN,ETN,AFN,DAN;" ""

But the CUPS does not show my USB printer on the list of the Local Prnters

Installed gstoraster_s533-9.05.pet... same result.
Installed tahrfix-5.8.0.8.pet ... same result.
.
In all cases, the CUPS does not show my USB printer Crying or Very sad
cups_doesnt_show_usb_printer.png
 Description   
 Filesize   4.87 KB
 Viewed   378 Time(s)

cups_doesnt_show_usb_printer.png


_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 8904
Location: Stratford, Ontario

PostPosted: Wed 11 Jun 2014, 05:58    Post subject:  

When you turn on your printer, two things should happen. The device node /dev/usb/lp0 gets created. And the module usblp gets loaded.

It sounds like this isn't happening with some users. I cannot duplicate the problem.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2581
Location: Japan

PostPosted: Wed 11 Jun 2014, 10:00    Post subject: CUPS on Tahr Puppy does not show my USB printer  

1. Power off the USB connected printer
2. Boot the Tahr Puppy 5.8.0.8 without pupsave
3. Power on the USB connected printer

Code:
# /usr/lib/cups/backend/usb
direct usb://EPSON/EP-704A "EPSON EP-704A" "EPSON EP-704A" "MFG:EPSON;CMD:ESCPL2,BDC,D4,D4PX,ESCPR2;MDL:EP-704A;CLS:PRINTER;DES:EPSON EP-704A;CID:EpsonRGB;FID:FXN,DPN,WFN,ETN,AFN,DAN;" ""
# ls /dev/usb/lp0
/dev/usb/lp0
# lsmod | grep usblp
usblp                   7582  0


CUPS --> Administration --> Add Printer shows only the SCSI Printer and PDF writer on the Local Printers list. Crying or Very sad
I couldn't find anything particular in /var/log/cups/error.log.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html

Last edited by shinobar on Wed 11 Jun 2014, 10:41; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 8904
Location: Stratford, Ontario

PostPosted: Wed 11 Jun 2014, 10:15    Post subject:  

Try clicking on Find New Printers.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2581
Location: Japan

PostPosted: Wed 11 Jun 2014, 10:38    Post subject: Find New Printers  

rcrsn51 wrote:
Try clicking on Find New Printers.

Tried again and agin, but only the PDF writer shows.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
666philb


Joined: 07 Feb 2010
Posts: 1626
Location: wales

PostPosted: Wed 11 Jun 2014, 11:54    Post subject:  

rcrsn51

i can reproduce this odd problem ... printing is working on my netbook on a vanilla tahr5.8.0.8 with your pet or mine (this is the computer i've been using for testing) but i've just tried on my desktop, same setup as above and the same printer isn't found.

output is the same on both computers

Code:
#  /usr/lib/cups/backend/usb
direct usb://hp/deskjet%205550?serial=MY29A1J2NS2L "hp deskjet 5550" "hp deskjet 5550" "MFG:hp;MDL:deskjet 5550;CID:hpdeskjet_5550A851;CMD:MLC,PCL,PML,DW-PCL,DYN,DESKJET;CLS:PRINTER;DES:hp deskjet 5550;SN:MY29A1J2NS2L;S:0380008084001000002c14d0000c2570000;P:1962,FL,B0;J:                    ;" ""
# ls /dev/usb/lp0
/dev/usb/lp0
#  lsmod | grep usblp
usblp                   7582  0
#

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8904
Location: Stratford, Ontario

PostPosted: Wed 11 Jun 2014, 12:46    Post subject:  

This is like the occasional situation where CUPS refuses to detect a network printer. In that case, you can manually install the printer using the AppSocket/JetDirect protocol.

I don't know why it is happening with a USB printer, but can someone try this?

1. Run CUPS. Under Add Printer, select AppSocket/JetDirect.
2. On the next screen, delete "socket" and type "parallel:/dev/usb/lp0"
3. Finish the install as usual. You will still need the gstoraster patch.

Then try using the URI that comes out of /usr/lib/cups/backend/usb, like
Code:
usb://hp/deskjet%205550?serial=MY29A1J2NS2L
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1626
Location: wales

PostPosted: Wed 11 Jun 2014, 14:29    Post subject:  

hi rcrsn51,
can you explain how to do the last bit 'use the URI'?

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8904
Location: Stratford, Ontario

PostPosted: Wed 11 Jun 2014, 14:31    Post subject:  

It is printer's identifier to CUPS. Instead of "socket", paste in that line.

Have you tried the first method yet?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 5 of 16 [239 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, ..., 14, 15, 16 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0845s ][ Queries: 13 (0.0077s) ][ GZIP on ]