Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Jul 2014, 01:02
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Abiword 2.9.4 included in Slacko 5.6 is unstable
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [25 Posts]   Goto page: Previous 1, 2
Author Message
mikeb


Joined: 23 Nov 2006
Posts: 8033

PostPosted: Tue 22 Apr 2014, 15:35    Post subject:  

Hmm well i tried qtconfig for both 3 and 4 but perhaps its looking elsewhere since it mentions chrome.... I do remember kde had some mysterious setting that could pass over gui settings to gtk...possibly related to that magic....libreoffice also plays the 'use system theme settings game' too but like all things linux its a free for all and standards don't apply.

If someone was bored they could fire up a kde based distro...and play with settings and then try and find what file gets altered then use a copy of that... plan b...ask softmaker.

mike
Back to top
View user's profile Send private message 
rufwoof

Joined: 24 Feb 2014
Posts: 308

PostPosted: Wed 23 Apr 2014, 16:44    Post subject:  

Tried mounting rather than union'ing the softmaker sfs

mkdir /mnt/softmaker
mount softmaker.sfs /mnt/softmaker -t squashfs -o loop


in

/mnt/softmaker/usr/share/freeoffice

ran

./textmaker

and it starts up the text editor ok, but throws out a

sh: getconf: command not found

error. Puppy doesn't have a getconf in bin nor busybox (that I know of), which could be the problem.
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 8033

PostPosted: Wed 23 Apr 2014, 16:52    Post subject:  

Hmm don't have getconf on here either...so you thinking its running blind so won't pick up any desktop managers config? After all gnome and KDE are different beasties.

A sneaky way might be to find out which font it is using then alias a larger one....looks like its using a fallback X bitmap but thats just a guess.

mike
Back to top
View user's profile Send private message 
rufwoof

Joined: 24 Feb 2014
Posts: 308

PostPosted: Wed 23 Apr 2014, 18:04    Post subject:  

No luck. I installed getconf and still the same.

There are loads of fonts already in their sfs. Which one's to swap !!! (I'm not going to spend any time trying to figure that one out).

I also tried a 2002 (Lucid) version - ran ok under slacko, but still the same again (spell check disabled in that version - I guess as encouragement to register. Did have an additional OS2 choice of theme, but that wasn't any better than any of the others).

For me, looks like using Softmakers spreadsheet and Libre Word processor are a nice combination. I find that Libre tends to stutter when arrowing around a spreadsheet whilst softmaker doesn't, but the small menu fonts make Softmaker less comfortable than Libre for word processing.
Back to top
View user's profile Send private message 
slavvo67

Joined: 12 Oct 2012
Posts: 337
Location: The other Mr. 305

PostPosted: Wed 23 Apr 2014, 21:26    Post subject:  

I don't see a problem with Gnumeric. It seems very stable and converts the excel spreadsheets fine, I think. I've used pretty advanced Excel spreadsheets in Gnumeric without issue.

By the way, I'm running Libre Office 4.2 (there's a thread with different pets around here somewhere) on Fluxpup (PAE on one pc, non-PAE on the older) with old Dell hardware and I am experiencing little to no lag. Very, very happy with this combo. I kept ABI and Gnumeric on the same distro and 2 browsers (Opera and Seamonkey) with no issues. I also have Chromium (non-root) on the PAE version). I just can't decide on a browser... Rolling Eyes
Back to top
View user's profile Send private message 
rufwoof

Joined: 24 Feb 2014
Posts: 308

PostPosted: Thu 24 Apr 2014, 03:02    Post subject:  

I've had a few charts in worksheets open up as massively wide under gnumeric. Adjust save, then edited by another spreadsheet program and reopen with gnumeric - to have to adjust the charts again.

Just downloaded Libre 4.2.3 sfs (http://murga-linux.com/puppy/viewtopic.php?t=85915) and scrolling/arrowing around/through charts does seem to be a lot better. Thanks Slavvo
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 143

PostPosted: Wed 30 Apr 2014, 09:16    Post subject: Unstable in Windows, too  

Hi
I tested Abiword versions from 2.9.1 to 2.9.4 to decide which one should be included it in Puli http://www.murga-linux.com/puppy/viewtopic.php?t=88691.
Unfortunately, only 2.8.6 and 2.9.1 are able to open my favorite single-page docx file (screenshot attached) but the rest of versions, from 2.9.2 to 2.9.4 fail.
Same behavior under Windows 7.

Finally, I did not remove Abiword 2.8.6 from Puli but added SoftMaker FreeOffice 2012 and LibreOffice 4.2., that run from the memory flawlessly.
However, in FreeOffice, the response time drops dramatically if the number of applied font types are more than eight, while Abiword and LibreOffice remains fast.

Later I tested Abiword 3 in Lubuntu 14.04 LTS. Opens and saves various formats of more complex documents nicely.
Test.jpg
Description 
jpg

 Download 
Filename  Test.jpg 
Filesize  177.74 KB 
Downloaded  58 Time(s) 
Back to top
View user's profile Send private message 
slavvo67

Joined: 12 Oct 2012
Posts: 337
Location: The other Mr. 305

PostPosted: Wed 30 Apr 2014, 21:07    Post subject:  

These are interesting findings. Thank you. I'll need to look closer at that!
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 2903
Location: Mer méditerrannée (1 kms°)

PostPosted: Sun 22 Jun 2014, 23:10    Post subject: Abiword default text processor : fine !
Subject description: 149MB to load if Abiword not enough ! (SFS LO oOo)
 

Using Libre office or Soft Maker does not help improving Abiword.
Abiword is the right tool pour everyday usage of Puppy's user. If you need more install SFS. Try the last version 3.0.0 here
completely agrre with Wilhelm about not installing unstable versions.
Newbies escape the puppy distro because of that !
Windows is competitive vs Puppy using Suites Office. JRE included. Libre Office and Open Office are free of charge too.
Puppy offers everything in light apps. That is the reason of its succes. Don't change that

_________________
Puppy, il ne lui manque que la parole !
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo


Joined: 10 Sep 2011
Posts: 2903
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 02 Jul 2014, 15:13    Post subject: Abiword 2.9.4 Slacko > use 2.8.2  

"However, due to the lack of time and people to contribute to the documentation effort, it is far from complete, and does not cover all features, including many of the new features available in the 2.x release series"

All versions 2.9 are instable. this version was for test by users and roots.
Use last version stable 2.8.2 for Slacko. Just add the pet joined.
administrators (root) had to inform Abisource to issue a new stable version. I hope they did it and that version 3.0.0 is safe.
Nevertheless the fact of having coloured borders instead of blacks ones for inserted tables is not a so important thing.
technosaurus abiword provides the pets for UK citizens, ASRI will furnish frenchies
Abiword fit the needs of common users. because they don't have a lot colleagues, they have only their wife (sometimes).
Those who need a full suite for slides, database,spreadsheets, can add their 150MB SFS with Abiword 4MB installed. et vice-versa.
vokoscreen.jpg
 Description   maquette 2.8.2
 Filesize   61.05 KB
 Viewed   27 Time(s)

vokoscreen.jpg

wv-1.2.4-i386.pet
Description 
pet

 Download 
Filename  wv-1.2.4-i386.pet 
Filesize  161.52 KB 
Downloaded  14 Time(s) 

_________________
Puppy, il ne lui manque que la parole !
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 2 of 2 [25 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0718s ][ Queries: 13 (0.0083s) ][ GZIP on ]