Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 21 Nov 2014, 12:33
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
Need driver for Nvidia Geforce MX440 graphic card (Solved)
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
georg1

Joined: 23 Sep 2013
Posts: 163

PostPosted: Thu 21 Aug 2014, 11:00    Post_subject:  Need driver for Nvidia Geforce MX440 graphic card (Solved)  

I ask if anyone can try compile nvidia driver for me.\

got slacko 5.7.0
kernel 3.10.32 i686

and nvidia geforce mx 440 graphic card LINK

I try with getnvidia 1.0 pet and always get error "some file is missing"

If anyone got 10 minutes his time to try if he got same error like me on this thread http://www.murga-linux.com/puppy/viewtopic.php?t=95342

thank you
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4042
Location: World_Hub

PostPosted: Thu 21 Aug 2014, 12:35    Post_subject:  

You need the kernel sources and the devx. Do you have'm?
_________________
>>>Punctuation Crash Course<<<
Back to top
View user's profile Send_private_message 
georg1

Joined: 23 Sep 2013
Posts: 163

PostPosted: Thu 21 Aug 2014, 12:48    Post_subject:  

got both
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4042
Location: World_Hub

PostPosted: Thu 21 Aug 2014, 13:22    Post_subject:  

Actually, you should work through your problem in the linked thread.
_________________
>>>Punctuation Crash Course<<<
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4042
Location: World_Hub

PostPosted: Thu 21 Aug 2014, 15:47    Post_subject:  

You could always give the manual method a whirl. What I would do is confirm your dwnld with it's "--check" option.
_________________
>>>Punctuation Crash Course<<<
Back to top
View user's profile Send_private_message 
georg1

Joined: 23 Sep 2013
Posts: 163

PostPosted: Fri 22 Aug 2014, 05:45    Post_subject:  

I got same result, no matter what I do, if use any driver for mx440 I allways wind up with error



and here is success when I try compile random driver from nvidia



So what Is my options ? Take another distro is allmost inpossible, because that PC is on remote location and that guy make me a lot of gray hair during installation, I like avoid that stress again LOL
Back to top
View user's profile Send_private_message 
CatDude


Joined: 03 Jan 2007
Posts: 1497
Location: UK

PostPosted: Sat 23 Aug 2014, 10:36    Post_subject: nvidia driver  

Hello georg1

georg1 wrote:
I ask if anyone can try compile nvidia driver for me.\

got slacko 5.7.0
kernel 3.10.32 i686

and nvidia geforce mx 440 graphic card LINK

I try with getnvidia 1.0 pet and always get error "some file is missing"

If anyone got 10 minutes his time to try if he got same error like me on this thread http://www.murga-linux.com/puppy/viewtopic.php?t=95342

thank you


I managed to compile this driver a couple of months back for Slacko-5.7 (non PAE),
and it was a right PITA as it requires patching.

Anyway mate, i have just built it again in Slacko-5.7.0
and put it together as a dotpet for you.

Before attempting to use this package, please make a backup of your savefile.
Use entirely at your own risk !


After installing the dotpet (allow it enough time), Exit to prompt
and run xorgwizard
Select nvidia from the list of options offered
Choose your screen res and then reboot.

When you boot back into Puppy,
it will probably stop at a window asking you to Test now (or something similar)
let it do so.

Hope it works for you.
CatDude
.
Screenshot.png
 Description   
 Filesize   136.66 KB
 Viewed   336 Time(s)

Screenshot.png


_________________

Back to top
View user's profile Send_private_message 
georg1

Joined: 23 Sep 2013
Posts: 163

PostPosted: Sat 23 Aug 2014, 14:31    Post_subject:    

yeahh Im really happy Smile

Thank you very very much

now work like must

Can I ask you, how you succes I try really hard allmost two day's and allways error.

Thank you again

Back to top
View user's profile Send_private_message 
CatDude


Joined: 03 Jan 2007
Posts: 1497
Location: UK

PostPosted: Sat 23 Aug 2014, 16:24    Post_subject:  

Hi

georg1 wrote:
..Can I ask you, how you succes I try really hard allmost two day's and allways error.


Step 1. Get rid of the nouveau driver.
    The first thing to do is make sure that the nouveau driver is nowhere to be seen. (ie: blacklisted)

    Use the xorgwizard choose nv or vesa, reboot if needed.
    Back in Puppy run lsmod to see if the nouveau driver appears anywhere,
    if it does run rmmod nouveau followed by lsmod and take another look.

    It is vital to establish a nouveau free zone. Laughing

Step 2. Building the driver.

Hope this helps.

CatDude
.

_________________

Back to top
View user's profile Send_private_message 
georg1

Joined: 23 Sep 2013
Posts: 163

PostPosted: Sat 23 Aug 2014, 17:18    Post_subject:  

Thank you for this tutorial, I Will thy doin my self too Smile
Back to top
View user's profile Send_private_message 
CatDude


Joined: 03 Jan 2007
Posts: 1497
Location: UK

PostPosted: Sun 24 Aug 2014, 09:49    Post_subject:  

Hello georg1

georg1 wrote:
Thank you for this tutorial, I Will thy doin my self too Smile

It's not so much a 'tutorial' but more of an 'overview' of what i did.

You will most likely need to install (via the PPM) pkgtools
otherwise the .SlackBuild's will fail to produce packages.

Don't forget that you also need both the devx and kernel-sources loaded.

CatDude
.

_________________

Back to top
View user's profile Send_private_message 
Griot


Joined: 12 Sep 2014
Posts: 36
Location: Serbia

PostPosted: Thu 02 Oct 2014, 18:19    Post_subject:  

Edited for clarity. Thanx CatDude & Flash.
Edited_times_total
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11150
Location: Arizona USA

PostPosted: Thu 02 Oct 2014, 21:53    Post_subject:  

Please don't post the same question several places in the forum. It causes problems for everyone, especially the people who are trying to help you but also anyone with the same problem who is looking for a solution. Smile

I made your other post into its own thread. Perhaps there it will draw more attention than when added to a general thread about drivers.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0859s ][ Queries: 13 (0.0091s) ][ GZIP on ]