Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 07:26
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
writing back to the pupxxx file on your ram disk - problem
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
John Doe
Guest


PostPosted: Sun 31 Jul 2005, 14:27    Post_subject:  writing back to the pupxxx file on your ram disk - problem  

I'm booting a USB stick off a floppy to run puppy. When I shut down or restart sometimes (more often than not) I do not see the message, "writing back to the pupxxx file on your ram disk".

The times that I do see the message, I can boot later and all is well. If I don't see that message, my install is all messed up the next time I boot.

Anyone else have this problem? It's "intermittent" to say the least. I can't find any pattern at all.
Back to top
guest
Guest


PostPosted: Sun 31 Jul 2005, 16:24    Post_subject:  

Hi,

I run chubby puppy from a USB stick (512megs), and don't use a floppy to start things off.....just select the stick at startup and don't have .... never have had in the past with older versions of puppy.... any boot problems or saving of anything, ever....I never see the statement - "writing back to the pupxxx file on your ram disk"....as far as I can remember.

Starting without the floppy might rectify your challange.
Back to top
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11164
Location: Arizona USA

PostPosted: Sun 31 Jul 2005, 16:28    Post_subject: Re: writing back to the pupxxx file on your ram disk - probl  

John Doe wrote:
I'm booting a USB stick off a floppy to run puppy. When I shut down or restart sometimes (more often than not) I do not see the message, "writing back to the pupxxx file on your ram disk".

The times that I do see the message, I can boot later and all is well. If I don't see that message, my install is all messed up the next time I boot.

Anyone else have this problem? It's "intermittent" to say the least. I can't find any pattern at all.
What do you do to fix it when it is messed up?
Back to top
View user's profile Send_private_message 
John Doe
Guest


PostPosted: Sun 31 Jul 2005, 16:40    Post_subject:  

I delete the pupxxx file and start over.

It completely corrupts the image when the save doesn't happen.
Back to top
Ian
Official Dog Handler


Joined: 04 May 2005
Posts: 1237
Location: Queensland

PostPosted: Sun 31 Jul 2005, 20:06    Post_subject:  

Have you checked all your USB connections to ensure there is nothing loose or faulty and have you tried the stick in any other machines to see if the stick might be faulty.
Back to top
View user's profile Send_private_message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sun 31 Jul 2005, 21:33    Post_subject:  

Is the USB keydrive writng back to a HD or the keydrive? Is there sufficient space?
_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
John Doe
Guest


PostPosted: Mon 01 Aug 2005, 00:29    Post_subject:  

Based on some quick tests tonight, I think the space issue is it.

I'm doing some testing tonight with a 1gig card (normally I use a 256meg). I'll post back tomorrow with some results.

Thanks all for the comments.

(yes, writing back to USB device)
(no, it isn't loose) - good idea though, based on what I described
Back to top
John Doe

Joined: 01 Aug 2005
Posts: 1689
Location: Michigan, US

PostPosted: Mon 01 Aug 2005, 14:56    Post_subject:  

How much space is required for the write back?

Is it equal to the size of the pupxxx file?

-------------------

The base files take up this much room:

pupxusb = 0KB
syslinux.cfg = 1KB
usr_cram.fs = 54,068KB
vmlinuz = 1,024KB
image.gz = 6,221 KB

total = 61,314

my 256MB usb drive after formating, has 241MB available.

241MB = 246,784KB

246,784 - 61,314 = 185,470KB available for pupxxx and writting (do I need to split the difference or less [92,735]?)

My pupxxx file is currently configured to be 131,072KB

That leaves 54,398KB which doesn't seem to work.
Back to top
View user's profile Send_private_message 
John Doe

Joined: 01 Aug 2005
Posts: 1689
Location: Michigan, US

PostPosted: Mon 01 Aug 2005, 15:29    Post_subject:  

Maybe 256 is just too small. I tried 92160 for the pupxxx file size and it still didn't work.

Anyone know if there is a minimum size?

I'm real confused as to why it worked for a few days on the 256 device, then stopped but WILL work on my 1gig stick.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0555s ][ Queries: 12 (0.0049s) ][ GZIP on ]