Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 17:41
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Localization Project
Swedish keybord on Dell and Toshiba laptops?
Moderators: Lobster, MU, raffy
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
bmjbmj

Joined: 03 Dec 2006
Posts: 3

PostPosted: Sun 03 Dec 2006, 06:14    Post_subject:  Swedish keybord on Dell and Toshiba laptops?
Sub_title: Swedish keybord on Dell and Toshiba laptops?
 

Hello

I have a problem on several laptops from Toshiba and Dell. The swedish characters "åäö" [a-ring, a-doubledot, o-doubledot] is mapped to AltGr + the characters key and not stright to the key. It is like having to press AltGr + A to get an A on a us keybord.

The language is set to .SE and I have tested several "setxkbmap" combinations in vain. I need to get the scancode for the AltGr + swedish character and "showkey" is not a part of puppy. Is ther a replacement comand? or is ther a way to figure out the scancode from that the ö letter is produced by AltGr ö? The files in xkb folder is a bit complex and depends on each other.

WR/ B Mathias Johansson
PS
I tryed to search the web and the forum and found nothing. If the answer is already posted pleas giv mi a link.
DS
Back to top
View user's profile Send_private_message 
pakt


Joined: 04 Jun 2005
Posts: 1089
Location: Sweden

PostPosted: Sun 03 Dec 2006, 11:39    Post_subject:  

Which version of Puppy are you using?
_________________
Testing Puppy since v0.9.2 - my desktop OS since v1.0.7
Running SlaxerPup-4.12 - Puppy with a Slackware 12.2 heart Cool
Back to top
View user's profile Send_private_message 
bmjbmj

Joined: 03 Dec 2006
Posts: 3

PostPosted: Sun 03 Dec 2006, 15:54    Post_subject:  

Oh sorry Embarassed !
That is of course a vital piece of information! I'm using 2.12.

WR BMJ
Back to top
View user's profile Send_private_message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Sun 03 Dec 2006, 22:23    Post_subject:  

if you are using the xvesa X server, it does not support xkb ... to use intl keyboards you should use the Xorg X server

look in the file /etc/X11/xorg.conf ... there should be a line like this:

Option "XkbLayout" "se" #xkeymap0

if it is set to "us", change it to "se" and restart X (or reboot)

there are variations in the basic keyboard:

Option "XkbLayout" "se" #xkeymap0
Option "XkbVariant" "se"

Option "XkbLayout" "se" #xkeymap0
Option "XkbVariant" "nodeadkeys"

Option "XkbLayout" "se" #xkeymap0
Option "XkbVariant" "rus"

# Norwegian Northern Sami keyboard
Option "XkbLayout" "se" #xkeymap0
Option "XkbVariant" "smi"
Back to top
View user's profile Send_private_message 
bmjbmj

Joined: 03 Dec 2006
Posts: 3

PostPosted: Mon 04 Dec 2006, 13:24    Post_subject: Thanks  

I was using xvesa X server and a switch to Xorg X server fixed the problem.

Thanks a bunch for explaing the differens for me Very Happy

You probably know this already but Puppy 2.12 works fantastic on Toshiba Tecra 530CDT and Dell Latitude C600 as long as you have 128 - 256 MB of RAM.

Once again Thanks
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects » Localization Project
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0490s ][ Queries: 12 (0.0044s) ][ GZIP on ]