Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 17 Dec 2017, 23:24
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
How to use Intel GMA3600 onboard graphics in Lucid 5.2.8?
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [18 Posts]   Goto page: Previous 1, 2
Author Message
mikeslr


Joined: 16 Jun 2008
Posts: 2069
Location: 500 seconds from Sol

PostPosted: Sat 30 May 2015, 11:11    Post subject: uvesafb and fbdev  

Hi tempestuous,

First, on behalf of myself and all other Puppyites who lack the skill and dedication it takes to compile applications, please accept our thanks for your interest and efforts. You are one of a handful of unsung heroes without which Puppy would have vanished along with many other "small" distros.

As I tend to be "all over the place", if and when you've compiled uvesafb and/or fbdev applications for Tahrpup or Slacko, please call them to my attention by email. I'll be more than happy to run tests on my Acer.

Thanks again,


mikesLr
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Fri 05 Jun 2015, 08:24    Post subject:  

Well I just packaged the fbdev driver for Tahrpup 6 and Slacko 6beta, but in the process I learned that the fbdev driver should be no better than the modesetting driver already included in these modern Puppies. So there's no point posting the packages.

But the modesetting driver is not compatible with the older kernel in Puppy Lucid 5.1/5.2.x, so the fbdev driver remains useful for Lucid.
It's available here -
http://www.murga-linux.com/puppy/viewtopic.php?t=67166

I just updated the installation instructions.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5468
Location: Australia

PostPosted: Sat 06 Jun 2015, 08:01    Post subject:  

UPDATE:
The modesetting driver has recently been further developed to support 2D/X-Video acceleration from X.Org Server 1.17 onwards -
http://www.phoronix.com/scan.php?page=news_item&px=X.Org-Server-1.17-Released
http://www.phoronix.com/scan.php?page=news_item&px=MTg2Mzc

How does this translate to Puppy? Slacko6-beta has xorg-server 1.14. Tahrpup 6.x has xorg-server 1.15. No good with either of these.
But I see that Ubuntu Vivid Vervet has xorg-server 1.17
... and I see that 666philb has created a Puppy derivative based on Vivid -
http://www.murga-linux.com/puppy/viewtopic.php?t=98032

Poulsbo graphics users - you should really try the modesetting driver in Vividpup beta!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [18 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0615s ][ Queries: 14 (0.0093s) ][ GZIP on ]