Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 12 Dec 2019, 19:41
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
tahrpup64 6.0.5 CE
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 8 of 58 [856 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, ..., 56, 57, 58 Next
Author Message
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Sun 06 Sep 2015, 16:32    Post subject: Re: tahrpup64 6.0.3.5 beta  

Billtoo wrote:


There is a problem with the kernel_sources-3.14.45-tahr64.sfs,I was
unable to compile the proprietary Nvidia Ion driver on this pc or the
ati proprietary on the other pc.


the latest nvidia driver compiled for me .... although getnvidia didn't work and i had to do it manually.

this kernel is just a stopgap and definitely isn't the final. just using it whilst ironing out the tahrpup64 build process

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Sun 06 Sep 2015, 16:46    Post subject:  

live wrote:
Super great, moving towards release candidate Smile

Results of my tahrpup64 6.0.3.5 beta tests:

To add/fix
At boot no Internet connexion box, as tahr32

If you could kindly update:
pfind 5.14 > 6.2 (update OK)
pburn 3.7.18 > 4.3.16 (update OK)
pbackup 3.1.6 > 3.1.9-1 (update OK)
VLC 2.1.6 > 2.2.1
Gparted 0.22 > 0.23
ntfs-3g 2013 > 2015

Wbar does not work properly:
Code:
Problem load font file. /usr/share/fonts/truetype/liberation/LiberationMono-Regular/12

/usr/share/icons/nuoveXT2/128x128/apps/kfm.png Couldn't load icon image.

The path to icons are incorrect

Regarding devx
whishing updates, for instance gcc 4.6.4 to 4.9.3

Themes
I noticed some themes differs from thar32, for instance MurrinaSpring (which I do prefer in Tahr32)

Request as of for Thar32
* fix the possibility to have blank/space in file name images under usr/share/backgrounds
* I tried to modify "Default Applications Chooser" in order to add a default for presentations.
It's my first hands into Puppy scripting, could someone help me to modify it; presently it refuses to execute, I wonder if it permission issue or error into to code which darfs everything. Next, I wish to add some features to pfind.

Request to move out of the iso and bundle apart into separated pet:
* all "fun" apps
* AbiWord + Gnumeric + Leafpad
* from "business" put everything into a pet, except Gcalculator
Note that the icons of Planner do not appear.

Many thanks.


P.S. Other tested apps such as Kdenlive 0.9.10, WPS office work super fine
Code:

hi live,

i'll update pfind
may update pburn .... will need to add ffmpeg though
vlc is probably a no-no ... the repo where i found vlc 2.0 for tahr32 seems to have gone.
as before i don't want to touch gparted and will go with the one in the repo
same with ntfs 3g
wbar says it's missing a font

Gcc 4.9 is in the PPM ... in tahrpup64 i plan to include a gcc switcher by 'jlst ' http://murga-linux.com/puppy/viewtopic.php?t=97981

"move all fun apps out of the iso" .... no chance grumpy! in fact i'm looking for some new ones to replace the 3 older ones in the menu.

tahrpup64 isn't about being cutting edge ...more about refining the build system so we have a sane usable 64bit ubu pup from woof. if it's as usable as tahr32 i'll be happy

cheers phil

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331

Last edited by 666philb on Sun 06 Sep 2015, 17:01; edited 1 time in total
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Sun 06 Sep 2015, 16:51    Post subject: Re: Addition to live's requests  

mikeslr wrote:
Hi all,

Regarding Default Application Chooser, could someone add "Terminal". I'd like this for all Pups.

Often the default Terminal for a Pup does not have a menu enabling "cut & paste" facilitating copying of text from a text editor to the terminal or vice-versa. The work-around is "middle-click" which I've never been able to do. So I install either Roxterm or LxTerminal. But then I have to manually change Pups to use it by default.

I'm almost certain I'm not the only person who runs into this problem.

mikesLr


hi mikeslr,

i think shinobar actually added this functionality but then gave me the link to an older version that doesn't have it ..... probably post this in the defaults chooser thread http://www.murga-linux.com/puppy/viewtopic.php?t=56282

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Sun 06 Sep 2015, 16:54    Post subject: Re: pBurn-3.7.18 vs 4.3.16 ?  

charlie6 wrote:
Hi phil,
live wrote:
[...
If you could kindly update:
pfind 5.14 > 6.2 (update OK)
pburn 3.7.18 > 4.3.16 (update OK)
pbackup 3.1.6 > 3.1.9-1 (update OK)
...


hmmmm...! one question: about pBurn, what is the most reliable version related to burning operations on CD/DVDs? ...in order to just avoid spilling of non-RW «misburned» CDs or DVDs ?
I'm now on the point to systematically burn a RW disk for checking purpose before burning a non-RW one ... Very Happy !

Latest puppiesl like the Tahrpup-6.0X, or vivid-4.0.1 or vivid-6.5beta have pburn-3.7.18 because they do not have an embedded ffmpeg.
Forum member Zigbert recommends version 4.3.16 for compatibility with Windows, among others.

Thanks for any answer Smile
Charlie


hi Charlie
i'll add ffmpeg and the latest pburn in the next build to see if it works

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12993
Location: S.C. USA

PostPosted: Sun 06 Sep 2015, 17:25    Post subject:  

666philb wrote:
bigpup wrote:
Tahrpup64 6.0.3.5
Live CD made with Burniso2cd
md5 check good
Burn check OK

Nvidia Geforce GTX 960

Boots to a black screen.

Have tried pfix=nox
Boots to black screen.
No prompt.

Boot process seems normal to the point of changing over the graphics.

Maybe no support in the kernel for this graphics hardware Idea
Using the latest Nouveau driver?

hi bigpup

with this kernel nouveau bottles out with my nvidia card and i get vesa .. i may go with a 4.+ kernel eventually but nouveau in 4.* crashes with my card so just for development i'm using the 3.14* so i can can boot to desktop
.. maybe try one of stemsees kernelshttp://murga-linux.com/puppy/viewtopic.php?t=96723&start=255

So, how do you get to a point where you can choose to use the Vesa driver??

I have read some stuff that says you need the latest Nouveau driver to run Nvidia Geforce GTX 900 series cards.
http://nouveau.freedesktop.org/wiki/

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12993
Location: S.C. USA

PostPosted: Sun 06 Sep 2015, 17:40    Post subject:  

Something you may want to add to Tahrpup.

How to turn JWM menu items into desktop shortcuts
http://www.murga-linux.com/puppy/viewtopic.php?t=100819

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Sun 06 Sep 2015, 18:40    Post subject:  

bigpup wrote:

So, how do you get to a point where you can choose to use the Vesa driver??

I have read some stuff that says you need the latest Nouveau driver to run Nvidia Geforce GTX 900 series cards.
http://nouveau.freedesktop.org/wiki/


the nouveau fails to recognize my card throwing an 'unknown kepler chipset'then carries on to vesa automatically.

with the 4.1 Kernel nouveau works but the desktop crashes after a bit for me

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331

Last edited by 666philb on Sun 13 Sep 2015, 12:31; edited 1 time in total
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Sun 06 Sep 2015, 18:48    Post subject: Re: tahrpup64 6.0.3.5 beta  

666philb wrote:


the latest nvidia driver compiled for me .... although getnvidia didn't work and i had to do it manually.

this kernel is just a stopgap and definitely isn't the final. just using it whilst ironing out the tahrpup64 build process


I moved my latest usb flash drive installation to my Acer Revo nettop
and tried compiling the Nvidia Ion proprietary driver again,
successfully this time.

Display
Resolution 1920x1080 pixels
OpenGL Renderer ION/integrated/SSE2
X11 Vendor The X.Org Foundation
OpenGL
Vendor NVIDIA Corporation
Renderer ION/integrated/SSE2
Version 3.3.0 NVIDIA 340.93
Direct Rendering Y_es

Thanks
acerrevo.jpg
 Description   
 Filesize   89.02 KB
 Viewed   1228 Time(s)

acerrevo.jpg


Last edited by Billtoo on Mon 07 Sep 2015, 08:22; edited 1 time in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12993
Location: S.C. USA

PostPosted: Mon 07 Sep 2015, 03:10    Post subject:  

666philb wrote:
bigpup wrote:

So, how do you get to a point where you can choose to use the Vesa driver??

the nouveau fails to recognize my card throwing an 'unknown keplar chipset'then carries on to vesa automatically.

with the 4.1 Kernel nouveau works but the desktop crashes after a bit for me

My Nvidia card is a NV110 family(Maxwell).

All I get is a black screen. Evil or Very Mad

Quote:
the nouveau fails to recognize my card then carries on to vesa automatically.

This never happens. Evil or Very Mad

Trying to boot using "puppy pfix=nox"
Boots to black screen with no prompt.

Did get to a prompt, booting Slacko 5.7, using "puppy pfix=nox"
Ran Xorgwizard choosing Vesa driver.
Got to a working desktop in Slacko 5.7

Got any idea why "puppy pfix=nox" will not get Tahrpup booted to a prompt??

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1931
Location: Italy

PostPosted: Mon 07 Sep 2015, 07:38    Post subject:  

I have tested working the combination:

jwm-976-april64
rox-filer-2011-10-22-patched-april64
gtkdialog-514-x86_64-1

Result: no more remaining blank window to be killed copying and renaming files.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4094
Location: Worcestershire, UK

PostPosted: Mon 07 Sep 2015, 10:46    Post subject: /usr/lib64 symlink & sfs  

The chromium64 sfs is built to install into /usr/lib64.

It works fine on Slacko64 and also on TahrPup64-6.0.2

TahrPup64-6.0.3.5 implements /usr/lib64 as a link to /usr/lib and this seems to cause a problem with loading sfs's that try to install into /usr/lib64 - i.e. they don't Crying or Very sad

Does the sfs loading mechanism need to be "adjusted" to take account of this system architecture and its associated problem??

Cheers
peebee

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
live

Joined: 10 Feb 2010
Posts: 223

PostPosted: Mon 07 Sep 2015, 16:55    Post subject:  

@666philb

Quote:
Gcc 4.9 is in the PPM ...

I just took devx_tahr64_6.0.3.5.sfs and think it would be good to directly update it.

Quote:
wbar says it's missing a font

In thar32, it readily works

More problematic are missing browser support, see
https://www.youtube.com/html5
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1931
Location: Italy

PostPosted: Tue 08 Sep 2015, 07:46    Post subject:  

I have not scripting skills but I have patched initrd.gz and I have light encryption working. I propose the following change:

Code:
mnt_enc_pupsave_func() {
   echo >/dev/console
    echo "NOTICE: As you type your password nothing will be displayed on the screen."  >/dev/console
    echo "This is a security measure. Just type it in then press ENTER key..." >/dev/console
    echo -e "\\033[1;36m" >/dev/console #aqua-blue
    echo -n "Password: " >/dev/console
    echo -en "\\033[0;39m" >/dev/console
    if [ "$CRYPTO" = "-e aes" ];then #v3.98
     read -s MYPASS #< /dev/console v403
     echo "$MYPASS" | losetup -p 0 -e aes /dev/loop1 /mnt/dev_save$PUPSAVEFILE
    else
     #losetup does not accept -p param for xor encryption... may not work...
     read -s MYPASS #< /dev/console v403
     echo "$MYPASS" | losetup -p 0 -E 1 /dev/loop1 /mnt/dev_save$PUPSAVEFILE
    fi
}


(change at the end of the above code). If something is wrong with this code let me know. I'm using losetup-FULL of prealpha version and fatdog 3.18.7 kernel.
Back to top
View user's profile Send private message 
oui

Joined: 20 May 2005
Posts: 3499
Location: near Woof (Germany) :-) - 3 PC's: DELL SX280 750 MB Pentium4, Acer emachines 2 GB AMD64. DELL XPS15

PostPosted: Tue 08 Sep 2015, 19:58    Post subject: Problematic Themes and absent icones  

Hi

I did install xxxterm (old name in Ubuntu Tahr for the Xombrero browser) and remaster tahrpup64 with xxxterm.

At remastering time I did observe a great disturb in the squashing message (see picture, on top, left, the field with the 3 green points: The text is yellow on white background and you can read nothing)! This disturb happens in all puplets having those white default background pictures! Where is the place where the colour values for those texts is registered?

My xxxterm installation came directly from Ubuntu depository (see bottom part left of the picture, where the red point is to see). xxxterm/xombrero works perfectly (spelling control in 3 languages en/fr/de as well as use of flashplayer: you can see on the picture a view on the French national TV news, an extremely exigent channel concerning flashplayer http://france2.fr/jt/20h - if that goes more than 5 minutes, all goes with flash!!!) but I have a terrible deception with web pages using entry fields like the editor of the murga-forum, or, above on the picture, right, groups of 4 turcoise points on the screen of cups: The lines of the fields mask the content of the fields!

An idea how to change both bugs?
ProblematicThemes.jpg
 Description   
 Filesize   55.83 KB
 Viewed   901 Time(s)

ProblematicThemes.jpg

Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 3089

PostPosted: Wed 09 Sep 2015, 07:29    Post subject:  

watchdog wrote:
I have not scripting skills but I have patched initrd.gz and I have light encryption working. I propose the following change:

Code:
mnt_enc_pupsave_func() {
   echo >/dev/console
    echo "NOTICE: As you type your password nothing will be displayed on the screen."  >/dev/console
    echo "This is a security measure. Just type it in then press ENTER key..." >/dev/console
    echo -e "\\033[1;36m" >/dev/console #aqua-blue
    echo -n "Password: " >/dev/console
    echo -en "\\033[0;39m" >/dev/console
    if [ "$CRYPTO" = "-e aes" ];then #v3.98
     read -s MYPASS #< /dev/console v403
     echo "$MYPASS" | losetup -p 0 -e aes /dev/loop1 /mnt/dev_save$PUPSAVEFILE
    else
     #losetup does not accept -p param for xor encryption... may not work...
     read -s MYPASS #< /dev/console v403
     echo "$MYPASS" | losetup -p 0 -E 1 /dev/loop1 /mnt/dev_save$PUPSAVEFILE
    fi
}


(change at the end of the above code). If something is wrong with this code let me know. I'm using losetup-FULL of prealpha version and fatdog 3.18.7 kernel.

This does not work with the original files. Is an old problem with both losetup and mount that do not support encryption any more and need to be patched. So the encrypted savefile is not even generated.
Needs the patched verions and should not need any changes in the init (not sure how fd's is patched)

Latter: attached is a losetup-FULL of losetup version 2.21.2 (known to work with crypto) compiled in Tahr64.
It still needs changes in the init script though (I guess because of different busybox 1.21.0/2013 vs 1.21.1/2014) as suggested by watchdog.
Here is a patch
Code:
--- init.orig   2015-08-25
+++ init   2015-09-09
@@ -585,12 +585,12 @@
     echo -e "\\033[1;36m" >/dev/console #aqua-blue
     echo -n "Password: " >/dev/console
     echo -en "\\033[0;39m" >/dev/console
-    if [ "$CRYPTO" = "-e aes" ];then #v3.98
-     read -s MYPASS
+    read -s MYPASS #< /dev/console v403
+    if [ "$CRYPTO" = "-e aes" ];then #v3.98     
      echo "$MYPASS" | losetup -p 0 -e aes /dev/loop1 /mnt/dev_save$PUPSAVEFILE
     else
      #losetup does not accept -p param for xor encryption... may not work...
-     losetup $CRYPTO /dev/loop1 /mnt/dev_save$PUPSAVEFILE
+     echo "$MYPASS" | losetup -p 0 $CRYPTO /dev/loop1 /mnt/dev_save$PUPSAVEFILE
     fi
 }
 

This patch also works with the 32bit Tahr 6.0.3
The -p argument may fail with older pupps and busybox versions so if anybody could test and report would be nice.
losetup-FULL.gz
Description  losetup version 2.21.2
gz

 Download 
Filename  losetup-FULL.gz 
Filesize  18.75 KB 
Downloaded  187 Time(s) 

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 8 of 58 [856 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, ..., 56, 57, 58 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1108s ][ Queries: 13 (0.0281s) ][ GZIP on ]