Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 17:28
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Thinkpad 600E with neomagic video, cs4232 audio, D-link G630
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

PostPosted: Thu 21 Jul 2005, 17:20    Post_subject:  Thinkpad 600E with neomagic video, cs4232 audio, D-link G630  

(neomagic video and crystal audio, quite possible the worst of both worlds)
Also with D-link G630 PCMCIA wireless.

I've been poring over the forum archives the past few days, trying to make everything on my laptop run properly. I started with Bladehunter's custom 1.0.3 with framebuffer and atheros. The video worked fine, though I could not get the wireless running. Sound was easy - two people had posted modprobe lines for the cs4232. Cardbus was also easy - there is another 600E person here who used "modprobe xircom_cb".

Bladehunter's custom build would not install to hard drive properly. Next I tried 1.0.4.

1.0.4 works fairly well. Sound and cardbus are still good. However, video has gotton much more interesting. After X loads, everything goes wrong. Xvesa makes X look fine (small distortion at the right edge of the screen, but very minor). However, the command line is gone. I just get a flat blue screen. I can blindly type "startx" and X loads normally. This only happens after loading X. The boot looks normal, not blue.

1.0.4 with framebuffer was the opposite. I may have broken something in framebufferwizard, as I did not install Unleashed. I just unzipped the packages and manually copied files into place. All framebuffer options produced the same result. Boot was normal, command line was normal (even after X) but X was blue. Anything which was normaly black became blue, and all other colors became black. (think of a monochrome negative of your desktop.) It didn't matter how I configured framebufferwizard, I got this every time.

For now I've given up on a readable command line and am sticking with Xvesa. (only 1024x768x16 works properly, but its fine)

The atheros D-link card has also been trouble. Cardmgr says nothing, just that cardmgr is already running. Cardctl returns the name string, voltage, and status without trouble. But I still can't initialize wlan0.

Then I installed the basic perl and ndiswrapper, but that was a total flop since I didn't have any proper conf files for ndis. Also tried a manual insmod of Bladehunter's collection of atheros drivers, ath_pci.tar.gz. None of them would load, all complaining about "unresovled symbols". Also tried Bladehunter's wifi-beta, but I haven't a clue as to how it should be configured.

I'm also working on a webpage of the entire config process, hopefully part of it can go into the wiki.
Back to top

PostPosted: Fri 22 Jul 2005, 01:36    Post_subject:  

The non hard drive thing is interesting...

Of course the atheros tarball won't work 1.0.3 used a 2.4.27 kernel nad 1.0.4 uses a 2.4.29 kernel....

cardmgr will not load the dirvers for as the DWL-G630 ( and about 99% of CardBus cards) are seen as a PCI device....I tried doing a config for DWL-G630 for pcmcia but never had much luck despite reading of others having success..

If you could explain what went wrong with the install to hdd I might be able to help out as for that hw combination my version seems about the easiest to use. In the next week or so I might try a 1.0.4 version.

But like I said I'd really like to know what went wrong because the only changes I made were to usr_cram.fs for the XFree modules and to image.gz to add in the atheros drivers...all scripts and such were not touched.

As for the wireless not running what hardware and firmware versions of the DWL-G630 are you using...DLink and many others keep the same model designation but change chipsets through the lifetime of a product....
Back to top

PostPosted: Fri 22 Jul 2005, 08:21    Post_subject:  

hard drive install: It seemed the CD custom boot options 1.0.3 did not carry over to the hard drive. 1.0.4 seems to be working better than 1.0.3, can any parts be migrated, despite the different kernel? (Probably not.) I'll also try _all_ the wizard's "more" options next. There are quite a few, and one may turn up something.

G630 stats:

Cardmgr says "another is already running".

Cardctl status returns "3.3V CardBus card function 0: [ready]"

Cardctl config returns voltage info, "interface is cardbus", and "irq 11 [exclusive] [level].

Cardctl ident give what I think you want.
Atheros Comm. Inc., AR5001-0000-0000 Wireless LAN Reference 00
manfid: 0x0271, 0x0012
function: 6 (network)

Cardctl info agrees.
PRODID_1="Atheros Communications, Inc."
PRODID_3="Wireless LAN Referene Card"

Xproc gave nothing useful.

Hardware probe (PCI) sucessfully located the two PCMCIA slots, but also says no info for "device 168c. 1a (ETHERNET)".

Hardware probe (modules) says the same thing.

Ethernet Wizard gave nothing. Detection scan turned up an "Ehternet controller: PCI device 168c:001a (rev 1)" and a module which doesn't work, "3c574_cs". Then it finds "3c589_cs". Next "fmvj18x_cs", "netwave_cs", "nmclan_cs", "orinoco_cs", "pcnet_cs", "ray_cs", "smc91c92_cs", "wavelan_cs", "xirc2ps_cs". All of these return 0 active interfaces.

I'm going to be away for the weekend. I'll be fighting for internet with dozen other people, but I should be able to give updates and test anything that doesn't require a huge download.

Whoever gives wlan0
will forever be my hero
Back to top

PostPosted: Fri 22 Jul 2005, 08:39    Post_subject:  

Ok I just downloaded the 2.4.29 kernel source have the lastest madwifi source and will compile a kernel and the drivers.

Looking at the info you supplied (thanks for that) everything matches my card so I can say we are playing on the same field with the same equipment.

What I'll try and do is throw togther a dotpup for the XFree86 setup I'm using for my NeoMagic (NeoEvil ?) chip and upload that to my site.....Just out of interest everything worked fine with my modded 1.0.3 version apart from the hd install ?

As for configuring the wifi beta dotpup....Tis very very very easy......Do not be affraid of a text file as long as you back it up first you can't do too much harm.
All that needs to be done is to edit wireless.conf to match the wireless options your site uses...eg whatever iwconfig command you use just edit those paramteres to the file (which is quite well commented).....
Back to top

PostPosted: Fri 22 Jul 2005, 10:44    Post_subject:  


Yes, everything worked fine except HD install. (Wireless wasn't quite right, but that was my fault)

Ah, okay. I think I understand how the wifi-beta works. I didn't even realize you were to hard code a single access into it. I just finished reading a huge tcl/tk book (and assuming I can learn to play friendly with my Wifi), I will try to make a "multiple profile" frontend. Maybe even trial and error channel scanning?

Thanks for the encouragement.
Back to top

PostPosted: Fri 22 Jul 2005, 17:24    Post_subject:  

Hey excellent.....Maybe we could get togther and have a Bull Session (as it may) about a wifi wizzard or at least front end configuration applet..

Was thinking (about 10 minutes ago) that I should put into wireless.conf a choice of driver to load.

At the moment I have the floowing adapters that I know work

1. Prism 2/2.5 pcmcia card that works with the pcmcia subsystem

2. Dlink DWL-G630 and DWL-G510 that work with madwifi

3. RTL8180 based card that works with ndiswrapper

4. A usb adapter that works with the at76c503 driver

So I think I have the hardware that covers 4 major types, now should I get a card that uses the Prism54 driver....Yeah I need some new toys Laughing

I think too that we should maybe reaccess the wireless.conf format too.....

Paul aka BlackAdder your input would really be appreciated on this one too.
Back to top

PostPosted: Sat 23 Jul 2005, 07:15    Post_subject:  

Also, there has been another person with a Thinkpad 600E. From what I can tell, they haven't had my video problems. But they also don't have a username, so they might never read this.
Back to top

PostPosted: Sat 23 Jul 2005, 08:31    Post_subject:  

I got wireless drivers!

Here's why ndis didn't work for me before: no one ever said you needed the FULL directory. I thought you just needed in INF. Here's everything I did, for those with similar problems.

Installed perl, installed ndis. Unzipped full XP drivers at /root/my-drivers/xp/

ndiswrapper -i /root/my-drivers/xp/Drivers/net5211.inf
"cardctl info" returned "MANFID = 0271,0012"
ndiswrapper -d 0271:0012 net5211
ndiswrapper -m
modprobe ndiswrapper
Back to top

PostPosted: Sat 06 Aug 2005, 01:18    Post_subject: Please Summarize Your Setup?  

keenerd wrote:
I got wireless drivers!
Here's why ndis didn't work for me before: no one ever said you needed the FULL directory. I thought you just needed in INF. Here's everything I did, for those with similar problems.
Installed perl, installed ndis. Unzipped full XP drivers at /root/my-drivers/xp/
ndiswrapper -i /root/my-drivers/xp/Drivers/net5211.inf
"cardctl info" returned "MANFID = 0271,0012"
ndiswrapper -d 0271:0012 net5211
ndiswrapper -m
modprobe ndiswrapper

I really want to load Puppy with Java and Thingamablog - together with wired and wireless drivers and as much else as I may need to talk to a variety of PC's -- to have a complete and portable OS for writing, blogging, and Internet access on a 1G USB stick.

At Download I am confused by the iso's rather than RPM's or GZ's or Zips, etc. Do I have to load Puppy to a CD before I can load it to my USB stick?

Thanks! doc
Back to top

Joined: 13 Jun 2005
Posts: 168
Location: Vancouver Island

PostPosted: Sat 06 Aug 2005, 01:37    Post_subject:  

edoc, this may be of some help tp you


It looks like there may be options for you, if you don't wish to/can't burn an ISO...

Also, try searching the forums for USB and scrolling down a bit...

Hope that helps! Very Happy
Back to top
View user's profile Send_private_message 
Official Dog Handler

Joined: 04 May 2005
Posts: 11463
Location: Arizona USA

PostPosted: Sat 06 Aug 2005, 01:59    Post_subject:  

It can be done without a CD. Barry's 'old' instructions in the bottom half of this page show how. They may still apply, but that seems like the hard way to do it.

Puppy is a small download and CDs are cheap.

Go to this page and download

puppy-1.0.4-mozilla.iso_______61730 KB_7/19/2005__4:14:00 AM

Burn it as a bootable CD (how to do that depends on which burning software you use) and then boot and enjoy!
Back to top
View user's profile Send_private_message 

Joined: 08 May 2005
Posts: 294
Location: Albany, NY

PostPosted: Mon 08 Aug 2005, 20:20    Post_subject:  

I just got my Thinkpad R-30 working with the D-Link DWL-G650 wireless card using PCMCIA. It is an Atheros chipset. I used the stock Puppy Mozilla 1.0.4 version and added Perl and ndiswrapper.

It loads on boot!

I will put a how-to on the wiki, off my wiki page. Not much different than my original article located here.

I added directions that I found from other posts to get ndiswrapper to use the pcmcia slot. I wish that I could find the original post to give credit where it is due.

I love it when a plan comes together

--Hannibal Smith
Back to top
View user's profile Send_private_message Visit_website 

PostPosted: Tue 09 Aug 2005, 06:32    Post_subject:  

Check the announcements page for some new news re neomagic & atheros
Back to top

Joined: 27 Jun 2005
Posts: 429
Location: VT USA

PostPosted: Tue 09 Aug 2005, 22:14    Post_subject:  

I am glad I found this thread. I have a 600E on the way with a DVD drive.
The Only video problems I have found on anything I have run Puppy on is an old packard bell monitor that only allows for 640x480. I can't use most of the apps because I can't fit them to the window. The desktop fits fine bit depending on the app I can't get to the top or left side of the window.

Been searching but haven't found the right keywords.

Questions? Search Puppy Linux Answers with Google
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0851s ][ Queries: 12 (0.0047s) ][ GZIP on ]