Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Nov 2017, 19:24
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Package Collections / Repositories
Quirky/April 64bit Contributed Packages
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 4 [59 Posts]   Goto page: Previous 1, 2, 3, 4
Author Message
Jerror

Joined: 28 Feb 2015
Posts: 28

PostPosted: Sat 15 Aug 2015, 12:10    Post subject:  

Great packages, thank you! Unfortunately VNC server fails to install.
Back to top
View user's profile Send private message 
Jerror

Joined: 28 Feb 2015
Posts: 28

PostPosted: Sun 16 Aug 2015, 15:32    Post subject: AwesomeWM  

I just finished building AwesomeWM 3.5.6 for Quirky 7.041. It wasn't easy... I built it for Lua 5.1 but it should build on the Lua 5.2 package in the Quirky repo if you'd prefer. Runtime requirements include the lua lgi module and Pango built with introspection (and hence GObject-Introspection as well). If there's interest I'll find somewhere to upload the package and the dependencies.

I've built some other packages, but few were difficult, most were niche, and none were packaged well Razz. I needed the old Inkscape 0.48.5 for it's TeX extraction ability, which is broken in 0.91; that was pretty hard to get done on Q7.041 so I'll put that up too if anyone has a use for it.
Back to top
View user's profile Send private message 
xanad


Joined: 28 Feb 2014
Posts: 400
Location: 2 locations: MonteRosa Alp and Milano

PostPosted: Thu 27 Aug 2015, 05:21    Post subject:  

Everything on the front page:

- New version of Popcorn Time by ETP.
Updated version at PopcornTime-0.3.8.3-LINUX-V5.pet

- New version of mtPaint by don570
mtpaint-april64-mod-3.44.93.pet
mtpaint-april64_NLS-3.44.93.pet
Quote:
It will open a folder of images. It is launched by a right click on the folder.

'Edit with mtpaint'

----
@jerror
- What type of error you're experiencing with VNC Server?
To me it works well ...
- Send when you want your programs compiled for Quirky64 that we test them and publish them, thanks.

_________________
www.xanad.tk Html5 Parallax
Back to top
View user's profile Send private message Visit poster's website 
xanad


Joined: 28 Feb 2014
Posts: 400
Location: 2 locations: MonteRosa Alp and Milano

PostPosted: Fri 04 Sep 2015, 08:49    Post subject:  

wmctrl-1.07-x86_64-1.pet by ETP

is a UNIX/Linux command line tool to interact with an EWMH/NetWM compatible X Window Manager.
The tool provides command line access to almost all the features defined in the EWMH specification. It can be used, for example, to get information about the window manager, to get a detailed list of desktops and managed windows, to switch and resize desktops, to make windows full-screen, always-above or sticky, and to activate, close, move, resize, maximize and minimize them.

EXAMPLE tested:

Placed the attached test script in Startup & then re-started X.

Code:
Code:
#!/bin/sh
# This is auto-launch. ETP Aug 2015
# Place in Startup folder to launch any app(s) on other workspace(s) at boot up.
# e.g. defaultemail or firefox --new-tab $@ &
# All sleep commands may need adjusting depending on the speed of the hardware.
# Script as it stands needs 3 virtual desktops.
#
# In JWM hover mouse over any workspace on taskbar & then use scroll wheel to move between them.
#
sleep 11
wmctrl -s 1 # Move to second workspace.
defaultbrowser &
sleep 1.5
wmctrl -s 0 # Return to first workspace.
wmctrl -s 2 # Move to third workspace.
defaultemail &
sleep 1.5
wmctrl -s 0 # Return to first workspace having launched app(s) on workspace(s).
auto-launch.gz
Description 
gz

 Download 
Filename  auto-launch.gz 
Filesize  665 Bytes 
Downloaded  231 Time(s) 

_________________
www.xanad.tk Html5 Parallax
Back to top
View user's profile Send private message Visit poster's website 
xanad


Joined: 28 Feb 2014
Posts: 400
Location: 2 locations: MonteRosa Alp and Milano

PostPosted: Mon 07 Sep 2015, 11:52    Post subject:  

In main page:

pequalizer-0.9.0-x86_64.pet
based on 32bit program created by 01micko and Zigbert

Find'n'Run
by L18L and RSH, performed by step

_________________
www.xanad.tk Html5 Parallax
Back to top
View user's profile Send private message Visit poster's website 
xanad


Joined: 28 Feb 2014
Posts: 400
Location: 2 locations: MonteRosa Alp and Milano

PostPosted: Mon 14 Sep 2015, 03:51    Post subject:  

ETP wrote:

VLC 2.1.5 64-bit
Preview:
http://murga-linux.com/puppy/viewtopic.php?mode=attach&id=90356

In Quirky and Rapid, Xine is included OOTB but VLC is not. To install VLC 2.1.5 64-bit:

1: In PPM search for vlc then load it together will ALL its dependencies.

2: Install the dbus-1.8.0-x86_64-1 pet (517KB) from within the "Optional Pets" folder here:
https://drive.google.com/open?id=0B_iVVJCd9q09fnEyWV9jZHQtS0lMUG5jVnJrWDZVa295WkFMNUJEV091QXNsRFU0TVVnM3M

3: Install the attached fix pet.
http://murga-linux.com/puppy/viewtopic.php?mode=attach&id=90358

4: Reboot.

Thanks again ETP Very Happy

_________________
www.xanad.tk Html5 Parallax
Back to top
View user's profile Send private message Visit poster's website 
vega

Joined: 13 Sep 2015
Posts: 1

PostPosted: Mon 14 Sep 2015, 05:08    Post subject:  

Thanks !
Very Happy

(only remame the file dbus-1.8.0-x86_64-1.gz to dbus-1.8.0-x86_64-1 pet)
Back to top
View user's profile Send private message 
quirkian2new

Joined: 06 Oct 2015
Posts: 92
Location: on the inter-planet train

PostPosted: Fri 09 Oct 2015, 03:46    Post subject: WINE for 64bit Quirky7.0.4.1
Subject description: WINE for 64bit Quirky7.0.4.1
 

dear all, I am new to Quirky64. Just downloaded the 64bit Quirky7.0.4.1 two weeks ago and run smoothly. Thanks for Barry and all contributors for such a wonderful derivative.

Is there anyone who can give me some guidance & advice as how to run WINE in 64bit Quirky7.0.4.1 (and where to download) as I need to run one windows application. I tried several pets of WINE but all failed . Thank you all in advance .
Back to top
View user's profile Send private message 
xanad


Joined: 28 Feb 2014
Posts: 400
Location: 2 locations: MonteRosa Alp and Milano

PostPosted: Fri 09 Oct 2015, 04:03    Post subject: Re: WINE for 64bit Quirky7.0.4.1
Subject description: WINE for 64bit Quirky7.0.4.1
 

quirkian2new wrote:

Is there anyone who can give me some guidance & advice as how to run WINE in 64bit Quirky7.0.4.1 (and where to download) as I need to run one windows application. I tried several pets of WINE but all failed . Thank you all in advance .


I'm working for a long time but have not been able to make a version operated fully. Quirky 7.2 (new) should have the ability to upload applications also 32bit, so I think even wine 32bit.

_________________
www.xanad.tk Html5 Parallax
Back to top
View user's profile Send private message Visit poster's website 
scsijon

Joined: 23 May 2007
Posts: 1251
Location: the australian mallee

PostPosted: Thu 22 Oct 2015, 01:06    Post subject:  

I have (four now) two for you as soon as my website is working 'properly' again (it had a crash), both compiled on quirky april 7.2 x64 using src2pkg v3.0 with simple x64config fixes (ok i'll make a pet of that too).

If there are non-google sites for the others I will add them to it.

1- xmahjongg v3.7 with the gxmahjongg script borrowed from the squeeze version (why reinvent the wheel).
www.lamiaworks.com.au/puppy/april_72_721/pets/xmahjongg-3.7-x64-1.pet

2- libinklevel version 0.9.2, works for hp's up to drum size at least (I only have hp printers).
www.lamiaworks.com.au/puppy/april_72_721/pets/libinklevel-0.9.2-x64-1.pet

3- dbus and dbus-glib
www.lamiaworks.com.au/puppy/april_72_721/pets/dbus-1.9.4-x64-1.pet
www.lamiaworks.com.au/puppy/april_72_721/pets/dbus-glib-0.102-x64-1.pet

4- 7zip
www.lamiaworks.com.au/puppy/april_72_721/pets/p7zip_9.2.0-x64-1.pet

I have others yet too do and add after I update my 32bit satellite workstation from 5.5 (x86) to become 7.2.1 (x86) / 7.2 (x64).

?Has anyone a sucessfull qt5 (5.2.0 to 5.3.2) anywhere, I have a need and i'm against reinventing wheels when not it's not needed to do so.

btw xanad, I believe BarryK's working on x64 running x86-32 apps now, check his blog. Maybe that will run wine 32bit.

EDIT: Ok, that's the first lotup, enjoy, I shall also do x86 versions soon.

OH, yeah, src2pkg changes for april72 are easy.
1- install the package src2pkg-3.0-noarch-2.pet (use v3.0 NOT 2.5 or 2.9)
2- from a console screen run src2pkg --setup to install the helpers an don't worry about fails and versions, there just the bits in puppy and not quirky, it uses your versions if they are installed.
3- in a console type src2pkg, you should get the help commands (the last 5 lines are the important ones). !Important step for internal setup, don't miss it out!
4- goto /etc/src2pkg and open src2pkg.conf (or src2pkg.conf.new depending on the build) in your favorite TEXT editor
5- goto line 32 and 33 and change the lines to match
Code:
[[ $ARCH ]] || ARCH="x64"
[[ $MARCH_FLAG ]] || MARCH_FLAG="x64"

and save.
6- and that's it. Just remember it's a command line package and needs to start in a console screen.
Just be carefull when building to erase the word unknown in the petspecs (last) stage against prerequisites, else you can install, but can't uninstall again without having to 'fudge' your .packages/user-installed-packages and removing it there, but of course then everyone installing your package has to do the same (very anoying). If you need a step-by-step example on how to use it let me know and i'll add it here, but it's simple to use.
have fun

Last edited by scsijon on Wed 28 Oct 2015, 12:40; edited 8 times in total
Back to top
View user's profile Send private message Visit poster's website 
xanad


Joined: 28 Feb 2014
Posts: 400
Location: 2 locations: MonteRosa Alp and Milano

PostPosted: Thu 22 Oct 2015, 03:16    Post subject:  

thanks scsijon,
send when you're ready.
I have not had time to try the new Quirky, but I will soon. If wine works, it will be a huge step forward.

_________________
www.xanad.tk Html5 Parallax
Back to top
View user's profile Send private message Visit poster's website 
Puppus Dogfellow


Joined: 07 Jan 2013
Posts: 1497
Location: nyc

PostPosted: Wed 28 Oct 2015, 14:09    Post subject: wish i had kept better track of some of what worked...
Subject description: recoll 20, slocate 2.7, roxterm, lxterminal and task, vte.28...
 

libreoffice 5.0.2 and deps:

LibreOffice-5.0.2_64_en-US_xz.petQuirky72 LO Deps (libdbus-1-3_1.2.16_amd64.pet and libdbus-glib-1-2_0.84_amd64.pet)

installing recoll 1.20 was easier than 19, but i'm not sure if any of the failed compiling i did for 1.19 helped 20 install correctly. anyway, after failing (despite having succeeded with 1.19 in an earlier quirky64) with 1.19 and the make install bit, i grabbed some 64 bit debs for 1.20 and it's working well.

other things that seem to be working well:

slocate-2.7-7.x86_64.rpm
musher0's wrapper for it

lxtask-0.1.6-1pclos2014.x86_64.rpm

roxterm_1.18.5-3_amd64.deb

vte-0.28.2-5-x86_64.pkg.tar.pet

lxterminal-0.2.0-1-x86_64.pkg.tar.pet
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 1029
Location: UK

PostPosted: Thu 29 Oct 2015, 05:00    Post subject: Minidlna server for Smart TVs  

64bit Mini DLNA server for Smart TVs

The following pet has been tested with Quirky 7.2 - k 4.1.7

Minidlna-1.1.5_x86_64_Quirky7.2-V1.pet -- 253 KB

Having installed the pet and before rebooting: 

1. Edit line 14 of /etc/minidlnad.conf. It currently reads as follows: 

Code:
14 media_dir=/mnt/sdd1/81movie/Popcorn-Time


In this case sdd1 is a fat32 32GB USB2 nano stick permanently plugged into a port on the 
rear of my box. As such it is accessible from Win8.1, Manjaro & various Pups running off 
the SSD and a variety of USB sticks. Such an arrangement is versatile & strongly recommended. 
A smaller stick can be used but will hold less mp4/mov files. Minidlna will atomatically mount the stick. 

2. Visit "BootManager Configure Bootup" and ensure that in services a tick is present in the "minidlna" box. 

3. Place a test mp4 trailer on the stick, reboot, then head off to the TV. 

Tip: 
If your smart TV struggles with some mkv files just use FFConvert to change them to mp4.
Minidlna-1.1.5_x86_64_Quirky7.2-V1.pet
Description 
pet

 Download 
Filename  Minidlna-1.1.5_x86_64_Quirky7.2-V1.pet 
Filesize  252.82 KB 
Downloaded  204 Time(s) 

_________________
Regards ETP



Kennels
Back to top
View user's profile Send private message 
Puppus Dogfellow


Joined: 07 Jan 2013
Posts: 1497
Location: nyc

PostPosted: Thu 29 Oct 2015, 18:38    Post subject: tiny bit of progress...  

https://github.com/goldendict/goldendict/wiki/Early-Access-Builds-for-Linux-Portable

got the above to load and crash, which is more than i got from any .rpm or .deb for goldendict up to now.

failed to compile dillo (says it's missing things the ppm says it has Question )

i was wrong about it being predominately .debs that got recoll up and running for me. it's reading as version 1.20, but as for what got installed, this is what i pulled from the .packages folder in root:

Quote:

xapian-core-1.2.21-x86_64-1_slack|xapian-core|1.2.21-x86_64-1_slack|xapian-core-1.2.21-x86_64-1_slack||||xapian-core-1.2.21-x86_64-1_slack.txz|||
recoll-1.21.2-x86_64-1_slack|recoll|1.21.2-x86_64-1_slack|recoll-1.21.2-x86_64-1_slack||||recoll-1.21.2-x86_64-1_slack.txz||Runs in background to extract and index text from modified documents|
libjpeg8-8.0.2-3.1.x86_64|libjpeg8|8.0.2-3.1.x86_64|||||libjpeg8-8.0.2-3.1.x86_64.rpm|||
recoll-1.19.5-1.2.lk.x86_64|recoll|1.19.5-1.2.lk.x86_64||Utility|||recoll-1.19.5-1.2.lk.x86_64.rpm||Find documents by specifying search terms|
unrtf-0.21.0-i486|unrtf|0.21.0-i486|||||unrtf-0.21.0-i486.pet|||
antiword_0.37-8|antiword|0.37-8||BuildingBlock|657K|pool/universe/a/antiword|antiword_0.37-8_i386.deb|+libc6&ge2.7|Converts MS Word files to text PS and PDF|ubuntu|precise|
catdoc-0.94.2-i486|catdoc|0.94.2-i486|||||catdoc-0.94.2-i486.pet|||
recoll 120.6


it's working very well and is very quick (once the files are indexed, which gets done significantly faster on a 64 bit machine from what i can tell). as for concerns about the enormous databases--they're pretty big. 4 gigs of mostly text files (odt, doc, docx, txt, rtf) ended up as a three or four db.s totaling about half a gig. once a database is made, it can be moved out of .recoll (which is where i believe they're located. it's been a while, but the method is solid) and reaccessed by set external databases dialog.


___


tip for chrome--untick the box for allow it to run in the background. it's a terrible hog if you don't.

firefox is working well, chrome and sea monkey are working well, vlc's doing nothing untoward, --

distro's a lot of fun. i'm so happy with how it's running i don't want to mess with much...

wmctrl and xdotool still seem to work better in 32 bit but are working well for the most part.

i'm convinced this distro is faster off an f2fs sd card on this machine than precise 5.7.1 (or anything else i've tried for that matter) was off the hard drive.

Very Happy


-------

edit: seems both the older recoll and the newer ones have a feature i overlooked. if you interrupt the initial indexing, it gives you an option to select the location for the stored databases--you could start with them outside the save file. seems a better choice than moving them after the fact.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 4 [59 Posts]   Goto page: Previous 1, 2, 3, 4
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Package Collections / Repositories
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0662s ][ Queries: 13 (0.0087s) ][ GZIP on ]