Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 16:42
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Error compilando Driftnet en Puppy 2.12
Moderators: rarsa
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
caka

Joined: 07 Dec 2006
Posts: 202

PostPosted: Fri 29 Dec 2006, 07:33    Post_subject:  Error compilando Driftnet en Puppy 2.12  

Hola, no consigo instalar driftnet en mi Puppy 2.12. Me da error y dice que no tiene el comando makedepend.

Estuve buscando información en google y en el foro de Puppy y parece que a Barry se le olvidó incluir este comando en la última versión de Puppy y en cambio en las 1.x.x si lo tienen y compilaría sin problemas.

¿Alguiuen me podría ayudar a solucionar el problema para poder compilar driftnet?. Es que a mi no se me ocurre nada que hacer y no quiero cambiar de versión de Puppy, ya que a esta ya le metí muchos programas que me interesan

Os pego el error:
Code:

sh-3.00# make
cc -g -Wall -I/usr/include/pcap -D_BSD_SOURCE `gtk-config --cflags` -DDRIFTNET_VERSION='"0.1.6"' -o endian endian.c
./endian > endianness
makedepend -- -g -Wall -I/usr/include/pcap -D_BSD_SOURCE `gtk-config --cflags` -DDRIFTNET_VERSION='"0.1.6"' `cat endianness` -- audio.c mpeghdr.c gif.c img.c jpeg.c png.c driftnet.c image.c display.c playaudio.c connection.c media.c
/bin/sh: makedepend: command not found
make: *** [depend] Error 127


Gracias por leer el post y por ayudarme.
Back to top
View user's profile Send_private_message 
caka

Joined: 07 Dec 2006
Posts: 202

PostPosted: Wed 03 Jan 2007, 16:55    Post_subject:    

¿Ninguna idea? Crying or Very sad . ¿Nadie sabe que es el makedepend?. Crying or Very sad . Perdonad si soy demasiado pesado y novato.

Por favor decirme algo y si no sabeis como solucionarlo os agradecería que tambien me lo dijeseis.

Gracias.
Back to top
View user's profile Send_private_message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Thu 04 Jan 2007, 21:36    Post_subject:  

Ni idea, solo te queda bajar otra version de Puppy y el devx respectivo.
_________________

Back to top
View user's profile Send_private_message 
caka

Joined: 07 Dec 2006
Posts: 202

PostPosted: Fri 05 Jan 2007, 05:15    Post_subject:  

wow gracias por tu respuesta. Entonces lo dejo por imposible hasta que me actualice a otra versión de Puppy.
Back to top
View user's profile Send_private_message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Fri 05 Jan 2007, 22:58    Post_subject:  

No es necesario que actualices el sistema Confused bastaría con compilarlo en otro Puppy o Distro, después de eso lo instalas en tu sistema actual.

Para hacerlo con otro Puppy descarga alguna otra versión e inicia en modo ram(arrancando desde el CD):


Después ve a reiniciar para que crees un nuevo pup_save#.3fs, carga Puppy desde el CD y eliges el .3fs que acabas de crear. Ahora copia el devx_###.sfs junto al nuevo pup_save#.3fs

Descomprime el código fuente en alguna partición ext2/ext3 para puedes acceder a él desde otro linux.

Haz las modificaciones que necesites y compila el código desde el nuevo Puppy/Distro. Reinicia, pero ahora arranca con el sistema operativo en el que deseas instalar los binarios previamente compilados, en este caso Puppy-2.12.

Dirígete a la carpeta en la que fue compilado el software(como lo hiciste en una partición externa puedes acceder a ella facilmente) e instala el software(escribiendo "make install" si tienes el módulo devx_###.sfs).

Eso es todo. Claro que tambíen puedes compilarlo dentro del mismo pup_save#.#fs u otro archivo que contenga un sistema de archivos linux, y para instalarlo obviamente necesitas montar el medio que contiene los binarios.

_________________

Back to top
View user's profile Send_private_message 
caka

Joined: 07 Dec 2006
Posts: 202

PostPosted: Sat 06 Jan 2007, 16:20    Post_subject:  

wow FUNCIONA Very Happy Very Happy Very Happy .

Gracias por tu gran idea.

Tenía por aquí un Live-Cd de una distribución de Slax; así que probé a compilar driftnet con ese Live-Cd y se compiló sin problemas: Así que copie la carpeta y el ejecutable creado en /usr/local/bin a mi Puppy 2.12.

Cargué el Puppy 2.12 e intenté hacer el "make install" pero no funciona; me da erros y me dice que el kernel es diferente. Pero a pesar de eso el ejecutanle si funciona y si escribo "driftnet" se ejecuta sin problema aparente Very Happy . Así que ya puse un icono de acceso directo en mi escritorio.

Muchas gracias. La verdad es que con vuestra ayuda me está quedando un Live-Cd muy chulo. Estoy muy contento con el resultado. Ya probé a remasterizarlo en un CD y es una maravilla, aparecen todos los drivers de mis tarjetas y los programas que instalé funcionan muuy bien. Gracias a todos y en especial a wow y a rarsa.

PD: Ahora el programa que me está dando dolores de cabeza es el ettercap (y con este no me funciona lo de compilarlo en otra distribución y copiarlo a pelo Crying or Very sad ). Voy a seguir unos dias intentando compilarlo y sino ya os pediré ayuda.
Back to top
View user's profile Send_private_message 
Superlatino

Joined: 19 Jun 2007
Posts: 25

PostPosted: Wed 20 Jun 2007, 14:43    Post_subject: puppy con etercapp  

me parece que en www.elhacker.net hay un puppy con todas las herramienta para una auditoria de red wireless, seria bueno que te des una vuelta por ahi, un avor puedes decirme como se puede poner un acceso directo para un progrma en PUPPY linux? es una novtada, pero pues no se como hacerlo , gracias a quien responda Laughing
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0722s ][ Queries: 12 (0.0215s) ][ GZIP on ]