Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 12 Dec 2019, 04:36
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Pupjibaro jessie Beta.
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 5 [75 Posts]   Goto page: 1, 2, 3, 4, 5 Next
Author Message
josejp2424


Joined: 01 Aug 2010
Posts: 520

PostPosted: Sun 03 Apr 2016, 16:32    Post subject:  Pupjibaro jessie Beta.
Subject description: Package Debian Jessie.
 

This is the continuation of the post at the Spanish subforum. As requested by some users, the PupJibaro Jessie thread will continue here.

Thank you :Vicmz, nilsonmorales, musher0 , stemsee

Pupjibaro Jessie BETA, a test ISO created with woof-ce testing..

I had problems with Xorg building the ISO. I added more libraries and voilà! It worked.




Arrow Fluxbox (system default).
Arrow Lxaparence.
Arrow VLC
Arrow DeaDBeef
Arrow Wifi-Connect 2016 by stemsee .
Arrow Rox y spacefm.
Arrow geany 1.2.8 gtk3.
Arrow Abiword 3.0.0.
Arrow evince
Arrow Uextract by SFR .
Arrow PackIt by SFR .
Arrow Zram gui (to enable zram).

and a lot more.


.

Download.

pupjibaro_jessie_fluxbox-09102016.iso. .

# MD5
295c02572847d6a36b95efb3185e703a pupjibaro_jessie_fluxbox-09102016.iso
# SHA1
27a662facfe55a5d238b24f5d1fdce207c5568b2 pupjibaro_jessie_fluxbox-09102016.iso
# SHA256
b170e78d8263ee965ba3288b2aa598ca5661167750a1329c1f3d91b3c057a327 pupjibaro_jessie_fluxbox-09102016.iso

DEVX .

https://sourceforge.net/projects/pupjessie/files/devx/devx_jessie_6.4.1.sfs

# MD5
0efe6e03017eb258ac0dc1e525fab2a6 devx_jessie_6.4.1.sfs
# SHA1
6b588dd6477b710e45d2dac96fd1f3713d6560e4 devx_jessie_6.4.1.sfs
# SHA256
b6f9a69cd7cf7d2e289d0494cbaa5588111433f17a1e02f0a097bd58e42f6da9 devx_jessie_6.4.1.sfs

Kernel sources.

https://sourceforge.net/projects/pupjessie/files/repo/kernel_sources-3.16.3_PAE.sfs

# MD5
d27bf029bb91023bc4e05595eb4c777f kernel_sources-3.16.3_PAE.sfs
# SHA1
f5d4baa2a28fab599364520b3ebf0d5f1903cae0 kernel_sources-3.16.3_PAE.sfs
# SHA256
a052d0e1c36df5bd1f37fb544faa52ef9ea7e5c83145a691621375e25b322dff kernel_sources-3.16.3_PAE.sfs

Pupjibaro jessie synaptic.

http://www.murga-linux.com/puppy/viewtopic.php?t=108496

_________________
Shiba Inu | Pupjibaro jessie | My Blog

Last edited by josejp2424 on Tue 11 Oct 2016, 23:00; edited 4 times in total
Back to top
View user's profile Send private message Visit poster's website 
charlie6


Joined: 30 Jun 2008
Posts: 1221
Location: Saint-Gérard / Walloon part of Belgium

PostPosted: Mon 04 Apr 2016, 03:15    Post subject: desktop icons not translated after installing langpack_fr  

Hi josesp2424,
thanks again for this pupjibaro !
now using pupjibaro_03042016 (have used the delta_iso)

musher0 wrote:
@Charlie6:
... you need to create a pupsave file before installing any pet,
not just the language pack pet.


Now having created a pupsave ... but again the desktop icons are not french translated after installing langpack_fr-20130304.pet from the puppy noarch repo.

Thanks for any advice
Cheers, Charlie.
Back to top
View user's profile Send private message 
josejp2424


Joined: 01 Aug 2010
Posts: 520

PostPosted: Mon 04 Apr 2016, 07:28    Post subject: Re: desktop icons not translated after installing langpack_fr  

charlie6 wrote:
Hi josesp2424,
thanks again for this pupjibaro !
now using pupjibaro_03042016 (have used the delta_iso)

Cheers, Charlie.


delta corrupt.
new delta 19mb.

http://www.mediafire.com/download/ca9mtxa4cbmbj8c/pupjibaro_jessie_beta-26032016.iso___pupjibaro_jessie_beta-30032016.iso.delta

# MD5
a4f270beec38fb17486e8cdb653fff17 pupjibaro_jessie_beta-26032016.iso___pupjibaro_jessie_beta-30032016.iso.delta
# SHA1
5d28add7ab9bc2079fb3003aa9304b62283f0393 pupjibaro_jessie_beta-26032016.iso___pupjibaro_jessie_beta-30032016.iso.delta

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
musher0

Joined: 04 Jan 2009
Posts: 14538
Location: Gatineau (Qc), Canada

PostPosted: Mon 04 Apr 2016, 07:51    Post subject:  

Thanks, José

The new devx is not there, only the hash file? Or I need new glasses? Smile

BFN.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 2038
Location: London, England

PostPosted: Mon 04 Apr 2016, 11:42    Post subject:  

The devx was in the mega storage but not in the mediafire one.
It appears to be OK but I have not tested it much yet.

I booted the .iso as a manual frugal. I found that ffmpeg still gives a missing library error and the media players including pMusic do not work.

Has the ffmpeg 3.0.1 been included in the .iso?

This issue with ffmpeg is quite a problem. Official Debian Jessie uses libav/avconv packages as a substitute for ffmpeg. Obviously it is tempting to compile your own latest ffmpeg but mixing ffmpeg with libav files and libs is never a good idea. Remember also that mixing or substituting will often break compatibility of the many official Debian Jessie packages that depend on libav libraries. So you can stick to the official Jessie libs or if you use ffmpeg you may need to provide "Puppy Jessie" media applications, but this is a bit of a shame, because compatibility with Debian is supposed to be a feature of a Dpup. It is up to the developer to decide which way to go but you have to look at all the effects of your choice.

Interestingly, MPlayer compiles by default with static ffmpeg so if you do that you can take MPlayer out of the dependency on system libav/ffmpeg libs.

_________________
Oscar in England

Back to top
View user's profile Send private message 
stemsee

Joined: 27 Jun 2013
Posts: 2544
Location: In The Way

PostPosted: Mon 04 Apr 2016, 13:14    Post subject:  

I was not able to compile a kernel using the new devx ... no make!
Back to top
View user's profile Send private message MSN Messenger 
musher0

Joined: 04 Jan 2009
Posts: 14538
Location: Gatineau (Qc), Canada

PostPosted: Mon 04 Apr 2016, 14:28    Post subject:  

musher0 wrote:
Thanks, José

The new devx is not there, only the hash file? Or I need new glasses? Smile

BFN.

Ok. Got it from MEGA. Thanks, OscarTalks.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 14538
Location: Gatineau (Qc), Canada

PostPosted: Mon 04 Apr 2016, 14:36    Post subject:  

stemsee wrote:
I was not able to compile a kernel using the new devx ... no make!

Ahem. Smile Well, I loaded the new devx and I have a < make >!

An old one, too! That's typical of Puppy: the latest version is 4.1, published
in Oct. 2014. Please see bottom of this page. And we don't have it!

BFN.
where_is_make_2016-04-04(2).jpg
 Description   
 Filesize   26.27 KB
 Viewed   2020 Time(s)

where_is_make_2016-04-04(2).jpg


_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 14538
Location: Gatineau (Qc), Canada

PostPosted: Mon 04 Apr 2016, 15:17    Post subject:  

Hello all.

Just for fun -- and to break a Puppy "rule"!
This I compiled for and on "The Pooch". (C lib version 2.13)
-- https://www.adrive.com/public/xPgYsV/make-4.1.pet --
Probably it will work in this JessiePup.

Do not enjoy! Smile BFN.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
davids45


Joined: 26 Nov 2006
Posts: 1237
Location: Chatswood, NSW

PostPosted: Mon 04 Apr 2016, 21:47    Post subject: CUPS not connecting to localhost
Subject description: Desktop icons text not localised for here (Australia)?
 

G'day josejp2424,

Thank you for this update. I had your earlier English version so am pleased for this newer Pup to try.

I've installed a new Frugal and loaded it with my sfs files and pets which are working.

As my preferred email+browser (I did not want any of your default browsers), I am running Seamonkey-2.40 from a sym-link to my data partition. This is my usual method of running the latest Seamonkey with my many Pups. This seems to be all right in pupjibarojessie - posting from it now.

However, I cannot reach CUPS to get my networked printer/scanner set up. The screenshot shows the error when I run the CUPS wizard.

I also see the text under the default desktop icons is in Spanish. Icons I drag to the desktop are in English so it looks to be just the original desktop icons? Is there a simple fix for these?

Thank you again,

David S.
pupjibaro_CUPS.jpg
 Description   
 Filesize   87.66 KB
 Viewed   1984 Time(s)

pupjibaro_CUPS.jpg

Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1268

PostPosted: Mon 04 Apr 2016, 21:53    Post subject: Re: desktop icons not translated after installing langpack_fr  

charlie6 wrote:
Hi josesp2424,
thanks again for this pupjibaro !
now using pupjibaro_03042016 (have used the delta_iso)

musher0 wrote:
@Charlie6:
... you need to create a pupsave file before installing any pet,
not just the language pack pet.


Now having created a pupsave ... but again the desktop icons are not french translated after installing langpack_fr-20130304.pet from the puppy noarch repo.

Thanks for any advice
Cheers, Charlie.


Your langpack is old. Try a newer one:

ftp://download.tuxfamily.org/toutou/5xx/internationalisation/Slacko_6./

_________________
Puppy Linux en español
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 14538
Location: Gatineau (Qc), Canada

PostPosted: Mon 04 Apr 2016, 21:59    Post subject:  

Hello all.

I noticed that the < fixmenus > in this Pup actually builds the jwm menu twice.
May I suggest the following edit, starting at line 74:
Code:
#w001 support for fbpanel, lxpanel, openbox, fluxbox, pekwm...
WndwmngR="`cat /etc/windowmanager`" # musher0, 4 avril 2016

case "$WndwmngR" in
   fluxbox)[ `which jwm2fluxbox` ] && jwm2fluxbox 
                # current fluxbox_menu_refresh doesn't support menu icons while this does
   ;;
   pekwm)[ `which jwm2pekwm` ] && jwm2pekwm
   ;;
#   jwm)#[ `which jwm` ] &
#      /usr/local/jwmdesk/func -menu_update
#   ;; # Already at lines 42 to 55. Because these lines here create a repeat.
   
                openbox)[ `which obmenu-refresh` ] && obmenu-refresh
   ;;
   *)[ `which variconlinks` ] && variconlinks #100404 for my fbpanel pkg.
   [ `which tempicons` ] && tempicons
   [ `which fbpanel_menu_refresh` ] && fbpanel_menu_refresh
   [ `which lxpanel_menu_refresh` ] && lxpanel_menu_refresh
   ;;
esac
# end of edit by musher0
###END###

The jwm menu does not need this "support" at the end, since it is itself the basis
for the menus of other window managers. The jwm menu has already been updated
at lines 42-55. It doesn't need to be updated twice.

This works for me when in jwm, but anyone interested, please test, as I do not have
installed all the window manager necessary for further testing.

I've separated the window managers with a < case...esac > fork, it looked like the logical
thing to do. But don't hesitate to refine my code as well.

TIA. BFN.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)

Last edited by musher0 on Tue 05 Apr 2016, 02:33; edited 3 times in total
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1268

PostPosted: Mon 04 Apr 2016, 22:03    Post subject: Re: CUPS not connecting to localhost
Subject description: Desktop icons text not localised for here (Australia)?
 

davids45 wrote:
I cannot reach CUPS to get my networked printer/scanner set up. The screenshot shows the error when I run the CUPS wizard.


Try setiing defaulthtmlviewer to 'defaultbrowser'. Maybe defaulthtmlviewer is set to a browser not installed or to an inexisting command.

_________________
Puppy Linux en español
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 14538
Location: Gatineau (Qc), Canada

PostPosted: Mon 04 Apr 2016, 22:10    Post subject:  

@david245 and charlie6:

The simplest way to localize the legend at the bottom of your icons may be to do a
manual edit of file PuppyPin located at /root/Choices/ROX-Filer/PuppyPin.

A little how-to:
    -- Make a copy of the original < PuppyPin > as < PuppyPin.orig >.
    -- Open the PuppyPin file and translate the designation of "label" in your language.
    These start at line 4.
    -- Save when finished.
    -- Make a copy of your edited < PuppyPin > as < PuppyPin.mine > or something to
    that effect. I ask you to do this because the PuppyPin is part of the main sfs,
    which is unchangeable. If on next boot Puppy acts "teflon", you'll have a copy for
    restoration.
I hope this helps.

BFN.
labels_in_PuppyPin_2016-04-04(1).jpg
 Description   
 Filesize   68.5 KB
 Viewed   2123 Time(s)

labels_in_PuppyPin_2016-04-04(1).jpg


_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)

Last edited by musher0 on Mon 04 Apr 2016, 22:34; edited 2 times in total
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 14538
Location: Gatineau (Qc), Canada

PostPosted: Mon 04 Apr 2016, 22:12    Post subject: Re: CUPS not connecting to localhost
Subject description: Desktop icons text not localised for here (Australia)?
 

vicmz wrote:
davids45 wrote:
I cannot reach CUPS to get my networked printer/scanner set up. The screenshot shows the error when I run the CUPS wizard.
Try setiing defaulthtmlviewer to 'defaultbrowser'. Maybe defaulthtmlviewer is set to a browser not installed or to an inexisting command.
Perhaps true. But I have observed that the jibaro comes without a browser. Make sure
that you have downloaded and installed one first! Smile

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 5 [75 Posts]   Goto page: 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0779s ][ Queries: 14 (0.0125s) ][ GZIP on ]