Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 28 May 2017, 18:34
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Chromium 58 with pepper-flash
Post new topic   Reply to topic View previous topic :: View next topic
Page 19 of 24 [348 Posts]   Goto page: Previous 1, 2, 3, ..., 17, 18, 19, 20, 21, 22, 23, 24 Next
Author Message
peebee


Joined: 21 Sep 2008
Posts: 2699
Location: Worcestershire, UK

PostPosted: Sat 18 Jun 2016, 12:28    Post subject:  

18-jun-2016

Updated to chromium_51.0.2704.103

follow link in post #1

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 2699
Location: Worcestershire, UK

PostPosted: Wed 13 Jul 2016, 12:17    Post subject: chromium_51.0.2704.103+pepper_22.0.0.209  

Adobe are now supplying pepperflash as direct downloads....

chromium_51.0.2704.103+pepper_22.0.0.209_lx.sfs

chromium64_51.0.2704.103+pepper_22.0.0.209_lx.sfs
version.png
 Description   
 Filesize   132.8 KB
 Viewed   5071 Time(s)

version.png


_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 2699
Location: Worcestershire, UK

PostPosted: Mon 25 Jul 2016, 12:11    Post subject: chromium_52.0.2743.116 + pepperflash_22.0.0.209  

UPDATED 06-aug-2016

THIS VERSION WILL ONLY WORK ON "MODERN" PUPPIES - e.g. LxPup, LxPupTahr, Slacko6, TahrPup6, X-tahr, X-Slacko
and then only on versions with kernels newer than 3.14 unless you apply the patch here which does affect sandboxing


Courtesy of AlienBob

32bit sfs:
chromium_52.0.2743.116+pepper_22.0.0.209_lx.sfs

64bit sfs:
chromium64_52.0.2743.116+pepper_22.0.0.209_lx.sfs

older .pet versions are available or use the converter.

Caveats and constraints as detailed above

If you need a .pet instead of a .sfs or you want the 64-bit .sfs to run on tahrpup64 then use this converter.

To use services, such as Netflix, with protected content, you probably need to add the widevine plugin to Chromium (see testing thread). Links to the versions compatible with the above versions of Chromium are below. Just download the .txz file and then click on the downloaded file to install it.

32-bit widevine plugin
64-bit widevine plugin
version.png
 Description   
 Filesize   123 KB
 Viewed   4920 Time(s)

version.png


_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 2699
Location: Worcestershire, UK

PostPosted: Sat 06 Aug 2016, 03:14    Post subject: 52.0.2743.116  

52.0.2743.116 is available see above.
_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
solex

Joined: 05 Sep 2014
Posts: 52

PostPosted: Sat 20 Aug 2016, 21:13    Post subject:  Chromium Crashes  

I have installed the latest SFS on my Slack 6.3 install on my X61.

Frequently Chromium will freeze up and cause a screen flash. I have launched it from the console and am receiving the attached errors. Particularly when I use the back arrow navigation and when switching tabs.

I have tried installing and un-installing widevine with the same results

Any ideas would be appreciated.

Thanks,
Dan

I did some research and found that this is an intel driver issue, starting chroumium with the following settings seems to mitigate the issue:

Code:
"always_flush_cache=true always_flush_batch=true chromium-browser"


just need to determine how to always start chromium with these flags instead of through the console.
Screenshot(1).png
 Description   
 Filesize   39.91 KB
 Viewed   4214 Time(s)

Screenshot(1).png

Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 609

PostPosted: Sun 21 Aug 2016, 02:53    Post subject: Re: chromium_52.0.2743.116 + pepperflash_22.0.0.209  

peebee wrote:

To use services, such as Netflix, with protected content, you probably need to add the widevine plugin to Chromium (see testing thread). Links to the versions compatible with the above versions of Chromium are below. Just download the .txz file and then click on the downloaded file to install it.

32-bit widevine plugin
64-bit widevine plugin


I can't remember if I installed widvine but in July I installed Chromium 43.0.2357.132 and it worked with netflix on tahrpup. FOr me to get it to work I also installed some codec files from the puppy package manager.

There is this one:

chromium-codecs-ffmpeg-extra_50.0.2661.102.files
Code:

/usr/
/usr/share/
/usr/share/lintian/
/usr/share/lintian/overrides/
/usr/share/lintian/overrides/chromium-codecs-ffmpeg-extra
/usr/share/doc/
/usr/share/doc/chromium-codecs-ffmpeg-extra/
/usr/share/doc/chromium-codecs-ffmpeg-extra/copyright
/usr/share/doc/chromium-codecs-ffmpeg-extra/changelog.Debian.gz
/usr/lib/
/usr/lib/chromium-browser/
/usr/lib/chromium-browser/libs/
/usr/lib/chromium-browser/libs/libffmpeg.so


and this one:

chromium-codecs-ffmpeg_50.0.2661.102.files
Code:

/usr/
/usr/share/
/usr/share/lintian/
/usr/share/lintian/overrides/
/usr/share/lintian/overrides/chromium-codecs-ffmpeg
/usr/share/doc/
/usr/share/doc/chromium-codecs-ffmpeg/
/usr/share/doc/chromium-codecs-ffmpeg/copyright
/usr/share/doc/chromium-codecs-ffmpeg/changelog.Debian.gz
/usr/lib/
/usr/lib/chromium-browser/
/usr/lib/chromium-browser/libs/
/usr/lib/chromium-browser/libs/libffmpeg.so


While this worked for netflix it didn't work for shomi.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2699
Location: Worcestershire, UK

PostPosted: Sun 21 Aug 2016, 02:54    Post subject: Re: Chromium Crashes  

solex wrote:

Code:
"always_flush_cache=true always_flush_batch=true chromium-browser"


just need to determine how to always start chromium with these flags instead of through the console.

Hi Dan

Edit /usr/bin/chromium

and add them to the exec line - suspect you just need the 2 =true flags

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
solex

Joined: 05 Sep 2014
Posts: 52

PostPosted: Sun 21 Aug 2016, 07:58    Post subject: Re: Chromium Crashes  

[quote="peebee"]
solex wrote:


Hi Dan

Edit /usr/bin/chromium

and add them to the exec line - suspect you just need the 2 =true flags


Hi,
I tried this but the flags actually need to come before the chromium-browser. I tried editing all of the scripts to start the browser but none will let me put the flags before the actual command.

Thanks,
Dan
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2699
Location: Worcestershire, UK

PostPosted: Sun 21 Aug 2016, 12:28    Post subject: Re: Chromium Crashes  

solex wrote:
Hi,
I tried this but the flags actually need to come before the chromium-browser. I tried editing all of the scripts to start the browser but none will let me put the flags before the actual command.

Thanks,
Dan

Hi Dan

if they are environment variables rather than cli parameters then they need to go on separate lines preceeding the exec line.....

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
solex

Joined: 05 Sep 2014
Posts: 52

PostPosted: Sun 21 Aug 2016, 15:04    Post subject: Re: Chromium Crashes  

peebee wrote:

Hi Dan

if they are environment variables rather than cli parameters then they need to go on separate lines preceeding the exec line.....



Thanks peebee,

I got it to work, had to research how to set environment variables so they are available to a new process. Attached is my code in /usr/bin/chromium

Code:
#!/bin/sh
# Chromium64 launcher
export LD_LIBRARY_PATH=/usr/lib64/chromium:$LD_LIBRARY_PATH
export CHROME_VERSION_EXTRA="Puppy Linux 64"

if [ ! -f /usr/lib64/chromium/chromium-run1 ]; then
touch /usr/lib64/chromium/chromium-run1
BROWSER=chromium
Xdialog --title "Default Browser" --yesno "Would you like $BROWSER to be \n the default browser?" 0 0
case $? in
0)cp /usr/local/bin/defaultbrowser /usr/local/bin/ORIGdefaultbrowser
echo '#!/bin/sh
exec '"$BROWSER"' "$@"' > /usr/local/bin/defaultbrowser ;;
*)exit ;;
esac
fi

export always_flush_cache=true
exec /usr/lib64/chromium/chromium --user-data-dir=$PWD/.config/chromium --ppapi-flash-path=/usr/lib64/chromium/PepperFlash/libpepflashplayer.so --ppapi-flash-version=22.0.0.209 --disk-cache-size=10000000 --media-cache-size=10000000 --allow-outdated-plugins "$@"
Back to top
View user's profile Send private message 
howling_hound

Joined: 11 Jun 2016
Posts: 4

PostPosted: Tue 23 Aug 2016, 18:15    Post subject:  

G'day All,

For what it is worth, several of my older computer single core systems exhibited the freeze up and on occasions displaying the black squares in the four corners of the screen. My solution search returned a recommendation to disable hardware acceleration in the browser "settings". Since this was easy to do, I gave it a try and have had improved results for playback and stability. The black square issue appears to be eliminated. There are still some news web sites with auto loading flash video feeds that occasionally still lock things up to the point of a power cycle but those are much less frequent.

Cheers!
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 609

PostPosted: Thu 25 Aug 2016, 02:50    Post subject: Re: chromium_52.0.2743.116 + pepperflash_22.0.0.209  

s243a wrote:

I can't remember if I installed widvine but in July I installed Chromium 43.0.2357.132 and it worked with netflix on tahrpup. FOr me to get it to work I also installed some codec files from the puppy package manager.

There is this one:

chromium-codecs-ffmpeg-extra_50.0.2661.102.files


I'm not sure if this is interesting at all but I would like to report chromecast works with this browser via the following extension:
https://chrome.google.com/webstore/detail/google-cast/boadgeojelhgndaghljhdicfkmllpafd/support

One downside is that when you share a tab with chromecast it stops the audio on your local computer and sends it to the TV. I would like to be able to choose which device (or possibly have both) play/s the audio.

Also it is supposedly possible to share an entire desktop. I haven't figured out how to do this yet.

edit: I found a solution but the task bar comes partly off the screen when I do it.

From redit:

Quote:

Figured it out.
1) Go to "Back to the Device List" on the Google Cast button in your browser.
2) Click the little chevron/down arrow
3) Click "Cast Entire Screen." Now the audio should play through your laptop; this means you can play it via headphones, or through BlueTooth audio as I'm doing!
Hope this helps.

https://www.reddit.com/r/Chromecast/comments/2c2cyh/need_to_stream_video_to_chromecast_but_keep_the/
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 609

PostPosted: Wed 31 Aug 2016, 03:52    Post subject: Re: chromium_52.0.2743.116 + pepperflash_22.0.0.209  

s243a wrote:


I can't remember if I installed widvine but in July I installed Chromium 43.0.2357.132 and it worked with netflix on tahrpup. FOr me to get it to work I also installed some codec files from the puppy package manager.



I'm not sure if this is fixed in the newer releases but the history feature (either cntrl-H or via the menu) is shutting down the browser.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2699
Location: Worcestershire, UK

PostPosted: Wed 31 Aug 2016, 04:52    Post subject: Re: chromium_52.0.2743.116 + pepperflash_22.0.0.209  

s243a wrote:
s243a wrote:


I can't remember if I installed widvine but in July I installed Chromium 43.0.2357.132 and it worked with netflix on tahrpup. FOr me to get it to work I also installed some codec files from the puppy package manager.



I'm not sure if this is fixed in the newer releases but the history feature (either cntrl-H or via the menu) is shutting down the browser.

Not for me - works fine......

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 2699
Location: Worcestershire, UK

PostPosted: Fri 09 Sep 2016, 05:09    Post subject: chromium-53.0.2785.9+pepperflash_22.0.0.209_lx.sfs
Subject description: 32-bit & 64-bit - only for latest pups
 

Updated 14-sep-2016

The world moves on.....

At the moment it looks like chromium-52 will be the last version for the slackware-14.1 / tahrpup era...

chromium-53 is available - tested for the slackware-14.2 (slacko and LxPupSc) and xenialpup era pups

chromium-53.0.2785.92+pepper_23.0.0.162_lx.sfs

chromium64_53.0.2785.92+pepper_23.0.0.162_lx.sfs - only tested on slacko64-6.9.5-uefi

_________________
LxPup = Puppy + LXDE

Last edited by peebee on Wed 14 Sep 2016, 02:38; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 19 of 24 [348 Posts]   Goto page: Previous 1, 2, 3, ..., 17, 18, 19, 20, 21, 22, 23, 24 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1501s ][ Queries: 13 (0.0764s) ][ GZIP on ]