Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 22 Jul 2018, 10:54
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Epson scanner driver
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 4 [50 Posts]   Goto page: Previous 1, 2, 3, 4
Author Message
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Sun 12 Jun 2016, 19:46    Post subject:  

To avoid a duplicate post, which will annoy people of importance, there is a post relevant to this thread in another thread (to which it is also relevant), here.
_________________

Back to top
View user's profile Send private message 
jakobcornelis


Joined: 06 Nov 2007
Posts: 162
Location: Elliot Lake, Ontario

PostPosted: Wed 05 Oct 2016, 18:17    Post subject:  

rcrsn51: Thanks for all your posts on installing printers and scanners. As a result I can now print and scan off Puppy and forget about W*nd*ws, which is a relief. This looks like an unbelievable amount of work you did, and I just want to let you know how much I appreciate this, plus your patient helpfulness.

jake

Slacko531
Back to top
View user's profile Send private message 
dcung

Joined: 13 Jul 2018
Posts: 25
Location: Sydney, Down Under.

PostPosted: Today, at 03:02    Post subject:  

Hi all,

Continue after Fresh install - a bit of history from this thread.
http://www.murga-linux.com/puppy/viewtopic.php?p=999630#999630

I have read these threads and few others...
http://murga-linux.com/puppy/viewtopic.php?t=41939
http://murga-linux.com/puppy/viewtopic.php?t=61885
http://murga-linux.com/puppy/viewtopic.php?t=59015

But not able to get scanner (Epson WF-2760) working yet.

I used eppi-pet-maker, created epson_wf2760-18.04.pet following http://murga-linux.com/puppy/viewtopic.php?t=61885. Install the .pet afterward. I can see "Epson ImageScan" but nothing happened when trying to run the app.

I used iscan-2.19.0-i486.pet following http://murga-linux.com/puppy/viewtopic.php?t=41939. I can see "Epson Iscan scanner" but also nothing happened when trying to run the app.

I tried installing by clicking all .deb files...install success, can't run app still.
I tried running install.sh from a terminal....errors.

I can't seem to progress...apart from seeing the items created on menu...

What else to do please?
FYI - I use XenPup64-7.5, and downloaded 64 bit driver from Epson.
capture10726.png
 Description   
 Filesize   50.3 KB
 Viewed   55 Time(s)

capture10726.png

capture5728.png
 Description   
 Filesize   143.7 KB
 Viewed   57 Time(s)

capture5728.png

capture10100.png
 Description   Content of tarball from Epson Download
 Filesize   110.32 KB
 Viewed   58 Time(s)

capture10100.png

Back to top
View user's profile Send private message 
dcung

Joined: 13 Jul 2018
Posts: 25
Location: Sydney, Down Under.

PostPosted: Today, at 05:51    Post subject:  

Further tinkering, after reading few more postings by rcrsn51 and Mike Walsh.
Probably does not apply to me, but.... Sad
I put net 10.0.0.44 which is my scanner IP.
rcrsn51 wrote:
Open the file /etc/sane.d/dll.conf and add "epkowa" on the end.

Open the file /etc/sane.d/epkowa.conf and add "usb 0x04b8 0x0118" on the end.

Try again with iscan and xsane.

Run "sane-find-scanner" and "scanimage -L"
capture15900.png
 Description   
 Filesize   159.52 KB
 Viewed   40 Time(s)

capture15900.png

Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12222
Location: Stratford, Ontario

PostPosted: Today, at 07:53    Post subject:  

It looks like you have been mixing 32 and 64bit drivers.

Here is the 64bit version of the Epson epkowa SANE driver, that should work with the XSane scanner app.

As a first test, you should connect directly by USB.
sane-backend_epkowa-1.0.27-64bit.pet
Description 
pet

 Download 
Filename  sane-backend_epkowa-1.0.27-64bit.pet 
Filesize  166.04 KB 
Downloaded  0 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 4 [50 Posts]   Goto page: Previous 1, 2, 3, 4
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0699s ][ Queries: 15 (0.0241s) ][ GZIP on ]