Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 17 Nov 2017, 15:56
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Quirky Xerus 8.1.4 for Raspberry Pi2 and 3
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 7 of 44 [654 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, ..., 42, 43, 44 Next
Author Message
don570


Joined: 10 Mar 2010
Posts: 4755
Location: Ontario

PostPosted: Mon 03 Oct 2016, 14:16    Post subject:  

Sound report - on raspberry pi2

This time I used a computer monitor instead of TV set.

I booted with

Code:
hdmi_safe=1

and used 99-alsa init file

Sound worked better this time. I don't think I needed to set retrovol.
There is no stuttering of sound files even when one of the sliders
is not set. (see image)

I listened to audio using earphones over the analog channel.




______________________________________
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8312
Location: Perth, Western Australia

PostPosted: Tue 04 Oct 2016, 03:14    Post subject:  

Version 8.0.25 is out, now promoted to "alpha quality":

http://barryk.org/news/?viewDetailed=00426

_________________
http://barryk.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8312
Location: Perth, Western Australia

PostPosted: Wed 05 Oct 2016, 08:27    Post subject:  

I finally got rid of theose /DEBIAN* folders Very Happy

I took a look at 'raspi-config' in Raspbian. It is a text-mode utility to set various things. A bit like QuickSetup in Quirky, kind of.

One thing it offers is to grow the filesystem to fill the drive.
This situation occurs if the image file that was written to the flash drive is smaller than the drive. An example is a 8GB image written to a 16GB drive.

Ubuntu Mate for the Odroid XU4 does this resizing automatically at first boot, which caught me by surprise. It actually got to the login screen, then before I could login, it rebooted!

Yikes, I thought it was a bug. Anyway, that is a bit of an uncouth way of doing it. I prefer to ask.

So, I have put a checkbox into QuickSetup, haven't finished implementing it yet.

_________________
http://barryk.org/news/
Back to top
View user's profile Send private message Visit poster's website 
eowens2

Joined: 27 Aug 2008
Posts: 172

PostPosted: Wed 05 Oct 2016, 18:01    Post subject:  

I've been taking Quirky Version 8.0.23 out for a spin this afternoon, and things are looking good.

I updated the package lists in Quirky Package Manager, and downloaded/installed "HPLIP' and 'Chromium'. CUPS 2.1.3 doesn't seem to recognize new network printers too well, but since I already knew the network address for the printer was able to install my HP Office Jet 6500 without any problems. The test print was fine.

There was a problem with Chromium however. There was a menu entry for Chromium, but clicking on it did not get any results. I looked in /root/.Packages, and there were lots of files associated with Chromium and the binary seemed to be at /usr/bin/chromium-browser.

Typing 'chromium'browser' in a terminal gave me:


Code:
# chromium-browser
[1:1:1004/205402:FATAL:setuid_sandbox_client.cc(126)] Check failed: IsFileSystemAccessDenied().
#0 0x000076e51e5e base::debug::StackTrace::StackTrace()
#1 0x000076e640e6 logging::LogMessage::~LogMessage()
#2 0x000073d8c2ba sandbox::SetuidSandboxClient::ChrootMe()
#3 0x000075d333c2 <unknown>
#4 0x000075abe0f4 <unknown>
#5 0x000075abe62c <unknown>
#6 0x000075abdcf6 content::ContentMain()
#7 0x000054cdd3c0 ChromeMain
#8 0x0000725c48aa __libc_start_main

Received signal 6
#0 0x000076e51e5e base::debug::StackTrace::StackTrace()
#1 0x000076e52148 <unknown>
#2 0x0000725d3260 <unknown>
#3 0x0000725c4af6 <unknown>
#4 0x0000725d2638 gsignal
#5 0x0000725d333a abort
[end of stack trace]


I am not sure what to make of this.

Any suggestions?
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 934

PostPosted: Wed 05 Oct 2016, 18:08    Post subject:  

That seems to be the normal "make Chromium run as root" problem.

Try

Code:
/usr/bin/chromium-browser  --no-sandbox


or
Code:

/usr/bin/chromium-browser --user-data-dir=/root/chrome/user --disk-cache-dir=/root/chrome/cache  --no-sandbox


You can put that in a script or edit the chromium wrapper script for convenience if it works.

PM Mike Walsh if that doesn't work, he's the Chrome guy.
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 4755
Location: Ontario

PostPosted: Wed 05 Oct 2016, 19:56    Post subject:  

BarryK wrote:
I took a look at 'raspi-config' in Raspbian. It is a text-mode utility to set various things. A bit like QuickSetup in Quirky, kind of.


The feature I like best about raspi-config --->
it allows user to set up ssh if desired

__________________________________
Back to top
View user's profile Send private message 
eowens2

Joined: 27 Aug 2008
Posts: 172

PostPosted: Wed 05 Oct 2016, 21:29    Post subject:  

Hi dancytron,

Thank you for your response.

I tried
Code:
/usr/bin/chromium-browser  --no-sandbox

and the response was
Code:
# /usr/bin/chromium-browser --no-sandbox
[2624:2624:1004/180406:ERROR:browser_main_loop.cc(231)] Running without the SUID sandbox! See https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the sandbox on.
Segmentation fault
# [2805:2805:1004/180417:ERROR:sandbox_linux.cc(343)] InitializeSandbox() called with multiple threads in process gpu-process.


and I tried
Code:

/usr/bin/chromium-browser --user-data-dir=/root/chrome/user --disk-cache-dir=/root/chrome/cache  --no-sandbox
with the response
Code:
# /usr/bin/chromium-browser --user-data-dir=/root/chrome/user --disk-cache-dir=/root/chrome/cache  --no-sandbox
[5623:5623:1004/180802:ERROR:browser_main_loop.cc(231)] Running without the SUID sandbox! See https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the sandbox on.
Segmentation fault
# [5761:5761:1004/180811:ERROR:sandbox_linux.cc(343)] InitializeSandbox() called with multiple threads in process gpu-process.


I will do as you suggest and send a PM to Mike Walsh. Thanks again.
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 934

PostPosted: Wed 05 Oct 2016, 21:40    Post subject:  

Apparently you aren't the only one.

https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1563184

https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1576079

https://ubuntu-mate.community/t/chromium-crashes-when-starting-segfaults/4578
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 4755
Location: Ontario

PostPosted: Thu 06 Oct 2016, 11:43    Post subject:  

I was able to compile the latest
imagemagick 7.0.3

It's a big package. It could be reduced I'm sure if I knew more about the app.

File: imagemagick-v7-7.0.3.pet
Size: 22.39 MB
https://www.datafilehost.com/d/c0033361


______________________________________
Back to top
View user's profile Send private message 
eowens2

Joined: 27 Aug 2008
Posts: 172

PostPosted: Thu 06 Oct 2016, 22:48    Post subject:  

Hi dancytron,

Thank you for those links on Chromium browser crashing, very interesting and informative.

For those who have not read the links, the problem seems to affect the armhf version of Chromium rather than any specific device. The problem has been described on Raspberry Pi 2 and 3, also on the odroid XU3. It has been described with Ubuntu Mate and Arch Linux Arm (not sure about Raspbian).

Apparently Chromium browser was stable through version 48, and the seg fault problem began appearing with version 49. The chromium-browser version in Quirky Xerus 8.0.25 is 52.0.2743.116.

I did a PM to Mike Walsh about the problem, including the error messages. He said that Chromium usually contains cutting-edge work and is compiled against the latest glibc. Google then takes this source code and then alters it as Chrome and re-compiles it against an older glibc to give a new ‘stable’ release compatible with as much hardware as possible. His thoughts were that the problems I encountered were due to conflicts between the ARM porting, the kernel used and Chromium’s source code. I sure wish Chrome were available in the repository.

Interesting…Raspberry Pi just released a new operating system called ‘PIXEL’, and the default browser is chromium-browser 51.0.2704.91. In my limited experience with it, the browser seems to boot without problem and take you where you want to go. But thus far it will not allow me to sign in to my gmail account (“Uh-oh! Service unavailable try again later”) . Reportedly the sign-in issue has been solved but I have not had a chance to try it yet.

Also interesting. I have an Asus Chromebook Flip, and I am running Arch Linux ARM on it from an SD card. The Chromium browser (works fine) on the distro is version 52.0.2743.82; the kernel is 3.14.0.

The bug reports are posted on the Chromium problem, and the priority is high. Hope they get it fixed soon.
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 4755
Location: Ontario

PostPosted: Sat 08 Oct 2016, 12:30    Post subject:  

Testing version 8.0.25

The sound is much better!!

Audio setup procedure:

Retrovol needed the sliders moved to left hand
side to make active, but sound volume was correct and persisted between boots.

Retrovol didn't need the sliders adjusted so there was no crash. Very Happy

_________________________________________________________


There appears to be a new bug introduced in this version.
leafpad version 0.8.18 appears to have a bug with some arm kernels
when saving a bash script to disk. It produces garbage characters
making the script unusable. sometimes the files are "application/octet-stream"

Geany doesn't have this problem fortunately.

Fatdogarm version .0.8.17 works OK so replacing may be the solution.

________________________________________________
leafpad-v7-0.8.17.pet
Description  fatdog arm version of leafpad
pet

 Download 
Filename  leafpad-v7-0.8.17.pet 
Filesize  96.38 KB 
Downloaded  50 Time(s) 
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8312
Location: Perth, Western Australia

PostPosted: Sat 08 Oct 2016, 20:32    Post subject:  

I have bypassed the problem of Retrovol showing bogus sliders in the mixer (and crashing), by using pnmixer and aumix:

http://barryk.org/news/?viewDetailed=00431

I got xine working on the Pi2, but it is very unsatisfactory. Weird error messages, videos don't play, etc.
http://barryk.org/news/?viewDetailed=00432

...also in above link, I reported that ethernet reconnection at bootup is now fixed.

Anyway, the video player. I know that you guys have been trying various video players. Which one do you reckon would be the best replacement for xine?

I guess the choices are VLC, mplayer, xfmedia. Anything else?

The replacement should be something that doesn't have too many dependencies.

_________________
http://barryk.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8312
Location: Perth, Western Australia

PostPosted: Sat 08 Oct 2016, 20:35    Post subject:  

Testing on the Pi2, Shutdown -> Exit to prompt just produces a black screen, and the keyboard no longer responds.

I don't know why, so I have implemented a workaround.

For the Pi only, "Exit to prompt" is replaced with "Reboot to commandline". This works.

_________________
http://barryk.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8312
Location: Perth, Western Australia

PostPosted: Sat 08 Oct 2016, 20:37    Post subject:  

don570 wrote:
There appears to be a new bug introduced in this version.
leafpad version 0.8.18 appears to have a bug with some arm kernels
when saving a bash script to disk. It produces garbage characters
making the script unusable. sometimes the files are "application/octet-stream"

Geany doesn't have this problem fortunately.

Fatdogarm version .0.8.17 works OK so replacing may be the solution.

________________________________________________


Thanks for that info, I'll check it out.

_________________
http://barryk.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8312
Location: Perth, Western Australia

PostPosted: Sat 08 Oct 2016, 20:51    Post subject:  

BarryK wrote:
don570 wrote:
There appears to be a new bug introduced in this version.
leafpad version 0.8.18 appears to have a bug with some arm kernels
when saving a bash script to disk. It produces garbage characters
making the script unusable. sometimes the files are "application/octet-stream"

Geany doesn't have this problem fortunately.

Fatdogarm version .0.8.17 works OK so replacing may be the solution.

________________________________________________


Thanks for that info, I'll check it out.


I looked at the leafpad website, 0.8.17 is the latest version. I wonder where 0.8.18 comes from?

http://tarot.freeshell.org/leafpad/

_________________
http://barryk.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 7 of 44 [654 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, ..., 42, 43, 44 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0788s ][ Queries: 13 (0.0063s) ][ GZIP on ]