Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 00:40
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Puppy-2.13 en castellano(también funciona con puplets 2.13)
Moderators: rarsa
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [29 Posts]   Goto page: 1, 2 Next
Author Message
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Tue 23 Jan 2007, 23:04    Post subject:  Puppy-2.13 en castellano(también funciona con puplets 2.13)
Subject description: Unofficial langpack es versión 0.1.2 (3ra entrega)
 

Click here to read this post in english

Esta es la tercera versión de mi paquete de idioma, esta vez para Puppy-2.13(teóricamente debería funcionar con puplet basados en Puppy-2.13, estoy descargando algunos ahora). El dotpup puede ser instalado en otras versión pero sin ninguna garantía de que funcione

Lista de cambios desde la versión 0.1.1 a 0.1.2:
Code:
-----------------------------
0.1.2 - Solo para Puppy 2.13
-----------------------------

Para esta version solo prevalecerá el DotPup, los archivos del .sfs
fueron movidos hacia el DotPup, excepto:
- Clipart para Abiword
- Seamonkey 1.0.5

Programas traducidos/Actualizados:
- XArchive 0.2.8-6
- PBrename-0.4
- chooselocale
- connect-wizard
- dotpup
- gaim-autosetup.sh
- input-wizard
- modem-wizard
- panel-buttons(JWM Config)
- petget
- video-wizard
- xorgwizard(Parcialmente traducido)

Archivos de traducción:

- rox-2.5
- gtksee-0.6.0b
- Seamonkey-1.0.6
- ld
- libc
- libexif-12
- libexo-0.3
- libgphoto2-2
- libidn
- sed
- tar

Cosas adicionales:

- Base de datos MIME(contiene información, en varios idiomas, sobre los tipos de archivo)

Restauré el nombre del menu JWM a "Menu", en las versiones anteriores era "Menú" pero esto
implica la pérdida de los botones en el panel JWM al desinstalar este paquete de idioma.
Los botones y demás configuraciones se guardan en el archivo /root/.jwmrc-tray, cambiar el
nombre del menu a por ejemplo "Inicio" requiere el modificar el script que se encarga de los
botones, el no hacerlo inutiliza el script (/usr/local/jwmconfig/panel-buttons).


La instalación es simple como en otros DotPups, lee los mensajes cuidadosamente, y no olvides cerrar todas las ventanas de Seamonkey después de instalar su paquete de idioma(el langpack de Seamonkey, no mi langpack)

Para recuperar las versiones originales de las Utilidades de Sistema de Puppy y otras aplicaciones, ejecuta el script de desinstalación:
Code:
/usr/local/Unofficial-langpack-es_0.1.2/uninstall


Unofficial-langpack-es-213.pup tamaño: 2.37 MB, tamaño desempaquetado: 9.9 MB

Descargar desde: [www.filefront.com] [ftp.servage.net]
Parche 05Feb06 (obligatorio) [langpack-es-213-fix-05feb07.pup](añadido al final de este mensaje)
__________________
Nota: Todos los archivos(incluyendo versiones anteriores) están disponibles en: http://hosted.filefront.com/rockinfreak/1880985

Click here to read this post in english
langpack-es-213-fix-05feb07.pup
Description  Parche 05Feb06 (obligatorio)
pup

 Download 
Filename  langpack-es-213-fix-05feb07.pup 
Filesize  14.61 KB 
Downloaded  1231 Time(s) 

_________________


Last edited by wow on Fri 16 Feb 2007, 21:10; edited 4 times in total
Back to top
View user's profile Send private message 
caka

Joined: 07 Dec 2006
Posts: 202

PostPosted: Wed 24 Jan 2007, 05:17    Post subject:  

wow gracias por tu trabajo. Yo hoy en dia tengo instalado Puppy 2.12 y he traducido el menu incico al castellano gracias a un dotpup que publicaste hace ya bastante tiempo.

Cuando me cambie a una versión más reciente tendré en cuenta este nuevo dotpup. Hasta has traducido el menu del "petget" Laughing . Tengo ganas de probar la versión 2.13 para ver que tal fuciona la creación e instalación de archivos *.pet, pero quizás me esperaré al mes de Febrero a por el Puppy 2.14. Laughing

Gracias wow.
Back to top
View user's profile Send private message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Wed 24 Jan 2007, 22:15    Post subject: Funciona con Litepup 2.13 y eBoxPup-2.13-0.1alpha  

Probé el dotpup con en los siguientes puplets(derivados de puppy):

Litepup 2.13
    Estado: Funciona correctamente, desinstalación limpia.
    Conflictos con los script traducidos: Ninguno encontrado
    Scripts personalizados que fueron reemplazados: Ninguno encontrado

Screenshot:


eBoxPup-2.13-0.1alpha
    Estado: Funciona correctamente, desinstalación limpia.
    Conflictos con los script traducidos: Ninguno encontrado
    Scripts personalizados que fueron reemplazados: Ninguno encontrado
    Traducciones i18n faltantes: beaver-0.2.7 | opera-9.02 | GQmpeg-0.91.1 | bluefish-pre0.7

Screenshot:


Aunque no encontré problemas con esas versiones, no garantizo que sea 100% libre de errores Twisted Evil, cuando tenga algo de tiempo bajaré otros puplets para ver como funciona el langpack en ellos.

Gracias caka por tu comentario y sobre el menú de Puppy, todo indica que para la versión 2.14 incluirá el sistema de menús XDG, en el que está trabajando rarsa, el cual incluye información en múltiples idiomas(o debo decir "puede incluir") solo resta esperar a que esté disponible la primera beta de Puppy-2.14 Smile

_________________

Back to top
View user's profile Send private message 
apendragon

Joined: 15 Jan 2007
Posts: 56

PostPosted: Thu 25 Jan 2007, 19:00    Post subject: problemas con 2.13 pasado al castellano  

Buenas.

Tengo la versión 2,13 en CD para arrancar y uso memoria USB para almacenar las sesiones. Con la 2,12 no había problema, pero en la versión 2,13 me da errores continuos de lectura en la memoria USB Confused . Tambien me da error en la escritura/lectura del CD, y en general, me da problemas cada vez que intento recuperar el trabajo hecho anteriormente sea cual sea la forma de grabación.

Tal vez la 2,13 no dé problemas si se ha instalado en el disco duro, pero si se pretende que sea un sistema portátil, como es mi caso, no merece la pena pasarse a la nueva versión.....

.... O quizá tengo algún fallo grave en mi equipo. Si esto fuera Windows diría que tengo un virus Wink

Comprobadlo, por favor. Gracias
Back to top
View user's profile Send private message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Thu 25 Jan 2007, 22:16    Post subject: Re: problemas con 2.13 pasado al castellano  

apendragon wrote:
Tengo la versión 2,13 en CD para arrancar y uso memoria USB para almacenar las sesiones. Con la 2,12 no había problema, pero en la versión 2,13 me da errores continuos de lectura en la memoria USB Confused . Tambien me da error en la escritura/lectura del CD, y en general, me da problemas cada vez que intento recuperar el trabajo hecho anteriormente sea cual sea la forma de grabación.

Yo tambien tengo algunos problemas con Puppy 2.xx por eso no he migrado completamente; pero no me quedo claro lo que escribiste, instalaste el dotpup y experimentaste esos problemas o el desastre ya viene con el ISO de Puppy-2.13?¿ Va a ser un poco complicado encontrar la solución, especialmente porque USB tiene 3 letras y la búsqueda en el foro tiene problemas con palabras de solo 3 caracteres Confused de todas formas es posible que alguien más halla reportado el error en alguna otra sección del foro:

Bugs ( Submit bugs )
Hardware

Y algo más, descartaste la posibilidad de error en tu hardware?¿ es decir, probaste con otra unidad de CD/DVD, otro drive USB o incluso descargar y grabar otro CD/DVD ?¿

_________________

Back to top
View user's profile Send private message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Fri 26 Jan 2007, 21:29    Post subject:  

@apendragon, pasé por alto esto: "Post subject: Re: problemas con 2.13 pasado al castellano" Embarassed

Debido al mensaje que escribiste decidí hacer algunas pruebas más: grabé un CD en modo multisesión, el iso elegido fue el de la versión oficial de Puppy-2.13; seguidamente instalé el dotpup, después de terminar con la instalación ejecuté cada uno de los programas que modifiqué iniciandolos desde una ventana de terminal (para ver los mensajes de error en caso de que se dieran), y único problema que encontre fue al añadir botones al panel de JWM(pero no le di mucha importancia porque esto me sucede tambíén en la versión original del script, la solución es restablecer el archivo /root/.jwm-tray desde el sfs en /initrd/pup_ro2/root/.jwm-tray) algo que me pareció extraño fue que Gtksee funcionó correctamente al cambiar entre pantalla completa y modo ventana Confused (normalmente falla con este mensaje: "segmentation fault" desde que que actualizaron gtk en Puppy 2). Guardé los cambios en el mismo CD (multisesión) al reiniciar. Apagué la PC desconecté el disco duro (sin nungún motivo en especial, solo es una comprobación) y arranqué el sistema desde el Live-CD ya parchado en castellano, en ese momento me preocupó el consumo de RAM, yo temía que Puppy intentara cargar el sfs de controladores(zdrv_213.sfs) en RAM pero no lo hizo Smile solo mostró un mensaje advirtiendo que no encontró partición de intercambio(swap) y que no cargaría zdrv_213.sfs en RAM(todo eso en inglés, yo no modifiqué ese script ni otros scripts vitales del sistema), ok entonces apareció el escritorio(no pude evitar la tentación de personalizarlo, así que lo hice Wink ) grabé algunos documentos con Abiword, Gnumeric, Geany, Inkscape y mtPaint reinicié el sistema guardando la sesión en el CD. Hasta entonces sin ningún problema Cool

Después arranqué otras 3 PC's con el mismo CD sin problemas(guardando sesión y reiniciando). Ahora, con USB aún no intento nada Rolling Eyes.

_________________

Back to top
View user's profile Send private message 
apendragon

Joined: 15 Jan 2007
Posts: 56

PostPosted: Mon 29 Jan 2007, 21:14    Post subject: problemas con versión 2.13 en castellano  

Hola, Wow.

En primer lugar, gracias por tomarte la molestia de atenderme.

He hecho pruebas de salvado de datos de puppy 2,13 en otra memoria USB (un reproductor MP3 de 121 megas) y funciona perfectamente. En la memoria flash USB anterior (de 512 megas) empezaba a dar problemas de lectura justo si previamente había hecho la conversión a castellano y había salvado los archivos en la memoria USB.

No consigo entender el porqué ocurre esto, pero al menos puedo usar el 2,13 en español de forma totalmente portátil. Aunque me gustaría poder usar una memoria más grande.

En cuanto a los discos regrabables, consigo hacer la grabación, pero cuando reinicio el ordenador con el disco dentro, descubro que ya no arranca puppy con él. Próximamente haré una prueba en otro equipo, pero me temo que puede ser un problema de no entender correctamente las instrucciones a seguir.

Gracias de nuevo, Wow, por tu atención. os mandaré los resultados de mis pruebas próximamente.
Back to top
View user's profile Send private message 
caka

Joined: 07 Dec 2006
Posts: 202

PostPosted: Wed 31 Jan 2007, 15:18    Post subject:  

wow no me pude resistir a probar tu traducción; así que me baje la iso de Puppy 2.13 y me puse manos a la obra para instalar tu paquete.

Me ha gustado mucho, la única pega que le encontré es que se te olvido traducir lo de ocultar/mostrar archivos del explorador ROX:



Una chorrada que seguro que conocias. Lo dicho, una pasada la de cosas que se traducen con tu archivo pup.

Gracias.
Back to top
View user's profile Send private message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Wed 31 Jan 2007, 21:31    Post subject:  

caka wrote:
Me ha gustado mucho, la única pega que le encontré es que se te olvido traducir lo de ocultar/mostrar archivos del explorador ROX


La traducción de ROX la hizo Marcelo Ramos, eso según el código fuente de rox.
Code:
"PO-Revision-Date: 2004-10-16 14:45-0300\n"
"Last-Translator: Marcelo Ramos <mramos@montevideo.com.uy>\n"

Solo hice 2 ligeras modificaciones en el menu contextual. Originalmente la opción de "Abrir Con..." era "Enviar A..." pero eso es diferente en Puppy asi que cambié eso y también "Count" la traducción "Contar", sirve para abrir la ventana "Uso del Disco"/"Disk usage", que traduje como "Uso del Disco" por razones obvias("Contar" es un nombre poco intuitivo para mostrar el espacio que ocupa una carpeta/s o archivo/s).

El resto de programas que están en castellano muestra el nombre del traductor en la ventana de "Créditos" en "Acerca de".

Los archivos que traduje total o parcialmente están en /usr/local/Unofficial-langpack-es_0.1.2/resource/213-es.tar.bz2 (excepto los binarios de mtpaint y gtksee, que no necesitan ser editados). Si algun script o aplicación da problemas pueden restaurar la versión que viene en el CD/DVD de Puppy desde "/usr/local/Unofficial-langpack-es_0.1.2/resource/bak213-en.tar.bz2". Abren el archivo y descomprimen el script que necesiten hacia "/" (el directorio raiz).

_________________


Last edited by wow on Sun 04 Feb 2007, 20:14; edited 1 time in total
Back to top
View user's profile Send private message 
vicio1

Joined: 25 Jan 2007
Posts: 5

PostPosted: Thu 01 Feb 2007, 13:29    Post subject: felicitaciones  

a mi la verdad me gousto mucho como quedo el paquete el cierto que no todo absolutamente todo quedo traducido pero la mayor parte si
y con eso estoy conforme muchas gracias wow sigue haciendo este script que al paso que va muy pronto se tendra una traduccion 100% para el disfrute de todos los usuarios Razz
Back to top
View user's profile Send private message 
apendragon

Joined: 15 Jan 2007
Posts: 56

PostPosted: Fri 02 Feb 2007, 10:17    Post subject: resullto problema de grabado en USB con versión en español  

Hola. Como prometí, he hecho pruebas con otros equipos y parece ser que el problema era de la memoria USB. Respecto al grabado en disco he probado a remasterizarlo en un disco regrabable y el resultado me ha dejado muy satisfecho.

Gracias por todo.
Back to top
View user's profile Send private message 
Leo-Ko


Joined: 04 Feb 2007
Posts: 37
Location: Santiago de Chile

PostPosted: Sun 04 Feb 2007, 09:52    Post subject:  

Hola, gracias probe el pup para cambiar el idioma, esta muy buena la traduccion y todo, solo les queria contar que despues de instalarlo el comando xorgwizard deja de funcionar, me di cuenta cuando trate de cambiar la resolucion de la pantalla a 800x760 Sad , y realize los mismos pasos en dos computadores y estoy seguro que es por el pack para traducir lo que da el problema. Eso si quien lo use solo va a tener el problema si quiere cambiar la resolucion,si no necesitan cambiarla no ahi problema, el pup funciona perfecto en todo lo demas.

Estoy ocupando el puppy 2.13 instalado en el disco duro (ext3) en un p3 733, 128 ram.

Bueno es lo unico que no me funciono bien, de todas formas gracias por las ganas y el esfuerzo de hacer el pup.


Saludos


Wink
Back to top
View user's profile Send private message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Sun 04 Feb 2007, 20:08    Post subject:  

Leo-Ko wrote:
solo les queria contar que despues de instalarlo el comando xorgwizard deja de funcionar, me di cuenta cuando trate de cambiar la resolucion de la pantalla a 800x760


Para solucionarlo rapidamente abre este archivo: /usr/local/Unofficial-langpack-es_0.1.2/resource/bak213-en.tar.bz2 luego busca /usr/sbin/xorgwizard en la lista y extraes el script hacia /

Haciendo esto restablecerás "xorgwizard" que viene en el CD de puppy, es decir el que no está traducido. Gracias por reportar el error, lo verificaré al llegar a casa.

_________________

Back to top
View user's profile Send private message 
Leo-Ko


Joined: 04 Feb 2007
Posts: 37
Location: Santiago de Chile

PostPosted: Sun 04 Feb 2007, 20:19    Post subject:  

Ok les gracias Smile
_________________

Back to top
View user's profile Send private message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Mon 05 Feb 2007, 19:31    Post subject:  

Aqui está el parche para solucionar el problema de "xorgwizard":
Parche 05Feb06 [langpack-es-213-fix-05feb07.pup]

El error estaba en la línea 84 del script, eliminé esa línea accidentalmente durante la traducción.

_________________

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [29 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1114s ][ Queries: 13 (0.0054s) ][ GZIP on ]