Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 20 Oct 2017, 17:24
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Teamviewer 11
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [29 Posts]   Goto page: Previous 1, 2
Author Message
cimarron


Joined: 30 May 2013
Posts: 293

PostPosted: Wed 25 Nov 2015, 12:13    Post subject:  

Teamviewer 11 beta is available for testing. I put together an SFS if anyone wants to try it (it's basically the tar.xz version with a menu entry added):

[Downloads in first post]

It worked fine in my initial tests, and was able to keep all my settings from version 10. Much faster (also significantly larger). More info here: https://www.teamviewer.com/en/download/currentversion.aspx

Last edited by cimarron on Thu 17 Dec 2015, 10:17; edited 1 time in total
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 360

PostPosted: Sat 28 Nov 2015, 19:57    Post subject: Replaced wine 1.6 with wine 1.7 in teamviewer  

I found that the official TeamViewer packages include wine 1.6 libs while Puli supports wine 1.7.21.

To mitigate this, I assembled teamviewer-11w17.pet with wine 1.7.21 modules.

Tested successfully in Puli - both in "standalone mode" and also when wine 1.7.21 package is co-installed. Probably work in other puppies, too.

Uploaded to www.smokey01.com/gjuhasz/packages

The teamviewer-10w17.pet and wine_puli_wdt-1.7.21.pet packages are available at the same URL


See Puli at http://murga-linux.com/puppy/viewtopic.php?t=96964


Have fun!

Regards,

gjuhasz
Back to top
View user's profile Send private message 
cimarron


Joined: 30 May 2013
Posts: 293

PostPosted: Sat 28 Nov 2015, 23:01    Post subject:  

That's interesting. Do the wine components included in Teamviewer (which are all located in /opt/teamviewer) interact with any other wine components that might be installed in the system?

It looks pretty self-contained to me. But I don't have wine installed separately.
Back to top
View user's profile Send private message 
tlchost

Joined: 05 Aug 2007
Posts: 2050
Location: Baltimore, Maryland USA

PostPosted: Sun 29 Nov 2015, 06:32    Post subject:  

cimarron wrote:
That's interesting. Do the wine components included in Teamviewer (which are all located in /opt/teamviewer) interact with any other wine components that might be installed in the system?


I am using wine 1,41 and find the wine components in the teamviewer sfs
conflict with the ones on my system...so I replaced the ones in teamviewer with the ones in wine 1.41

Does the 11 teamviewer communicate with the 10 version...in the past, one needed to update all the teamviewers on different systems to match.
Back to top
View user's profile Send private message Visit poster's website 
cimarron


Joined: 30 May 2013
Posts: 293

PostPosted: Sun 29 Nov 2015, 09:34    Post subject:  

In my experience, newer versions of Teamviewer can run a remote computer with an older version of Teamviewer on it, but not the other way around.

I was able to use Teamviewer 11 on Puppy to operate a remote Windows computer with Teamviewer 10 (then updated that one remotely).
Back to top
View user's profile Send private message 
cimarron


Joined: 30 May 2013
Posts: 293

PostPosted: Mon 30 Nov 2015, 00:28    Post subject:  

Found this in another thread, posted by CatDude:
Quote:
To get around the clash of the different wine versions (with regard to TV10), i use a launcher script:
Code:
#!/bin/sh
export LD_LIBRARY_PATH="/opt/teamviewer/tv_bin/wine/lib"
cd /opt/teamviewer
./teamviewer

So I've updated my Teamviewer 11 SFS to use this launcher script (/usr/bin/teamviewer):
Code:
#!/bin/sh

export LD_LIBRARY_PATH="/opt/teamviewer/tv_bin/wine/lib"
cd /opt/teamviewer
./teamviewer

sleep 5
pkill -9 teamviewer

exit 0
It incorporates CatDudes code to prevent conflicts with installed wine components (in case they are a different version) and also kills any remaining Teamviewer processes when Teamviewer is closed. I noticed sometimes a process remains (in TV11, TVGuiSlave) that prevents unloading the SFS.

Seems to work. I'd appreciate anyone with wine installed (other than version 1.6) to test if this does indeed solve the conflict problem.

Last edited by cimarron on Tue 29 Mar 2016, 12:03; edited 4 times in total
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 931

PostPosted: Mon 30 Nov 2015, 18:00    Post subject:  

I didn't test your sfs, I'm using Fatdog64, but I did have a conflict, and following your method solved it. Thanks.
I have wine 1.8_rc1 installed and TV11. I download the TV archive, unpack it in a folder and run it directly from there. This is the script I use to start TV:
Code:

#!/bin/sh

here="$(readlink -f "${0%/*}")"
exec env LD_LIBRARY_PATH="${here}/tv_bin/wine/lib" "${here}/teamviewer"


_________________
Fatdog64-710|+Packages|Kodi|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
tlchost

Joined: 05 Aug 2007
Posts: 2050
Location: Baltimore, Maryland USA

PostPosted: Tue 01 Dec 2015, 19:21    Post subject:  

The updated teamviewer11 sfs does not load correctly in Tahr 6.02....it appears to load, but does not show up in /opt/

I am running a bootable usb with 16 gigs of memory.
Back to top
View user's profile Send private message Visit poster's website 
cimarron


Joined: 30 May 2013
Posts: 293

PostPosted: Tue 01 Dec 2015, 22:26    Post subject:  

Can anyone else confirm the problem loading the Teamviewer 11 SFS? It loads fine in Precise.

EDIT: I just downloaded Tahr 6.0.2 and tried it and the SFS loaded and ran properly. Are you maybe using a savefile in which you previously deleted the Teamviewer directory from /opt? You could try booting without using a savefile then loading the SFS to test if the savefile is the problem.
Back to top
View user's profile Send private message 
tlchost

Joined: 05 Aug 2007
Posts: 2050
Location: Baltimore, Maryland USA

PostPosted: Wed 02 Dec 2015, 07:38    Post subject:  

cimarron wrote:
Can anyone else confirm the problem loading the Teamviewer 11 SFS? It loads fine in Precise.

EDIT: I just downloaded Tahr 6.0.2 and tried it and the SFS loaded and ran properly. Are you maybe using a savefile in which you previously deleted the Teamviewer directory from /opt? You could try booting without using a savefile then loading the SFS to test if the savefile is the problem.


What version of Wine did you install for your test?
Back to top
View user's profile Send private message Visit poster's website 
cimarron


Joined: 30 May 2013
Posts: 293

PostPosted: Wed 02 Dec 2015, 09:27    Post subject:  

I didn't install wine on Tahr. I was just testing if the SFS loaded properly. The startup script in the SFS should make it use the wine 1.6 included in Teamviewer (instead of using any wine libraries already installed in your system).


EDIT: I installed Wine 1.4.1 as a test, and Teamviewer would not start without the new startup script above (apparently due to the Wine conflict). But when I used the startup script, Teamviewer started successfully. So it seems the new SFS does avoid Wine version conflicts.
Back to top
View user's profile Send private message 
cimarron


Joined: 30 May 2013
Posts: 293

PostPosted: Thu 03 Dec 2015, 17:59    Post subject:  

Teamviewer 11 is out of beta now. Updated SFS and .pet in first post.
Last edited by cimarron on Thu 17 Dec 2015, 10:14; edited 1 time in total
Back to top
View user's profile Send private message 
cimarron


Joined: 30 May 2013
Posts: 293

PostPosted: Thu 17 Dec 2015, 10:13    Post subject:  

Teamviewer 11 SFS updated to version 11.0.53191 in first post.
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 3041
Location: King's Lynn, UK.

PostPosted: Thu 27 Oct 2016, 12:13    Post subject:  

Hi, Cimarron.

Thank you very much for the Teamviewer 11 SFS. It's enabled me to update from Teamviewer 9, which I've been using for almost 2 years now.

I've tried updating with other people's packages, but they always fail to actually work; possibly because I always run WINE in all my PUPS. This one, however, loads and runs first time, without hassle.

Running in Tahr 6.05. Precise 5.7.1, Slacko 5.7.0, Lucid 5.2.8.7, ETP's Chromebook Pup (v.1).....and rg66's X-Slacko 2.3.2.

Cheers!


Mike. Wink

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 2 [29 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0521s ][ Queries: 14 (0.0092s) ][ GZIP on ]