Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 26 May 2017, 13:00
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to use Brother MFC-L2680W in Tahr? SOLVED
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [25 Posts]   Goto page: Previous 1, 2
Author Message
perdido


Joined: 09 Dec 2013
Posts: 472
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Wed 07 Dec 2016, 23:25    Post subject:  

J_D_ wrote:
Maybe this will help. When I open the console to enter the cupswrapper, I type,
debbi cupswrappermfcl2680w-3.2.0-1.i386.deb


How about this

debbi mfcl2680wcupswrapper-3.2.0-1.i386.deb

_________________
.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 107
Location: Indiana

PostPosted: Wed 07 Dec 2016, 23:56    Post subject:  

Will try. I wifsh I knew what I did last night . I also wish I understood the error message.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 107
Location: Indiana

PostPosted: Thu 08 Dec 2016, 00:00    Post subject:  

File not found.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 472
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Thu 08 Dec 2016, 00:20    Post subject:  

You've got a mail (PM)

Easier

_________________
.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 107
Location: Indiana

PostPosted: Thu 08 Dec 2016, 12:15    Post subject:  

Booted from the flah drive and the install went pretty easy. No error messages. Went to CUPS and did the set up. CUPS sees the printer when It scans for printers but when I tell it to print a test page it is unable to communicate with the printer.
I did print from Windows to be sure that still worked.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 472
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Thu 08 Dec 2016, 20:19    Post subject:  

J_D_ wrote:
Booted from the flah drive and the install went pretty easy. No error messages. Went to CUPS and did the set up.
CUPS sees the printer when It scans for printers but when I tell it to print a test page it is unable to communicate with the printer.
I did print from Windows to be sure that still worked.


The printer is now working. Smile

To document what you have done then with Brother MFC-L2680W printer to get it to work.

1. Fresh install of puppy tahr 6.05 booting from USB
2. Connected printer to wireless
3. Connected computer to wireless.
4. Followed Brother install instructions from rscn51
5. Sucessfully installed the debbi 1.2pet from the link listed in step 4 above, the debbi pet is available from the bottom of the first post in the link listed above, it is not already in puppy.
5. Installed mfcl2680wcupswrapper-3.2.0-1.i386.deb with debbi
6. Installed mfcl2680wlpr-3.2.0-1.i386.deb with debbi ,
J_D_ wrote:
You my be able to ignore the following error message after entering the downloaded packages in Terminal.
Code:
   
n: failed to create symbolic link ‘/usr/share/cups/model/brother-MFCL2680-cups-en.ppd’: File exists
Post- install script completed!
Done   


7.CUPS is now seeing the wireless printer
J_D_ wrote:


When trying to print test page received the following error
Code:
   
Unable to locate   


This was due to puppy not knowing the IP of the wireless printer.
CUPS had entered, BRW441CA84A019E as the http address of the printer.
I went to my Belkin router control page searching. On the LAN-DHCP client list I found the IP address AND the printer was listed correctly. This finally got it going.
I entered the correct IP address in CUPS under manage printers, rebooted the printer and the Dell laptop and the printed the CUPS test page.



To sum it up for someone else, if you follow the instructions from rscn51 and receive the "Unable to find" error when trying to print,
and you have the Brother printer installed as a wireless printer (Something like Connection:lpd://BRW70188BEF51A3/BINARY_P1 )
then you need to supply the printer IP to CUPS so puppy can find the printer.
_________________

.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 107
Location: Indiana

PostPosted: Fri 09 Dec 2016, 22:12    Post subject:  

Finally printing. What perdido failed to post was how many PMs he sent helping me with this for the last 5 days.
Big THANKS to him.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 107
Location: Indiana

PostPosted: Wed 14 Dec 2016, 12:05    Post subject:  

Just an update. Did no printing the last 3 or 4 days, today it would not print even though Windows would. After a few tries, I rebooted the router and it printed fine. I totally do not understand this as the same router was getting internet, no problem.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 472
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Wed 14 Dec 2016, 16:26    Post subject:  

Did you get "Unable to Locate" as the error or different?

The router may have changed the IP of the printer.

Check out the last part of earl's post where he ran into that and the following discussion with rscn51.

http://murga-linux.com/puppy/viewtopic.php?t=42533&start=76

.

_________________
.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 107
Location: Indiana

PostPosted: Wed 14 Dec 2016, 17:13    Post subject:  

CUPS kept trying to connect with the printer. I tried going to management and going through the settings. Ip was not changed. I rebooted the laptop and the printer to no avail. I finally just rebooted the router. Not even a problem to me. Easy fix. Odd that it printed fine for a few days and then stopped. Anyway, if someone else has this problem they may just try the router reboot, first.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [25 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.2598s ][ Queries: 14 (0.0643s) ][ GZIP on ]