Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 23 Oct 2017, 00:33
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
configure: error: C preprocessor /lib/cpp fails sanity check
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [19 Posts]   Goto page: Previous 1, 2
Author Message
belham2

Joined: 15 Aug 2016
Posts: 1182

PostPosted: Tue 17 Jan 2017, 19:46    Post subject:  

Keef wrote:
Brightness definitely works, and the temp settings respond too. Preview does the business as well.


Keef,

Jesus, instead of saying it works, post what redshift you are using. P.S. I spoke to the developer...it does not work on LxPupSc latest releases. Period. Whatever your using must be something custom, because nothing that is existing in Slackware, Slackbuilds, github or on Puppy boards or any of the other redhsift builds (on the net anywhere) work. They've all been tested. I am not trying to pick an argument, but this has been thoroughly vetted and tested. Post some facts, not gibberish. If you have somehow miraculously coded your own redshift, please do tell, and please post the link. Don't just say you have an "old .pet lying" around. All the old .pets and current new .pets from the last few years in existence have been tested by more than a handful of people--the developer (Jon) included---trying to get them to work on LxPupSc! Conclusion, through mutliple testing---it cannot work because LxPupSC doesn't have the ability (because of what is missing out of the kernel and drivers) to set gamma settings, or brightness settings, or the whole frigging gambit of what redshift is coded for. Post something, anything, then we'll talk, and I'll zip it off to Jon and see what he says. Unreal Rolling Eyes
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2936
Location: Worcestershire, UK

PostPosted: Wed 18 Jan 2017, 03:12    Post subject:  

belham2 wrote:
I downloaded both of Micko's Slacko 32 (his latest 6.9.6.4) and redshift compiled easily & ran well. Then I took what Micko's compiled and transferred it all to Peebee's latest 32-bit Slacko (LxPupSc.17.01.23R), and it still would not run.

The thing to do therefore, is to replace the LxPupSc kernel with the one from Slacko32-6.9.6.4 (just replace the vmlinuz and zdrv files - renaming the zdrv appropriately) and then try the redshift build you have made.

The woof-ce builds of LxPupSc and Slacko32-6.9.6.4 are almost identical so it must be a kernel issue.....I would think Confused

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 3243
Location: Ontario Canada

PostPosted: Wed 18 Jan 2017, 08:37    Post subject:  

I think I got it.

I compiled the newest source code (redshift-1.11.tar.xz) and made a pet
of it.
After installing the pet I click on run in the puppy menu and enter
redshift -l 00.0:-00.00 -t 5500K:3500K (put the latitube and longitude
of your location in place of the zeros)

It's showing up in Task Manager along with a noticable change in the
screen.
redshift-1.11-i686.pet
Description 
pet

 Download 
Filename  redshift-1.11-i686.pet 
Filesize  97.97 KB 
Downloaded  55 Time(s) 
taskmanager.jpg
 Description   
 Filesize   59.8 KB
 Viewed   115 Time(s)

taskmanager.jpg

Back to top
View user's profile Send private message 
belham2

Joined: 15 Aug 2016
Posts: 1182

PostPosted: Thu 19 Jan 2017, 05:45    Post subject:  

Billtoo wrote:
I think I got it.

I compiled the newest source code (redshift-1.11.tar.xz) and made a pet
of it.
After installing the pet I click on run in the puppy menu and enter
redshift -l 00.0:-00.00 -t 5500K:3500K (put the latitube and longitude
of your location in place of the zeros)

It's showing up in Task Manager along with a noticable change in the
screen.



Bill,

Sent you a PM. I (and two others) tried repeatedly to install your .pet and get it to work in LxPupSc. It would install, but just like our compiling creations, would not run. This was tried on both Intel and AMD motherboards, where redshift runs in nearly all other pups (I personally have about 14 pup and pup-related OSes I am constantly testing). I know Keef and you have it working, but this is now a complete mystery how it is failing on not only several of my machines (5 to be exact), but it also failed ro run on others machines.

Thank you to Keef and you for keeping this alive (seriously appreciate it because I do really like Peebee's creations). And thank you for compiling your version. This has me totally stumped...especially when I've compiled and ran redshift so much, for so long, and many other machines, and never had a problem on one of my setups. But knowing my two other friends, with completely different setups, also again failed with redshift, tells me something is out of my hands here.

Thanks again, guys! Wink
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [19 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0739s ][ Queries: 15 (0.0130s) ][ GZIP on ]