Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 15 Dec 2017, 08:23
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Loopback in Alsamixer
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
riedzig

Joined: 01 Oct 2015
Posts: 25

PostPosted: Sat 28 Jan 2017, 04:32    Post subject:  Loopback in Alsamixer  

With my MB GA-M68MT-D3P I have always had troubles with niose in the sound (only in Linux). Later I found a perfect solution by disabling Loopback in Alsamixer. But this option is in Alsamixer present only in the latest Puppy derivates(Xenial, Slacko), not in Tahrpup etc. Can in these cases the Loopback be disabled somewhere in the configuration files? Updating alsa-utils or transfer /etc/asound.state from another distro does not produce a result.
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 25 Aug 2017, 07:48    Post subject: Loopback, what is that ?  

Loopback, what is that ?
_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
bigpup


Joined: 11 Oct 2009
Posts: 9681
Location: Charleston S.C. USA

PostPosted: Fri 25 Aug 2017, 12:18    Post subject:  

The options offered in Retrovol are dependent on the driver being used and the Linux kernel being used.
The Linux kernel provides the driver.

Basically, change the Linux kernel, used in Tahrpup, to a newer kernel, and the option should be offered.

This worked for me to get loopback option in retrovol in Tahrpup64 6.0.6.
Also, made my sound card work better.

Note:
A small chance this could make something else not work, but it would usually happen on really, really old hardware.

Here is how to change the kernel:
In a console enter:
Code:
change_kernels

In the change_kernels window click on kernels button.

That will open the browser to the repository for kernels used in Puppies.
Select one of the kernels being used by Xenialpup.
Make sure to get the correct 32bit or 64bit that matches the Tahrpup bit version you are using.
Download the .tar.bz2 kernel package to some easy to find location.
Now you have to unpack the .tar.bz2 kernel package.
In Rox file manager navigate to the download location.
Left click on the .tar.bz2 kernel package.
XArchive should open showing the contents of package.
Click on select all.
Click on extract.
Click on OK.
Now should have two new files in the location of the .tar.bz2 package.
a vmlinuz file.
kernel-modules.sfs-XXXXX (or similar) or could be zdrv sfs.

Now back at the change_kernels window.
Enter these files in the entry boxes.
vmlinuz file for the first entry box.
kernel-modules.sfs-XXXXX or zdrv sfs for 2nd box.
Hit OK.

The program should change the kernel with no errors.

If all went correctly.

Reboot now using the new kernel.

Note:
Anything that is compiled for a specific kernel will have to be recompiled.
Example:
A manufacturers graphics driver is kernel specific.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Sat 26 Aug 2017, 17:09    Post subject: if Puppy could improve audio quality
Subject description: that is a great step forward..
 

merci Bigpup. if Puppy could improve audio quality compared to Windows, that is a great step forward..
_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Peterm321

Joined: 29 Jan 2009
Posts: 386

PostPosted: Mon 28 Aug 2017, 14:33    Post subject:  

Apparently Tahr now has the Loopback Mixing option:

Code:
amixer  set 'Loopback Mixing' Enabled


Enables it,

Code:
amixer  set 'Loopback Mixing' Disabled


Disables it.

Code:
amixer
by itself to see sound setting contents.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0540s ][ Queries: 14 (0.0080s) ][ GZIP on ]