Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 07 Dec 2019, 00:05
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
josephjp2424's pupjibaro jessie synaptic BETA 32-bit
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
mikeslr


Joined: 16 Jun 2008
Posts: 3540
Location: 500 seconds from Sol

PostPosted: Tue 24 Jan 2017, 21:19    Post subject:  josephjp2424's pupjibaro jessie synaptic BETA 32-bit
Subject description: Can install via PPM, Synaptic & use SFSes
 

Hi All,

This is a link to my initial impressions about josephjp2424's pupjibaro jessie synaptic BETA, where you'll also find a link to the ISO. http://murga-linux.com/puppy/viewtopic.php?p=940724#940724. Edited as I now think a specific thread about this Pup would be appropriate.

As indicated by the subtitle, this version of pupjibaro can install pets via Puppy Package Manager (or otherwise) and application-debs via Synaptic. Among its other capabilities, It can also uses SFSes, a better procedure so as not to confuse synaptic.

I thought it worth specifically bringing to your attention. I'm also pretty sure that josephjp2424 would welcome your exploration and feedback.

Edit: After reading the above linked post, unless and until josephjp2424 starts his own thread, feel free to discuss pupjibaro jessie synaptic here, as I did in the following thread.

mikesLr

Last edited by mikeslr on Wed 25 Jan 2017, 18:00; edited 2 times in total
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 3540
Location: 500 seconds from Sol

PostPosted: Wed 25 Jan 2017, 17:55    Post subject: Further evaluation of pupjibaro synaptic  

Hi all,

Decided that a thread on Projects would be a useful place for posting information about it. Have edited the first post accordingly.

As previously mentioned, josephjp242 classified pupjibaro synaptic as Beta. I have not completely explored its faults and limitations. There are some builtin applications I never use, and some procedures –like printing and networking-- I don’t. So, I wouldn’t feel competent to test those. The following consist of some “rough-edges” I’ve discovered while customizing it to my liking.

Although it is possible to register wine-portable [Right-Click portable-wine folder on /mnt/home, select “Look Inside”, Left-Click Register: Puppy Package Manager installs it] the links between Wine-portable and pupjibaro’s operating system do not survive a shutdown/reboot; with added complications. /root/.packages and Puppy Package Manager>Uninstall both show that wine-portable has been installed. But, it no longer functions. Until someone with greater knowledge devises a better solution, I’ve come up with this work around:

1. Open file manager to /root/.packages and delete the reference to Wine-portable. Execute a Save to your SaveFile/Folder. [This may not be necessary. However, in general Puppy Package Manager doesn’t permit the installation of an application already installed, and it looks to “packages” for what is installed].
2. Right-click an empty space in /root/Startup, select New>Script. Name it register-wine. Open register-wine in a text editor, and press enter at the end of the line which reads: “#!/bin/sh”. On the new line that creates, enter the following code:

exec /mnt/home/wine-portable/Register "$@"

Save the changed bash-script and execute a SAVE to your SaveFile/Folder.

The above assumes your wine-portable folder is named wine-portable. Accordingly, make any necessary adjustments to the above.

What that does is register Wine-portable each time at bootup. There’s an annoying Notice that that’s taking place on restart and bootup. However, Puppy Package Manager does not recognize it as an “installed pet”, no package reference is created @ /root/.packages and, consequently, no obstacle is created to that operation being performed each time pupjibaro boots or is X-restarted.

Rox does not have a bookmarking function by default. It can be added via Right-click, Options.

Edit. I created a new SaveFile and didn't experience the following problem. Not sure what I did differently. On the initial boot into pupjibaro, the second lxpanel appears at the top of the screen. My previous experience with lxpanel is that you could Right-Click it and change Preferences to Left-Center and make other customizations. Under pupjibaro, those changes do not survive a reboot/shutdown. The work-around is to Right-Click the panel, Select New Panel and customize the new panel to your hearts content. Then delete the original second panel. Remember to Save and your new second panel will be both present and further customizable on reboot.

Do not restart-X if you think some operation is taking too long. That will clear all lxpanels of all applications included on their Application Launch Bars.

However, I’m not sure where lxpanel looks to include applications on launch bars. It appears NOT to be /usr/share/applications as “desktops” files are there for “default Wordprocessor”, “Default Spreadsheet”, etc which contain the argument “NoDisplay=true”. That argument prevents them from appearing on the Start Menu, but does not prevent them from being specified in a launcher. As a consequence, you can not include launchers for default applications rather than specific applications. The former is preferable, especially if your default applications are loaded via SFS-load rather than installed. Loading via SFS enables you to quickly upgrade an application and specify it as the default, and then open it via a panel’s icon. Without that capability, the launcher on the panel will still point to a now non-existent application, either preventing the panel from opening at all, or requiring that the previous launcher be deleted and a new launcher added. And by specifying the default icons for default applications, it makes it easier to have a display of launchers on an lxpanel consistent with the rest of the desktop display.

Left-Clicking a drive icon mounts the drive, but doesn’t open it. A second click is necessary. But Menu>Desktop>Desktop Preferences>Check Open Folders from desktop in New Window solves that. However, I'm not sure that was such procedure's purpose.

Menu>Setup shows both Default Application Chooser and PuppyApps Default Application Chooser. Booth are functional, but the latter offers more categories of applications. It may be a “woof thing” which generates both. In Tahrpup, the one named "Default-Applications Chooser" on pupjibaro's Menu>Setup>Menu Manager is turned off. I did the same.

I’m not sure I agree with all the decisions about what applications should appear on the Start Menu. But, that’s a matter of personal preference.

Although it’s built in, pfind didn’t appear on menu. IIRC, to get it to appear I had to edit its desktop file to show the same category argument used in rox-file-manager. I may have also included an ending semi-colon (Wink. Openbox usually insists on that.

As I mentioned, I wanted to remove Gimp 4.5 and replace it with a newer version. “Gimp” didn’t appear among the applications removable via Remove Builtin. There was an application named “gmp” – no “i”-- but I wasn’t sure if that was some other application.

Perhaps more later.

mikesLr
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 3540
Location: 500 seconds from Sol

PostPosted: Sat 11 Feb 2017, 20:24    Post subject: pupjibaro on an Asus 701sd
Subject description: 512 Mb RAM
 

Hi All,

Actually, I'm was rather surprised. I got the Asus 701sd several years ago for traveling and did a frugal install of Saluki to its 8 Gb internal "hard-drive". Now, when traveling, I can get bye with a LgGPad 7" tablet. Stumbling upon the forlorn eeepc, I wondered if it could handle a more recent OS.

It booted into pupjibaro from a USB-Key without incident [except trying to remember how to boot the Asus from a Key Embarassed }. I had to considerably reduce the number of pixels used by the launchers in the top panel and set it to hide unless moused-over to recover screen space. Before doing that, however, I couldn't change the setting on the First Run dialog. Couldn't figure out how to minimize it so as to click the OK button which was below the screen. But configurations via the Menu worked and I got to the internet: a opera 12.16 @ /mnt/home.

Pupjibaro worked comparative well considering that the eeepc only has 512 Mbs of RAM. I would think Tahrpup, on which pupjibaro is based, would do as well. Has something changed in how efficiently Puppies utilize RAM? Saluki, based on Racy, was published with the recommendation of 512 Mbs. More recent Puppies use newer graphics libraries which are larger. So I figured 512 Mbs wouldn't provide satisfactory performance.

I'll play around with it from the Key before deciding whether or not to replace Saluki. A modern web-browser would be nice. Perhaps (firefox) Light, http://murga-linux.com/puppy/viewtopic.php?p=939929#939929. And the 47 MB KDE Office that pelo just discovered. http://murga-linux.com/puppy/viewtopic.php?p=865105#865105. If not, WPS Office does a pretty good job. http://www.murga-linux.com/puppy/viewtopic.php?p=879738#879738.

Well, you can't demand miracles from a 10 year old minimal-resources netbook. But it's nice to know that it can still be useful.

Edit: Although it ran well from the USB-key, like Tahrpup and even Carolina Vanguard, I couldn't get pupjibaro to boot to desktop once it was on the 701sd's "ssd" drive. No idea why.

mikesLr
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 22 Feb 2017, 10:54    Post subject: josejp24 makes tries  

Saluki and Carolina are still so nice Puppies, succeeding with applications that other puppies fail to to install..
Pupjibaro Jessie is going the same way, josejp24 makes tries, sometimes wrong, sometimes efficient. What is sure is that he tries to go ahead. I am dowloading the new version of Jessie. My version at work is dated 2014..
I am glad that users as Musher0 and mikeslr taste (with an 'a') josejp24 puppies. Perhaps he would become a new Pemasu Exclamation
Josejp24 takes in account his usarios, in spite of he is occupied a lot elsewhere, outside the english forum
"mpaint , se elimino gimp 2.4.
Pmusic.
Light. . ( recomendado por Pelo y mikeslr), me gusto ese navegador.
quickpet jessie.
LXAppearance 0.6.3
LXPanel 0.9.3
notificaciones.
youtube-dl gui.
Take a Shot!. , y mas librerías.
" Muchas gracias, senor (i miss the "tilde" in my keyboard)
synaptic.png
Description  Out old Jessies, only two kept in my puppytheque
png

 Download 
Filename  synaptic.png 
Filesize  78.34 KB 
Downloaded  224 Time(s) 
Menu.jpg
 Description   Joejp24 re-introduces MTpaint as defaut in his newest Jessie
 Filesize   61.18 KB
 Viewed   667 Time(s)

Menu.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
oui

Joined: 20 May 2005
Posts: 3499
Location: near Woof (Germany) :-) - 3 PC's: DELL SX280 750 MB Pentium4, Acer emachines 2 GB AMD64. DELL XPS15

PostPosted: Fri 24 Feb 2017, 16:40    Post subject:  

it is probably one of the best puppy's...

really!

and it is a Puppy, not a Quirky (not be afraid: you need no own partition, no usb memory, nothing...)

in the actual times, it is more and more rare...

why PCmanFM?

what is light browser?

(it works! I don't know what it is, but... the most important thing: It works Rolling Eyes Idea !!!!)

what doesn't work?

- rox, sorry (yes, I know, is very bad Mad ...)

- the old flashplayer from oldest Puppy (9740 kB), so beautiful so small does not work as usual any more (you can't find your video in /tmp as usual anymore: Debian did make an important concession to Adobe Rolling Eyes Wink and block it for Adobe Wink Idea , I would say a case of prostitution for capital Mad , not evident from Debian ...)

- it seems not possible to install ibus and make it will work: it is installed, the icons appear, but nothing to do...

really magic is the use of synaptic. remaster? hm, I would say, they are better environment for that (LazY remaster suite and other). seriously: it is a bad point as you can using synaptic easily create a very different system for you self!

good luck: I recommend it warmst!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0827s ][ Queries: 13 (0.0119s) ][ GZIP on ]