Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 17 Nov 2017, 19:32
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Take a Shot! - yet another screenshot utility...
Post new topic   Reply to topic View previous topic :: View next topic
Page 9 of 9 [127 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9
Author Message
SFR


Joined: 26 Oct 2011
Posts: 1640

PostPosted: Thu 16 Feb 2017, 15:01    Post subject:  

mavrothal wrote:
I do not know about "any" but in slacko and xenial 32 and 64 bit versions works just fine.

Thanks for confirmation!

Quote:
Just unpack make it executable and copy Wink

Oh yeah, corrected.

Quote:
(the static file is small but still 10+ times bigger that the dynamic one so puppy builders might consider compiling it)

By all means, that would be the right way of doing it.
The static one is only for testing purposes, since it should work everywhere.

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11133
Location: Gatineau (Qc), Canada

PostPosted: Thu 16 Feb 2017, 15:05    Post subject:  

SFR,

Your message overshadowed mine (bottom of previous page)!

I attached a xrectsel for 32-bits pet archive to it, in case it is useful.
Works fine with your TAS-1.13 (please see attached screen shot).

IHTH.
region-select-with-xrectsel-in-TAS.jpg
 Description   
 Filesize   14.15 KB
 Viewed   169 Time(s)

region-select-with-xrectsel-in-TAS.jpg


_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2307
Location: Queensland

PostPosted: Thu 16 Feb 2017, 16:18    Post subject:  

xrectsel compiled in Tahr 32bit, source from git version 0.3.2
xrectsel-0.3.2.pet
Description 
pet

 Download 
Filename  xrectsel-0.3.2.pet 
Filesize  3.51 KB 
Downloaded  42 Time(s) 

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11133
Location: Gatineau (Qc), Canada

PostPosted: Thu 16 Feb 2017, 16:37    Post subject:  

You've beat me by 1,8 Kb! Smile
_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2307
Location: Queensland

PostPosted: Thu 16 Feb 2017, 16:51    Post subject:  

musher0 wrote:
You've beat me by 1,8 Kb! Smile


Code:
strip --strip-unneeded xrectsel


That took mine from 30.2kB to 9.7kB Very Happy

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11133
Location: Gatineau (Qc), Canada

PostPosted: Thu 16 Feb 2017, 17:24    Post subject:  

Geoffrey wrote:
musher0 wrote:
You've beat me by 1,8 Kb! Smile


Code:
strip --strip-unneeded xrectsel


That took mine from 30.2kB to 9.7kB Very Happy

I know the trick, Geoffrey. Mine went from 27 Kb to 6.536 Kb. However
I did include a little doc directory at /usr/share/doc/xrectsel.

Besides, it's not what I'm talking about, but never mind. The important
thing is not your compilation or mine, but that TAS now has a tool which
enables users to do regional screen crops properly and easily on 32-bits.

I looked for --enable-static=no in the configure parameters and it wasn't
there. It didn't have an --enable-dynamic=something either, BTW. I
suppose it's not important to have those parms for such a small utility.

Also, what's the glibc version of the TahrPup you compiled xrectsel on?

BFN.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2307
Location: Queensland

PostPosted: Thu 16 Feb 2017, 17:56    Post subject:  

musher0 wrote:
what's the glibc version of the TahrPup you compiled xrectsel on?


Code:
root# ldd --version
ldd (Ubuntu EGLIBC 2.19-0ubuntu6.6) 2.19

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 9 of 9 [127 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0422s ][ Queries: 15 (0.0084s) ][ GZIP on ]