Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 21 Aug 2017, 04:51
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
OpenOrienteering_mapper.0.6.8.sfs for Tahr 6.0.6
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
rockedge


Joined: 11 Apr 2012
Posts: 374
Location: Connecticut, United States

PostPosted: Sat 11 Mar 2017, 00:35    Post subject:  OpenOrienteering_mapper.0.6.8.sfs for Tahr 6.0.6  

here is an SFS of OpenOrienteering_mapper.0.6.8
made in Tahr 6.0.6. A menu entry will be in Menu>Utility.

https://drive.google.com/open?id=0By2RUsFzFaMkOU1GMUh5LXVVQkk

More Info :
http://www.openorienteering.org/apps/mapper/
Back to top
View user's profile Send private message Visit poster's website 
rockedge


Joined: 11 Apr 2012
Posts: 374
Location: Connecticut, United States

PostPosted: Sat 11 Mar 2017, 13:34    Post subject:  

Tested with Tahr 6.0.5 successfully.
Back to top
View user's profile Send private message Visit poster's website 
davids45


Joined: 26 Nov 2006
Posts: 961
Location: Chatswood, NSW

PostPosted: Sat 11 Mar 2017, 19:53    Post subject: Sfs - downloaded for testing  

G'day rockedge,

Wow! That's quick - I'll see how it goes with my multitude of frugals after I do my full Pups the slow way (.deb installs, etc).

Hopefully, there won't be too many lib issues with older (kernel) Pups and with Slackos.

Thanks,

David S.
Back to top
View user's profile Send private message 
davids45


Joined: 26 Nov 2006
Posts: 961
Location: Chatswood, NSW

PostPosted: Sun 12 Mar 2017, 20:51    Post subject: Frugal Pups that run OpenOrienteering Mapper  

G'day rockedge,

It's turning out easier for me to check your sfs in my Frugals than trying this program with .deb files in my Full Pups - not surprisingly when considering frugal vs full installations.

Here's my list of Pups that, so far, for me, run your OpenOrienteering sfs:
XenialPups 7.00 to 7.04, 7.0.8.1
TahrPup-5.8.4
TahrPup-6.0.2
TahrPup-6.0CE
UnicornPup
PupJibaroJessie
PupJibaroJessieSynaptic
PuppEx479
Puppex401

SlackoPups seem to need the "xcb" fix (symlink /usr/lib/qt5/plugins/Platforms to /usr/bin) found by Semme then will run:
Slacko-700Beta
Slacko-6.3.0
Slacko-6.9.6.1


Unsuccessful Pups, usually ending with the 'can't find Qt platform plugin "xcb" ' problem or a 'libstdc++' mismatch after I installed/copied missing libs that terminal messages reported:
WheezyPup (pemasu's)
OVPrecisePup
PupJibaroWheezy

Some early Pups only have qt4 but copying qt5 from a working Pup's /usr/lib may work if the libstdc++ problem doesn't arise.


I'll update this list with any further successes but I do now have quite few options to run the Mapper program, so thanks for your contribution.

And I can symlink each Frugal's Mapper's profile (located in /.config/OpenOrienteering.org) back to the version stored on my data partition.
So whichever Mapper/Pup I start up with, I will have the latest files I've been working on displayed in the opening 'Recent maps' window.

David S.

Last edited by davids45 on Mon 13 Mar 2017, 18:30; edited 1 time in total
Back to top
View user's profile Send private message 
rockedge


Joined: 11 Apr 2012
Posts: 374
Location: Connecticut, United States

PostPosted: Mon 13 Mar 2017, 08:13    Post subject:  

I could build one for the Slacko series and a work around might be possible for Wheezy and the libstdc++ mismatch....is there a demand for these versions?

best regards,
Erik S
Back to top
View user's profile Send private message Visit poster's website 
davids45


Joined: 26 Nov 2006
Posts: 961
Location: Chatswood, NSW

PostPosted: Mon 13 Mar 2017, 18:49    Post subject:  

G'day rockedge (Erik),

Thanks for the offer.

I've found Semme's link to ask.ubunutu in the other OpenOrienteering thread provided an answer for me to fix the most recent Slackos. So I have updated my list in my earlier post in this thread.

I suspect older Pups in general will have the libstdc++ problem (GLIBC?).

However, I doubt there's any demand for getting OpenOrienteering to run in older Pups by a libstdc++ fix.
It's so easy to download and install a current Pup version if someone needed to run Mapper,
the wine-version runs in the older Pups I have, and
I'm not sure if there are many orienteers, and mappers in particular, who use Puppy - mainstream Linuxes and Windows would be the norm.
Or how many Puppy users are orienteers, even with a good smattering of Scandanavians (with names like Erik Wink ) on the forum.

So I'm saying only try it (the libstdc++ fix) if you want the "intellectual challenge".

Thanks again for your help,

David S.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0350s ][ Queries: 14 (0.0039s) ][ GZIP on ]