Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 23 Aug 2019, 01:14
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Woof CE Debian Stretch and Devuan Ascii Based Development
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 29 of 49 [723 Posts]   Goto page: Previous 1, 2, 3, ..., 27, 28, 29, 30, 31, ..., 47, 48, 49 Next
Author Message
ttuuxxx


Joined: 05 May 2007
Posts: 11226
Location: Ontario Canada,Sydney Australia

PostPosted: Wed 22 Mar 2017, 19:39    Post subject:  

Just download and check md5sum and both checkout fine for me.
Are you guys loading other sfs by accent? Remember its a different kernel, You might have to keep an eye when booting and see if anything is being loaded that shouldn't be. I've had it running for 12hrs since this morning before I went to work.
This is my Xerrs.log


X.Org X Server 1.19.1
Release Date: 2017-01-11
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.16.0-4-amd64 i686 Debian
Current Operating System: Linux puppypc16459 4.1.38 #1 SMP Thu Mar 9 23:23:15 +08 2017 i686
Kernel command line: pmedia=cd
Build Date: 20 January 2017 02:28:45AM
xorg-server 2:1.19.1-4 (https://www.debian.org/support)
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 22 18:29:48 2017
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
resize called 1280 1024
ls: cannot access '/root/.pup_event': No such file or directory
/usr/bin/jwm
cat: /root/.packages/user-installed-packages: No such file or directory
/usr/sbin/quicksetup: line 1068: 7129 Terminated /usr/lib/gtkdialog/box_splash -placement center -close never -fontsize large -icon_width 60 -icon /usr/share/pixmaps/puppy/puppy.svg -text "$WELCOMEMSG"
Playing Sparc Audio '/usr/share/audio/2barks.au' : Mu-Law, Rate 8000 Hz, Mono
EXIT="abort"

(palemoon-bin:10052): GLib-GIO-WARNING **: Failed to execute child process "update-desktop-database" (No such file or directory)
gFTP Warning: Skipping line 248 in config file: entropy_source
gFTP Warning: Skipping line 251 in config file: entropy_len
gFTP Warning: Skipping line 254 in config file: verify_ssl_peer

ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
musher0

Joined: 04 Jan 2009
Posts: 14271
Location: Gatineau (Qc), Canada

PostPosted: Wed 22 Mar 2017, 22:56    Post subject:  

Hi ttuuxxx.

I have no time for this, for hunting down those boot errors. My hunch is that
you are developing on sda9 and that you left a hard-code of it somewhere,
in the kernel or perhaps in the initrd.

Also, please provide a change log from now on, it will be greatly
appreciated. You're the senior Puppy guy on this thread, you know the drill.

Best regards.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 11226
Location: Ontario Canada,Sydney Australia

PostPosted: Wed 22 Mar 2017, 23:58    Post subject:  

zigbert wrote:
ttuuxxx
Tested briefly you latest build - looks good !

gtkdialog is a bit old, so some advanced options fail (like tree-headers in pMusic). Please update to gtkdialog 0.8.4

Thank you for your effort
Sigmund

Hi Sigmund If you still have it could you test this Gtkdialog and see if it works fine, your the king of gtldialog, So you probably would be the best tester Smile, I had to re-compile the gexttext that came with Stretch and install some unicode perl files to make it compile right. I'm just wondering it it works fine with the default debian gettext, or if I should use my package.
ttuuxxx
gtkdialog-0.8.4pre-svn514-i386.pet
Description 
pet

 Download 
Filename  gtkdialog-0.8.4pre-svn514-i386.pet 
Filesize  117.6 KB 
Downloaded  93 Time(s) 

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
ttuuxxx


Joined: 05 May 2007
Posts: 11226
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 23 Mar 2017, 00:01    Post subject:  

musher0 wrote:
Hi ttuuxxx.

I have no time for this, for hunting down those boot errors. My hunch is that
you are developing on sda9 and that you left a hard-code of it somewhere,
in the kernel or perhaps in the initrd.

Also, please provide a change log from now on, it will be greatly
appreciated. You're the senior Puppy guy on this thread, you know the drill.

Best regards.

Hi Musher I wish it was that easy Smile I have sda1,sda2,sda4 and sdc1(portable hard drive) and that's it, Nothing over 4
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
musher0

Joined: 04 Jan 2009
Posts: 14271
Location: Gatineau (Qc), Canada

PostPosted: Thu 23 Mar 2017, 01:17    Post subject:  

Then I'll have to give a mouthful to Linus T. !!! Laughing
_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 6587
Location: Valåmoen, Norway

PostPosted: Thu 23 Mar 2017, 04:05    Post subject:  

ttuuxxx
Your gtkdialog works fine (as far as I can see). I will use your build some more to see if I can catch any issues.

You are including the old jwmconfig tool. I don't think this one is maintained by anyone. It has been used as a base for the one available in Woof-CE (as a rootfs-package) - now called jwm_config. If you don't like this one, Radky offers an alternative with his JwmDesk.

pTheme is missing... - I guess you have your reasons... ?

Thank you
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3960
Location: Worcestershire, UK

PostPosted: Thu 23 Mar 2017, 05:11    Post subject:  

ttuuxxx wrote:
Next release is up, Smile
http://smokey01.com/ttuuxxx/WoofCe/stretch-7.0.0a1.iso <-- Iso
3d99450da65bde06c88e35133b05e1ab stretch-7.0.0a1.iso

Hi ttuuxxx

Scripts put into /root/Startup don't seem to be executed on startup?? My test script is attached - remove the false .gz and set executable before adding to /root/Startup and testing...

checkdeps -system
is a useful tool to run after each new build - it is showing some missing dependencies....

Some version naming of the iso's might be useful to avoid confusion....

Cheers
peebee
test-startup.sh.gz
Description 
gz

 Download 
Filename  test-startup.sh.gz 
Filesize  113 Bytes 
Downloaded  84 Time(s) 

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Thu 23 Mar 2017, 08:07    Post subject:  

peebee wrote:

Scripts put into /root/Startup don't seem to be executed on startup??


I had the same problem with a script created by arandr and placed in /root/startup.
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 14271
Location: Gatineau (Qc), Canada

PostPosted: Thu 23 Mar 2017, 10:23    Post subject:  

Yay!

Someone read the French thread for Stretch yesterday! Very Happy I had the same
problem with alternate WM's. And of course peebee's Pup is based on a
non-jwm WM, openbox.

Can it be because in the whole wide world, only jwm executes whatever is
in /root/.config/automate? Nah.

Here's what I have as a "bypass" for icewm.
Code:
#!/bin/sh
# ~/Startup/aa_if-icewm.sh
# Lance le panier d'icônes d'icewm et autres
# (c) ) musher0, Gatineau (Qc), Canada, 2017-03-20. GPL3.
####
if [ "`cat /etc/windowmanager`" = "icewm" ];then
   [ -f /usr/bin/icewmtray ] && /usr/bin/icewmtray &
   sleep 0.7s

# Ceux dans /root/.config/autostart/*.desktop
   [ "`pgrep netmon_wce`" = "" ] && `which netmon_wce` &

   [ "`pgrep flsynclient`" = "" ] && `which flsynclient` -s &

   if [ -f /root/.config/autostart/lxrandr-autostart.desktop ];then
      ExeC="`awk -F"'" '$1 ~ /Exec/ { print $2 }' /root/.config/autostart/lxrandr-autostart.desktop`"
      $ExeC
   fi
fi

Except for the icewmtray peculiarity, it's the same for all WM's when you
change WM's. They all need to go though something like this if they are
launched through restartwm, whereas such a script is not necessary on a
first, regular, boot.

restartwm is an incarnation of wmexit. The little "for-do-done" kill sub-
routine at the end of the wmexit script certainly needs to be much
abbreviated (and corrected) to
Code:
WndWMngR="`cat /etc/windowmanager`"
kill -s 9 `pgrep $WndWMngR`
Take a look at what's there presently and you may be tempted to say "Ouch".

I need to generalize my script above to any *.desktop file that would later
be added in the automate directory. For now, it's just an ok "ad hoc"
approach.

Another problem is that if we use a formula such as
Code:
[ "`pgrep netmon_wce`" = "" ] && `which netmon_wce` &
here, the Exec line in its *.desktop file in the autostart directory needs to
be the same in order to recognize if it's running and if so not re-run as a
double. We don't want two netmons (or of anything) in the tray. Because it
seems that at 1st boot the files at /root/.config/automate are used and
upon "restartw's" they are not. But we need to populate the icon tray of
our WM whatever way they are run from.

The "which" command may seem over-cautious, but the ex-factory
woof-CE Stretch originally came without a netmon. So we check.

Have fun !

BFN.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)

Last edited by musher0 on Thu 23 Mar 2017, 10:43; edited 1 time in total
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Thu 23 Mar 2017, 10:36    Post subject: Woof CE Debian Stretch and Devuan Ascii Based Development  

I'm running a manual frugal install of a woof-CE auto build, it's using
the latest 4.9.16 kernel.

System: Host: puppypc8455 Kernel: 4.9.16-4G i686 (32 bit) Desktop: Openbox 3.6.1 Distro: Dpup Stretch 7.0.0a1
Machine: Device: desktop Mobo: Acer model: Aspire X3950 serial: U02C120500059
BIOS: American Megatrends v: P01-A3 date: 05/05/2010
CPU: Dual core Intel Core i3 540 (-HT-MCP-) speed/max: 1200/3067 MHz
Graphics: Card: Intel Core Processor Integrated Graphics Controller
Display Server: X.org 1.19.2 driver: intel tty size: 140x44 Advanced Data: N/A for root
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
Drives: HDD Total Size: 508.1GB (6.7% used)
Info: Processes: 191 Uptime: 1:06 Memory: 169.9/2892.5MB Client: Shell (bash) inxi: 2.3.5

I installed applications with PPM + LibreOffice-5.31 + google_earth-7.1.1.1888.sfs

I'm using radky's FbBox-4.1

Like all recent woof-CE builds Vlc segfaults, Kodi does all the
multimedia stuff well.

************************************************************************

EDIT: Kernels get updated pretty often, 4.9.17 was out 4 days after
4.9.16, I compiled the new one with the kernel kit.

I did a new install to my HP desktop:

System: Host: puppypc12054 Kernel: 4.9.17-4G i686 (32 bit) Desktop: Openbox 3.6.1
Distro: Dpup Stretch 7.0.0a1
Machine: Device: desktop System: Hewlett-Packard product: HPE-410f serial: MXX0370KF3
Mobo: FOXCONN model: 2AB1 v: 1.00 BIOS: American Megatrends v: 6.02 date: 07/21/2010
CPU: Hexa core AMD Phenom II X6 1045T (-MCP-) speed/max: 800/2700 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Redwood PRO [Radeon HD 5550/5570/5630/6510/6610/7570]
Display Server: X.org 1.19.2 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
tty size: 135x41 Advanced Data: N/A for root
Network: Card-1: Ralink RT3090 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
Drives: HDD Total Size: 1000.2GB (2.0% used)
Info: Processes: 197 Uptime: 1:33 Memory: 213.9/3281.0MB Client: Shell (bash) inxi: 2.3.5
Screenshot2.jpg
 Description   
 Filesize   50.37 KB
 Viewed   302 Time(s)

Screenshot2.jpg

Screenshot.jpg
 Description   
 Filesize   31.68 KB
 Viewed   491 Time(s)

Screenshot.jpg


Last edited by Billtoo on Fri 24 Mar 2017, 10:53; edited 1 time in total
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 11226
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 23 Mar 2017, 11:02    Post subject:  

zigbert wrote:
ttuuxxx
Your gtkdialog works fine (as far as I can see). I will use your build some more to see if I can catch any issues.

You are including the old jwmconfig tool. I don't think this one is maintained by anyone. It has been used as a base for the one available in Woof-CE (as a rootfs-package) - now called jwm_config. If you don't like this one, Radky offers an alternative with his JwmDesk.

pTheme is missing... - I guess you have your reasons... ?

Thank you
Sigmund

I usually include ptheme, it probably was an oversight in the last build, I'll make sure its in future builds and thanks for the testing Smile
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
belham2

Joined: 15 Aug 2016
Posts: 1667

PostPosted: Thu 23 Mar 2017, 11:07    Post subject: My creation is out!  

Hi Guys,

I posted the creation, over on "Puppy Derivatives". Heaven help us or me. Without you, ttuuxxx, none of this goes....your the engine master of the train, and I am barely hanging on in the caboose. And huge thank you(s) to Oscar, Musher, Billtoo and Fred!

After this experience, I think I can safely say I am going back to being a "user". Holy f-r-e-a-k-i-n-g crap, I am not patient and/or smart enough for this stuff, lol Laughing

http://murga-linux.com/puppy/viewtopic.php?t=110012[/url]
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 11226
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 23 Mar 2017, 12:04    Post subject:  

peebee wrote:
ttuuxxx wrote:
Next release is up, Smile
http://smokey01.com/ttuuxxx/WoofCe/stretch-7.0.0a1.iso <-- Iso
3d99450da65bde06c88e35133b05e1ab stretch-7.0.0a1.iso

Hi ttuuxxx

Scripts put into /root/Startup don't seem to be executed on startup?? My test script is attached - remove the false .gz and set executable before adding to /root/Startup and testing...

checkdeps -system
is a useful tool to run after each new build - it is showing some missing dependencies....

Some version naming of the iso's might be useful to avoid confusion....

Cheers
peebee
Ok I fixed the startup issue, it was starting too fast. Your little splash dialog script was handy Smile , yes I knew about the missing deps, I haven't addressed them due to the reason as I compile and fix issues, some of deps become redundant, They either get replaced by newer versions that are/aren't used anymore due to being built on a smaller base system. I like the one missing looking for KDE, lol But I'm starting to think its near time to fulfill them, I have a couple more fixes to do first.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Thu 23 Mar 2017, 17:31    Post subject: Woof CE Debian Stretch and Devuan Ascii Based Development  

I did a new woof-CE auto build this afternoon + added a new kernel
compiled with the kernel kit.

System: Host: puppypc19160 Kernel: 4.4.56-4G i686 (32 bit) Desktop: Openbox 3.6.1
Distro: Dpup Stretch 7.0.0a1
Machine: Device: desktop System: Compaq-Presario product: AU194AA-A2L CQ5123F serial: MXX9300M0F
Mobo: MSI model: Boston v: 1.0 BIOS: Phoenix v: 5.24 date: 06/19/2009
CPU: Dual core Pentium E5200 (-MCP-) speed/max: 1600/2500 MHz
Graphics: Card: NVIDIA GF108 [GeForce GT 430]
Display Server: X.org 1.19.2 driver: nvidia tty size: 132x40 Advanced Data: N/A for root
Network: Card: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
Drives: HDD Total Size: 500.1GB (6.5% used)
Info: Processes: 145 Uptime: 1:18 Memory: 206.5/3153.9MB Client: Shell (bash) inxi: 2.3.5

I'm using radky's FbBox-4.1.

Works good so far.
Screenshot.jpg
 Description   
 Filesize   69.14 KB
 Viewed   331 Time(s)

Screenshot.jpg

Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3444
Location: wales

PostPosted: Thu 23 Mar 2017, 18:07    Post subject:  

hi ttuuxxx,

the battery monitor powerapplet_tray is missing icons and isn't showing in the tray. the one from tahrpups repos works and it also has pemasus low battery warning.

the gnome-mplayer.desktop file needs the %u removing from the exec line.
also /usr/local/bin/defaultmediaplayer needs setting to
gnome-mplayer, at the moment it's vlc.
i tried playing a hevc x265 encoded file and it works fine Smile ... this fails on 32bit tahrpup with vlc ..... sample files here https://x265.com/hevc-video-files/ (needs a good cpu)

where's abiword 3,0,2? thought you had compliled it (i'm having problems compiling it in xenialpup so any pointers would be good)

thanks for putting 'run in terminal' right click .... every pup should have it
(edit: ooops i had installed it myself ... i'll get together a pet of tahrpups nicer right clicks.... dri2pet, dirsfs, run in terminal etc..and post)

on the whole it's feeling really nippy.

now if you would only work with woof, rather than remastering, we could get a 64bit version Wink

looking forward to the next release

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 29 of 49 [723 Posts]   Goto page: Previous 1, 2, 3, ..., 27, 28, 29, 30, 31, ..., 47, 48, 49 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1155s ][ Queries: 13 (0.0427s) ][ GZIP on ]