Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 20 Aug 2017, 08:11
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
gnuplot 5.0.6 para Puppy Tahr 6.0.5 CE
Moderators: rarsa
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
tenochslb

Joined: 10 Jul 2010
Posts: 62
Location: Mexico

PostPosted: Fri 31 Mar 2017, 00:10    Post subject:  gnuplot 5.0.6 para Puppy Tahr 6.0.5 CE  

GnuPlot 5.0.6 para Puppy Linux Tahr 6.0.5 C.E.


Wikipedia:
gnuplot es un programa muy flexible para generar gráficas de funciones y datos.
Este programa es compatible con los sistemas operativos más populares (Linux, UNIX, Windows, Mac OS X...). El origen de gnuplot data de 1986.
gnuplot puede producir sus resultados directamente en pantalla, así como en multitud de formatos de imagen, como PNG, EPS, SVG, JPEG, etc. Se puede usar interactivamente o en modo por lotes (batch), usando scripts. Este programa tiene gran base de usuarios y está convenientemente mantenido por sus desarrolladores. Existe una ingente cantidad de ayuda en Internet, aunque gran parte está en inglés.
gnuplot es la herramienta de dibujo de gráficas del programa GNU Octave. Existen además interfaces para su empleo a través de diversos lenguajes de programación como Perl (via CPAN), Python (via Gnuplot-py o SAGE), Java (via jgnuplot), Ruby (via Ruby Gnuplot), Ch (via Ch Gnuplot), o Smalltalk (Squeak y GNU Smalltalk). Gnuplot también puede ser empleado a través de tuberías.


librería Cerf:

libcerf: Esta libreria hace posible el uso de las funciones complejas cerf, cdawson, erf, ddeeva, y Voigt VP(x,sigma,gamma).

Gnuplot:



El software no utiliza entrada de menu, el modo de terminal interactiva se presenta asi:
Code:
root# gnuplot

   G N U P L O T
   Version 5.0 patchlevel 6    last modified 2017-03-18

   Copyright (C) 1986-1993, 1998, 2004, 2007-2017
   Thomas Williams, Colin Kelley and many others

   gnuplot home:     http://www.gnuplot.info
   faq, bugs, etc:   type "help FAQ"
   immediate help:   type "help"  (plot window: hit 'h')

Terminal type set to 'qt'
gnuplot>



Ya estando en esa terminal interactiva el codigo mas sencillo para demostrar el funcionamiento de gnuplot seria algo asi:
Code:
gnuplot>plot tan(x)


si todo funciono bien, eso generara la funcion:


Los detalles sobre como usar gnuplot se pueden consultar en el sitio del software.

Last edited by tenochslb on Sun 02 Apr 2017, 01:13; edited 1 time in total
Back to top
View user's profile Send private message 
Galbi


Joined: 21 Sep 2011
Posts: 916
Location: Bs.As. - Argentina.

PostPosted: Fri 31 Mar 2017, 08:10    Post subject:  

Cuántos recuerdos... yo usaba GnuPlot en la universidad el siglo pasado (literalmente, año 1996) Smile
Eso sí, era en Windows 3.11 y el programa nos lo pasaba el profesor en diskette de 3.5'

Gracias por el aporte.

Saludos.

_________________
Remember: "pecunia pecuniam parere non potest"
Back to top
View user's profile Send private message 
mister_electronico


Joined: 20 Jan 2008
Posts: 955
Location: Asturias_ España

PostPosted: Fri 31 Mar 2017, 14:06    Post subject: Me da error a instalarlo.  

Me da error al instalarlo, gnuplot 5.0.6 pet package:

Cuando intento ver el contenido de la pet me da error, como si fuera un problema con gzip.

Bueno puede ser un error mio, pero me da que no.

Un saludo.
gnu_plot_error.jpg
 Description   
 Filesize   22.66 KB
 Viewed   58 Time(s)

gnu_plot_error.jpg

Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger 
wow

Joined: 29 Jun 2006
Posts: 1034
Location: Peru

PostPosted: Sat 01 Apr 2017, 22:25    Post subject:  

No tuve problemas para instalar el .pet de gnuplot:


Pero si con el de libcerf, luego de reintentar la descarga vi que que error estaba en el archivo, no es un .pet y no contiene ese lib.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0411s ][ Queries: 15 (0.0088s) ][ GZIP on ]