Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 12 Dec 2019, 10:00
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Woof CE Debian Stretch and Devuan Ascii Based Development
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 34 of 49 [723 Posts]   Goto page: Previous 1, 2, 3, ..., 32, 33, 34, 35, 36, ..., 47, 48, 49 Next
Author Message
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Sat 08 Apr 2017, 16:33    Post subject: Woof CE Debian Stretch and Devuan Ascii Based Development  

I did a build using the newest woof-CE:

# inxi -F
System: Host: puppypc26495 Kernel: 4.9.20-4G i686 (32 bit) Desktop: JWM 2.3.6 Distro: Dpup Stretch 7.0.0a1
Machine: Device: desktop System: Compaq-Presario product: AU194AA-A2L CQ5123F serial:
Mobo: MSI model: Boston v: 1.0 BIOS: Phoenix v: 5.24 date: 06/19/2009
CPU: Dual core Pentium E5200 (-MCP-) cache: 2048 KB
clock speeds: max: 2500 MHz 1: 1600 MHz 2: 1600 MHz
Graphics: Card: NVIDIA GF108 [GeForce GT 430]
Display Server: X.org 1.19.2 driver: nvidia tty size: 112x37 Advanced Data: N/A for root
Audio: Card-1 NVIDIA GF108 High Definition Audio Controller driver: snd_hda_intel
Card-2 Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.9.20-4G
Network: Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
IF: eth0 state: up speed: 100 Mbps duplex: full mac:
Card-2: D-Link System AirPlus G DWL-G122 Wireless Adapter(rev.C1) [Ralink RT2571W] driver: rt73usb
IF: wlan0 state: N/A mac: N/A
Drives: HDD Total Size: 500.1GB (12.0% used)
ID-1: /dev/sda model: Hitachi_HDP72505 size: 500.1GB
Partition: ID-1: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: None detected - is lm-sensors installed and configured?
Info: Processes: 164 Uptime: 3 min Memory: 176.3/3152.6MB Client: Shell (bash) inxi: 2.3.5
#

I wanted to make the pae version of kernel-4.9.20 but it didn't complete fully when compiling with the kernel-kit.

This is working well so far.
Screenshot.jpg
 Description   
 Filesize   84.95 KB
 Viewed   892 Time(s)

Screenshot.jpg

Back to top
View user's profile Send private message 
Robert123

Joined: 20 May 2016
Posts: 374
Location: Pacific

PostPosted: Sun 09 Apr 2017, 05:34    Post subject:  

Machine: Emachines E625
build: 7.0.0a3 build by Ttuuxxx
Same problem with ext 4 and getting stretch to boot so used ext2.
would not boot consistently to desktop so added radeon.modeset=0 to menu.lst have also added acpi=off on separate line.
Applied trayfix.pet after some weird JWM behavior

Will keep using this build to test other problems and what works well.

_________________
Devuan Linux, Stardust 013 (4.31) updated https://archive.org/details/Stardustpup013glibc2.10
s57(2018)barebonehttps://sourceforge.net/projects/puppy-linux-minimal-builds/files/s57%282018%29barebones.iso/download
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12805
Location: Stratford, Ontario

PostPosted: Sun 09 Apr 2017, 08:14    Post subject:  

Quote:
have also added acpi=off on separate line.

That shouldn't be. Please post your current GRUB menu.lst file.
Back to top
View user's profile Send private message 
Robert123

Joined: 20 May 2016
Posts: 374
Location: Pacific

PostPosted: Sun 09 Apr 2017, 09:33    Post subject:  

For some reason modern pups give me inconsistent booting to desktop - Lucid doesn't namely 5.25. Boots to a black screen.




# menu.lst produced by grub4dosconfig-v1.9.2
color white/blue black/cyan white/black cyan/black
#splashimage=/splash.xpm
timeout 10
default 0

# Frugal installed Puppy

# Full installed Linux

title Dpup Stretch 7.0.0a1 (sda2/boot)
acpi=off
radeon.modeset=0
uuid 1f2a5e67-6206-4f3f-ad5a-4e911013fc9d
kernel /boot/vmlinuz root=/dev/sda2 ro

# Windows
# this entry searches Windows on the HDD and boot it up
title Windows\nBoot up Windows if installed
errorcheck off
find --set-root --ignore-floppies --ignore-cd /bootmgr
chainloader /bootmgr
find --set-root --ignore-floppies --ignore-cd /ntldr
chainloader /ntldr
find --set-root --ignore-floppies --ignore-cd /io.sys
chainloader /io.sys
errorcheck on

# Advanced Menu
title Advanced menu
configfile /menu-advanced.lst
commandline

_________________
Devuan Linux, Stardust 013 (4.31) updated https://archive.org/details/Stardustpup013glibc2.10
s57(2018)barebonehttps://sourceforge.net/projects/puppy-linux-minimal-builds/files/s57%282018%29barebones.iso/download
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12805
Location: Stratford, Ontario

PostPosted: Sun 09 Apr 2017, 09:42    Post subject:  

Code:
title Dpup Stretch 7.0.0a1 (sda2/boot)
acpi=off
radeon.modeset=0
uuid 1f2a5e67-6206-4f3f-ad5a-4e911013fc9d
kernel /boot/vmlinuz root=/dev/sda2 ro


should look like

Code:
title Dpup Stretch 7.0.0a1 (sda2/boot)
uuid 1f2a5e67-6206-4f3f-ad5a-4e911013fc9d
kernel /boot/vmlinuz root=/dev/sda2 ro acpi=off radeon.modeset=0
Back to top
View user's profile Send private message 
Robert123

Joined: 20 May 2016
Posts: 374
Location: Pacific

PostPosted: Sun 09 Apr 2017, 10:30    Post subject:  

Wow made the changes and booted to a vesa like desktop with the wrong resolution and my connection with SNS was stuffed up so rebooted with the following change


# menu.lst produced by grub4dosconfig-v1.9.2
color white/blue black/cyan white/black cyan/black
#splashimage=/splash.xpm
timeout 10
default 0

# Frugal installed Puppy

# Full installed Linux

title Dpup Stretch 7.0.0a1 (sda2/boot)
uuid 1f2a5e67-6206-4f3f-ad5a-4e911013fc9d
kernel /boot/vmlinuz root=/dev/sda2 ro radeon.modeset=1

_________________
Devuan Linux, Stardust 013 (4.31) updated https://archive.org/details/Stardustpup013glibc2.10
s57(2018)barebonehttps://sourceforge.net/projects/puppy-linux-minimal-builds/files/s57%282018%29barebones.iso/download
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12805
Location: Stratford, Ontario

PostPosted: Sun 09 Apr 2017, 10:47    Post subject:  

When you had those boot options on separate lines, they were not doing ANYTHING.

Once you put them on the kernel line where they belong, they are doing SOMETHING, but it may not be what you want.
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 14538
Location: Gatineau (Qc), Canada

PostPosted: Sun 09 Apr 2017, 16:04    Post subject:  

Hello all.

Here is an easy remedy for the Debianized gcc's "pie", SYN file-type
instead of EXEC file-type, bug,

Fire up your editor and add the following line as the last alias in your
/root/.bashrc file:
Code:
alias cnfgr="configure CFLAGS\='-no-pie' CXXFLAGS\='-no-pie'"
Please notice how the equal signs are escaped within the expression.
Save, exit your text editor and type
Code:
source ~/.bashrc
in console to activate it. (Alternatively, you can restart X or reboot.)

(That solution was found and shared by mavrothal, here.)

Now, next time you wish to compile some code, you simply type < cnfgr >
instead of the full
Code:
./configure CFLAGS='-no-pie' CXXFLAGS='-no-pie
Plus the required parameters, such as --prefix=/usr, etc.

Of course, one could select a different word as an alias. I chose "cnfgr"
because it's the word "configure" with the vowels squeezed out. It's easy
to remember and hard to confuse with any other word.

IHTH.

~~~~~~~~~
Reminder -- You can also use elfedit to rectify an already compiled hybrid
executable, as mentioned by OscarTalks here.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)

Last edited by musher0 on Wed 12 Apr 2017, 10:37; edited 2 times in total
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Sun 09 Apr 2017, 21:39    Post subject: Woof CE Debian Stretch and Devuan Ascii Based Development  

I did a manual frugal install to the usb-3.0 hard drive, computer is a
HP mini which is connected to a 32" TV by hdmi cable.

# inxi -F
System: Host: puppypc17808 Kernel: 4.9.20-4G i686 (32 bit) Desktop: JWM 2.3.6 Distro: Dpup Stretch 7.0.0a1
Machine: Device: desktop System: Hewlett-Packard product: 200-009 serial:
Mobo: Hewlett-Packard model: 2B38 v: 1.02 serial:
UEFI [Legacy]: AMI v: 80.03 date: 12/15/2014
CPU: Dual core Intel Celeron 2957U (-MCP-) cache: 2048 KB
clock speeds: max: 1400 MHz 1: 1000 MHz 2: 1000 MHz
Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller
Display Server: X.org 1.19.2 driver: intel tty size: 122x27 Advanced Data: N/A for root
Audio: Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel Sound: ALSA v: k4.9.20-4G
Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
IF: eth0 state: up speed: 1000 Mbps duplex: full mac:
Card-2: Broadcom Limited BCM43142 802.11b/g/n
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 1166.5GB (1.2% used)
ID-1: /dev/sda model: SanDisk_SDSA6MM size: 32.0GB
ID-2: /dev/sdb model: Overdrive_3.0 size: 126.3GB
ID-3: /dev/sdc model: MQ01ABD100 size: 1000.2GB
ID-4: USB /dev/sdd model: USB_Flash_Drive size: 8.0GB
Partition: ID-1: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sdc2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: None detected - is lm-sensors installed and configured?
Info: Processes: 177 Uptime: 1:06 Memory: 149.2/1917.8MB Client: Shell (bash) inxi: 2.3.5
#
No problems so far.
Screenshot.jpg
 Description   
 Filesize   86.03 KB
 Viewed   571 Time(s)

Screenshot.jpg

Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Wed 12 Apr 2017, 02:09    Post subject: Woof CE Debian Stretch and Devuan Ascii Based Development  

I did a new build, it's using the 4.4.60 kernel:

# inxi -F
System: Host: puppypc12117 Kernel: 4.4.60-4g i686 (32 bit) Desktop: JWM 2.3.6 Distro: Dpup Stretch 7.0.0a1
Machine: Device: desktop Mobo: Gateway model: FX6860 serial:
BIOS: American Megatrends v: P01-A3 date: 04/19/2011
CPU: Quad core Intel Core i7-2600 (-HT-MCP-) cache: 8192 KB
clock speeds: max: 3401 MHz 1: 1600 MHz 2: 1800 MHz 3: 2000 MHz 4: 2200 MHz 5: 1800 MHz 6: 2200 MHz
7: 1800 MHz 8: 1600 MHz
Graphics: Card: NVIDIA GF110 [GeForce GTX 560 Ti OEM]
Display Server: X.org 1.19.2 driver: nvidia tty size: 145x41 Advanced Data: N/A for root
Audio: Card-1 NVIDIA GF110 High Definition Audio Controller driver: snd_hda_intel Sound: ALSA v: k4.4.60-4g
Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller driver: snd_hda_intel
Network: Card-1: Ralink RT3090 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
IF: wlan0 state: down mac:
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
IF: eth0 state: up speed: 1000 Mbps duplex: full mac:
Drives: HDD Total Size: 2000.4GB (2.0% used)
ID-1: /dev/sda model: Hitachi_HDS72302 size: 2000.4GB
Partition: ID-1: swap-1 size: 17.18GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: None detected - is lm-sensors installed and configured?
Info: Processes: 212 Uptime: 34 min Memory: 237.5/3018.7MB Client: Shell (bash) inxi: 2.3.5
#

I'm using the proprietary nvidia driver.
I don't need to use "intel_pstate=disable" in the kernel line, the
CPU Frequency Scaling Tool works fine and defaults to Ondemand.

*********************************************************************
EDIT:
I did another build that uses the 4.9.22 kernel:

# inxi -b
System: Host: puppypc4677 Kernel: 4.9.22-4g i686 (32 bit) Desktop: JWM 2.3.6 Distro: Dpup Stretch 7.0.0a1
Machine: Device: desktop Mobo: Gateway model: FX6860 serial:
BIOS: American Megatrends v: P01-A3 date: 04/19/2011
CPU: Quad core Intel Core i7-2600 (-HT-MCP-) speed/max: 1600/3401 MHz
Graphics: Card: NVIDIA GF110 [GeForce GTX 560 Ti OEM]
Display Server: X.org 1.19.2 driver: nvidia tty size: 133x43 Advanced Data: N/A for root
Network: Card-1: Ralink RT3090 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
Drives: HDD Total Size: 2000.4GB (2.3% used)
Info: Processes: 242 Uptime: 3 min Memory: 174.9/3017.7MB Client: Shell (bash) inxi: 2.3.5
#

The 4.4.60 kernel has also been updated to 4.4.61
Screenshot.jpg
 Description   
 Filesize   47.33 KB
 Viewed   482 Time(s)

Screenshot.jpg


Last edited by Billtoo on Thu 13 Apr 2017, 14:04; edited 1 time in total
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 14538
Location: Gatineau (Qc), Canada

PostPosted: Wed 12 Apr 2017, 05:50    Post subject:  

Hi gang.

Great rock guitarists and famous classical pianists practice their scales
every day. It's what makes them great.

Have you noticed? Billtoo is a virtuoso too, but instead of doing scales, he
woofes Puppies !!! Very Happy Wink

BFN.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 14538
Location: Gatineau (Qc), Canada

PostPosted: Fri 14 Apr 2017, 01:51    Post subject:  

Hello all.

I just asked two questions about RAM usage in Puppy Stretch here.
(belham2's thread)

If you could kindly have a read and see if you've experienced similar
concerns?

TIA, BFN.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
Robert123

Joined: 20 May 2016
Posts: 374
Location: Pacific

PostPosted: Fri 14 Apr 2017, 01:58    Post subject:  

So what is wrong with Vlc. Why is it not playing mp4's - what is missing ???
_________________
Devuan Linux, Stardust 013 (4.31) updated https://archive.org/details/Stardustpup013glibc2.10
s57(2018)barebonehttps://sourceforge.net/projects/puppy-linux-minimal-builds/files/s57%282018%29barebones.iso/download
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Mon 17 Apr 2017, 00:04    Post subject: Woof CE Debian Stretch and Devuan Ascii Based Development  

I did a fresh install of woof-CE and did a build of Stretch-7.0.0a1,
it's using the 4.9.22-pae kernel compiled with the kernel kit.

# inxi -b
System: Host: puppypc21485 Kernel: 4.9.22-pae i686 (32 bit) Desktop: JWM 2.3.6
Distro: Dpup Stretch 7.0.0a1
Machine: Device: desktop System: Hewlett-Packard product: HPE-410f serial:
Mobo: FOXCONN model: 2AB1 v: 1.00 BIOS: American Megatrends v: 6.02 date: 07/21/2010
CPU: Hexa core AMD Phenom II X6 1045T (-MCP-) speed/max: 800/2700 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Redwood PRO [Radeon HD 5550/5570/5630/6510/6610/7570]
Display Server: X.org 1.19.2 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
tty size: 110x35 Advanced Data: N/A for root
Network: Card-1: Ralink RT3090 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
Drives: HDD Total Size: 1000.2GB (9.0% used)
Info: Processes: 188 Uptime: 1:10 Memory: 229.2/8091.6MB Client: Shell (bash) inxi: 2.3.5
#

Installed packages show as shared libs, Vlc,Kodi, etc work well.
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 2038
Location: London, England

PostPosted: Mon 17 Apr 2017, 07:21    Post subject:  

Stll experimenting with manually remastering the version posted some time ago.
Some people have commented about JWM
I have always liked it.
The configuration methods are changed in these recent JWM versions
Some of the tags are different so the jwmrc-theme file and also the jwmrc template file in /etc/xdg/templates need modification. Not sure if this has been done in WoofCE yet.
Use jwm -p to test for config errors.

Dpup Stretch has JWM 2.3.6 which is latest release but I have compiled snapshot 1592 which is 2.3.7 dev.

I did some corrections and tweaks to the DeepBlueBold theme which was the only one included in the .iso and I implemented the decorations="motif" attribute which gives it a look which some may find quite elegant.
jwm-theme-working.jpg
 Description   This newer JWM can be made to look nice if configured correctly
 Filesize   124.66 KB
 Viewed   585 Time(s)

jwm-theme-working.jpg


_________________
Oscar in England

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 34 of 49 [723 Posts]   Goto page: Previous 1, 2, 3, ..., 32, 33, 34, 35, 36, ..., 47, 48, 49 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0890s ][ Queries: 13 (0.0291s) ][ GZIP on ]