Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 27 Jun 2017, 20:37
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
google hangouts plugin for pidgin
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
noalternative

Joined: 10 Nov 2009
Posts: 99

PostPosted: Fri 30 Dec 2016, 04:47    Post subject:  google hangouts plugin for pidgin  

Anyway to create this plugin for xenial pup? https://www.maketecheasier.com/use-google-hangouts-on-pidgin/

following the debian ubuntu directions doesn't work.
Back to top
View user's profile Send private message Visit poster's website 
OscarTalks


Joined: 05 Feb 2012
Posts: 1534
Location: London, England

PostPosted: Fri 30 Dec 2016, 12:59    Post subject:  

I haven't tried xenial pup yet and I don't use pidgin, but as a test in Wheezy I just followed the instructions on the page to build from source and the plugin libhangouts.so compiled quite easily. There are 2 or 3 dependencies mentioned in the instructions, mostly dev libs, I just grabbed those from packages.debian.org and clicked on them to install them before running make on the source code.

EDIT:-
I have also now managed to compile the latest Pidgin version 2.11.0 in Wheezy Puppy. Debian repos have an earlier version. Anyway, the plugin appears in the list as it should. The logging in process is a bit more complicated than just a password though.
pidgin-hangouts.jpg
 Description   "HANGOUTS" becomes available as a protocol in the list
 Filesize   101.39 KB
 Viewed   118 Time(s)

pidgin-hangouts.jpg


_________________
Oscar in England

Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1534
Location: London, England

PostPosted: Sat 31 Dec 2016, 21:24    Post subject:  

Hello noalternative,

Not sure what version of Pidgin you are running. Is it in the xenial distro or was it from the Ubuntu repos via PPM or maybe QuickPet.

Anyway, I am uploading a .pet of the hangouts plugin. This was compiled in Wheezy as I said so it may or may not work for you. It installs the plugin library in /usr/lib/purple-2 and the hangouts icons under /usr/share/pixmaps/pidgin/protocols/. It did seem OK in Tahr with the Pidgin from QuickPet so give it a try and if it is no good just discard it.
http://smokey01.com/OscarTalks/purple-hangouts-0.1-i686.pet

_________________
Oscar in England

Back to top
View user's profile Send private message 
noalternative

Joined: 10 Nov 2009
Posts: 99

PostPosted: Fri 24 Mar 2017, 15:28    Post subject:  

OscarTalks wrote:
Hello noalternative,

Not sure what version of Pidgin you are running. Is it in the xenial distro or was it from the Ubuntu repos via PPM or maybe QuickPet.

Anyway, I am uploading a .pet of the hangouts plugin. This was compiled in Wheezy as I said so it may or may not work for you. It installs the plugin library in /usr/lib/purple-2 and the hangouts icons under /usr/share/pixmaps/pidgin/protocols/. It did seem OK in Tahr with the Pidgin from QuickPet so give it a try and if it is no good just discard it.
http://smokey01.com/OscarTalks/purple-hangouts-0.1-i686.pet


I am using the deb from the Ubuntu repos. I can't find a Pidgin pet.

This plugin seems to freeze the program in some way, without producing errors. I have xenialpup installed on an sdcard.
Back to top
View user's profile Send private message Visit poster's website 
noalternative

Joined: 10 Nov 2009
Posts: 99

PostPosted: Wed 19 Apr 2017, 21:28    Post subject:  

OscarTalks wrote:
Hello noalternative,

Not sure what version of Pidgin you are running. Is it in the xenial distro or was it from the Ubuntu repos via PPM or maybe QuickPet.

Anyway, I am uploading a .pet of the hangouts plugin. This was compiled in Wheezy as I said so it may or may not work for you. It installs the plugin library in /usr/lib/purple-2 and the hangouts icons under /usr/share/pixmaps/pidgin/protocols/. It did seem OK in Tahr with the Pidgin from QuickPet so give it a try and if it is no good just discard it.
http://smokey01.com/OscarTalks/purple-hangouts-0.1-i686.pet


I found your plugin pet worked fine with this lupo version of pidgin. http://www.murga-linux.com/puppy/viewtopic.php?t=64385

Unfortunately the facebook plugin wouldn't work with lupo pidgin. Do you happen to have that compiled too?
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0328s ][ Queries: 15 (0.0067s) ][ GZIP on ]