Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 17 Jan 2020, 13:06
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Puppy Linux UEFI boot EASY
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 5 [61 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
Limbomusic


Joined: 15 Apr 2016
Posts: 279
Location: Norway

PostPosted: Sun 16 Apr 2017, 10:04    Post subject: thats cool
Subject description: and
 

Tahts cool Smile I have done some testing on various pc s and MY verdict is that there ARE some bugs - with 64 bit - NOT 32 bits. but I,m not sure to post anything except here. (people could get angry, and kill me, and I dont want that to happen)

https://youtu.be/WTCE812gohk

kisses u Wink
Back to top
View user's profile Send private message Visit poster's website 
Limbomusic


Joined: 15 Apr 2016
Posts: 279
Location: Norway

PostPosted: Sun 16 Apr 2017, 13:17    Post subject: yeah
Subject description: u huh
 

Yeah. The problem disrcibed before in earlier tidings does NOT happen on a 32 bit pup.
( I just woke up with my knickers around my head)

So my earlier description of events DO indeed stand against the tides of time.
cheerio miss sophies
Back to top
View user's profile Send private message Visit poster's website 
ticthak

Joined: 28 Mar 2011
Posts: 3

PostPosted: Fri 28 Apr 2017, 11:35    Post subject: UEFI hell
Subject description: maybe my rescue
 

So, I fell down Hell's spiral staircase this week with a Dell laptop- the UEFI firmware won't accept any other media without the HDD in place, and the HDD won't even boot into RE after the customer tried to do a factory restore. All of the partitions and files look correct, and I ran the typical repair-console commands externally. It even looks like it has the original factory recovery partition. It will not boot off the optical drive or any other USB bootable I've tried. Now I will try this.
On the plus side, I've jimmied the HDD enough to get the POST to failover into a "Process1 initialization failed" screen without simply POSTing to the UEFI screen as was the situation the customer brought to me.
I have a extensive post on Steemit about this(I'm trying to wean myself off the Book of Face).
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 13168
Location: S.C. USA

PostPosted: Fri 28 Apr 2017, 11:50    Post subject:  

Quote:
the UEFI firmware won't accept any other media without the HDD in place

Tried it with secure boot disabled in the UEFI bios?

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 13168
Location: S.C. USA

PostPosted: Fri 28 Apr 2017, 12:03    Post subject:  

The Puppies now being released as UEFI versions are now setup as stated in this topic.
A little different names for the needed files for UEFI booting, but the same method as stated in this topic.

Example:
Tahr6.0.6uefi
capture30012.png
 Description   
 Filesize   35.88 KB
 Viewed   752 Time(s)

capture30012.png


_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
Burn_IT


Joined: 12 Aug 2006
Posts: 3624
Location: Tamworth UK

PostPosted: Sat 29 Apr 2017, 07:07    Post subject:  

I only recently got hold of a 64 bit machine and haven't really had time to play with it under Puppy. I've got it apart at the moment trying to fit a better screen and somebody has sold me a duff part. The problem is which bit is duff without alternates to try.

Is Lenovo still playing silly buggers with restrictions?
I've used a different BIOS on mine to bypass them, but the machine is old and 32 bit only.

_________________
"Just think of it as leaving early to avoid the rush" - T Pratchett
Back to top
View user's profile Send private message 
Limbomusic


Joined: 15 Apr 2016
Posts: 279
Location: Norway

PostPosted: Wed 24 May 2017, 13:37    Post subject: no probs
Subject description: with 64 bit pup
 

Just posting a follow-up on some of my... sort of silly responses to bugs in 64 bit versions.

Point is - I tried the 4.9.15 kernel in tahrpup64 6.0.6 and EVERYTHING just works. Love that kernel - (well, on my main gaming pc the icon for volume is gone, thats the only thing, workin ok on the Lenovo laptop)

BurnIT: Lenovo restrictions? I'm not aware of any, sorry Smile
---------------
Installed a 250gb samsung 850 evo ssd on my main gaming pc a couple of days ago - after fresh install of win 10 (and booting puppy from usb) and holy %¤"#¤! - major difference indeed. Recommended! - but u guys know that already.

PC: http://helledussen.com/video/dill/feelin_good.html
Back to top
View user's profile Send private message Visit poster's website 
Burn_IT


Joined: 12 Aug 2006
Posts: 3624
Location: Tamworth UK

PostPosted: Wed 24 May 2017, 14:18    Post subject:  

They put restrictions in the BIOS that tries to stop you using none-authorised parts.
They added a "call home" utility that only worked under Windows and powered down the machine if it failed.
They also sold many new machines with malware built into the BIOS - you need to check up on this one. EDIT: SUPERFISH
Don't forget that Lenovo is Chinese nowadays.

_________________
"Just think of it as leaving early to avoid the rush" - T Pratchett
Back to top
View user's profile Send private message 
Limbomusic


Joined: 15 Apr 2016
Posts: 279
Location: Norway

PostPosted: Fri 26 May 2017, 11:26    Post subject: huh
Subject description: superfish
 

Jaysis. Didnt know that - did a simple search:
https://support.lenovo.com/no/en/product_security/superfish

But according to that page they have seen the error of their ways and want everyone to get rid of it - WEIRD that they offered/included it in the first place.

ANyhoo - MY experience - well - I tried a recent puppy with some quite new laptops recently (i think it was a hp and a acer), and it didnt work very well, one woulndt even load the x desktop. But my 1 1/2 year lenovo ideapad 100 works really well with puppy.
(but they might work with the 4.9.15 kernel, have to try next time I get the chance)

Anyway - in my humble experience - Lenovo Laptops works quite well with puppies as opposed to other brands

EDIT 7 aug 2017:
All problems solved by using new kernel 4.9.13 ( or 30)

Last edited by Limbomusic on Mon 07 Aug 2017, 11:31; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Burn_IT


Joined: 12 Aug 2006
Posts: 3624
Location: Tamworth UK

PostPosted: Fri 26 May 2017, 12:50    Post subject:  

Don't get me wrong, I use a T43P most of the time and have overcome most of problems.
The only thing you need to look out for are update that they push through the MS update channel. It is alway worth while checking/delaying them before applying as they have been know to cause problems on several occasions.
I also stop any W10 and associated updates - mainly because I have no intention of upgrading this machine to W10 and also because it shouldn't even run Win 7 according to them (not the User groups though).
Puppy works fine and I tend to use it when I've finished work and are relaxing - though that is often late and I have another play machine for that sort of thing that supports more memory - which is this machine's biggest drawback.

_________________
"Just think of it as leaving early to avoid the rush" - T Pratchett
Back to top
View user's profile Send private message 
Limbomusic


Joined: 15 Apr 2016
Posts: 279
Location: Norway

PostPosted: Mon 29 May 2017, 14:21    Post subject: win10
Subject description: updates
 

I get what u mean - like the new creators update for win10 has apparently caused many problems for users.
But,
I updated my lenovo idepad 100 to the creators update a week ago - and it works fine. I also last week - installed a new ssd drive to my main gaming pc - and I downloaded the most recent windows 10 ISO to install to it - and that already HAD the latest creators update / version- - so almost no updates afterwards - cause it was already "up to speed" - maybe I,ve been lucky Smile

I love windows 10 actually, (as long as u have ssd) but I love the puppies more Wink
Back to top
View user's profile Send private message Visit poster's website 
T-Biscuit

Joined: 23 Apr 2016
Posts: 14

PostPosted: Sat 10 Jun 2017, 10:22    Post subject: Re: Puppy Linux UEFI boot EASY
Subject description: how to make any puppy ISO boot from a pc with UEFI bios
 

Limbomusic wrote:
. . . Then just make a folder called "EFI" and a "boot" folder inside that. (EFI/boot) and then just put this file:
http://helledussen.com/linux/files/bootx64.efi inside it. . . .


Hello, Limbomusic. I am interested in trying out your contribution above. But, my cheap W10 2-in-1 netbook/tablet uses the nasty Baytrail Atom Z3735F soc. For reasons that seem to me silly or mean it has W10-32 and requires a 32 bit UEFI. Nor does it have a legacy boot option in its firmware. I was wondering if you might have a bootx32.efi handy.

Thanks for your very kind consideration.

PS. Sparky Linux boots but (1) is not Puppy, and (2) does not have the 4.9 kernel yet. I read somewhere that the drivers I need for this soc are in 4.9 or 4.10.

Travis "T-Biscuit" (because "Travis-T" just sounds wrong)
Back to top
View user's profile Send private message 
Limbomusic


Joined: 15 Apr 2016
Posts: 279
Location: Norway

PostPosted: Sat 10 Jun 2017, 14:14    Post subject: hey
Subject description: yeah
 

Hey man Smile I did a google search Wink And altho I havent tried it - the file youre looking for is probably the bootia32.efi
I downloaded it and put it here:
http://helledussen.com/linux/files/UEFI_boot/bootia32.efi

Smile
Back to top
View user's profile Send private message Visit poster's website 
T-Biscuit

Joined: 23 Apr 2016
Posts: 14

PostPosted: Sat 10 Jun 2017, 18:41    Post subject: Re: hey
Subject description: yeah
 

Thank you, Limbomusic. I downloaded it and will let you know what happens. Very Happy
Back to top
View user's profile Send private message 
Limbomusic


Joined: 15 Apr 2016
Posts: 279
Location: Norway

PostPosted: Mon 07 Aug 2017, 11:39    Post subject: huhey
Subject description: man
 

what happened ? Did it work?
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 5 [61 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1147s ][ Queries: 13 (0.0197s) ][ GZIP on ]