Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 24 May 2017, 19:41
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
Booting UEFI/EFI Computers - What Works, What Doesn't
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [34 Posts]   Goto page: Previous 1, 2, 3
Author Message

Joined: 04 Nov 2008
Posts: 505
Location: PH

PostPosted: Sun 12 Feb 2017, 02:53    Post subject:  

X-Slacko Slim works fine on UEFI, even on Secure Boot mode. Vesa may not work on UEFI, use fbdev instead
Back to top
View user's profile Send private message 

Joined: 06 Aug 2014
Posts: 148

PostPosted: Fri 17 Feb 2017, 23:54    Post subject:  

My build of Lightweight Trusty are be works at UEFI too... (but it's a oldest anyway) -> murga-linux.com/puppy/viewtopic.php?t=108681 [Non-Rationalise for Now at Stable only']
Back to top
View user's profile Send private message 

Joined: 15 Apr 2016
Posts: 71
Location: Norway

PostPosted: Sat 29 Apr 2017, 10:25    Post subject: Lenovo ideapad 100 with puppy tahr 6.0.5
Subject description: uefi / installing to hd.

Well, u asked what works and what doesnt, so here's my contribution Smile
PC: Lenovo Ideapad 100. SSD drive, 4gb ram. (bought new a year ago)
Have a remastered version of tahr 6.0.5 with the 4.1.11 (or something) kernel.
(had to use the newer kernel or else wifi card was not found)

Boots from usb as long as secure boot is turned off.
As mentioned earlier in the thread, its easy to make a bootable usb on uefi machine.
Explained at http://blog.puppylinux.com/?viewDetailed=00009
and also on my own posting at http://murga-linux.com/puppy/viewtopic.php?t=109702

I coulnd't install to disk tho, using the SETUP->PUPPY INSTALLER because Grub4dos wouldn't install - just got the error message:
"somewhat error occured" - I assume bacause of some windows 10 thing.
What DID work - was to install LICK - in win10 - dragged the .iso over and machine now works fine with dual-boot puppytahr/windows.

Whats NOT so good is my wifi connection just stops working. (have to setup wifi network again to get it going again)
Have researched this and there is apparently problems with the driver-modules for the Realtek8723be wifi card.
I have tried the rtlwifi-new-something.pet (which I mirrored on
http://helledussen.com/linux/tahr/) but it doesnt seem to work - same problem with connection.
I would really appreciate help from any puppy users with dealings with the rtl8723be wifi card.
Back to top
View user's profile Send private message Visit poster's website 

Joined: 14 Apr 2017
Posts: 7
Location: Massachusetts

PostPosted: Sun 07 May 2017, 19:30    Post subject:  

MacBook5,2 (MacBook non-Pro, non Air (13", Mid-2009)

Built-in EFI (not rEFInd, rEFIt, etc), on its latest El Capitan version (this Puppy didn't get Sierra).
I can put the version up if you wish.

Tried slacko 6.3.2, slacko64 6.3.2, and the test tahr64 6.0.6 UEFI build.

TL;DR: Works, but incredibly unreliably. Needs a workaround, and hangs for long periods most of the time before booting.

TL;DR: Works, needs workaround. Also hangs while booting if the built-in SuperDrive is broken.

OS X will only recognize a USB if the efi files are in a directory on the root of the partition. efi.img won't work, unless Puppy is directly burned to a CD.

This is what mostly works on a fat32 partition on GPT and MBR. I haven't tested hybrid MBR or the steps in this guide (but I want to boot Windows off it as well).

So, for a frugal install, instead of

---- /efi.img

it must be

---- /efi/
--------- /boot/
-------------- /bootx64.efi

After doing this, holding Option at boot will show "EFI Boot" as a boot option.

My MacBook seems to be very finicky. It prefers to boot from 64-bit (which is what I have heard a lot). When it isn't working, most issues arise from inability to find VESA BIOS extensions, mainly with "Mac Linux USB Installer".

I looked into the problem I had in the quote below and it seems to only happen because my SuperDrive is busted.

So ignore this quote, this has to be just me.

However, the main issue is that for some reason, about 75% of the time, it doesn't matter if it is on a live CD/DVD or a USB drive, you start the boot from GRUB, and it will hang on a black screen for 10 minutes plus before booting. The flash drive or DVD drive will go silent after a moment when it does that.

Out of that 75%, about 10% will just do nothing.

It seems to be related to unplugging the flash drive and plugging it back in, but I can't reliably get it to work.

I have tried pmediatype=whatever, pfix=ram, nomodeset, noefi, acpi=force, acpi=off, and noexec=off, but none of them do the trick.

It is still an issue, but I have even had this in Ubuntu 16.04.

The dmesg shows multiple attempts of accessing ata2, the device where the SuperDrive is internally connected, but reporting
"ata2: COMRESET failed (errno=32)"
repeatedly until it gives up. Then it boots.

I might have a faulty connection internally. I did get the thing used, and out of the box, it had an upgraded hard drive to 1TB, but the case was obviously pried off unprofessionally, as the edges are chipped off and some screws were missing.

I could try taking it apart later this month once finals are over and I don't have to rely on my MacBook for college work.

I don't know if this is directly related to EFI, but on Slacko (and Slacko64) 6.3.2, battery stats are only reported in /sys/class/power_supply/BAT0, not /proc/acpi/battery/BAT0. I have tried everything, trust me.

In tahr64, oddly, the battery stats work perfectly.

As a result of this, there is no battery icon in Slacko.

I modded powerapplet_tray 2.6 (can't find 2.7.x sources) to make it work with power_supply here. Sorry, no PETs, just source code.

It also has a lot of other issues, mostly with drivers. But these were simple to fix once you found the solution.

(in case you are wondering, WiFi, brightness control, trackpad, and standby mode were the main ones).

Another thing:

Removed the boot hang which was a problem with my already broken hardware.

Slacko64- boots with no battery stats, but WiFi works…Very Happy
Ubuntu 16.04 doesn't have battery stats either.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 3 [34 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0833s ][ Queries: 14 (0.0144s) ][ GZIP on ]