Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 17 Nov 2019, 15:54
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Create Debian 9 (Stretch) minimal ISO similar to DebianDog
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 32 of 103 [1533 Posts]   Goto page: Previous 1, 2, 3, ..., 30, 31, 32, 33, 34, ..., 101, 102, 103 Next
Author Message
belham2

Joined: 15 Aug 2016
Posts: 1696

PostPosted: Sun 27 Aug 2017, 07:23    Post subject:  

fredx181 wrote:
Hi All,

Added fvwm-crystal to the Desktop choice GUI



Did some hacking (configuration in extra module "zz_fvwm-crystal_config.squashfs"):
- Changed fonts to be more elegant (instead of the big bold fonts)
- Reboot and Shutdown will show the 'Save or No save' window (in case porteus-boot EXIT:/ is used)
- Will autologin and autostart X (no login manager needed, such as slim)
Without adding more packages to be installed to the fvwm-crystal list, the ISO size becomes 184 MB

New mklive-stretch:
mklive-stretch script

@belham, indeed fvwm-crystal is some 'piece of art' Smile, although some things don't work, e.g. font setting from menu, but found config files in /usr/share/fvwm-crystal/fvwm/preferences.

@backi Thanks, I added ntfs-3g to all configs

@jd7654, added filemnt-caja to the repos, didn't test though, can you try it ?

About the browser choice, I like to have a reasonable working browser to be standard in the build, the latest firefox-esr is almost twice as big as version 24, but v24 can be easily upgraded to latest version from apt-get or Synaptic
Btw, I don't understand the issue, it's easy IMO just to modify the Applications field and change "firefox-esr=24.8.0esr-1~deb8u2" to "firefox-esr" or whatever browser.

Fred



Thank you, Fred!
Very Happy

Hope others give it a whirl, giving it some time to grow on them, and see what they think!
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4159
Location: holland

PostPosted: Sun 27 Aug 2017, 10:37    Post subject:  

You are welcome Belham !!

Maybe someday, someone makes a full featured "CrystalDog" , who knows... Wink

@ALL Added firmware .squashfs module:
https://debiandog.github.io/MakeLive/modules/99-firmware-stretch-live.squashfs

Fred
Back to top
View user's profile Send private message 
roadkill13

Joined: 10 Aug 2011
Posts: 154
Location: United States

PostPosted: Sun 27 Aug 2017, 20:53    Post subject:  

Quote:
root# ./mklive-stretch -gui
Checking network connection...
OK
Unable parse command line: Unknown option --borders=6
Unable parse command line: Unknown option --borders=4


Script fails on initialization with this message.

OOPS I see my mistake!
Back to top
View user's profile Send private message Yahoo Messenger 
dancytron

Joined: 18 Jul 2012
Posts: 1387

PostPosted: Mon 28 Aug 2017, 01:03    Post subject:  

dancytron wrote:
Is there a specific package that has to be included for lz4 to work on the Quick Remaster? Or is it just not supported yet.

I did a quick remaster using lz4 and it seemed to do what it was supposed to, but when I rebooted, I got the errors in the screenshot I've attached. It worked fine when I redid it with gzip and I've used xz in the past and that's worked too.

I saved the bad 01-filesystem.squashfs if there is something you'd like me to check.

Luckily someone had the great idea to include emergency backups as a part of the quick remaster program. Very Happy Very Happy


I am still seeing this issue. http://murga-linux.com/puppy/viewtopic.php?p=965101#965101

It only happens with 64 bit builds, 32 bit works fine.

I cannot mount the 01-filesystem.squashfs file on my 64 bit Stretch builds, but it will mount on my 64 bit Jessie remaster. But, editsfs seems to open it up and redo it, but it still won't mount or work on 64 bit Stretch.

If I create a LZ4 *.squashfs file with apt2sfs, it won't mount on my 64 bit build either and doesn't appear to load correctly from right click.

Could you please try to reproduce this?

Dan
Back to top
View user's profile Send private message 
jd7654

Joined: 06 Apr 2015
Posts: 297

PostPosted: Mon 28 Aug 2017, 03:09    Post subject:  

fredx181 wrote:
@jd7654, added filemnt-caja to the repos, didn't test though, can you try it ?


Tried filemnt-caja in Mate build, mount works OK, unmount works, but has same error dialog I saw before. (can't copy text, see attach)

Other interesting problem, I was using Frisbee in Mate build before for WiFi, and with new config there is a failure with key/password, an immediate error popup:
Invalid Key or Password

I know it worked before, only thing different is zz_mate_config.squashfs in new build. I disabled zz_mate_config and then Frisbee connected OK. Don't see anything in there that would/should cause that. Will check some more.
Screenshot at 2017-08-27 20-50-49.png
 Description   
 Filesize   22.56 KB
 Viewed   771 Time(s)

Screenshot at 2017-08-27 20-50-49.png

Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4047
Location: Worcestershire, UK

PostPosted: Mon 28 Aug 2017, 04:34    Post subject:  

jd7654 wrote:
Other interesting problem, I was using Frisbee in Mate build before for WiFi, and with new config there is a failure with key/password, an immediate error popup:
Invalid Key or Password

That is usually a theme problem - try a different GTK theme.....

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4159
Location: holland

PostPosted: Mon 28 Aug 2017, 06:58    Post subject:  

@dancytron

Quote:
I am still seeing this issue. http://murga-linux.com/puppy/viewtopic.php?p=965101#965101

It only happens with 64 bit builds, 32 bit works fine.

I cannot mount the 01-filesystem.squashfs file on my 64 bit Stretch builds, but it will mount on my 64 bit Jessie remaster. But, editsfs seems to open it up and redo it, but it still won't mount or work on 64 bit Stretch.

If I create a LZ4 *.squashfs file with apt2sfs, it won't mount on my 64 bit build either and doesn't appear to load correctly from right click.

Could you please try to reproduce this?


Looks like you found another bug
But the weird thing is that I cannot reproduce (I tried a few times after you mentioned earlier and tried just now)
But looking at the script, I've found a mistake
It's that inside /lib/modules/4.9.0-3-amd64/kernel/fs/squashfs/ there's a folder "squashfs64" copied, but squashfs.ko module (with LZ4 support) should be there only.
For some reason on my computer the right squashfs.ko gets loaded (inside squashfs64) and apparently not for you.
Anyway, should be fixed now ! Can you test ?

New mklive-stretch:
mklive-stretch script

@jd7654
Quote:
Tried filemnt-caja in Mate build, mount works OK, unmount works, but has same error dialog I saw before. (can't copy text, see attach)


Yes tested that now, I guess that's a caja thing, don't know how to solve, looks like caja is looking for /media/root/.... when unmounting
Also when unmounting the directory in /mnt/ from terminal, I got the same message.
About Frisbee, no idea, nothing inside the extra module that should influence connection AFAIK
EDIT: To be sure I removed the ~/.config folder from the extra mate module:
https://debiandog.github.io/MakeLive/modules/mate
(although I doubt that it would make any difference)

Fred
Back to top
View user's profile Send private message 
jd7654

Joined: 06 Apr 2015
Posts: 297

PostPosted: Mon 28 Aug 2017, 13:50    Post subject:  

fredx181 wrote:
@jd7654...
About Frisbee, no idea, nothing inside the extra module that should influence connection AFAIK
EDIT: To be sure I removed the ~/.config folder from the extra mate module:
https://debiandog.github.io/MakeLive/modules/mate
(although I doubt that it would make any difference)


I tried with the new zz_mate_config sfs, and Frisbee worked first time!
Unfortunately, I didn't keep the old one, deleted stretch directory to make space, so can't reconfirm the original failure. And also removed it from ISO with ISOMaster to try on another PC.
So combined with what Peebee said,(why in the heck would/should a theme affect the Frisbee password?) I guess we can just chalk this up to some Frisbee weirdness...move along, nothing to see here.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4047
Location: Worcestershire, UK

PostPosted: Mon 28 Aug 2017, 14:35    Post subject:  

jd7654 wrote:
why in the heck would/should a theme affect the Frisbee password?) I guess we can just chalk this up to some Frisbee weirdness...move along, nothing to see here.

'Cos some themes don't play nicely with gtkdialog and produce error strings which are added on to the typed password producing a corrupted password - if I can find it there's a post on one of the Frisbee threads with a test prog - there's also a patch to the theme somewhere which cures the problem....but can't remember where that is....

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 4047
Location: Worcestershire, UK

PostPosted: Mon 28 Aug 2017, 15:22    Post subject:  

see http://murga-linux.com/puppy/viewtopic.php?p=660511#660511 for test prog and subsequent posts for theme edits....

or type into a terminal:
Code:
Xdialog  --title "Frisbee" --password --inputbox "Please enter the password" 0 0 > /opt/Pwireless-entry 2>&1

and then look in /opt/Pwireless-entry for the result

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64

Last edited by peebee on Mon 28 Aug 2017, 15:39; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
dancytron

Joined: 18 Jul 2012
Posts: 1387

PostPosted: Mon 28 Aug 2017, 15:37    Post subject:  

fredx181 wrote:
@dancytron

Quote:
I am still seeing this issue. http://murga-linux.com/puppy/viewtopic.php?p=965101#965101

It only happens with 64 bit builds, 32 bit works fine.

I cannot mount the 01-filesystem.squashfs file on my 64 bit Stretch builds, but it will mount on my 64 bit Jessie remaster. But, editsfs seems to open it up and redo it, but it still won't mount or work on 64 bit Stretch.

If I create a LZ4 *.squashfs file with apt2sfs, it won't mount on my 64 bit build either and doesn't appear to load correctly from right click.

Could you please try to reproduce this?


Looks like you found another bug
But the weird thing is that I cannot reproduce (I tried a few times after you mentioned earlier and tried just now)
But looking at the script, I've found a mistake
It's that inside /lib/modules/4.9.0-3-amd64/kernel/fs/squashfs/ there's a folder "squashfs64" copied, but squashfs.ko module (with LZ4 support) should be there only.
For some reason on my computer the right squashfs.ko gets loaded (inside squashfs64) and apparently not for you.
Anyway, should be fixed now ! Can you test ?

New mklive-stretch:
mklive-stretch script


Fred


That seems to have fixed it.
Back to top
View user's profile Send private message 
jd7654

Joined: 06 Apr 2015
Posts: 297

PostPosted: Tue 29 Aug 2017, 22:19    Post subject:  

Did a Jwm build, to look more like basic Puppy., removed:
edit-sfs-pcmanfm filemnt-pcmanfm pcmanfm

Added:
filemnt-rox desktop-drive-icons

Worked OK (with some config entrys) but my browser modules were not working. Had to add back:
libdbus-glib-1-2
which was installed with pcmanfm.

Tried to add roxterm but seems this is not available in 32-bit, only 64-bit?
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4159
Location: holland

PostPosted: Wed 30 Aug 2017, 07:37    Post subject:  

jd7654 wrote:
Tried to add roxterm but seems this is not available in 32-bit, only 64-bit?


It's now in 32 bit custom repo also, it's officially from Debian Jessie repo , but works fine in Stretch , from what I tested.
Install as roxterm-gtk2
(trying to sync 64 and 32 bit custom repos as much as possible)

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
festus


Joined: 14 Jan 2015
Posts: 221

PostPosted: Wed 30 Aug 2017, 12:31    Post subject: openbox_lx  

Hey, all

Yesterday, I ran the mklive-stretch -gui, using "openbox_lx.conf", with a few added pkgs, and it turned out great.

How does a person set programs to run @ startup, and choose the default applications?

Thank you, Fred, and all involved.

festus Smile
Back to top
View user's profile Send private message 
Doglover

Joined: 24 Jun 2006
Posts: 262
Location: Humboldt

PostPosted: Wed 30 Aug 2017, 13:26    Post subject:  

Very nice Fred.. kudos

Anyway, tried all the desktops and could not get kodi to run. Seg fault every time. Can't figure it out. any ideas?

Thanks for an excellent script.
debdog-20170830171450.jpg
Description 
jpg

 Download 
Filename  debdog-20170830171450.jpg 
Filesize  70.68 KB 
Downloaded  169 Time(s) 
debdog-20170830171905.jpg
Description 
jpg

 Download 
Filename  debdog-20170830171905.jpg 
Filesize  196.82 KB 
Downloaded  158 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 32 of 103 [1533 Posts]   Goto page: Previous 1, 2, 3, ..., 30, 31, 32, 33, 34, ..., 101, 102, 103 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1386s ][ Queries: 13 (0.0344s) ][ GZIP on ]