Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 16 Dec 2017, 22:47
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Problem converting avi to mp4 with FFConvert
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [23 Posts]   Goto page: Previous 1, 2
Author Message
aarf

Joined: 30 Aug 2007
Posts: 3613
Location: around the bend

PostPosted: Sat 14 Aug 2010, 20:42    Post subject:  

aarf wrote:
will ask this here because people here know things about media files.

lobsters Lucid dream
http://www.youtube.com/watch?v=xb_nUn5OMbs
when using opera you can pull its local temporary file out of /tmp as something like FlashXXXxxx then play it in gnome-player, however it will not play in gxine

Code:

# ffmpeg -i Flash*

(long output disappears from history)

[flv @ 0xb77df58c]Unsupported video codec (7)
[flv @ 0xb77df58c]Unsupported video codec (7)
[flv @ 0xb77df58c]Unsupported video codec (7)
[flv @ 0xb77df58c]Unsupported video codec (7)
[flv @ 0xb77df58c]Unsupported video codec (7)
[flv @ 0xb77df58c]skipping flv packet: type 97, size 7627016, flags 0

Seems stream 0 codec frame rate differs from container frame rate: 1000.00 (1000/1) -> 29.97 (30000/1001)
Input #0, flv, from 'FlashXXXfcgIo':
  Duration: 00:01:14.4, start: 0.000000, bitrate: N/A
  Stream #0.0: Video: 0x0007, 29.97 fps(r)
  Stream #0.1: Audio: 0x000a, 44100 Hz, stereo
Must supply at least one output file
#

how to get either gxine, or Xfmedia player, to play it because puppeee doesn't include gnome-player. puppeee does have FFconvert. may also need to just add codecs. you2pet keeps breaking.
note the clips from http://www.clipshack.com obtained in the same way will play in gxine.
will look into this further myself but have to go out now. if you have some spare brainpower please have a shot.

solved briefly:
transcoder with settings video:avi, mpeg2, 1440, same,4.3, auto
audio mp2,128,48000,2
will then play opera sourced youtube in gxine
here if you want to look at it.

_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send private message Visit poster's website 
aarf

Joined: 30 Aug 2007
Posts: 3613
Location: around the bend

PostPosted: Sun 15 Aug 2010, 06:59    Post subject:  

have a kdenlive solution to the previous post as well at http://www.murga-linux.com/puppy/viewtopic.php?p=442366#442366
_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4722
Location: Southeast Georgia, USA

PostPosted: Thu 02 Sep 2010, 13:46    Post subject:  

aarf wrote:
Cool from info at Mysp's link http://www.murga-linux.com/puppy/viewtopic.php?t=43363
#


Thanks!

MediaInfo worked fine!

I will post the output for the AVI file that works with our daughter's MP4 player and see what y'all think I need to use to convert other video sources to those same specs.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
TahrPup64 & Lighthouse64-b602 & JL64-603
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4722
Location: Southeast Georgia, USA

PostPosted: Thu 02 Sep 2010, 13:51    Post subject:  

Here is the snapshot of the MediInfo output for a music video that works:



How would I get ffmpeg to generate these same specs for a variety of video inputs, please?

BTW: Is there a way for MediaInfo to produce a .jpp or .txt output?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
TahrPup64 & Lighthouse64-b602 & JL64-603

Last edited by edoc on Thu 02 Sep 2010, 18:23; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4722
Location: Southeast Georgia, USA

PostPosted: Thu 02 Sep 2010, 18:21    Post subject:  

Same file format error.

Here is the MediaInfo output for your file:



And here is the MediaInfo output for a video file she created on the camera:


_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
TahrPup64 & Lighthouse64-b602 & JL64-603
Back to top
View user's profile Send private message Visit poster's website 
Makoto


Joined: 03 Sep 2009
Posts: 2087
Location: Out wandering... maybe.

PostPosted: Thu 02 Sep 2010, 21:24    Post subject:  

I've used MediaInfo on Windows and haven't tried the Linux version (yet), but if it's more or less the same (it does look the same to me), you can try switching the View in the View menu to Tree View. That might give you a comprehensive info dump you can copy to the clipboard and paste wherever you want.
_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * [ Puppy Precise 5.7.1 JP, Frugal install ]
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4722
Location: Southeast Georgia, USA

PostPosted: Fri 03 Sep 2010, 12:50    Post subject:  

I tried pvideo to do the conversion but the file is also incorrectly formatted for the MP4 player.

It looks like the kbps and fps need to be adjusted.


_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
TahrPup64 & Lighthouse64-b602 & JL64-603
Back to top
View user's profile Send private message Visit poster's website 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 11 Sep 2017, 23:42    Post subject: AVI to MP4 without trouble. FFconvert 1.3.1  

2017 ; new versions seem to convert .AVI to MP4 without trouble.
Screencast with ffconvert five .MPG . You can convert it to MP4 or AVI,
FFconcert 1.3.1 on Racy 5.5 does the job, in my studios.Why siome interest in video processing in 2017 ? Most of questions has been solved in the past, by Puppy Linux Users, when movies were a popular Hobby.
Avidemux : i was editing MPG done by FFconvert to add my comments (MP3) and saved as MP4.. no sound. But AVI was OK.
Then AVI to MP4 with FFconvert and audio works.
Where have you gone, dear video lovers. I feel alone in the forum, speaking about video editing. We are few now to practice. Please come back to Puppy (Racy or Precise for MP3 MP4 MPEG will do editing without adding libs)
aviTOmp4.jpg
 Description   FFconvert 1.3.1
 Filesize   34.13 KB
 Viewed   20 Time(s)

aviTOmp4.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 2 of 2 [23 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0424s ][ Queries: 13 (0.0075s) ][ GZIP on ]