Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 20 Oct 2017, 05:02
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Flowblade-0.16.0 for Carolina
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [26 Posts]   Goto page: Previous 1, 2
Author Message
battleshooter


Joined: 14 May 2008
Posts: 1333
Location: Australia

PostPosted: Wed 10 Dec 2014, 23:49    Post subject:  

LazY Puppy wrote:
Best of all: it comes in DE now - completely!

Exquisite! Very Happy


I had a feeling you'd like that when I saw that on the new feature list Very Happy

LazY Puppy wrote:
Still seems to work in Precise


I think it works with your system because you don't have a clashing Python. How your FFMPEG could happen to be the same version as the one I compile MLT with however, is a mystery to me Smile

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 2007
Location: Germany

PostPosted: Thu 11 Dec 2014, 00:02    Post subject:  

Quote:
# ffmpeg -version
ffmpeg version 0.8.6-4:0.8.6-0ubuntu0.12.04.1, Copyright (c) 2000-2013 the Libav developers
built on Apr 2 2013 17:00:59 with gcc 4.6.3
*** THIS PROGRAM IS DEPRECATED ***
This program is only provided for compatibility and will be removed in a future release. Please use avconv instead.
ffmpeg 0.8.6-4:0.8.6-0ubuntu0.12.04.1
libavutil 51. 22. 1 / 51. 22. 1
libavcodec 53. 35. 0 / 53. 35. 0
libavformat 53. 21. 1 / 53. 21. 1
libavdevice 53. 2. 0 / 53. 2. 0
libavfilter 2. 15. 0 / 2. 15. 0
libswscale 2. 1. 0 / 2. 1. 0
libpostproc 52. 0. 0 / 52. 0. 0
#

Since I did not change anything on ffmpeg, it should be still the one that is built into precise 5.7.1.

_________________
RSH

"you only wanted to work your Puppies in German", "you are a separatist in that you want Germany to secede from Europe" (musher0) Laughing

No, but I gave my old drum kit away for free to a music store collecting instruments for refugees! Wink
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1333
Location: Australia

PostPosted: Thu 11 Dec 2014, 00:13    Post subject:  

LazY Puppy wrote:
Since I did not change anything on ffmpeg, it should be still the one that is built into precise 5.7.1.


Code:
ffmpeg -v
ffmpeg version 0.8.12, Copyright (c) 2000-2011 the FFmpeg developers
  built on Jul 25 2012 04:52:58 with gcc 4.3.4
  configuration: --prefix=/usr --cpu=i486 --enable-shared --enable-gpl --enable-nonfree --enable-x11grab --enable-small --enable-runtime-cpudetect --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libdc1394 --enable-libfaac --enable-libfreetype --enable-libmp3lame --enable-libschroedinger --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-zlib --enable-postproc --disable-debug --enable-bzlib --enable-version3 --enable-libtheora --enable-swscale
  libavutil    51.  9. 1 / 51.  9. 1
  libavcodec   53.  8. 0 / 53.  8. 0
  libavformat  53.  5. 0 / 53.  5. 0
  libavdevice  53.  1. 1 / 53.  1. 1
  libavfilter   2. 23. 0 /  2. 23. 0
  libswscale    2.  0. 0 /  2.  0. 0
  libpostproc  51.  2. 0 / 51.  2. 0


Looks like it's not exactly the same version, but close enough to be compatible.

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
live

Joined: 10 Feb 2010
Posts: 220

PostPosted: Mon 22 Dec 2014, 17:57    Post subject:  

Could you also build a version for tahrpup 6.

Thanks
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 1929
Location: 500 seconds from Sol

PostPosted: Mon 19 Jan 2015, 12:16    Post subject: Errors loading in Vanguard Release 2 [Solved]
Subject description: See following posts
 

Hi Battleshooter,

Under Vanguard Release 2, while flowblade-0.14 starts without a hitch --I didn't test further-- flowblade-0.16 doesn't. Attempting to start via terminal reports the following:

# flowblade
FLOWBLADE MOVIE EDITOR 0.16
---------------------------
Launch script dir: /usr/bin
Running from installation...
modules path: /usr/share/flowblade/Flowblade
MLT found, version: 0.9.2

** (process:12553): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:12553): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:12553): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Failed to import module app.py to launch Flowblade!
ERROR: /usr/lib/python2.7/site-packages/_dbus_bindings.so: undefined symbol: dbus_message_iter_abandon_container
Installation was assumed to be at: /usr/share/flowblade/Flowblade

Hopefully, until the above problems are solved, flowblade 0.14 remains available somewhere as it remains the easiest, most complete video editor for Carolina/Vanguard. An older version which works is better than a newer version which doesn't.

I was unable to find a download link for flowblade 0.14. And a cursory check of Carolina's repo also failed to locate it. If it is no longer available and you've kept a copy, perhaps you could upload it again for those who, unlike myself, don't have a copy.

Thanks,

mikesLr

Last edited by mikeslr on Tue 20 Jan 2015, 12:36; edited 1 time in total
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1333
Location: Australia

PostPosted: Mon 19 Jan 2015, 20:32    Post subject:  

Hey Mike,

http://puppylinuxstuff.meownplanet.net/battleshooter/Carolina/Flowblade/flowblade-0.14.0.sfs

That error you're getting, are you running a clean Pupsave? Seems to work fine here, a few warnings but nothing show stopping.

Code:
# flowblade
FLOWBLADE MOVIE EDITOR 0.16
---------------------------
Launch script dir: /usr/bin
Running from installation...
modules path: /usr/share/flowblade/Flowblade
MLT found, version: 0.9.2

** (process:10678): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:10678): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:10678): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Python 2.7.2 (default, Feb 12 2012, 18:36:30)
[GCC 4.3.4]
GTK+ version: (2, 24, 8)
Locale: en_US
mlt_repository_init: failed to dlopen /usr/lib/mlt/libmltresample.so
  (libsamplerate.so.0: cannot open shared object file: No such file or directory)
Detecting environment...
---
---Cut out codecs section---
...
MLT detection succeeded, 105 formats, 54 video codecs and 51 audio codecs found.
308 MLT services found.
Loading render profiles...
Apple ProRes 4:2:2 / .mov...NOT available, video codec prores missing
Proxy encoding MPEG-4 Preset Ultrafast ...available
Proxy encoding MPEG-2 Transport Stream ...available
Loading filters...
MLT service lumakey not found.
MLT service ladspa.1194 not found.
MLT service ladspa.1197 not found.
Brightness dropped, MLT version too low for this filter.
Loading transitions...
RGB Adjustment dropped for Color Adjustment
Hue dropped for Color Adjustment
Gamma dropped for Lift Gain Gamma
default profile from prefs nor found
Player initialized with profile:  DV/DVD PAL
Autosave started...
Save project autosave_267b1fc852266d067a2c2135c4c22cda


live wrote:
Could you also build a version for tahrpup 6.

Thanks


No sorry, I tried but there was just too many issues. Confused

battleshooter wrote:
Quote:
I̶t̶ ̶s̶h̶o̶u̶l̶d̶ ̶w̶o̶r̶k̶ ̶o̶n̶ ̶m̶o̶s̶t̶ ̶P̶u̶p̶s̶ ̶b̶e̶s̶i̶d̶e̶s̶ ̶C̶a̶r̶o̶l̶i̶n̶a̶ ̶a̶s̶ ̶i̶t̶'̶s̶ ̶d̶e̶p̶e̶n̶d̶e̶n̶c̶i̶e̶s̶ ̶a̶r̶e̶ ̶s̶i̶m̶p̶l̶e̶ ̶a̶n̶d̶ ̶t̶h̶e̶ ̶p̶r̶o̶g̶r̶a̶m̶ ̶i̶t̶s̶e̶l̶f̶ ̶i̶s̶ ̶a̶ ̶p̶y̶t̶h̶o̶n̶ ̶s̶c̶r̶i̶p̶t̶.̶


Boy was that ever an assumption. I tried getting Flowblade 0.16.0 going on Tahr and ran into on problem after another! One of the main issues was it came with its own Python which installed plugins in a different directory from Carolina, dist-packages vs. site-packages. Symlinking didn't work. I cheated off the Tahr Ubuntu repo, but the needed dependencies had more dependencies than the ones in Carolina, gave up after deb package number 9. I also had to recompile MLT to compensate for the different FFMPEG. As I told someone, it's not impossible to get FLowblade going on Tahr, I just think it would take an afternoon of compiling the needed dependencies by hand, instead of trying to leech.

So, whoops, definitely not going to work on most Pups besides Carolina mostly because of different Python and FFMPEG configurations.

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 1929
Location: 500 seconds from Sol

PostPosted: Tue 20 Jan 2015, 12:35    Post subject: flowblade-0.16 runs on Vanguard Version 2 w/Clean SaveFile  

Hi battleshooter,

"That error you're getting, are you running a clean Pupsave? "

Well, anyone can do that! Embarassed

Good reason not to start projects at 1.00 A.M. when shortcuts seem important.

mikesLr
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1333
Location: Australia

PostPosted: Wed 21 Jan 2015, 09:04    Post subject: Re: flowblade-0.16 runs on Vanguard Version 2 w/Clean SaveFile  

mikeslr wrote:
Hi battleshooter,

"That error you're getting, are you running a clean Pupsave? "

Well, anyone can do that! Embarassed

Good reason not to start projects at 1.00 A.M. when shortcuts seem important.

mikesLr


Ahh I see Smile

If I had to guess at what was causing the error, I'd say that pupsave of yours had an existing dbus_bindings.so that wasn't compiled with the symbols Flowblade's was and as it existed, the SFS was not able to overwrite it.

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 02 Feb 2015, 05:50    Post subject: Precise 5.4.3 ToOpPy France : Flowblade 016
Subject description: fully installed
 

Due to problems with mlt, i replaced existing files by the files of the SFS (python 2.7 and all common files)
I use Edit-sfs and get files transfered in my structure.
And Flowblade appears on my screen, Loaded one video from my tool case.
No further test. I shall see if better than Openshot .
YouTube permit to decorate your videos too.
as most of files were already existing in ToOppy, the Puppy is not much bigger. with Flowblade included. Smile Is it worth of it : i shall tell you.
Demo youtube Kdenlive, mais c'est pareil click the blue

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 04 Nov 2015, 23:41    Post subject: tahrpup64 6.0.3.9 Flowblade from PPM
Subject description: freiOr is the hurting point
 

tahrpup64 6.0.3.9 Flowblade from PPM. 137MB are needed. It's a lot Exclamation
Eh Pelo posted here before that flowblade was running ToOppy. I'am using Tharpup. SFS flowbade does not lauch. Check it. I come back
freiOr is the hurting point
I Take a glance at RSH SFS, The Lazy Puppy german manager.
Smile complete unsuccess !
flowblade.jpg
 Description   always the same libs miss
 Filesize   81.63 KB
 Viewed   144 Time(s)

flowblade.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 27 Sep 2017, 15:38    Post subject: Many tracks are available to mix videos.  

Flowblade 0.8.3 installed on Puppybang, tahrpup really efficient.
No videos available to verify if flowblade edit really .
Many tracks are available to mix videos.
Version 0.8.3 is old ? Yes, but this version installed from PPM, Nothing to do.
Puppy bang had yet Openshot inclluded.

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 2 of 2 [26 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0542s ][ Queries: 15 (0.0039s) ][ GZIP on ]